[WEBDEV] Problème avec indirection et libellé

Le
Sebastien B.
Bonjour,

Sur une page j'ai une centaine de libellé que je voudrais modifier les
libellés via une indirection mais ceci ne fonctionne pas.

La seule parade que j'ai trouvé est d'initialiser le libellé à vide
avant Et ceci est très embetant vu le nombre de libellé..(surtout
que l'indirection fonctionne bien si il s'agit d'un champ de
saisie)

Autre dit :

{"Libelle1"} = "test" ne fonctionne pas

mais si je mets :

libelle1 = ""
{"Libelle1"} = "test" cela fonctionne correctement

quelqu'un a t-il une autre solution ?

Merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
tjfromparis
Le #14547051
On 4 fév, 12:05, "Sebastien B."
Bonjour,

Sur une page j'ai une centaine de libellé que je voudrais modifier les
libellés via une indirection mais ceci ne fonctionne pas.

La seule parade que j'ai trouvé est d'initialiser le libellé à vide
avant ... Et ceci est très embetant vu le nombre de libellé..(surtout
que l'indirection fonctionne bien si il s'agit d'un champ de
saisie...)

Autre dit :

{"Libelle1"} = "test" ne fonctionne pas

mais si je mets :

libelle1 = ""
{"Libelle1"} = "test" cela fonctionne correctement

quelqu'un a t-il une autre solution ?

Merci



essaye ca :

for i = 1 to 10
{"Libelle"+i} = "toto"
FIN

j'utilise les indirections un peu partout et un peu sur n'importe quoi
et ca roule tres bien. Par contre, de temps en temps c'est un peu
chaud sur la syntaxe
Sebastien B.
Le #14546981
Une telle boucle ne fonctionne pas ...
En fait on vient de me dire comment farie il suffit de passer les
libelles de type 'dynamique', et non le laisser en automatique, pour
résoudre le problème. Encore fallait il le savoir ...



On 4 fév, 12:33, "" wrote:
On 4 fév, 12:05, "Sebastien B."


> Bonjour,

> Sur une page j'ai une centaine de libellé que je voudrais modifier les
> libellés via une indirection mais ceci ne fonctionne pas.

> La seule parade que j'ai trouvé est d'initialiser le libellé à vid e
> avant ... Et ceci est très embetant vu le nombre de libellé..(surtou t
> que l'indirection fonctionne bien si il s'agit d'un champ de
> saisie...)

> Autre dit :

> {"Libelle1"} = "test" ne fonctionne pas

> mais si je mets :

> libelle1 = ""
> {"Libelle1"} = "test" cela fonctionne correctement

> quelqu'un a t-il une autre solution ?

> Merci

essaye ca :

for i = 1 to 10
{"Libelle"+i} = "toto"
FIN

j'utilise les indirections un peu partout et un peu sur n'importe quoi
et ca roule tres bien. Par contre, de temps en temps c'est un peu
chaud sur la syntaxe


tjfromparis
Le #14546901
> Une telle boucle ne fonctionne pas ...


hein ???
je l'ai meme essayé avant de poster !




On 4 fév, 13:48, "Sebastien B."
Une telle boucle ne fonctionne pas ...
En fait on vient de me dire comment farie il suffit de passer les
libelles de type 'dynamique', et non le laisser en automatique, pour
résoudre le problème. Encore fallait il le savoir ...

On 4 fév, 12:33, "" wrote:

> On 4 fév, 12:05, "Sebastien B."
> > Bonjour,

> > Sur une page j'ai une centaine de libellé que je voudrais modifier l es
> > libellés via une indirection mais ceci ne fonctionne pas.

> > La seule parade que j'ai trouvé est d'initialiser le libellé à v ide
> > avant ... Et ceci est très embetant vu le nombre de libellé..(surt out
> > que l'indirection fonctionne bien si il s'agit d'un champ de
> > saisie...)

> > Autre dit :

> > {"Libelle1"} = "test" ne fonctionne pas

> > mais si je mets :

> > libelle1 = ""
> > {"Libelle1"} = "test" cela fonctionne correctement

> > quelqu'un a t-il une autre solution ?

> > Merci

> essaye ca :

> for i = 1 to 10
> {"Libelle"+i} = "toto"
> FIN

> j'utilise les indirections un peu partout et un peu sur n'importe quoi
> et ca roule tres bien. Par contre, de temps en temps c'est un peu
> chaud sur la syntaxe


Sebastien B.
Le #14546881
Bah chez moi cela ne fonctionne pas du tout.(à moins de définir les
libellés en type 'dynamique')
Je suis avec WEBDEV 12

ET ceci ne fonctionne pas sur les libellés mais cela fonctionne bien
avec des champs de saisis.


On 4 fév, 15:51, "" wrote:
> Une telle boucle ne fonctionne pas ...

hein ???
je l'ai meme essayé avant de poster !

On 4 fév, 13:48, "Sebastien B."
> Une telle boucle ne fonctionne pas ...
> En fait on vient de me dire comment farie il suffit de passer les
> libelles de type 'dynamique', et non le laisser en automatique, pour
> résoudre le problème. Encore fallait il le savoir ...

> On 4 fév, 12:33, "" > wrote:

> > On 4 fév, 12:05, "Sebastien B."
> > > Bonjour,

> > > Sur une page j'ai une centaine de libellé que je voudrais modifier les
> > > libellés via une indirection mais ceci ne fonctionne pas.

> > > La seule parade que j'ai trouvé est d'initialiser le libellé à vide
> > > avant ... Et ceci est très embetant vu le nombre de libellé..(su rtout
> > > que l'indirection fonctionne bien si il s'agit d'un champ de
> > > saisie...)

> > > Autre dit :

> > > {"Libelle1"} = "test" ne fonctionne pas

> > > mais si je mets :

> > > libelle1 = ""
> > > {"Libelle1"} = "test" cela fonctionne correctement

> > > quelqu'un a t-il une autre solution ?

> > > Merci

> > essaye ca :

> > for i = 1 to 10
> > {"Libelle"+i} = "toto"
> > FIN

> > j'utilise les indirections un peu partout et un peu sur n'importe quoi
> > et ca roule tres bien. Par contre, de temps en temps c'est un peu
> > chaud sur la syntaxe


tjfromparis
Le #14546871
suis avec Windev moi
p'tet ca : le web et le client ca reagit pas tout à fait pareil

On 4 fév, 16:03, "Sebastien B."
Bah chez moi cela ne fonctionne pas du tout.(à moins de définir les
libellés en type 'dynamique')
Je suis avec WEBDEV 12

ET ceci ne fonctionne pas sur les libellés mais cela fonctionne bien
avec des champs de saisis.

On 4 fév, 15:51, "" wrote:

> > Une telle boucle ne fonctionne pas ...

> hein ???
> je l'ai meme essayé avant de poster !

> On 4 fév, 13:48, "Sebastien B."
> > Une telle boucle ne fonctionne pas ...
> > En fait on vient de me dire comment farie il suffit de passer les
> > libelles de type 'dynamique', et non le laisser en automatique, pour
> > résoudre le problème. Encore fallait il le savoir ...

> > On 4 fév, 12:33, "" > > wrote:

> > > On 4 fév, 12:05, "Sebastien B."
> > > > Bonjour,

> > > > Sur une page j'ai une centaine de libellé que je voudrais modifi er les
> > > > libellés via une indirection mais ceci ne fonctionne pas.

> > > > La seule parade que j'ai trouvé est d'initialiser le libellé à vide
> > > > avant ... Et ceci est très embetant vu le nombre de libellé..( surtout
> > > > que l'indirection fonctionne bien si il s'agit d'un champ de
> > > > saisie...)

> > > > Autre dit :

> > > > {"Libelle1"} = "test" ne fonctionne pas

> > > > mais si je mets :

> > > > libelle1 = ""
> > > > {"Libelle1"} = "test" cela fonctionne correctement

> > > > quelqu'un a t-il une autre solution ?

> > > > Merci

> > > essaye ca :

> > > for i = 1 to 10
> > > {"Libelle"+i} = "toto"
> > > FIN

> > > j'utilise les indirections un peu partout et un peu sur n'importe qu oi
> > > et ca roule tres bien. Par contre, de temps en temps c'est un peu
> > > chaud sur la syntaxe


Roumegou Eric
Le #14546741
a utilisé son clavier pour écrire :
suis avec Windev moi
p'tet ca : le web et le client ca reagit pas tout à fait pareil



non c'est tout simplement qu'en webdev si tu ne déclares par un objet
en dynamique c'est qu'il n'est pas sensé être modifié par
programmation.

Donc tout action directe ou par des opérateurs d'indirection revient à
pisser ds un violon ;-)
tjfromparis
Le #14546701
pis c'est dur ke violon !


On 5 fév, 11:08, Roumegou Eric
a utilisé son clavier pour écrire :> suis avec W indev moi
> p'tet ca : le web et le client ca reagit pas tout à fait pareil

non c'est tout simplement qu'en webdev si tu ne déclares par un objet
en dynamique c'est qu'il n'est pas sensé être modifié par
programmation.

Donc tout action directe ou par des opérateurs d'indirection revient à
pisser ds un violon ;-)


Publicité
Poster une réponse
Anonyme