Wheezy : echec de montage automatique d'une clé USB formatée en fat16

Le
Yann Cohen
--MP_/Pt8hgL5QbkSHBT_ocelD.Lg
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Bonjour,

Suite à une réinstallation de wheezy, ma machine n'est plus capable de
monter en automatique une clé au format vfat ou fat16.

Sur une autre machine, j'ai vérifié que la clé est bien "montable". Et
sur cette machine je peux monter une clé avec une partition LUKS puis
ext3.

Je ne trouve pas la faille de mon installation, car je pense qu'il doit
manquer quelques paquets ou configuration

Ci-joint vous trouverez la trace dans "messages" de la détection et de
la tentative de montage de la clé USB.

Ci-après le message de gnome suite à l'insertion de la clé

Error mounting: mount exited with exit code 1: helper failed with:
mount: wrong fs type, bad option, bad superblock on /dev/sdg1,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so


Enfin le fdisk de la clé

yann@yan:~$ sudo fdisk -l /dev/sdg
Disk /dev/sdg: 1039 MB, 1039663104 bytes
256 heads, 32 sectors/track, 247 cylinders
Units = cylinders of 8192 * 512 = 4194304 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xc3072e18

Device Boot Start End Blocks Id System
/dev/sdg1 1 248 1015280 4 FAT16 <32M
Partition 1 has different physical/logical endings:
phys=(249, 255, 32) logical=(247, 223, 32)


Cordialement.
--
Yann

--MP_/Pt8hgL5QbkSHBT_ocelD.Lg
Content-Type: text/plain
Content-Transfer-Encoding: 7bit
Content-Disposition: attachment; filename=message.txt

May 15 11:44:22 yan kernel: [ 145.592023] usb 1-6: new high speed USB device using ehci_hcd and address 5
May 15 11:44:23 yan kernel: [ 145.727622] usb 1-6: New USB device found, idVendor 0c, idProduct00
May 15 11:44:23 yan kernel: [ 145.727628] usb 1-6: New USB device strings: Mfr=1, Product=2, SerialNumber=3
May 15 11:44:23 yan kernel: [ 145.727633] usb 1-6: Product: USB DISK
May 15 11:44:23 yan kernel: [ 145.727636] usb 1-6: Manufacturer: SMI Corporation
May 15 11:44:23 yan kernel: [ 145.727639] usb 1-6: SerialNumber: AA04012702038
May 15 11:44:23 yan kernel: [ 145.800071] usbcore: registered new interface driver uas
May 15 11:44:23 yan kernel: [ 145.829382] Initializing USB Mass Storage driver
May 15 11:44:23 yan kernel: [ 145.829604] scsi6 : usb-storage 1-6:1.0
May 15 11:44:23 yan kernel: [ 145.829904] usbcore: registered new interface driver usb-storage
May 15 11:44:23 yan kernel: [ 145.829908] USB Mass Storage support registered.
May 15 11:44:24 yan kernel: [ 146.829253] scsi 6:0:0:0: Direct-Access USB Flash Disk 3000 PQ: 0 ANSI: 0 CCS
May 15 11:44:24 yan kernel: [ 146.830229] sd 6:0:0:0: Attached scsi generic sg7 type 0
May 15 11:44:24 yan kernel: [ 146.831981] sd 6:0:0:0: [sdg] 2030592 512-byte logical blocks: (1.03 GB/991 MiB)
May 15 11:44:24 yan kernel: [ 146.832821] sd 6:0:0:0: [sdg] Write Protect is off
May 15 11:44:24 yan kernel: [ 146.884113] sdg: sdg1
May 15 11:44:24 yan kernel: [ 146.887354] sd 6:0:0:0: [sdg] Attached SCSI removable disk
May 15 11:44:24 yan kernel: [ 147.400392] UDF-fs: No VRS found
May 15 11:44:24 yan kernel: [ 147.400396] UDF-fs: Rescanning with blocksize 2048
May 15 11:44:24 yan kernel: [ 147.417639] UDF-fs: No VRS found
May 15 11:44:24 yan kernel: [ 147.417642] UDF-fs: No partition found (1)
May 15 11:44:24 yan kernel: [ 147.483130] ISOFS: Unable to identify CD-ROM format.


--MP_/Pt8hgL5QbkSHBT_ocelD.Lg--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/20110515115909.752462f7@yan.ianco.homelinux.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Tulum
Le #23363401
Le dimanche 15 mai 2011 11:59:09 Yann Cohen, vous avez écrit :
Bonjour,

Suite à une réinstallation de wheezy, ma machine n'est plus cap able de
monter en automatique une clé au format vfat ou fat16.

Sur une autre machine, j'ai vérifié que la clé est bien "m ontable". Et
sur cette machine je peux monter une clé avec une partition LUKS puis
ext3.

Je ne trouve pas la faille de mon installation, car je pense qu'il doit
manquer quelques paquets ou configuration...

Ci-joint vous trouverez la trace dans "messages" de la détection et de
la tentative de montage de la clé USB.

Ci-après le message de gnome suite à l'insertion de la clé

Error mounting: mount exited with exit code 1: helper failed with:
mount: wrong fs type, bad option, bad superblock on /dev/sdg1,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so


Enfin le fdisk de la clé

:~$ sudo fdisk -l /dev/sdg
Disk /dev/sdg: 1039 MB, 1039663104 bytes
256 heads, 32 sectors/track, 247 cylinders
Units = cylinders of 8192 * 512 = 4194304 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xc3072e18

Device Boot Start End Blocks Id System
/dev/sdg1 1 248 1015280 4 FAT16 <32M
Partition 1 has different physical/logical endings:
phys=(249, 255, 32) logical=(247, 223, 32)


Cordialement.
--
Yann


J'ai le même problème que ce soit une clé en fat16 ou fat 32 ou ntfs. par
contre elle se monte bien sous win et squeeze.
Je l'ai même reformater sous win : impossible de la monter. idem si je la
formate avec partition manager.
Est-ce un bug ou un problème dans notre installation ?

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Pascal Ognibene
Le #23363451
--001485e8eb2e4a938304a34e66cf
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

Bonjour,
Regarde dans ton fichier /etc/fstab si tu n'a pas un lecteur de cd qui
prendrait le même device que ta clef usb (par exemple, /dev/scd1). Si c' est
le cas supprime l'entrée dans le fichier, qui cause un conflit. J'ai c e
problème aussi.
Pascal

Ps : désolé pour le top posting, mon client mail ne me laisse pas le choix.

Le 15 mai 2011 12:24, "Tulum" Le dimanche 15 mai 2011 11:59:09 Yann Cohen, vous avez écrit :

Bonjour,

Suite à une réinstallation de wheezy, ma machine n'est plus cap able de
monter en a...


J'ai le même problème que ce soit une clé en fat16 ou fat 32 ou ntfs. par
contre elle se monte bien sous win et squeeze.
Je l'ai même reformater sous win : impossible de la monter. idem si je la
formate avec partition manager.
Est-ce un bug ou un problème dans notre installation ?

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/

--001485e8eb2e4a938304a34e66cf
Content-Type: text/html; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

<p>Bonjour,<br>
Regarde dans ton fichier /etc/fstab si tu n&#39;a pas un lecteur de cd qui prendrait le même device que ta clef usb (par exemple, /dev/scd1). Si c&#39; est le cas supprime l&#39;entrée dans le fichier, qui cause un conflit. J&#39;ai ce problème aussi.<br>

Pascal</p>


contre elle se monte bien sous win et squeeze.<br>
Je l&#39;ai même reformater sous win : impossible de la monter. idem s i je la<br>
formate avec partition manager.<br>
Est-ce un bug ou un problème dans notre installation ?<br>
<font color="#888888"><br>
--<br>
Lisez la FAQ de la liste avant de poser une question :<br>
<br>
Pour vous DESABONNER, envoyez un message avec comme objet &quot;unsubscribe &quot;<br>
vers En cas de soucis, contactez EN ANGLAIS Archive: <br>
</font></blockquote></p>

--001485e8eb2e4a938304a34e66cf--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Yann Cohen
Le #23363521
Le Sun, 15 May 2011 12:57:05 +0200,
Pascal Ognibene
Bonjour,
Regarde dans ton fichier /etc/fstab si tu n'a pas un lecteur de cd qui
prendrait le même device que ta clef usb (par exemple, /dev/scd1). Si
c' est le cas supprime l'entrée dans le fichier, qui cause un
conflit. J'ai ce problème aussi.
Pascal



Well done !
Il y avait bien une entrée dans le /etc/fstab sur le /dev/sdg1.
En la mettant en commentaire le montage automatique refonctionne.

#/dev/sdg1 /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/scd0 /media/cdrom1 udf,iso9660 user,noauto 0 0

Mais alors d'où vient cette ligne ? de l'installation ? d'une règle
udev ?



Ps : désolé pour le top posting, mon client mail ne me laisse pas le
choix.



No problem !

[...]

--
Yann.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Tulum
Le #23363781
Le dimanche 15 mai 2011 12:57:05 Pascal Ognibene, vous avez écrit :
Bonjour,
Regarde dans ton fichier /etc/fstab si tu n'a pas un lecteur de cd qui
prendrait le même device que ta clef usb (par exemple, /dev/scd1). S i c'
est le cas supprime l'entrée dans le fichier, qui cause un conflit. J'ai
ce problème aussi.
Pascal


impeccable, merci

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme