Wifi DWA-510 (driver rt61pci) en point d'accès (hostapd)

Le
newsreader
Bonjour,

J'ai une carte DWA-510 reconnue par le driver rt61pci que j'ai associée à
ma carte ethernet dans un bridge.
br0 composé de eth0 et wlan1


le log du boot me dit :
rt61pci 0000:01:0a.0: PCI INT A -> Link[APC1] -> GSI 16 (level, high) ->
IRQ 16
wlan0 (rt61pci): not using net_device_ops yet
Registered led device: rt61pci-phy0:radio
Registered led device: rt61pci-phy0:assoc
cfg80211: World regulatory domain updated:
(start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
(2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
(2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
(2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
(5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
(5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
udev: renamed network interface wlan0 to wlan1


Voilà, maintenant, j'aimerais faire de mon PC un point d'accès en WPA-PSK.

J'ai tenté tout ce que j'ai trouvé sur internet (notamment le tuto sur
lea-linux concernant une G520) mais il n'y a pas moyen, hostapd dit que ma
carte est bien configurée en point d'accès SSID 'Maison', mais je n'arrive
pas à "voir" ce réseau depuis mes autres PC Wifi

J'ai mis ça dans hostapd.conf :
Code:
interface=wlan1
bridge=br0
driver=wired
..
dump_file=/tmp/hostapd.dump
ctrl_interface=/var/run/hostapd
ctrl_interface_group=0
ssid=Maison
country_code=FR
ieee80211d=1
hw_mode=g
..
wpa=1
wpa_passphrase2345678901234567890123456789
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP


Quand je démarre avec le driver wired ou nl80211, j'ai :
Code:
Using interface wlan1 with hwaddr 00:22:b0:75:a0:9a and ssid 'Maison'

J'ai ça dans les logs mais rien de plus :
Code:
hostapd: wlan1: IEEE 802.11 Fetching hardware channel/rate support not
supported.


Problème de quoi ?

Merci de votre aide parce que j'ai tout essayé en vain.

Lolotte
--
(enlever pasdespam pour répondre)
http://www.dansmongrenier.com/ : les pages du manuel, les newsgroups,
recherche whois, les codes postaux, des jeux et plein d'autres bêtises
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
newsreader
Le #19324601
Précédemment, Lolotte a écrit :
Bonjour,

J'ai une carte DWA-510 reconnue par le driver rt61pci que j'ai associée à
ma carte ethernet dans un bridge.
br0 composé de eth0 et wlan1


le log du boot me dit :
rt61pci 0000:01:0a.0: PCI INT A -> Link[APC1] -> GSI 16 (level, high) ->
IRQ 16
wlan0 (rt61pci): not using net_device_ops yet
Registered led device: rt61pci-phy0:radio
Registered led device: rt61pci-phy0:assoc
cfg80211: World regulatory domain updated:
(start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
(2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
(2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
(2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
(5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
(5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
udev: renamed network interface wlan0 to wlan1


Voilà, maintenant, j'aimerais faire de mon PC un point d'accès en WPA-PSK.

J'ai tenté tout ce que j'ai trouvé sur internet (notamment le tuto sur
lea-linux concernant une G520) mais il n'y a pas moyen, hostapd dit que ma
carte est bien configurée en point d'accès SSID 'Maison', mais je n'arrive
pas à "voir" ce réseau depuis mes autres PC Wifi...

J'ai mis ça dans hostapd.conf :
Code:
interface=wlan1
bridge=br0
driver=wired
...
dump_file=/tmp/hostapd.dump
ctrl_interface=/var/run/hostapd
ctrl_interface_group=0
ssid=Maison
country_code=FR
ieee80211d=1
hw_mode=g
...
wpa=1
wpa_passphrase2345678901234567890123456789
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP


Quand je démarre avec le driver wired ou nl80211, j'ai :
Code:
Using interface wlan1 with hwaddr 00:22:b0:75:a0:9a and ssid 'Maison'

J'ai ça dans les logs mais rien de plus :
Code:
hostapd: wlan1: IEEE 802.11 Fetching hardware channel/rate support not
supported.


Problème de quoi ?

Merci de votre aide parce que j'ai tout essayé en vain.

Lolotte



Bon désolé pour le formatage du premier envoi.

Pour info, avant lancement de hostapd iwconfig donne :
wlan1 IEEE 802.11bg Mode:Master Frequency:2.412 GHz Tx-Power dBm
Retry min limit:7 RTS thr#47 B Fragment thr#46 B
Encryption key:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
Et après :
wlan1 IEEE 802.11bg Mode:Master Frequency:2.412 GHz Tx-Power dBm
Retry min limit:7 RTS thr#47 B Fragment thr#46 B
Encryption
key:5036-A531-17F1-7551-B211-90DD-A238-D493-F624-BBC3-14FB-4BD8-7628-878B-89EE-76CA
[2]
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

mon.wlan1 IEEE 802.11bg Mode:Monitor Frequency:2.412 GHz Tx-Power
dBm
Retry min limit:7 RTS thr#47 B Fragment thr#46 B
Encryption key:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

On voit que hostapd a crée un mon.wlan1 et qu'il y a une clé mais côté
Link, Signal et tout ce qui suit, c'est pas la joie...

Lolotte
--
(enlever pasdespam pour répondre)
http://www.dansmongrenier.com/ : les pages du manuel, les newsgroups,
recherche whois, les codes postaux, des jeux et plein d'autres bêtises...
newsreader
Le #19328181
Bon, c'est bon, avec le driver nl80211 y a pas d'erreurs dans les logs et
la diode de la carte clignote.

Le vrai problème était en fait le paramètre channel par défaut à 60 que
j'ai mis à 10.

Ca marche nickel !

J'ai autorisé le FORWARD entre mon bridge br0 et lui-même et j'ai donc
accès aux autres machines du réseau.

Il faut maintenant juste que je trouve pourquoi squid et/ou dansguardian
rament pour envoyer les réponse aux requêtes HHTP aux clients qui sont sur
le Wifi...

Lolotte
--
(enlever pasdespam pour répondre)
http://www.dansmongrenier.com/ : les pages du manuel, les newsgroups,
recherche whois, les codes postaux, des jeux et plein d'autres bêtises...
Publicité
Poster une réponse
Anonyme