WiFi

Le
Roger Cahn
Bonsoir,

J'ai un nouveau PC avec carte-mère AsusP5K-E WiFi-AP Édition
et une Gentoo installée depuis peu.
Je ne parviens pas à me connecter à Internet avec ma Club-Internet Box.

Le module est rtl8187
Dans /etc/conf.d/net j'ai mis, avec le essid et une clé wep,:
config_wlan0=( "dhcp" )
mode managed
channel 11

Un ping 192.168.1.1 répond bien et dans lsmod j'ai:
rtl8187 34880 0
mac80211 109324 1 rtl8187
cfg80211 13320 1 mac80211
eeprom_93cx6 2560 1 rtl8187

Un iwconfig montre Access Point: not-associated

Comment parvenir à me connecter?
Merci pour votre aide
Roger
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
O 3
Le #1916944
"Roger Cahn" news:47ec1579$0$21151$
Bonsoir,

J'ai un nouveau PC avec carte-mère AsusP5K-E WiFi-AP Édition
et une Gentoo installée depuis peu.
Je ne parviens pas à me connecter à Internet avec ma Club-Internet Box.

Le module est rtl8187
Dans /etc/conf.d/net j'ai mis, avec le essid et une clé wep,:
config_wlan0=( "dhcp" )
mode managed
channel 11

Un ping 192.168.1.1 répond bien et dans lsmod j'ai:
rtl8187 34880 0
mac80211 109324 1 rtl8187
cfg80211 13320 1 mac80211
eeprom_93cx6 2560 1 rtl8187

Un iwconfig montre Access Point: not-associated

Comment parvenir à me connecter?
Merci pour votre aide
Roger


ça s'annonce mal...

Mihamina Rakotomandimby
Le #1916935
O 3 wrote:
Comment parvenir à me connecter?
ça s'annonce mal...

T'es vraiment nul, toi.


Sinon, pour faire avancer le shmilblick, Roger peut utiliser 'iwconfig'
manuellement avec une ligne du _genre_ (ma machine actuelle n'a pas de
Wifi et pas d'utilitaires installés):

# iwconfig wlan0 scanning

Pour lister les reseaux Wifi disponibles.
(si la box diffuse le sien)

# iwconfig wlan0 ssid "le_nom_de_reseau"
(le nom de reseau est annoncé quelquepart sur la box ou un bout de
papier si elle ne diffuse rien)
Pour s'associer au réseau de ton choix.

Là, il faut "entrer" la clé WEP (si le modem utilise WEP).
Il y a la commande toute faite pour ça (# iwconfig wlan0 ....)

Moi je conseillerais de reconfigurer le modem pour qu'il n'utilise pas
de cryptage (ni qu'il n'empeche pas de diffuser son SSID) pour un début.
On peut toujours reconfigurer tout ça ensuite.

--
Huile Essentielle de Camphre http://www.huile-camphre.fr
Infogerance http://www.infogerance.us
(Serveurs, Postes de travail, Développement logiciel)


Roger Cahn
Le #1918500
O 3 wrote:
Comment parvenir à me connecter?
ça s'annonce mal...

T'es vraiment nul, toi.



Effectivement, la réponse n'est pas très constructive ;-(

Moi je conseillerais de reconfigurer le modem pour qu'il n'utilise pas
de cryptage (ni qu'il n'empeche pas de diffuser son SSID) pour un début.
On peut toujours reconfigurer tout ça ensuite.


Pour le moment toujours pas de solution :-(
Merci pour la réponse
Roger



Mihamina Rakotomandimby
Le #1963997
Roger Cahn wrote:
Pour le moment toujours pas de solution :-(


Tu pourrais déjà commencer par faire un rapport des resultats obtenus
par ce que je te conseille.

--
Huile Essentielle de Camphre http://www.huile-camphre.fr
Infogerance http://www.infogerance.us
(Serveurs, Postes de travail, Développement logiciel)

Roger Cahn
Le #1963995
Roger Cahn wrote:
Pour le moment toujours pas de solution :-(


Tu pourrais déjà commencer par faire un rapport des resultats obtenus
par ce que je te conseille.


Excuse-moi pour ma "mauvaise" réponse.
J'ai fait ce que tu as conseillé, y compris désactiver la clé wep
sur la club-internet box.
Je n'ai pas pu me connecter.
Même lorsque la clé est mise, elle n'est pas trouvée! Vois la réponse:

/etc/init.d/net.wlan0 start
* Starting wlan0
* Configuring wireless network for wlan0
* WEP key is not set for "TECOM-AH4222-xxxxxx" - not connecting
* Couldn't associate with any access points on wlan0
* Failed to configure wireless for wlan0

Merci encore pour ton aide
Roger


Mihamina Rakotomandimby
Le #1964139
Roger Cahn wrote:
Pour le moment toujours pas de solution
Tu pourrais déjà commencer par faire un rapport des resultats obtenus

par ce que je te conseille.
Excuse-moi pour ma "mauvaise" réponse.



Je t'enprie...

J'ai fait ce que tu as conseillé, y compris désactiver la clé wep
sur la club-internet box.
Je n'ai pas pu me connecter.
Même lorsque la clé est mise, elle n'est pas trouvée! Vois la réponse:
/etc/init.d/net.wlan0 start


Oui, mais là, tu utilise la machinerie Gentoo.
Moi, ce que je conseillais, c'est de ne pas utiliser la machinerie, mais
d'y aller par un niveau plus bas.

Cependant, on peut quand même commenter quelquechose

* Starting wlan0
* Configuring wireless network for wlan0
* WEP key is not set for "TECOM-AH4222-xxxxxx" - not connecting


Là, moi je vois que tu as déclaré quelquepart que le réseau est un
réseau crypté, mais tu n'a pas renseigné la clé. tu dois donc revoir ta
déclaration et dire que c'est un réseau non crypté.

En aucun cas, ça ne dit que la clé n'est aps reconnue.

--
Huile Essentielle de Camphre http://www.huile-camphre.fr
Infogerance http://www.infogerance.us
(Serveurs, Postes de travail, Développement logiciel)



Ptitjack
Le #1964273
Mihamina Rakotomandimby a gentiment tapote:

Cependant, on peut quand même commenter quelquechose

* Starting wlan0
* Configuring wireless network for wlan0
* WEP key is not set for "TECOM-AH4222-xxxxxx" - not connecting


Là, moi je vois que tu as déclaré quelquepart que le réseau est un
réseau crypté, mais tu n'a pas renseigné la clé. tu dois donc revoir ta
déclaration et dire que c'est un réseau non crypté.

En aucun cas, ça ne dit que la clé n'est aps reconnue.



Oui, il faut commenter la ligne déclarant la clé wep dans /etc/conf.d/net

--
Jacques


Publicité
Poster une réponse
Anonyme