WiFi sous Linux

Le
Bernard
Bonjour à tous,

Le WiFi, sous Linux, ce n'est pas gagné ! A voir les contrib dans ce
groupe, ce n'est pas évident non plus sous MSWIN.

Sur mon PC de bureau (Debian Sarge) çà fonctionne sans problème sur
le WiFi de ma Livebox A l'époque (il y a 4 mois environ), la config
n'avait pas été facile et la doc difficile à trouver, celle qu'on finit
par trouver devant être interprétée car, d'un système à l'autre et
d'une version à l'autre çà change. Cà fonctionne donc sur ma
Livebox mais pas ailleurs. Ayant transporté mon PC dans une salle
d'expo, je n'ai pas réussi à me connecter au WiFi local avec les
paramètres qui m'avaient été fournis. Sur les quelque 30 PC connectés
dans cette salle, dont 3 linuxiens, seulement la moitié environ avaient
réussi à obtenir une connexion, dont aucun linuxien (cryptage WPA). En
fait c'est très compliqué ces connexions sécurisées, et il est bien
rare de savoir comment remplir tous les paramètres: chiffrement TKIP ou
non des paswords qui ne conviennent pas (trop longs ou trop courts,
avec ou sans guillemets reconnaissance MAC ou non.. déjà qu'on ne
sait pas toujours trop bien ce que çà signifie exactement, ni où l'on
se situe par rapport à son propre matos et par rapport à celui du
routeur WiFi

en fait, il faudrait pouvoir faire des essais mais le jour d'un salon
ce n'est pas possible, car c'est la pression et la veille, si l'on est
autorisé à venir installer son matos, en général le WiFi n'est pas
activé. Et ce n'est pas parce qu'on a réussi à faire fonctionner cela
chez soi avec son routeur Livebox ou autre, que cela sera pour autant
opérationnel dans d'autres conditions.

Or, où trouver un contexte permettant d'aller essayer son PC sur un
réseau WiFi public en WPA ? Dans un lieu public ? Lesquels offrent
pareille possibilité ? A Paris peut-être ? J'irais volontiers si je
savais où aller pour faire des essais de connexion avec mon PC portable.
Où encore ? Dans un hôtel ? Dommage d'aller prendre une chambre rien
que pour cela, surtout si, au bout du compte, il s'avère que cela ne
fonctionne pas, ou encore, qu'il s'agissait d'un cryptage WEP, voire
d'un non cryptage

Merci d'avance pour vos tuyaux et recommandations
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Eric Masson
Le #18363411
Bernard
'Lut,

Le WiFi, sous Linux, ce n'est pas gagné !



Avec un noyau récent, ça s'améliore (mac80211), avant cela mis à part
pour les cartes supportées par MADWifi ou Host AP, c'était vraiment pas
terrible.

Or, où trouver un contexte permettant d'aller essayer son PC sur un
réseau WiFi public en WPA ?



En achetant un routeur ou un AP qui fournit le support WPA/WPA2 et en
faisant des tests (il est possible de prendre n'importe quel hard
supporté par OpenWRT, les possibilités de configuration wireless
permettent alors d'avoir une couverture très large des configurations
susceptibles d'être rencontrées)

Idéalement, pour le wireless, il faut disposer d'un noyau récent d'une
carte supportée sous mac80211 :
http://wireless.kernel.org/en/users/Devices
http://wireless.kernel.org/en/users/Drivers
Et de la doc plus générale :
http://wireless.kernel.org/en/users/Documentation

En Debian, une Lenny serait probablement la branche qui disposerait du
meilleur support wireless.

--
B: Quelqu'un a-t-il déjà fait fonctionner ce modem sous linux ????
G.P.: Je me demande si ça ne marcherait pas en faisant un proxy
avec un vieux PC sous Windows en réseau avec un PC sous Linux.
-+- in Guide de linuxien pervers : "le réseau, c'est simple comme un proxy"
Ludovic - F5PBG
Le #18365221
>
Le WiFi, sous Linux, ce n'est pas gagné !




Je viens d'installer le WiFi sur un PC sur lequel
j'ai placé Ubuntu. Il s'agissait d'utiliser la clé
WiFi (a priori premier modèle du genre) sur
une livebox.

Cela m'a pris de l'ordre d'une quinzaine de
minute, le temps de trouver les drivers via
Google.

A+
Ludovic.
Olivier Masson
Le #18375021
Ludovic - F5PBG a écrit :
Le WiFi, sous Linux, ce n'est pas gagné !




Je viens d'installer le WiFi sur un PC sur lequel
j'ai placé Ubuntu. Il s'agissait d'utiliser la clé
WiFi (a priori premier modèle du genre) sur
une livebox.

Cela m'a pris de l'ordre d'une quinzaine de
minute, le temps de trouver les drivers via
Google.

A+
Ludovic.



J'ai décidé d'utiliser linux pour mes postes de travail (uniquement mes
serveurs étaient sous Debian).
1 sous Ubuntu 8.10, l'autre sous Debian Lenny.
Le premier a eu le wifi fonctionnel pendant 2 ou 3 mois mais ne
s'arrêtait qu'une fois sur 20 (bien évidemment, j'ai passé quelques
heures à TOUT modifier ; mais ce serait un problème... de carte
graphique. Rien ne ressort en log) puis plus rien, du jour au lendemain,
côté wifi. Tout parfait sous XP.
Le second a eu le 54g à un débit exceptionnel de 1Mb/s (routeur wifi à
2m. pour les tests). J'ai installé tout ce qu'on m'a conseillé puis
déconseillé, puis tout, puis rien. Au final ? Plus de wifi et toujours
rien qd j'installe un package tout joli.

Bref, linux hors ligne de commande, c'est toujours aussi... sujet à troll :)
droopy191
Le #18377411
Ludovic - F5PBG wrote:
Le WiFi, sous Linux, ce n'est pas gagné !




Je viens d'installer le WiFi sur un PC sur lequel
j'ai placé Ubuntu. Il s'agissait d'utiliser la clé
WiFi (a priori premier modèle du genre) sur
une livebox.

Cela m'a pris de l'ordre d'une quinzaine de
minute, le temps de trouver les drivers via
Google.




Salut,

Je suis a peu de chose près dans le meme cas. Cependant à chaque mise à
jour du kernel, il faut recompiler les drivers. C'est pas gérable par un
débutant.

--
DR
Bernard
Le #18386821
Le Mon, 12 Jan 2009 00:21:23 +0100, a écrit :


Le WiFi, sous Linux, ce n'est pas gagné !




Je viens d'installer le WiFi sur un PC sur lequel j'ai placé Ubuntu. Il
s'agissait d'utiliser la clé WiFi (a priori premier modèle du genre)
sur une livebox.

Cela m'a pris de l'ordre d'une quinzaine de minute, le temps de trouver
les drivers via Google.



Le laptop que je viens d'acheter (DELL Inspiron) m'a été livré avec
Ubuntu 8.04 tout installé. Au début, la connexion WiFi ne fonctionnait
pas. Mon réseau Livebox était bien détecté (ainsi que ceux de mes
voisins), mais pas moyen de faire reconnaître le pswd. Et puis, après
moultes essais, çà s'est soudainement mis à fonctionner et, depuis
lors, çà se connecte à chaque démarrage, et ce, très rapidement et
çà reste très stable. Au début, je ne comprenais pas ce qui avait si
soudainement et si radicalement décidé mon système d'accepter cette
connexion, alors qu'auparavant ce n'étaient que refus obstinés.
Peut-être est-ce dû à l' "easy-pairing" : je ne suis pas bien certain
de tout comprendre ce que c'est. Il s'agit sans doute d' "apparier" le
routeur avec la machine à connecter : désormais l'adresse MAC de mon
laptop apparaît dans la config de ma Livebox, sans pour autant que je l'y
aie manuellement inscrite. Je pense qu'à la première connexion, après
avoir tapé le pasword qui vous est demandé, il faut faire un "REG" (ou
"REC") de sa Livebox en appuyant sur le bouton idoine durant au moins 5
secondes, puis attendre que les voyants cessent de clignoter, puis
débrancher et rebrancher et attendre à nouveau la stabilité des voyants
(RESET ?). Ceci ayant été fait, toute nouvelle connexion se fait
automatiquement, sans que le PSWD me soit demandé.

Problem is... je ne sais pas comment ce système va se comporter lorsqu'il
sera question de le connecter sur un autre réseau. Il n'y aura alors sans
doute pas d'Easy Pairing. Normalement, l'Easy Pairing n'est (sauf erreur
de ma part) qu'une commodité et, sans elle, la connexion devrait se
faire, à condition d'entrer chaque fois le mot de passe... mais ici cela
ne fonctionnait pas ; çà n'arrètait pas de me demander le mot de passe
; c'est sans doute que celui que je donnais n'était pas le bon, le bon
étant sans doute une sorte de compilation du mot de passe en question
avec le SSID et/ou les données MAC de l'une/ou/et l'autre machine... mais
comme je n'y comprends rien (doc difficile à trouver et jamais tout à
fait pertinente), je n'ai pas su trouver quoi entrer comme mot de passe.
J'ai trouvé quelque part un module permettant de calculer un mot de passe
hexadécimal à partir d'un SSID et d'une pasphrase... mais ce que j'ai
obtenu était trop long et ne fonctionnait pas. Je précise que le mot de
passe (passphrase) dont je dispose est le bon, qu'il est bien écrit comme
tel dans la Livebox lorsqu'on y entre via Firefox à l'adresse
192.168.1.1, et, par ailleurs, ce mot de passe fonctionne en WiFi sur mon
PC de bureau sous Debian Sarge (mais pas avec exactement les mêmes
commandes que sous Ubuntu, et celles ci ne sont pas reconnues sous ce
système).

Or donc, alors que çà fonctionne désormais parfaitement bien sur le
réseau WiFi de ma Livebox, et souhaitant essayer d'autres réseaux, j'ai
voulu bricoler avec les moyens du bord et, pour commencer, tâché de
créer un réseau wifi à partir d'un petit routeur bon marché, qu'on
appelle 'FONERA', dont je n'avais jusqu'ici pas fait grand usage. J'ai
donc relié ce routeur à ma Livebox grâce au câble Ethernet prévu pour
cela. Ceci étant fait, il y avait bien un nouveau réseau visible avec un
ssid "dd-wrt", qui s'affichait en même temps que ma Livebox et les
réseaux de mes voisins. J'ai d'abord essayé de me connecter à dd-wrt
sans cryptage, puis j'ai fait d'autres essais après être allé
bidouillé à l'intérieur de la FONERA (169.254.255.1) et y avoir
installé un mot de passe WPA de 10 chiffres (c'est ce qui était
recommandé dans une doc).

Eh bien, que ce soit sans cryptage, ou avec cryptage WPA, les résultats
ont été les mêmes, à ceci près que, dans le second cas, le système
m'a demandé de produire le pasword, lequel a été reconnu et a produit
une connexion... bidon ! Le passage du pointeur de la souris sur
l'icône Gnome-Ubuntu de la connexion WiFi, révélait une connexion, avec
un taux de 86 à 92%... Seul problème, la connexion n'était pas
opérationnelle ; Firefox recherche indéfiniment les sites distants.
Même une tentative ftp purement chiffrée n'a pas aboutit, ce qui tend à
démontrer qu'il ne s'agit pas d'un problème de DNS. Cà, c'est donc avec
mon laptop DELL sous Ubuntu 8.04. J'ai voulu tester ce réseau WiFi FONERA
avec mon desktop sous Debian Sarge, et j'ai également eu le même
résultat : une connexion bidon, et, enfin, sur le même PC, tentative de
connexion avec MSWIN (XP) => même résultat, l'icône vire bien au vert
et confirme une bonne connexion sur la FONERA (dd-wrt), mais c'est
inutilisable.

Merci d'avance à qui pourra m'aiguiller vers une explication/solution de
ce problème.
Ludovic - F5PBG
Le #18395461
>>
Je viens d'installer le WiFi sur un PC sur lequel
j'ai placé Ubuntu. Il s'agissait d'utiliser la clé
WiFi (a priori premier modèle du genre) sur
une livebox.

Cela m'a pris de l'ordre d'une quinzaine de
minute, le temps de trouver les drivers via
Google.




Je suis a peu de chose près dans le meme cas. Cependant à chaque mise à
jour du kernel, il faut recompiler les drivers. C'est pas gérable par un
débutant.




Je débute en Linux pour ma part... C'est la seule
config que j'ai réalisée (Je n'aime pas Linux...).
Ce n'est pas vraiment la mer à boire, je n'ai fait
que suivre des liens Google.

Certes, cela fait plus de 20 ans que je "m'amuse"
en informatique (programmation en assembleur
au tout début...).

A+
Ludovic.
prenom.nom
Le #18466221
Ludovic - F5PBG wrote :

Je débute en Linux pour ma part... C'est la seule
config que j'ai réalisée (Je n'aime pas Linux...).



MDR ! Ca fait des années que tu nous bassines avec
tes débuts en Linux...... Déjà du temps du packet
tu la ramenais avec ca. M'étonne pas que tu n'aime
pas, t'a pas le niveau.
Publicité
Poster une réponse
Anonyme