win 98, éthernet et veille ACPI : sac d'embrouilles

Le
NimbUs
Chers amis, j'ai un PC exploité sous Win 98 SE qui fonctionne à ma
pleine satisfaction (dans les limites de ce qu'on peut attendre d'un
OS de Microsoft, s'entend).

J'observe donc ceci, qui ressemble bien à un "bug" :

- PC avec Windows 98 SE,
- connecté via ethernet à un modem-routeur-commutateur ("switch" en
franglais)
- recevant ses coordonnées IP du serveur DHCP intégré à la bête
ci-dessus (dite Speedtouch 510).

Du grand classique rétro, même pas de sans fil ;=)

Venons-en au problème qui m'enquiquine :

- je passe le PC en "veille ACPI" en appuyant sur le bouton ad-hoc.
- si la période de veille est relativement courte - à savoir,
probablement,
inférieure à la durée à courir du "bail" DHCP, aucun problème au
réveil;

- si en revanche j'attends quelques heures avant de réveiller le PC,
l'adaptateur ethernet n'a plus d'IP, ou plus exactement, Windows
semble avoir /perdu/ l'adaptateur ethernet : il n'apparaît même plus
dans WinIPcfg par exemple ! Pas moyen donc de relâcher/renouveler le
bail.

A part ce "petit" ennui, Windows fonctionne normalement - je précise
bien que je n'ai pas un de ces problèmes bien connus de PC qui
n'arrivaient pas à sortir de l'état de veille
Mais plus de carte ethernet utilisable (elle est toujours visible
dans le gestionnaire de périphériques, heureusement).

- Je suis obligé de /relancer/ Wndows pour qu'il 'retrouve' la
carte-réseau, refasse une diffusion DHCP et tout baigne de
nouveau

Naturellement ce porblème rend peu attrayant l'usage de la veille
ACPI ! Je peux vivre sans, bien sûr! mais ma nature curieuse me
pousse à vous demander si ces symptomes évoquent quelque chose pour
vous, si c'est un "bug" connu (ou une limitation) de Windows 98 SE
? Et s'il y aurait moyen d'y remédier

Salut à tous et clin d'oil aux anciens !

--
//imbUs (sans email - jadis @oreka.com)
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Sergio
Le #16782051
NimbUs avait énoncé :

- je passe le PC en "veille ACPI" en appuyant sur le bouton ad-hoc.
- si la période de veille est relativement courte - à savoir,
probablement,
inférieure à la durée à courir du "bail" DHCP, aucun problème au
réveil;

- si en revanche j'attends quelques heures avant de réveiller le PC,
l'adaptateur ethernet n'a plus d'IP, ou plus exactement, Windows
semble avoir /perdu/ l'adaptateur ethernet : il n'apparaît même plus
dans WinIPcfg par exemple ! Pas moyen donc de relâcher/renouveler le
bail.

A part ce "petit" ennui, Windows fonctionne normalement - je précise
bien que je n'ai pas un de ces problèmes bien connus de PC qui
n'arrivaient pas à sortir de l'état de veille...
Mais plus de carte ethernet utilisable (elle est toujours visible
dans le gestionnaire de périphériques, heureusement).

- Je suis obligé de /relancer/ Wndows pour qu'il 'retrouve' la
carte-réseau, refasse une diffusion DHCP et... tout baigne de
nouveau...



À tout hasard, dans le gestionnaire de périphériques, y'a pas un truc à
régler concernant la mise en veille de la carte éthernet ?

--
Serge http://leserged.online.fr/
Mon blog: http://cahierdesergio.free.fr/
Soutenez le libre: http://www.framasoft.org
NimbUs
Le #16782571
"Sergio" a écrit ...

- je passe le PC en "veille ACPI" en appuyant sur le bouton




ad-hoc.

- si en revanche j'attends quelques heures avant de réveiller le




PC,
l'adaptateur ethernet n'a plus d'IP, ou plus exactement, Windows
semble avoir /perdu/ l'adaptateur ethernet : il n'apparaît même




plus
dans WinIPcfg par exemple ! Pas moyen donc de relâcher/renouveler




le
bail.





À tout hasard, dans le gestionnaire de périphériques, y'a pas un


truc à
régler concernant la mise en veille de la carte éthernet ?



Bonjour Sergio ! Bonne idée, mais, non! j'ai équipé ce relativement
vieux PC d'une carte ISA bien connue (non plug & play) Etherlink III
3C509. Aucune option relative à la mise en veille n'apparaît dans le
gestionnaire de périphs.


--
//imbUs (sans email - jadis @oreka.com)
_Dine & Clau_
Le #17674191
"NimbUs" news:48c8007b$0$896$:

Du grand classique rétro, même pas de sans fil ;=)


Architecture de ta machine : 80486, pentium 4, amd athlon ???

Venons-en au problème qui m'en...quiquine :


1ère raison : trop de quinquina ! ;+)

- je passe le PC en "veille ACPI" en appuyant sur le bouton
ad-hoc. - si la période de veille est relativement courte - à
savoir, probablement,



Voir la répartition des adresses mémoires irq (requêtes
d'interruption du processeur!) Il ne m'étonnerait pas de voir en irq
0 ce qui doit obligatoirement se trouver en irq 14 et 15 soit la
gestion des canaux ide primaires et secondaires (je n'ai pas de win98
sous la main...) à contrôler en employant le clic D sur le poste de
travail : propriétés de l'ordinateur. Autre façon : msinfo32 : liste
des irq.

inférieure à la durée à courir du "bail" DHCP, aucun problème au
réveil;



Justement, de ce côté; essaie plutôt sans attribution des adresses ip
automatiques. "Services.msc" et désactiver le service dhcp.
Introduire les adresses ip en dur sur le modem routeur firewall et
sur ton pc avec les adresses privées 192.168.1.1 pour le modem et
192.168.1.2 pour le pc.

Une gestion manuelle peut aussi supprimer le problème : établir la
connexion et désactiver la connexion. (même si dhcp le bail reprend
une durée à chaque nouvelle connexion ...)

- si en revanche j'attends quelques heures avant de réveiller le
PC, l'adaptateur ethernet n'a plus d'IP, ou plus exactement,
Windows semble avoir /perdu/ l'adaptateur ethernet : il
n'apparaît même plus dans WinIPcfg par exemple ! Pas moyen donc
de relâcher/renouveler le bail.




- Je suis obligé de /relancer/ Wndows pour qu'il 'retrouve' la
carte-réseau, refasse une diffusion DHCP et... tout baigne de
nouveau...



Salut à tous et clin d'oil aux anciens !


~~~~
Merci, cela fait du bien quand on voit le prix du litre à l'heure
actuelle ! ;) Mais t'aurais pu en mettre un peu plus qu'un clin ;+))
__
CB Camarade Lukoil ;+)))
C&C
Publicité
Poster une réponse
Anonyme