[Win XP] plusieurs problèmes liés (vraisemblablement) à une corruption des paramètres de sécurité

Le
Bidule Obsolète
{ Principaux problèmes :
- impossible d'accéder au gestionnaire des disques de Windows
- disque neuf reconnu par le système mais création de partition et formatage
par Acronis Disk Director échoue (vraisemblablement lié au pb précédent)
- Windows Installer inaccessible }

Il y a une semaine, après des opérations de conversion de fichiers vidéo,
qui ont plusieurs fois causé un remplissage à ras-bord de la partition
système (ce qui est très déconseillé -- maintenant je sais pourquoi),
plusieurs programmes ont cessé de fonctionner (je ne me souviens plus du
message exact, installation défectueuse, réinstallez, quelque chose dans ce
genre), puis plantage, écran bleu, redémarrage, vérification CHKDSK
Jusque là, c'était très énervant mais pas franchement inquiétant.
Brusquement, ont commencé à apparaître de nombreux messages d'erreur :

« Les attributs de type 0x80 et de balise d'instance 0x0 dans le fichier 0x9
ont une longueur allouée de 0xd5000 au lieu de 0xd6000.
L'entrée de liste d'attributs endommagée de type de code
128 dans le fichier 9 a été supprimée.
Impossible de localiser l'attribut de balise d'instance 0x0 et de référence
de segment 0x100000000369e. Le type d'attribut attendu est 0x80.
Suppression de l'enregistrement d'attribut endommagé (128, $SDS)
du segment d'enregistrement de fichier 13982.
L'enregistrement d'attribut de type 0x80 et de balise d'instance 0x3 a un
lien croisé
qui commence à 0x280031 pour 0x3fb clusters éventuels.
Correction de la référence croisée du fichier 26007.
Nettoyage en cours de petites incohérences sur le lecteur.
Le flux de données de sécurité est manquant du fichier 0x9.
La taille du flux de données de sécurité 0x0 ne devrait pas être inférieure
à 0x40000.
Réparation du segment d'enregistrement du fichier de sécurité.
Suppression d'une entrée d'index avec l'ID 256 à partir de l'index $SII du
fichier 9.
Suppression d'une entrée d'index avec l'ID 257 à partir de l'index $SII du
fichier 9.
Suppression d'une entrée d'index avec l'ID 258 à partir de l'index $SII du
fichier 9. [] »

Ensuite l'écran s'est rempli d'une liste littéralement interminable de
lignes de la forme :
« Remplacement de l'id de sécurité erroné par l'id de sécurité par défaut
pour le fichier xxx »

Cela s'est poursuivi pendant plusieurs heures (j'ai laissé tourner et suis
allé dormir, non sans flipper à l'idée du bazar que ce processus était en
train de me foutre, mais craignant des problèmes bien plus graves au cas où
je l'interromprais -- et manifestement, bien m'en a pris : d'après ce que
j'ai pu lire ensuite, certains qui ont eu le même problème ont complètement
bousillé leur système en éteignant la machine à la sauvage au cours de cette
opération).

Ensuite, une nuée de problèmes : plus de barre des tâches, copier-coller
impossible, la plupart des programmes refusaient de se lancer

A force de patience et de recherches (essentiellement sur des forums
anglophones -- sur les forums en français il est généralement conseillé de
formater et tout réinstaller), j'ai fini par résoudre la plupart de ces
problèmes ; cette page notamment m'a bien aidé :
http://forums.majorgeeks.com/showthread.php?t8462
J'ai essayé à la suite plusieurs solutions proposées, je ne saurais dire
exactement lesquelles ont résolu tel ou tel problème. Apparemment la
commande "cacls c: /g everyone:F /c /t" aurait rétabli les droits d'accès
aux fichiers du système, et donc la plupart des fonctions défectueuses
(c'est un domaine dont je n'ai qu'une connaissance très approximative,
n'hésitez pas à rectifier ou compléter).

MAIS quelques problèmes persistent :
- Il m'est toujours impossible d'installer des programmes nécessitant le
service Windows Installer : celui-ci est déclaré inaccessible. J'ai tenté la
réinscription dans le registre (msiexec /unregister puis msiexec
/regserver), sans succès ; les droits d'accès semblent correctement définis.
- Le partitionnement d'un nouveau disque dur branché en eSATA avec Acronis
Disk Director a échoué, j'obtiens un message « Failed to write to the sector
XXXXXX ». Or le disque est reconnu par le système et je ne pense pas qu'il
soit défectueux. Je pense plutôt que ce problème est lié à cet autre : il
m'est impossible d'accéder au gestionnaire de disques de Windows, « Vous
n'avez pas de droits d'accès au gestionnaire de disques logiques ». J'ai
pourtant récupéré les droits d'accès sur l'ensemble du dossier Windows.
Peut-être y a-t-il quelque chose à rétablir au niveau de la base de registre
? Ou quoi d'autre ?


Merci pour vos suggestions.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
DuboisP
Le #20945871
Le Sun, 10 Jan 2010 22:06:14 +0100, Bidule Obsolète


- Il m'est toujours impossible d'installer des programmes nécessitant le
service Windows Installer : celui-ci est déclaré inaccessible. J'ai
tenté la
réinscription dans le registre (msiexec /unregister puis msiexec
/regserver), sans succès ; les droits d'accès semblent correctement
définis.




peut-être une installation bloquée
essayer WindowsInstallerCleanupUtility.exe
ça se trouve sans trop de problème chez Microsoft


--
Utilisant le client e-mail révolutionnaire d'Opera :
http://www.opera.com/mail/
Jacques Dassié
Le #20946951
Le Sun, 10 Jan 2010 22:06:14 +0100, "Bidule Obsolète"


Merci pour vos suggestions.



Sans pouvoir t'aider, on ne peut que constater que ton sytème est dans une
merde noire... et compatir.
Dans un cas similaire, je m'en suis toujours sorti bien simplement en
restaurant C: et parfois C: et D: à partir d'images de sauvegarde faites au
moins sur un second disque dur. On les restaure à partir d'un CD de boot
créé par les programmes de sauvegarde 'Acronis, Paragon etc). Ce CD démarre
l'ordi d'un façon totalement indépendante de Windows et boote donc sans
jamais de problème.
Bien entendu, ces sauvegardes se concoctent avant la caraffe...
Je te souhaite d'avoir eu cette prudence.
--
Jacques DASSIÉ
http://archaero.com/sauvegarde.htm
Bidule Obsolète
Le #20951381
"Jacques Dassié" message de news:

Sans pouvoir t'aider, on ne peut que constater que ton sytème est dans une
merde noire... et compatir.




Il y a pire... Je peux écrire ce message, et utiliser à nouveau la
quasi-totalité des applications sans souci. Je pense m'en être déjà plutôt
bien sorti, par rapport à ce que j'ai pu lire au sujet de ce genre de "merde
noire".


Dans un cas similaire, je m'en suis toujours sorti bien simplement en
restaurant C: et parfois C: et D: à partir d'images de sauvegarde faites
au
moins sur un second disque dur. On les restaure à partir d'un CD de boot
créé par les programmes de sauvegarde 'Acronis, Paragon etc). Ce CD
démarre
l'ordi d'un façon totalement indépendante de Windows et boote donc sans
jamais de problème.
Bien entendu, ces sauvegardes se concoctent avant la caraffe...
Je te souhaite d'avoir eu cette prudence.




Bah nan, ou du moins la plus récente sauvegarde est trop ancienne pour être
plus judicieuse qu'une réinstallation complète. Si je dois le faire (il
faudra bien, tôt ou tard), j'aimerais au moins au préalable partitionner et
formater proprement ce nouveau disque pour y faire une sauvegarde intégrale.
Et pour ça, apparemment, il me faut rétablir les droits d'accès au
gestionnaire de disques.

Est-ce que quelqu'un pourrait confirmer que le problème avec Acronis Disk
Director peut être dépendant d'un blocage au niveau des autorisations du
système ? (Et, idéalement, suggérer une solution.)



--
Jacques DASSIÉ
http://archaero.com/sauvegarde.htm


pxg
Le #20951911
Bidule Obsolète wrote:

(Et, idéalement, suggérer une solution.)



Regarde du côté de subinacl.exe si tu penses que cela ne vient que des
droits.

Que te dit l'observateur d'évènements ?

Cordialement

pxg
Bidule Obsolète
Le #20952361
"pxg" 4b4b7021$0$955$
Bidule Obsolète wrote:

(Et, idéalement, suggérer une solution.)



Regarde du côté de subinacl.exe si tu penses que cela ne vient que des
droits.




Pourriez-vous être plus précis ? Je vais déjà chercher ça...

La version que j'ai trouvée est un fichier .MSI : requiert le service
Windows Installer, qui chez moi est pour l'instant inaccessible...



Que te dit l'observateur d'évènements ?




Où donc ? C'est que ça dit beaucoup de choses...
Je vois par exemple :
« Une erreur de parité a été détectée sur DeviceScsinvgts1. »
« Impossible de déterminer le numéro de périphérique d'un(e) disk drive. Ce
périphérique n'a pas pu être configuré. Cet événement a pu être enregistré
plusieurs fois dans le journal pour le même périphérique. »
« L'appel LoadUserProfile a échoué avec l'erreur : Accès refusé. »
« Cet ordinateur est configuré en tant que membre d'un groupe de travail, et
non en tant que membre d'un domaine. Il n'est pas nécessaire d'exécuter le
service Accès réseau dans cette configuration. »
« Une erreur a été détectée sur le périphérique DeviceHarddisk0D au cours
d'une opération de pagination. »



Cordialement

pxg



pxg
Le #20955981
Bidule Obsolète wrote:
« Une erreur de parité a été détectée sur DeviceScsinvgts1. »
« Impossible de déterminer le numéro de périphérique d'un(e) disk
drive. Ce périphérique n'a pas pu être configuré. Cet événement a pu
être enregistré plusieurs fois dans le journal pour le même
périphérique. »


...
« Une erreur a été détectée sur le périphérique DeviceHarddisk0D
au cours d'une opération de pagination. »



ces messages semblent pointer des problèmes matériels.

Pour les problèmes limités aux droits ntfs tu peux faire dans l'horreur
intégrale (conversion de la partition ou bien mieux copie du disque et
conversion de la partition en fat32 avec un outil tiers) pour éliminer
cette seule cause. ça ne veut pas dire que tu n'auras pas de problème de
droits sur d'autres objets (clés de registre par exemple).

courage

pxg
Bidule Obsolète
Le #20958291
"pxg" 4b4c577c$0$972$
Bidule Obsolète wrote:
« Une erreur de parité a été détectée sur DeviceScsinvgts1. »
« Impossible de déterminer le numéro de périphérique d'un(e) disk
drive. Ce périphérique n'a pas pu être configuré. Cet événement a pu
être enregistré plusieurs fois dans le journal pour le même
périphérique. »


...
« Une erreur a été détectée sur le périphérique DeviceHarddisk0D
au cours d'une opération de pagination. »



ces messages semblent pointer des problèmes matériels.




Cette erreur semble apparaître immédiatement avant cette autre :
« Le périphérique 'ST315005 41AS SCSI Disk Device'
(SCSIDisk&Ven_ST315005&Prod_41AS&Rev_CC324&304e02a7&0&110) a disparu du
système sans que sa suppression ait tout d'abord été préparée. »

C'est peut-être tout simplement l'extinction du disque dur externe (faut-il
« préparer » l'extinction d'un disque branché en eSATA ?).



Pour les problèmes limités aux droits ntfs tu peux faire dans l'horreur
intégrale (conversion de la partition ou bien mieux copie du disque et
conversion de la partition en fat32 avec un outil tiers) pour éliminer
cette seule cause. ça ne veut pas dire que tu n'auras pas de problème de
droits sur d'autres objets (clés de registre par exemple).

courage

pxg





Je pense que la commande "cacls c: /g everyone:F /c /t" a eu un effet
similaire (en moins "sauvage" peut-être !). Mais il se peut en effet qu'il
reste des restrictions au niveau de la base de registre. Maintenant, comment
savoir lesquelles et comment les corriger ?

Par ailleurs, comme je viens de l'indiquer sur fr.comp.stockage, le problème
avec Acronis et le nouveau disque semble n'avoir aucun rapport : ce serait
un souci au niveau des pilotes SATA de la carte mère (circuit NVidia),
inaptes à gérer les disques de capacité supérieure à 1,5To (au moins les
Seagate) :
http://www.tomshardware.co.uk/forum/247279-14-cannot-fully-format-seagate-st31500341as
http://seagate.custkb.com/seagate/crm/selfservice/search.jsp?DocId 6391&NewLang=en
http://seagate.custkb.com/seagate/crm/selfservice/search.jsp?DocId!1211&NewLang=en

Une mise à jour des pilotes suffirait à résoudre ce problème, mais je suis
en train de me prendre la tête pour savoir quels pilotes installer (chose
étrange : les pilotes SATA de la version 15.45 semblent plus anciens que
ceux de la version 15.24 -- et il semble impossible d'installer *uniquement*
les pilotes SATA, il n'y a qu'un gros paquet comportant tous les pilotes
NVidia).

Ironiquement, le logiciel gratuit Easeus Partition Master Home Edition
parvient à partitionner l'ensemble du disque sans problème (apparent). Je
suis de tester les partitions, toujours avec Easeus PM : il se peut qu'il y
ait quand même des problèmes d'accès au delà de 1To.
Ascadix
Le #20959251
Bidule Obsolète a formulé ce mardi :
"pxg" 4b4c577c$0$972$
Bidule Obsolète wrote:
« Une erreur de parité a été détectée sur DeviceScsinvgts1. »
« Impossible de déterminer le numéro de périphérique d'un(e) disk
drive. Ce périphérique n'a pas pu être configuré. Cet événement a pu
être enregistré plusieurs fois dans le journal pour le même
périphérique. »







...





« Une erreur a été détectée sur le périphérique DeviceHarddisk0D
au cours d'une opération de pagination. »



ces messages semblent pointer des problèmes matériels.




Cette erreur semble apparaître immédiatement avant cette autre :
« Le périphérique 'ST315005 41AS SCSI Disk Device'
(SCSIDisk&Ven_ST315005&Prod_41AS&Rev_CC324&304e02a7&0&110) a disparu du
système sans que sa suppression ait tout d'abord été préparée. »

C'est peut-être tout simplement l'extinction du disque dur externe (faut-il «
préparer » l'extinction d'un disque branché en eSATA ?).



Mouaip, c'est plutot mieux. 8-o

"Normalement" tu devrait avoir l'icone d'éjection ( comme pour l'USB) à
coté de l'heure.

Si tu l'as pas, et c'est trés courant, regarde donc ça :
http://mt-naka.com/hotswap/index_enu.htm

Ce p'tit soft est assez sympa
Je m'en sert depuis qq mois avec XP mon un rack SATA et depuis qq jours
avec Seven vu que ce balot ne me présente pas lui non plus l'icone de
retrait pour les disques SATA en rack.

[snip....]

--
@+
Ascadix
adresse @mail valide, mais ajoutez "sesame" dans l'objet pour que ça
arrive.
Bidule Obsolète
Le #20960591
"Bidule Obsolète" message de news: 4b4a4148$0$27916$

{ Principaux problèmes :
- impossible d'accéder au gestionnaire des disques de Windows
- disque neuf reconnu par le système mais création de partition et
formatage par Acronis Disk Director échoue (vraisemblablement lié au pb
précédent)
- Windows Installer inaccessible }

Il y a une semaine, après des opérations de conversion de fichiers vidéo,
qui ont plusieurs fois causé un remplissage à ras-bord de la partition
système (ce qui est très déconseillé -- maintenant je sais pourquoi),
plusieurs programmes ont cessé de fonctionner (je ne me souviens plus du
message exact, installation défectueuse, réinstallez, quelque chose dans
ce genre), puis plantage, écran bleu, redémarrage, vérification CHKDSK...
Jusque là, c'était très énervant mais pas franchement inquiétant.
Brusquement, ont commencé à apparaître de nombreux messages d'erreur :

« Les attributs de type 0x80 et de balise d'instance 0x0 dans le fichier
0x9
ont une longueur allouée de 0xd5000 au lieu de 0xd6000.
L'entrée de liste d'attributs endommagée de type de code
128 dans le fichier 9 a été supprimée.
Impossible de localiser l'attribut de balise d'instance 0x0 et de
référence
de segment 0x100000000369e. Le type d'attribut attendu est 0x80.
Suppression de l'enregistrement d'attribut endommagé (128, $SDS)
du segment d'enregistrement de fichier 13982.
L'enregistrement d'attribut de type 0x80 et de balise d'instance 0x3 a un
lien croisé
qui commence à 0x280031 pour 0x3fb clusters éventuels.
Correction de la référence croisée du fichier 26007.
Nettoyage en cours de petites incohérences sur le lecteur.
Le flux de données de sécurité est manquant du fichier 0x9.
La taille du flux de données de sécurité 0x0 ne devrait pas être
inférieure à 0x40000.
Réparation du segment d'enregistrement du fichier de sécurité.
Suppression d'une entrée d'index avec l'ID 256 à partir de l'index $SII du
fichier 9.
Suppression d'une entrée d'index avec l'ID 257 à partir de l'index $SII du
fichier 9.
Suppression d'une entrée d'index avec l'ID 258 à partir de l'index $SII du
fichier 9. [...] »

Ensuite l'écran s'est rempli d'une liste littéralement interminable de
lignes de la forme :
« Remplacement de l'id de sécurité erroné par l'id de sécurité par défaut
pour le fichier xxx »

Cela s'est poursuivi pendant plusieurs heures (j'ai laissé tourner et suis
allé dormir, non sans flipper à l'idée du bazar que ce processus était en
train de me foutre, mais craignant des problèmes bien plus graves au cas
où je l'interromprais -- et manifestement, bien m'en a pris : d'après ce
que j'ai pu lire ensuite, certains qui ont eu le même problème ont
complètement bousillé leur système en éteignant la machine à la sauvage au
cours de cette opération).

Ensuite, une nuée de problèmes : plus de barre des tâches, copier-coller
impossible, la plupart des programmes refusaient de se lancer...

A force de patience et de recherches (essentiellement sur des forums
anglophones -- sur les forums en français il est généralement conseillé de
formater et tout réinstaller...), j'ai fini par résoudre la plupart de ces
problèmes ; cette page notamment m'a bien aidé :
http://forums.majorgeeks.com/showthread.php?t8462
J'ai essayé à la suite plusieurs solutions proposées, je ne saurais dire
exactement lesquelles ont résolu tel ou tel problème. Apparemment la
commande "cacls c: /g everyone:F /c /t" aurait rétabli les droits d'accès
aux fichiers du système, et donc la plupart des fonctions défectueuses
(c'est un domaine dont je n'ai qu'une connaissance très approximative,
n'hésitez pas à rectifier ou compléter).

MAIS quelques problèmes persistent :
- Il m'est toujours impossible d'installer des programmes nécessitant le
service Windows Installer : celui-ci est déclaré inaccessible. J'ai tenté
la réinscription dans le registre (msiexec /unregister puis msiexec
/regserver), sans succès ; les droits d'accès semblent correctement
définis.
- Le partitionnement d'un nouveau disque dur branché en eSATA avec Acronis
Disk Director a échoué, j'obtiens un message « Failed to write to the
sector XXXXXX ». Or le disque est reconnu par le système et je ne pense
pas qu'il soit défectueux. Je pense plutôt que ce problème est lié à cet
autre : il m'est impossible d'accéder au gestionnaire de disques de
Windows, « Vous n'avez pas de droits d'accès au gestionnaire de disques
logiques ». J'ai pourtant récupéré les droits d'accès sur l'ensemble du
dossier Windows. Peut-être y a-t-il quelque chose à rétablir au niveau de
la base de registre ? Ou quoi d'autre ?


Merci pour vos suggestions.








# Pour le problème d'accès au gestionnaire de disques et le problème d'accès
au service Windows Installer, j'ai trouvé la solution ici :
http://www.developpez.net/forums/d453978/systemes/windows/iis/installation-serveur-iis-windows-xp-pro/

==> « - exécuter "regedit"
- supprimer la clé "HKEY_LOCAL_MACHINESOFTWAREMicrosoftCOM3" (la
sauvegarder avant au cas où !)
- aller dans "panneau de configurationAjout Suppression de programmes"
puis "Ajouter ou supprimer des composants Windows"
- ne rien changer, et faire "suivant", le système va tout reconfigurer et
recréer la clé COM3
- redémarrer l'ordinateur. »

Ça a résolu simultanément les deux problèmes. Si jamais quelqu'un est en
mesure d'expliquer la théorie derrière tout ça, le rôle de "COM3", etc., ça
m'intéresse (mais bon, je n'y crois pas trop... un tel puits de science se
serait déjà manifesté !).


# Quant au problème d'échec de partitionnement du disque Seagate 1,5To, cela
provenait effectivement des pilotes NVidia. En effectuant la mise à jour
depuis le gestionnaire de périphériques, j'ai pu mettre à jour uniquement
les pilotes SATA, sans installer l'ensemble de la mise à jour proposée sur
le site NVidia (laquelle comporte du reste, étrangement, un pilote SATA plus
ancien). Acronis Disk Director ne bronche plus. Le test d'erreur d'HD Tune
se passe sans encombre (mais, chose étrange, une fois dépassés les
~1040000Mo précédemment fatidiques, le test se poursuit en indiquant sous
"Position" des valeurs négatives, continuant à rebours jusqu'à -666925 MB --
comment se fait-ce-t-il donc ?).

Maintenant j'ai le processus SVCHOST qui me bouffe 50% de la puissance du
processeur... Mais ça va déjà beaucoup mieux !
Bidule Obsolète
Le #20968641
"Ascadix" 4b4cc6e1$0$965$
Bidule Obsolète a formulé ce mardi :
"pxg" 4b4c577c$0$972$
Bidule Obsolète wrote:
« Une erreur de parité a été détectée sur DeviceScsinvgts1. »
« Impossible de déterminer le numéro de périphérique d'un(e) disk
drive. Ce périphérique n'a pas pu être configuré. Cet événement a pu
être enregistré plusieurs fois dans le journal pour le même
périphérique. »







...





« Une erreur a été détectée sur le périphérique DeviceHarddisk0D
au cours d'une opération de pagination. »



ces messages semblent pointer des problèmes matériels.




Cette erreur semble apparaître immédiatement avant cette autre :
« Le périphérique 'ST315005 41AS SCSI Disk Device'
(SCSIDisk&Ven_ST315005&Prod_41AS&Rev_CC324&304e02a7&0&110) a disparu du
système sans que sa suppression ait tout d'abord été préparée. »

C'est peut-être tout simplement l'extinction du disque dur externe
(faut-il « préparer » l'extinction d'un disque branché en eSATA ?).



Mouaip, c'est plutot mieux. 8-o

"Normalement" tu devrait avoir l'icone d'éjection ( comme pour l'USB) à
coté de l'heure.

Si tu l'as pas, et c'est trés courant, regarde donc ça :
http://mt-naka.com/hotswap/index_enu.htm




« Le périphérique 'WDC WD10 EAVS-00D7B1 SCSI Disk Device' ne peut pas être
retiré tout de suite car il nécessite un redémarrage du système. Redémarrez
avant de le débrancher. »

==> Quel intérêt alors ?




Ce p'tit soft est assez sympa
Je m'en sert depuis qq mois avec XP mon un rack SATA et depuis qq jours
avec Seven vu que ce balot ne me présente pas lui non plus l'icone de
retrait pour les disques SATA en rack.

[snip....]

--
@+
Ascadix
adresse @mail valide, mais ajoutez "sesame" dans l'objet pour que ça
arrive.




Publicité
Poster une réponse
Anonyme