Winbind sur Domain Nt ne marche pas

Le
LEBRETON Philippe
Bonjour,

J'ai un gros problème avec Winbind :
Ma machine est configurée en tant serveur d'un domaine NT, voici mon
fichier de conf :
# Samba config file created using SWAT
# from 127.0.0.1 (127.0.0.1)
# Date: 2007/09/03 11:54:30

[global]
workgroup = D15490102
server string = %h server
security = DOMAIN
password server = w15490101abc soft154901
passdb backend = tdbsam
passwd program = /usr/bin/passwd %u
passwd chat = *EntersnewsUNIXspassword:* %n
*RetypesnewsUNIXspassword:* %n *passwordsupdatedssuccessfully* .
log level = 3
syslog = 0
log file = /var/log/samba/log.%m
max log size = 1000
name resolve order = lmhosts host bcast
server signing = auto
load printers = No
preferred master = No
domain master = No
ldap ssl = no
panic action = /usr/share/samba/panic-action %d
host msdfs = No
idmap uid = 10000-10500
idmap gid = 20000-20500
winbind enum users = Yes
winbind enum groups = Yes
winbind use default domain = Yes
winbind trusted domains only = Yes
invalid users = root
strict locking = No

[homes]
comment = Home Directories
valid users = %S
create mask = 0700
directory mask = 0700

[printers]
comment = All Printers
path = /var/spool/samba
create mask = 0700
printable = Yes
browseable = No

[print$]
comment = Printer Drivers
path = /var/lib/samba/printers

[Download]
comment = Download
path = /home/lebreton/download
guest ok = Yes

j'ai fait un "net rpc join -U administrateur"
la réponse est OK
J'ai vérifier avec un "net rpc testjoin"
toujours OK
par contre un "wbinfo -u" me répond : Error looking up domain users
De même pour wbinfo -g
dans les logs il y des chose bizarres qui font référence à=
Active
Directory :
dans le fichier wb.D15490102 il y a :
ads_sasl_spnego_bind: got server principal name
=w15490101abc$@D15490102.CTI-PAYSLOIRE.CNAMTS.FR
[2007/09/03 12:24:32, 3] libsmb/clikrb5.c:ads_krb5_mk_req(552)
ads_krb5_mk_req: krb5_cc_get_principal failed (No credentials cache=
found)
[2007/09/03 12:24:32, 0] libads/kerberos.c:ads_kinit_password(208)
kerberos_kinit_password
LEBRETON-00227$@D15490102.CTI-PAYSLOIRE.CNAMTS.FR failed: Cannot resolve
network address for KDC in requested realm
[2007/09/03 12:24:32, 1] nsswitch/winbindd_ads.c:ads_cached_connection(114)
ads_connect for domain D15490102 failed: Cannot resolve network
address for KDC in requested realm
[2007/09/03 12:26:05, 3]
nsswitch/winbindd_pam.c:winbindd_dual_pam_auth(1115)
[ 9236]: dual pam auth root
[2007/09/03 12:26:05, 3] rpc_client/cli_pipe.c:rpc_pipe_bind(2081)
rpc_pipe_bind: Remote machine SOFT154901 pipe NETLOGON fnum 0x400d
bind request returned ok.
[2007/09/03 12:26:05, 3] rpc_client/cli_pipe.c:rpc_pipe_bind(2081)
rpc_pipe_bind: Remote machine SOFT154901 pipe NETLOGON fnum 0x800f
bind request returned ok.
[2007/09/03 12:26:05, 2]
nsswitch/winbindd_pam.c:winbindd_dual_pam_auth(1290)
Plain-text authentication for user root returned
NT_STATUS_NO_SUCH_USER (PAM: 10)
[2007/09/03 12:26:26, 3]
nsswitch/winbindd_pam.c:winbindd_dual_pam_auth(1115)
[ 9236]: dual pam auth root
[2007/09/03 12:26:26, 2]
nsswitch/winbindd_pam.c:winbindd_dual_pam_auth(1290)
Plain-text authentication for user root returned
NT_STATUS_NO_SUCH_USER (PAM: 10)


Pourquoi kerberos?

Quelqu'un a-t-il une idée?

Merci

Philippe LEBRETON


--
LEBRETON Philippe
CTI Bretagne - Pays de Loire
Service Logistique
02 41 47 77 29


"Le contenu de ce courriel et ses éventuelles pièces jointes sont=
confidentiels. Ils s’adressent exclusivement à la personne=
destinataire.
Si cet envoi ne vous est pas destiné, ou si vous l’avez reÃ=
§u par erreur,et afin de ne pas violer le secret des correspondances,=
vous ne devez pas le transmettre à d’autres personnes ni le=
reproduire. Merci de le renvoyer à l’émetteur et de le d=
étruire.

Attention : L’Organisme de l'émetteur du message ne pourra Ã=
ªtre tenu responsable de l’altération du présent=
courriel. Il appartient au destinataire de vérifier que les messages=
et pièces jointes reçus ne contiennent pas de virus.
Les opinions contenues dans ce courriel et ses éventuelles pièces=
jointes sont celles de l’émetteur. Elles ne reflètent=
pas la position de l’Organisme sauf s’il en est disposÃ=
© autrement dans le présent courriel."
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
thomas.harding
Le #9597651
On Mon, Sep 03, 2007 at 12:27:28PM +0200, LEBRETON Philippe wrote:
Bonjour,

J'ai un gros problème avec Winbind :
Ma machine est configurée en tant serveur d'un domaine NT, voici mon
j'ai fait un "net rpc join -U administrateur"
la réponse est OK
J'ai vérifier avec un "net rpc testjoin"
toujours OK
par contre un "wbinfo -u" me répond : Error looking up domain users
De même pour wbinfo -g
Quelqu'un a-t-il une idée?



- sais pas - mais quand on configure un serveur membre avec un backend
ldap, il faut faire
# wbinfo --set-auth-user domaine\toto%passtoto

--
Thomas Harding


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme