windev 18 champ table

Le
eric
bonjour,

j'ai un comportement bizarre dans un champ table rempli par programmation.

composé de 6 colonnes, les 2 1éres sont en affichage , les 4 suivantes =
en saisies, la derniére colonne étant une combo
lors de la saisie, l'appuie sur la touche tab déplace vers la colonne sui=
vante a saisir, les valeurs sont retenues.sur la derniére colonne, la tou=
che tab ajoute un nouvel enregistrement.

si la saisie est validée par la touche entrée , les valeurs saisies ne =
sont pas retenues peu importe la colonne saisie, c'est comme si les valeurs=
étaient effacés par la validation de Entrée.

si quelqu'un a une solution, c'est franchement pénalisant ..et trés d=
épressif.

merci de votre aide
eric
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
eric
Le #26340528
Le lundi 23 février 2015 08:13:34 UTC+1, eric a écrit :

Je me réponds, c'est un bouton valider avec le mode ihm qui mettait un pr oblême, bouton situé avant le champ.


bonjour,

j'ai un comportement bizarre dans un champ table rempli par programmation .

composé de 6 colonnes, les 2 1éres sont en affichage , les 4 suivante s en saisies, la derniére colonne étant une combo
lors de la saisie, l'appuie sur la touche tab déplace vers la colonne s uivante a saisir, les valeurs sont retenues.sur la derniére colonne, la t ouche tab ajoute un nouvel enregistrement.

si la saisie est validée par la touche entrée , les valeurs saisies n e sont pas retenues peu importe la colonne saisie, c'est comme si les valeu rs étaient effacés par la validation de Entrée.

si quelqu'un a une solution, c'est franchement pénalisant ..et trés d épressif.

merci de votre aide
eric
Publicité
Poster une réponse
Anonyme