Windows Installer

Le
Jean
Bonsoir,

Depuis quelques heures j'essaie d'installer le plug-in de ma-config.com.
delà se termine toujours par un message d'erreur concernant le Package
Windows Installer, qui serait défaillant ou mal installé
J'ai fait une restauration systeme, un redémarrage sur la dernière bonne
configuration connue et installé "Windows Installer 3.1 (KB893803).
Rien n'y fait. Il me reste encore à voir si je trouve quelque chose sur
le CD de Windows XP et surtout VOUS qui allez bien trouver La solution.
Je vous remercie d'avance pour votre aide.

Jean
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Webinter
Le #6664311
Jean à hiéroglyphé sur ma banquise :
delà se termine toujours par un message d'erreur concernant le Package
Windows Installer, qui serait défaillant ou mal installé...


Bonsoir,
si le message est le suivant : http://cjoint.com/data/fmvJLwedub.htm
tu devrais pouvoir résoudre cela en faisant:
menu Exécuter taper msiexec /unreg
puis msiexec /regserver

--
Joël...

JF
Le #6664421
*Bonjour Jean* !

Bonsoir,

Depuis quelques heures j'essaie d'installer le plug-in de ma-config.com.
delà se termine toujours par un message d'erreur concernant le Package
Windows Installer, qui serait défaillant ou mal installé...
J'ai fait une restauration systeme, un redémarrage sur la dernière bonne
configuration connue et installé "Windows Installer 3.1 (KB893803).
Rien n'y fait. Il me reste encore à voir si je trouve quelque chose sur le CD
de Windows XP et surtout VOUS qui allez bien trouver La solution.
Je vous remercie d'avance pour votre aide.

Jean


Un message d'erreur s'affiche quand vous essayez d'installer dans
Windows XP un programme qui utilise Windows Installer
http://support.microsoft.com/kb/886630/fr
(3 méthodes)

--
Salutations, Jean-François
Index de la FAQ XP de Panthère Noire : www.d2i.ch/pn/az
Un problème difficile à décrire ? http://fspsa.free.fr/copiecran.htm
Les vecteurs d'infection www.libellules.ch/dangers_logiciels.php

Jean
Le #6666711
Jean à hiéroglyphé sur ma banquise :
delà se termine toujours par un message d'erreur concernant le Package
Windows Installer, qui serait défaillant ou mal installé...


Bonsoir,
si le message est le suivant : http://cjoint.com/data/fmvJLwedub.htm
tu devrais pouvoir résoudre cela en faisant:
menu Exécuter taper msiexec /unreg
puis msiexec /regserver

Merci pour ta réponse très rapide.

Malheureusement, la solution n'est pas là.
Je te joins les 2 messages, l'un concerne l'installation via le site et
l'autre à partir de mon DD.
J'ai suivi les conseils de JF (courrier suivant) sans plus de résultats.
La réponse au rapport ches Microsoft est aussi "sorry".
Dois-je essayer une réparation des fichiers systeme à partir du CD Windows ?
Si tu as d'autres idées, n'hésite pas !

Jean

http://cjoint.com/?fucpVThw1n

http://cjoint.com/?ful4mfal31


Jean
Le #6666951
*Bonjour Jean* !

Bonsoir,

Depuis quelques heures j'essaie d'installer le plug-in de ma-config.com.
delà se termine toujours par un message d'erreur concernant le Package
Windows Installer, qui serait défaillant ou mal installé...
J'ai fait une restauration systeme, un redémarrage sur la dernière
bonne configuration connue et installé "Windows Installer 3.1 (KB893803).
Rien n'y fait. Il me reste encore à voir si je trouve quelque chose
sur le CD de Windows XP et surtout VOUS qui allez bien trouver La
solution.
Je vous remercie d'avance pour votre aide.

Jean


Un message d'erreur s'affiche quand vous essayez d'installer dans
Windows XP un programme qui utilise Windows Installer
http://support.microsoft.com/kb/886630/fr
(3 méthodes)

Salut JF,


J'ai essayé les 3 méthodes et même en mode sans échec l'installation échoue.
Si tu veux voir la réponse à Webinter, j'y donnes plus de détails.

Merci encore,

Jean


JF
Le #6667691
*Bonjour Jean* !

Depuis quelques heures j'essaie d'installer le plug-in de ma-config.com.
http://support.microsoft.com/kb/886630/fr

J'ai essayé les 3 méthodes et même en mode sans échec l'installation échoue.



À tout hasard relire l'aide :
www.ma-config.com/AfficherAide.html
"Mon ActiveX ne se charge pas. Que faire ?" ==>
http://ma-config.com/Dossier-1-1-Installation+du+plugin.html

Vérifier la valeur
HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesMSIServer
ImagePath = C:WINDOWSSystem32msiexec.exe /V
E:WINDOWS... si le système est installé sur E:

Ou revoir l'ensemble :
Procédures de base de résolution des problèmes liés à Windows Installer
http://support.microsoft.com/kb/907749/fr

Exploiter l'Observateur d'évènements
http://forum.zebulon.fr/comment-resoudre-mon-probleme-avec-windows-install-t100077.html

Erreur 1603 Erreur fatale lors de l'installation lorsque vous essayez
d'installer un package Windows Installer
http://support.microsoft.com/kb/834484/fr

Plus tu seras précis sur le message d'erreur, plus tu as de chances de
trouver (google).

--
Salutations, Jean-François
FAQ XP de Panthère Noire (index) : www.d2i.ch/pn/az
Un problème à montrer ? http://fspsa.free.fr/copiecran.htm
Outil : http://fspsa.free.fr/Presse-Papier_vers_Regedit.htm



Droger Jean-Paul
Le #6668461
Dans ton cas, il y a quelques années, mais avec W2k, j'ai désinstallé
Windows installer (il y a un utilitaire de windows qui le fait WI
cleanup je crois, j'avais cherché sur Google) puis chargé la dernière
version sur le site de MS puis réinstallé l'engin; cela a marché
ensuite!!

--
Pour m'envoyer un mail, remplacer anti par droger et manama par
wanadoo; to send me directly a mail replace anti with droger and manama
with wanadoo;

Jean
Le #6670091
Plus tu seras précis sur le message d'erreur, plus tu as de chances de
trouver (google).

Salut JF,


Merci pour ces liens intéressants, surtout celui de Zebulon qui m'a
permis de corriger plusieurs entrées du registre.
J'ai aussi suivis tes autres conseils à part le support microsoft qui te
fait valser d'un chapitre à l'autre qu'à la fin tu connaîtrais le bible
de Crosoft par cœur !
Maintenant il se pourrait (je le garde au conditionnel) que le problème
"Windows installer" soit règlé, mais voici un autre message donc un
autre souci.
"L'administrateur système a configuré la politique de votre système pour
interdire cette installation"
Quand je regarde dans "Profil des utilisateurs", mon profil apparaît 2
fois, 1 fois en administrateur et 1 fois en Jean.
Je ne peux que celui d'administrateur car si je clique sur Jean, la case
suppression est grisée.
Je n'ai pas trouvé sur Google, je vais encore faire un tour chez la PN.

Bonne soirée,

Jean

JF
Le #6672281
*Bonjour Jean* !

Plus tu seras précis sur le message d'erreur, plus tu as de chances de
trouver (google).
Merci pour ces liens intéressants, surtout celui de Zebulon qui m'a permis de

corriger plusieurs entrées du registre.


Je regrette le manque de précision de ta réponse. Sois persuadé que les
solutions que tu trouves en intéressent plus d'un.


J'ai aussi suivis tes autres conseils à part le support microsoft qui te fait
valser d'un chapitre à l'autre qu'à la fin tu connaîtrais le bible de Crosoft
par coeur !


C'est comme ça :/
Comme les gens ne disent pas quelle solution a été efficace, on en est
réduit à toutes les citer en espérant que l'utilisateur trouve son
bonheur :o) Ce n'est pas près d'évoluer :oD


Maintenant il se pourrait (je le garde au conditionnel) que le problème
"Windows installer" soit règlé, mais voici un autre message donc un autre
souci.
"L'administrateur système a configuré la politique de votre système pour
interdire cette installation"


En faisant quoi ? En installant quoi ?
www.google.fr/search?q=The+system+administrator+has+set+policies+to+prevent+this+installation
http://want2knw.wordpress.com/2007/04/23/windows-the-system-administrator-has-set-policies-to-prevent-this-installation
http://www.appdeploy.com/messageboards/tm.asp?mˆ72&mpage=1
Ça peut venir d'un programme bancal
http://support.microsoft.com/kb/322963/fr
http://www.commentcamarche.net/forum/affich-1287186-l-administrateur-systeme-a-configure-la-polit

Avec XPPRO il est facile de vérifier si une restriction est appliquée :
Exécuter>rsop.msc
Exécuter>gpedit.msc

Sinon vérifier dans ces clés si une restriction est activée :
HKLMSoftwarePoliciesMicrosoftWindowsInstaller
HKCUSoftwarePoliciesMicrosoftWindowsInstaller
HKCUSoftwareMicrosoftWindowsCurrentVersionGroup Policy
Objects{44FA6DE1-030D-4712-8643-FCDC70834039}UserSoftwarePoliciesMicrosoftWindowsInstaller
HKCUSoftwarePoliciesMicrosoftWindowsInstaller

Exemple de restriction :
XPPRO
Exécuter>gpedit.msc
Modèles d'administration, Composants Windows, Windows Installer :
"Toujours installer avec des droits élevés"

XPHOME
AlwaysInstallElevated=1 restriction active
AlwaysInstallElevated=0 restriction inactive




Quand je regarde dans "Profil des utilisateurs", mon profil apparaît 2 fois,
1 fois en administrateur et 1 fois en Jean.
Je ne peux que celui d'administrateur car si je clique sur Jean, la case
suppression est grisée.


Propriétés Système, Onglet Avancé, Profil des utilisateurs
Comme tu utilises le Compte Jean, ce profil n'est pas supprimable,
c'est normal. Le système protège l'utilisateur contre lui-même :o)
Va plutôt dans Comptes utilisateurs
Exécuter>control userpasswords
et vérifie que Jean est Admin.
Renouvelle son mot de passe, quitte à remettre le même ..
Une bonne idée : créer un autre compte Administrateur JeanAdmin en
secours. Ça permet de ne pas avoir à passer par le mode sans échec en
cas de coup dur.


mon profil apparaît 2 fois
Vraiment ? http://fspsa.free.fr/copiecran.htm

Il y a un Profil "Administrateur" de secours qui n'a rien à voir avec
Jean. Ce Profil "Administrateur" est utilisé par la Console de
récupération et le Mode sans échec.

--
Salutations, Jean-François
Index de la FAQ XP de Panthère Noire : www.d2i.ch/pn/az
Un problème difficile à décrire ? http://fspsa.free.fr/copiecran.htm
Démo anti-parasites : http://forum.malekal.com/viewtopic.php?t€46


Jean
Le #6673121

Je regrette le manque de précision de ta réponse. Sois persuadé que les
solutions que tu trouves en intéressent plus d'un.
Soit, j'ai crée les entrées suivantes car elles n'existaient pas :


# Une intervention voulue ou non dans votre BDR peut provoquer la
désactivation de Windows Installer. Il vous faut donc vérifier les
paramètres suivants :

BRANCHE HKLMSOFTWAREPoliciesMicrosoftWindowsInstaller
valeur DWORD : DisableMSI
valeur : 0

0 : Aucune application n'est activable.
1 : uniquement pour les applications non gérées.
2 : Toutes les applications sont activables.


fichier Registre (DisableMSI.reg) - Réactiver Windows Installer
CODE
Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINESOFTWAREPoliciesMicrosoftWindowsInstaller]
"DisableMSI"=dword:00000002



NB : L'éditeur de stratégie de groupe permet de désactiver Windows
Installer.


# Une désactivation de Windows installer est peut être liée à l'éditeur
de Stratégie de groupe. Une intervention au niveau de l'éditeur de
Stratégie de groupe permet de désactiver Windows Installer lors du
paramètrage des privilèges de l'utilisateur. Vérifier dons les
paramètres suivants :

BRANCHE HKLMSOFTWAREPoliciesMicrosoftWindowsInstaller
valeur DWORD : AlwaysInstallElevated
valeur : 0 (Windows Installer est désactivé)

Pour réactiver Windows Installer mettre la valeur de
AlwaysInstallElevated à 1

fichier Registre (AlwaysInstallElevated.reg) - Réactiver Windows Installer
CODE
Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINESOFTWAREPoliciesMicrosoftWindowsInstaller]
"AlwaysInstallElevated"=dword:00000001


LES CORRECTIFS WINDOWS XP.
Windows Installer se bloque lorsque vous installez une mise à jour sous
Windows XP Service Pack 2.
- Télécharger et installer le correctif KB885894

Chargé et installé, pas de message d'erreur

Maintenant il se pourrait (je le garde au conditionnel) que le
problème "Windows installer" soit règlé, mais voici un autre message
donc un autre souci.
"L'administrateur système a configuré la politique de votre système
pour interdire cette installation"


En faisant quoi ? En installant quoi ?
Toujours la même application de "ma-config.com" qui est à l'origine de

ce problème et qui n'est pas un fichier.msi il a l'extension .exe
Et je me suis appercu qu'il me refuse (toute ?)installation maintenant
ex : Nero 6, Office 2003,Paint Shop Pro 9.
Comme je suis en train de refaire ma configuration, ça promet !
Ne vaudrait-il pas mieux de réinstaller ou réparer mon Windows XP sp2 ?
www.google.fr/search?q=The+system+administrator+has+set+policies+to+prevent+this+installation

http://want2knw.wordpress.com/2007/04/23/windows-the-system-administrator-has-set-policies-to-prevent-this-installation

http://www.appdeploy.com/messageboards/tm.asp?mˆ72&mpage=1
Ça peut venir d'un programme bancal
http://support.microsoft.com/kb/322963/fr
http://www.commentcamarche.net/forum/affich-1287186-l-administrateur-systeme-a-configure-la-polit


Avec XPPRO il est facile de vérifier si une restriction est appliquée :
Exécuter>rsop.msc
Exécuter>gpedit.msc
Beaucoup parlent de cette commande "gpedit" que je n'ai pas, est-ce bien

une commande XP ?

Sinon vérifier dans ces clés si une restriction est activée :
HKLMSoftwarePoliciesMicrosoftWindowsInstaller
il y a : EnableAdminTSRemote - REG_DWORD - valeur (1)

HKCUSoftwarePoliciesMicrosoft
il n'y a pas : WindowsInstaller

HKCUSoftwareMicrosoftWindowsCurrentVersion
il n'y a pas

Group Policy
Objects{44FA6DE1-030D-4712-8643-FCDC70834039}UserSoftwarePoliciesMicrosoftWindowsInstaller

HKCUSoftwarePoliciesMicrosoft
il n'y a pas

WindowsInstaller

Exemple de restriction :
XPPRO
Exécuter>gpedit.msc
Windows ne trouve pas "gpedit.msc"

Modèles d'administration, Composants Windows, Windows Installer :
"Toujours installer avec des droits élevés"

XPHOME
AlwaysInstallElevated=1 restriction active
AlwaysInstallElevated=0 restriction inactive


Propriétés Système, Onglet Avancé, Profil des utilisateurs
Comme tu utilises le Compte Jean, ce profil n'est pas supprimable, c'est
normal. Le système protège l'utilisateur contre lui-même :o)
Va plutôt dans Comptes utilisateurs
Exécuter>control userpasswords
et vérifie que Jean est Admin.
oui c'est ça (jamais utilisé de mot de passe)

Renouvelle son mot de passe, quitte à remettre le même ..
Une bonne idée : créer un autre compte Administrateur JeanAdmin en
secours. Ça permet de ne pas avoir à passer par le mode sans échec en
cas de coup dur.


mon profil apparaît 2 fois
Vraiment ? http://fspsa.free.fr/copiecran.htm

http://cjoint.com/?fvjfK885UZ

Il y a un Profil "Administrateur" de secours qui n'a rien à voir avec
Jean. Ce Profil "Administrateur" est utilisé par la Console de
récupération et le Mode sans échec.

Merci de te donner autant de peine, les problèmes s'enchaînent et

s'accumulent.

amicalement, Jean


Jean
Le #6673111
Dans ton cas, il y a quelques années, mais avec W2k, j'ai désinstallé
Windows installer (il y a un utilitaire de windows qui le fait WI
cleanup je crois, j'avais cherché sur Google) puis chargé la dernière
version sur le site de MS puis réinstallé l'engin; cela a marché ensuite!!

Merci pour ta réponse, Jean-Paul.


Je pense que dans mon cas ce serait plutôt un problème de parametrage et
configuration, Quoi-que une nouvelle installation pourrait aussi
remettre les choses en place (ça s'est déjà vu).

Bonne journée,

Jean

Publicité
Poster une réponse
Anonyme