Windows ne trouve pas raccourci internet

Le
Philco
Hello mesdemoiselles
Hello mesdames
Hello messieurs

Il y a quelque chose de cassé dans mon XP SP2 (à jour) : chaque que je
veux lancer un raccourci internet placé sur le bureau (mais ça le fait
aussi avec des liens http dans des applications) une fenêtre s'ouvre
pour me dire :
"windows ne trouve pas http://() verifiez que vous avez entrez le
nom correctement et essayez à nouveau. ()"
Malgré tout mon navigateur par défaut comprend bien que c'est à lui
qu'on s'adresse et ouvre la fenêtre correspondante.

Comment empêcher Windows (qui reconnaît pourtant dans les propriétés
du raccourci que c'est vers une url qu'il doit pointer) d'ouvrir cette
fenêtre ?

Merci de vos réponses.
Bien à vous
Phil
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jean-Claude BELLAMY
Le #1289787
Dans le message :,
Philco
Hello mesdemoiselles
Hello mesdames
Hello messieurs

Il y a quelque chose de cassé dans mon XP SP2 (à jour) : chaque que je
veux lancer un raccourci internet placé sur le bureau (mais ça le fait
aussi avec des liens http dans des applications) une fenêtre s'ouvre
pour me dire :
"windows ne trouve pas http://(...) verifiez que vous avez entrez le
nom correctement et essayez à nouveau. (...)"
Malgré tout mon navigateur par défaut comprend bien que c'est à lui
qu'on s'adresse et ouvre la fenêtre correspondante.

Comment empêcher Windows (qui reconnaît pourtant dans les propriétés
du raccourci que c'est vers une url qu'il doit pointer) d'ouvrir cette
fenêtre ?



Souvent ce genre de pb (classique) est du à une "merdouillerie
d'enregistrement" du contrôle ActiveX "URLMON"

Cela se répare par la commande :
Regsvr32 urlmon.dll


--
May the Force be with You!
La Connaissance s'accroît quand on la partage
----------------------------------------------------------
Jean-Claude BELLAMY [MVP]
http://www.bellamyjc.org ou http://jc.bellamy.free.fr

Philco
Le #1289783
Bonjour Monsieur Bellamy
et merci beaucoup pour votre réponse.
Philco
Le #1289779
Hello
me again

commande appliquée
mais toujours la même alerte.
Jean-Claude BELLAMY
Le #1289770
"Philco" news:
commande appliquée
mais toujours la même alerte.



Il doit alors y avoir un pb dans la BDR, du côté de HKEY_CLASSES_ROOThttp

Vérife la présence et le contenu des clefs suivantes :

HKEY_CLASSES_ROOThttpshellopencommand
Valeur par défaut (type REG_SZ) :
"C:Program FilesInternet Exploreriexplore.exe" -nohome

(à adapter suivant ta config, p.exe si IE est ailleurs)


HKEY_CLASSES_ROOThttpshellopenddeexec
Valeur par défaut (type REG_SZ) :
"%1",,-1,0,,,,

(attention au nombre de virgules !!!)
Il doit aussi y avoir une entrée "NoActivateHandler" de type REG_SZ et de
contenu vide


HKEY_CLASSES_ROOThttpshellopenddeexecApplication
Valeur par défaut (type REG_SZ) :
IExplore


HKEY_CLASSES_ROOThttpshellopenddeexecTopic
Valeur par défaut (type REG_SZ) :
WWW_OpenURL



Si on réunit ces clefs dans un fichier .reg (p.ex. "http.reg") , çà donne
ceci :

----------- couper ici -----------
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOThttpshellopen]

[HKEY_CLASSES_ROOThttpshellopencommand]
@=""C:\Program Files\Internet Explorer\iexplore.exe" -nohome"

[HKEY_CLASSES_ROOThttpshellopenddeexec]
@=""%1",,-1,0,,,,"
"NoActivateHandler"=""

[HKEY_CLASSES_ROOThttpshellopenddeexecApplication]
@="IExplore"

[HKEY_CLASSES_ROOThttpshellopenddeexecTopic]
@="WWW_OpenURL"

----------- couper ici -----------

--
May the Force be with You!
La Connaissance s'accroît quand on la partage
----------------------------------------------------------
Jean-Claude BELLAMY [MVP]
http://www.bellamyjc.org ou http://jc.bellamy.free.fr

Philco
Le #1289750
Bonsoir Jean-Claude
merci encore de t'être penché sur mon "cas".
Utilisant Firefox, la 1ère clef contient cette valeur :
C:PROGRA~1MOZILL~1FIREFOX.EXE -url "%1" -requestPending
Le -requestPending est peut être lié à une extension (?)

les autres clefs sont bien présentes comme tu l'indiques
Philco
Le #1289693
Hello
c'est Firefox qui est fautif : si je désigne IE comme navigateur par
défaut, un raccourci se lance sans message d'avertissement.

Le problème étant survenu depuis la dernière mise à jour (en 2.02),
c'est soit Firefox lui-même ou bien une extension (peut être
incompatible) qui mettrait le caillon.

Je vais interroger les spécialistes de Geckozone.

A plus
***FRGE***
Le #1289653
*Bonjour* *Philco*

Le 01/03/2007 jour de la Saint Aubin, Philco nous a écrit ceci:

Hello
c'est Firefox qui est fautif : si je désigne IE comme navigateur par
défaut, un raccourci se lance sans message d'avertissement.

Le problème étant survenu depuis la dernière mise à jour (en 2.02),
c'est soit Firefox lui-même ou bien une extension (peut être
incompatible) qui mettrait le caillon.

Je vais interroger les spécialistes de Geckozone.

A plus


J'ai rencontré exactement le même souci avec FF il y a une quinzaine de
jours, un point de restauration à une date antérieure au problème a
remis tout en place.
Bien sur cette méthode ne m'a pas permis de connaître l'origine du
problème...

--
***FRGE***

Philco
Le #1289609
On 1 mar, 16:18, ***FRGE***
*Bonjour* *Philco*

Le 01/03/2007 jour de la Saint Aubin, Philco nous a écrit ceci:

Hello
c'est Firefox qui est fautif : si je désigne IE comme navigateur par
défaut, un raccourci se lance sans message d'avertissement.
Le problème étant survenu depuis la dernière mise à jour (en 2. 02),
c'est soit Firefox lui-même ou bien une extension (peut être
incompatible) qui mettrait le caillon.
Je vais interroger les spécialistes de Geckozone.
A plus


J'ai rencontré exactement le même souci avec FF il y a une quinzaine de
jours, un point de restauration à une date antérieure au problème a
remis tout en place.
Bien sur cette méthode ne m'a pas permis de connaître l'origine du
problème...

--
***FRGE***


Hello
pas trouvé de réponse encore à cette question.
Le problème demeure donc.


***FRGE***
Le #1287432
*Bonjour* *Philco*

Le 02/03/2007 jour de la Saint Charles le Bon, Philco nous a écrit
ceci:

On 1 mar, 16:18, ***FRGE***
*Bonjour* *Philco*

Le 01/03/2007 jour de la Saint Aubin, Philco nous a écrit ceci:

Hello
c'est Firefox qui est fautif : si je désigne IE comme navigateur par
défaut, un raccourci se lance sans message d'avertissement.
Le problème étant survenu depuis la dernière mise à jour (en 2.02),
c'est soit Firefox lui-même ou bien une extension (peut être
incompatible) qui mettrait le caillon.
Je vais interroger les spécialistes de Geckozone.
A plus


J'ai rencontré exactement le même souci avec FF il y a une quinzaine de
jours, un point de restauration à une date antérieure au problème a
remis tout en place.
Bien sur cette méthode ne m'a pas permis de connaître l'origine du
problème...

--
***FRGE***


Hello
pas trouvé de réponse encore à cette question.
Le problème demeure donc.


Faites comme moi ;-)

--
***FRGE***



JF
Le #1286944
*Bonjour Philco* !
(news:)

On 1 mar, 16:18, ***FRGE***
*Bonjour* *Philco*

Le 01/03/2007 jour de la Saint Aubin, Philco nous a écrit ceci:

Hello
c'est Firefox qui est fautif : si je désigne IE comme navigateur par
défaut, un raccourci se lance sans message d'avertissement.
Le problème étant survenu depuis la dernière mise à jour (en 2.02),
c'est soit Firefox lui-même ou bien une extension (peut être
incompatible) qui mettrait le caillon.
Je vais interroger les spécialistes de Geckozone.
A plus


J'ai rencontré exactement le même souci avec FF il y a une quinzaine de
jours, un point de restauration à une date antérieure au problème a
remis tout en place.
Bien sur cette méthode ne m'a pas permis de connaître l'origine du
problème...

--
***FRGE***


Hello
pas trouvé de réponse encore à cette question.
Le problème demeure donc.


Pour info le commutateur "-requestPending" semble être apparu avec la dernière
mise à jour de FF (Version 2.0.0.2)

Essayer en désactivant quelques extensions ?

--
Salutations, Jean-François
Index du site de PN : www.d2i.ch/pn/az
Outlook Express : Suivez vos fils avec [CTL+H]
Montrez-nous ce que vous voyez : http://fspsa.free.fr/copiecran.htm



Publicité
Poster une réponse
Anonyme