WPA Supplicant sur Eee 1000H : je n'y arrive pas :-(

Le
David BERCOT
Bonjour,

Apparemment, c'est le jour des questions sur le Wifi ;-)

En ce qui me concerne, je débute totalement dans le domaine. Jusqu'Ã=
 
présent, je n'ai utilisé Debian qu'en Ethernet classique. Pour to=
ut
vous avouer, les rares fois où j'ai eu besoin d'une connexion en Wifi
depuis que j'ai mon netbook, je l'ai fait sous Windows ;-)

Bref, j'ai essayé de suivre les quelques docs en la matière, comm=
e :
http://wiki.debian.org/DebianEeePC/HowTo/Wifi/Rt2860
http://wiki.debian.org/DebianEeePCFrench/HowTo/Wifi
mais je n'arrive à rien

Alors, tout d'abord, ma carte semble opérationnelle avec son module :
# lsmod | grep rt2860
rt2860sta 422808 1
Ensuite, j'ai installé wpa_supplicant ainsi que wpa_gui (je pense
qu'avec ce dernier outil, ce sera plus facile pour découvrir les
réseaux).
J'ai suivi un how-to pour :
# cat /etc/wpa_supplicant/wpa_supplicant.conf
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
ap_scan=1
fast_reauth=1
eapol_version=1
network={
key_mgmt=NONE
}
et, dans mon /etc/network/interfaces, j'ai aussi :
allow-hotplug ath0
iface ath0 inet manual
wpa-driver wext
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf

Or, quand je lance (en root pour l'instant) wpa_gui, j'ai ceci :
Failed to open control connection to wpa_supplicant.
PING failed - trying to reconnect
PING failed - trying to reconnect
[]
et bien sûr, dans l'interface, je n'ai rien

Auriez-vous une piste qui me permette d'avancer ?

Merci d'avance.

David.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Stéphane Péchard
Le #18054781
> Bonjour,



Bonjour,
J'ai moi-même un eeePC 901 (donc le même module que toi) et c'est moi
qui ait rempli le wiki debian pour l'usage de NetworkManager avec ce
module... et comme ça marche plutôt bien pour moi (juste à installer
le module avec module-assistant), je voulais juste te demander si tu
avais essayer comme ça ? je n'ai donc pas eu besoin de tâter du
wpa_supplicant, et ça m'arrange bien...

Stéphane
David BERCOT
Le #18055201
Le Fri, 5 Dec 2008 14:53:22 +0100,
"Stéphane Péchard"
> Bonjour,

Bonjour,
J'ai moi-même un eeePC 901 (donc le même module que toi) et c'e st moi
qui ait rempli le wiki debian pour l'usage de NetworkManager avec ce
module... et comme ça marche plutôt bien pour moi (juste à installer
le module avec module-assistant), je voulais juste te demander si tu
avais essayer comme ça ? je n'ai donc pas eu besoin de tâter du
wpa_supplicant, et ça m'arrange bien...



Quand je fais nm-tool, j'ai ça :

NetworkManager Tool
State: disconnected

- Device: ra0
---------------------------------------------------------------- NM
Path: /org/freedesktop/NetworkManager/Devices/ra0
Type: 802.11 Wireless Driver: rt2860
Active: no
HW Address: 00:22:43:49:75:F5

Capabilities:
Supported: yes
Speed: 1 Mb/s

Wireless Settings
Scanning: yes
WEP Encryption: yes
WPA Encryption: yes
WPA2 Encryption: yes

Wireless Networks (* = Current Network)

Donc, j'aurais tendance à dire que c'est bon...
En revanche, pour la suite, si j'essaye de me connecter, il ne me
propose pas de scanner les réseaux. C'est possible avec le
network-manager ?

Merci.

David.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Stéphane Péchard
Le #18055311
> Quand je fais nm-tool, j'ai ça :
...
Donc, j'aurais tendance à dire que c'est bon...



ben en tout cas, il a l'air de fonctionner, mais il est pas connecté,
moi j'ai à peu près la même chose, sauf :

State: connected

et une liste de réseaux sous Wireless Networks (* = Current Network)

En revanche, pour la suite, si j'essaye de me connecter, il ne me
propose pas de scanner les réseaux. C'est possible avec le
network-manager ?



j'utilise knetworkmanager et oui, c'est possible, tu peux aussi
préciser un réseau non visible
mais j'ai eu la chance que tout marche du premier coup sans trop me
poser de questions, donc je suis pas rentré dans les détails...

--
~~
~ stéphane péchard | nantes | france
David BERCOT
Le #18058071
Bon, ben je reviens avec une configuration qui, finalement, fonctionne
(enfin presque ;-))).

Pour les personnes intéressées, voilà ce que j'ai dans
mon /etc/network/interfaces :
[je m'étais trompé dans le nommage !!!]
allow-hotplug ra0
iface ra0 inet manual
wpa-driver wext
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
et mon fichier /wpa_supplicant.conf :
ctrl_interface=/var/run/wpa_supplicant
update_config=1

Avec ça, en lançant wpa_gui, il réussit à faire ses sca ns, à trouver
les points d'accès et à sauvegarder les configurations...

Bref, tout semble aller pour le mieux dans le meilleur des mondes
(surtout que wpa_gui est très convivial, pour les anciens utilisateurs
de Windows par exemple ;-))), à un détail près :-(
En effet, il discute, échange les clés, et tout marche sauf
l'attribution de l'adresse IP (oui, oui, j'ai un serveur DHCP actif).

Si vous avez une idée, voici les logs :
########## 21:27:52 2008-12-05 ##########
IFACE=ra0 ACTION=DISCONNECTED
WPA_ID=0 WPA_ID_STR=
WPA_CTRL_DIR=/var/run/wpa_supplicant
Ignoring request to take "ra0" down, it is not up
########## 21:28:20 2008-12-05 ##########
IFACE=ra0 ACTION=CONNECTED
WPA_ID=0 WPA_ID_STR=
WPA_CTRL_DIR=/var/run/wpa_supplicant
Using fallback logical interface: default
No network defined for "default" in "/etc/network/interfaces"
bssid=xx...
ssid=xx...
id=0
id_str=
pairwise_cipher=TKIP
group_cipher=TKIP
key_mgmt=WPA-PSK
wpa_state=COMPLETED
Interface "ra0" failed to establish a connection.
Attempting reassociation...
OK
########## 21:28:26 2008-12-05 ##########
IFACE=ra0 ACTION=DISCONNECTED
WPA_ID=0 WPA_ID_STR=
WPA_CTRL_DIR=/var/run/wpa_supplicant
Ignoring request to take "ra0" down, it is not up

Merci d'avance.

David.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Pierre Meurisse
Le #18059751
Bonjour,

première chose, le module est-il installé correctement ?

Que donne

# iwlist scan ?

Normalement, tu dois voir ta borne wifi, plus éventuellement quelques
autres.

Si ça marche, reste à configurer /etc/network/interfaces. J'ai vu
quelque part que l'utilisation de wpasupplicant.conf est obsolète.

Je te donne la config :

allow-hotplug ra0
auto ra0
iface ra0 inet dhcp
wpa-conf managed
wpa-ssid _mon ssid_
wpa-psk _ma clé_


C'est bien le protocole WPA qui est utilisé ?
Pour WEP, suite à un bug du pilote, je m'en tire avec :

allow-hotplug ra0
auto ra0
iface ra0 inet dhcp
pre-up /sbin/ifconfig ra0 up
# pre-up sleep 5
pre-up /sbin/iwpriv ra0 set SSID=_mon ssid_
pre-up /sbin/iwpriv ra0 set AuthMode=WEPAUTO
pre-up /sbin/iwpriv ra0 set EncrypType=WEP
wireless-key _ma clé_

Bon courage.

--
Pierre Meurisse

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Jyce
Le #18067511
David BERCOT a écrit :
Bon, ben je reviens avec une configuration qui, finalement, fonctionne
(enfin presque ;-))).

Pour les personnes intéressées, voilà ce que j'ai dans
mon /etc/network/interfaces :
[je m'étais trompé dans le nommage !!!]
allow-hotplug ra0
iface ra0 inet manual
wpa-driver wext
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
et mon fichier /wpa_supplicant.conf :
ctrl_interface=/var/run/wpa_supplicant
update_config=1

Avec ça, en lançant wpa_gui, il réussit à faire ses scans, à trouver
les points d'accès et à sauvegarder les configurations...

Bref, tout semble aller pour le mieux dans le meilleur des mondes
(surtout que wpa_gui est très convivial, pour les anciens utilisateurs
de Windows par exemple ;-))), à un détail près :-(
En effet, il discute, échange les clés, et tout marche sauf
l'attribution de l'adresse IP (oui, oui, j'ai un serveur DHCP actif).

Si vous avez une idée, voici les logs :
########## 21:27:52 2008-12-05 ##########
IFACE=ra0 ACTION=DISCONNECTED
WPA_ID=0 WPA_ID_STR > WPA_CTRL_DIR=/var/run/wpa_supplicant
Ignoring request to take "ra0" down, it is not up
########## 21:28:20 2008-12-05 ##########
IFACE=ra0 ACTION=CONNECTED
WPA_ID=0 WPA_ID_STR > WPA_CTRL_DIR=/var/run/wpa_supplicant
Using fallback logical interface: default
No network defined for "default" in "/etc/network/interfaces"
bssid=xx...
ssid=xx...
id=0
id_str > pairwise_cipher=TKIP
group_cipher=TKIP
key_mgmt=WPA-PSK
wpa_state=COMPLETED
Interface "ra0" failed to establish a connection.
Attempting reassociation...
OK
########## 21:28:26 2008-12-05 ##########
IFACE=ra0 ACTION=DISCONNECTED
WPA_ID=0 WPA_ID_STR > WPA_CTRL_DIR=/var/run/wpa_supplicant
Ignoring request to take "ra0" down, it is not up

Merci d'avance.

David.




Salut,

Le drivers ralink de linux fonctionne tres mal avec WPA2 (TKIP & CCMP).
J'ai un eeePC 1000 sur lequel ma connection de la maison fonction en
WEP fonctionne a peu pres correctement.
Par contre au-boulot en WPA2 (TKIP + MSCHAPv2) ca fonctionne une
fois sur dix (et encore).
J'ai meme recompile wpa-supplicant pour inclure le driver 'ralink'
qui n'est pas inclus par defaut dans le package debian.
Je n'ai jamais teste en WPA-PSK mais ce ne m'etonnerais pas trop que
ca ne fonctionne pas tres bien ...

--
Jyce

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme