X forwarding sur un serveur sans ecran

Le
Daniel Huhardeaux
Bonsoir,

je me casse la tête sur un truc qui me parait simple.

Soit un serveur Etch 4.0 sans écran, carte graphique Intel G31 dont
voici la sortie lspci:

00:02.0 VGA compatible controller: Intel Corporation Unknown device 29c2
(rev 02) (prog-if 00 [VGA])
Subsystem: Giga-byte Technology Unknown device d000
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSELúst >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
Latency: 0
Interrupt: pin A routed to IRQ 5
Region 0: Memory at f2100000 (32-bit, non-prefetchable) [sizeQ2K]
Region 1: I/O ports at e400 [size=8]
Region 2: Memory at e0000000 (32-bit, prefetchable) [size%6M]
Region 3: Memory at f2000000 (32-bit, non-prefetchable) [size=1M]
Capabilities: [90] Message Signalled Interrupts: Mask- 64bit-
Queue=0/0 Enable-
Address: 00000000 Data: 0000
Capabilities: [d0] Power Management version 2
Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
Status: D0 PME-Enable- DSel=0 DScale=0 PME-

J'ai installé Xorg et xdm (xdmcp) pour pouvoir faire du X forwarding via
ssh (Xming + putty) vers des stations Windows. Malheureusement je me
heurte à ceci:

Xorg log
[]
(EE) /usr/lib/xorg/modules/drivers/fbdev_drv.so is an unrecognized
module type
(II) UnloadModule: "fbdev"
(EE) Failed to load module "fbdev" (unknown module type, 6)
(II) LoadModule: "kbd"
(II) Loading /usr/lib/xorg/modules/input/kbd_drv.so
(II) Module kbd: vendor="X.Org Foundation"
compiled for 7.1.1, module version = 1.1.0
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 0.6
(II) LoadModule: "mouse"
(II) Loading /usr/lib/xorg/modules/input/mouse_drv.so
(II) Module mouse: vendor="X.Org Foundation"
compiled for 7.1.1, module version = 1.1.1
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 0.6
(EE) No drivers available.

Fatal server error:
no screens found

Je peux mettre n'importe quel driver dans xorg.conf, y compris vesa, vga
ou dummy, même erreur. Bien sur ces drivers existent bien. La machine
boot en framebuffer vgay1, en mode console tout est ok.

lorsque je me connecte a partir du client j'obtiens inlassablement:

X connection to localhost:11.0 broken (explicit kill or server shutdown)

ce qui me parait logique puisque X ne tourne pas. Je m'en remet à vous
pour toute idée ou tout setup connu fonctionnel, en gardant à l'esprit
qu'il ne s'agit _pas_ de faire tourner X pour la carte graphique du
serveur, mais bien de ne gérer QUE les clients en X forwarding.

D'avance merci.

--
Daniel


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
  • Le smartphone Sony Xperia X voit sa résistance aux immersions testée durant deux ...
  • Présentation du Wendelstein 7-X le réacteur à fusion nucléaire le plus grand jamais ...
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel Huhardeaux
Le #9643781
Daniel Huhardeaux a écrit :
Bonsoir,

je me casse la tête sur un truc qui me parait simple.



[...]

Désolé pour le bruit, c'était réellement simple: pas besoin de xorg, xdm
et tout le stsoin tsoin si Xming est bien installé, ce qui n'était bien
évidemment pas le cas ici :-(

Pour info, Vista 32bits tourne bien dans une machine virtuelle KVM,
Windows XP en client via Putty+Xming

Bonne soirée
--
Daniel


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme