Xen sous lenny

Le
Sébastien NOBILI
Bonjour,

J'essaye de faire fonctionner Xen sur une machine sous Lenny mais ça
n'est pas très concluant.

Dans Etch, il y a des noyau estampillés Xen qui ont été patchés et qui
intègrent ce qu'il faut pour jouer le rôle d'hyperviseur. Lorsque l'un
de ces noyaux est installé, update-grub reconnait qu'il s'agit d'un
noyau Xen et adapte la configuration.

Sous Lenny, pas de noyau estampillé Xen. D'après ce que j'ai compris,
les noyaux récents intègrent ce qu'il faut, il n'est plus nécessaire de
les patcher. Au démarrage, le noyau 2.6.22 m'indique « Booting
paravirtualized kernel on bare hardware » ce qui semble correspondre à
ce fait. J'installe donc le paquet xen-hypervisor-3.2-1-i386 qui
installe un fichier (de mémoire) /boot/xen-3.2-1.gz. D'après ce que j'ai
lu, il s'agirait d'un noyau pour lequel il faudrait une entrée dans le
menu.lst de grub. J'ai donc modifié mon menu.lst comme indiqué dans la
doc de Xen :

title Un titre quelconque
root (hd0,0)
kernel /boot/xen-3.2-1.gz
module /boot/vmlinuz-2.6.22-3-686 root=/dev/sda1 ro console=tty0
module /boot/initrd.img-2.6.22-3-686

Cette configuration me semble correspondre à ce que j'ai lu dans la doc
et sur les différents forums que j'ai croisés.

Je reboote et là, c'est le drame :
***LOADING DOMAIN 0****
elf_init: not an ELF binary

Panic on CPU 0:
Could not set up DOM0 guest OS

Pas beaucoup d'information sur cette erreur. Ça pourrait être dû à une
erreur de config de Grub (j'ai eu beau relire dans tous les sens ma
config, je ne vois pas ce qui pourrait être problématique) ou bien à une
image corrompue (étant donnée la qualité légendaire de Debian, je n'y
crois pas une seconde).

J'ai également gunzippé le fichier xen-3.2-1.gz et reconfiguré grub pour
qu'il charge l'image non-compressée, même résultat. J'ai installé une
image PAE, une image NON-PAE, même résultat.

Je sèche !
Je suis preneur d'expériences, de conseils, de solutions toutes prêtes
aussi, bref, de tout ce que vous avez sous la main !

Merci
Seb

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Gilles Mocellin
Le #9704511
--nextPart3096736.DbWbYFFJ6T
Content-Type: text/plain;
charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Le Tuesday 04 March 2008 10:24:42 Sébastien NOBILI, vous avez écrit :
Bonjour,

J'essaye de faire fonctionner Xen sur une machine sous Lenny mais ça
n'est pas très concluant.


[...]

Je reboote et là, c'est le drame :
***LOADING DOMAIN 0****
elf_init: not an ELF binary

Panic on CPU 0:
Could not set up DOM0 guest OS

Pas beaucoup d'information sur cette erreur. Ça pourrait être dû à une
erreur de config de Grub (j'ai eu beau relire dans tous les sens ma
config, je ne vois pas ce qui pourrait être problématique) ou bien à une
image corrompue (étant donnée la qualité légendaire de Debian, je n'y
crois pas une seconde).



J'ai également gunzippé le fichier xen-3.2-1.gz et reconfiguré grub pour
qu'il charge l'image non-compressée, même résultat. J'ai installé une
image PAE, une image NON-PAE, même résultat.

Je sèche !
Je suis preneur d'expériences, de conseils, de solutions toutes prêtes
aussi, bref, de tout ce que vous avez sous la main !

Merci
Seb



Les noyaux Debian Xen > 2.6.18 n'integre que la partie nécessaire à fai re
tourner un DomU, pas un Dom0.
A l'heure actuelle, Xen ne supporte pas les noyaux > 2.6.18.
Cependant, ce n'est pas impossible à faire, Fedora et Ubuntu ont des noya u de
tests avec Xen.

Pour l'instant, je conseillerais de rester en Etch pour jouer avec Xen, tou t
du moins pour le Dom0.

--nextPart3096736.DbWbYFFJ6T
Content-Type: application/pgp-signature; name=signature.asc
Content-Description: This is a digitally signed message part.

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQBHzeVcDltnDmLJYdARApS2AJwM9BoOWaIgYItyUouvCnSPYfnwRQCeLNfa
2LF9FGfBi1UeD93OlaCwb6g =x6Hg
-----END PGP SIGNATURE-----

--nextPart3096736.DbWbYFFJ6T--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Sébastien NOBILI
Le #9704491
Le mercredi 05 mars 08 à 1:11, Gilles Mocellin a écrit :
| Les noyaux Debian Xen > 2.6.18 n'integre que la partie nécessaire à faire
| tourner un DomU, pas un Dom0.
| A l'heure actuelle, Xen ne supporte pas les noyaux > 2.6.18.
| Cependant, ce n'est pas impossible à faire, Fedora et Ubuntu ont des noyau de
| tests avec Xen.

Ça explique donc les messages trouvés sur le net dans lesquels les
auteurs expliquaient qu'ils avaient renoncé à faire marcher Xen sous
Lenny...

| Pour l'instant, je conseillerais de rester en Etch pour jouer avec Xen, tout
| du moins pour le Dom0.

Malheureusement j'ai une carte réseau Broadcom 44xx et elle ne
fonctionne pas avec le noyau Xen de Etch.

Merci pour l'éclaircissement en tout cas.

Seb

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
DavidCa
Le #9698281
Bonjour,
je ne sais pas si vous faites vous même vos noyaux,
mais le problème peut venir de la sélection de "Subarchitecture T ype".
Il faut sélectionner Xen-compatible au lieu de PC-compatible ...
Si les sources du noyau contiennent le nécessaire pour activer Xen bie n sûr.
--
View this message in context: http://www.nabble.com/Xen-sous-lenny-tp158233 34p16074295.html
Sent from the debian-user-french mailing list archive at Nabble.com.
Sébastien NOBILI
Le #9698171
Le samedi 15 mars 08 à 17:36, DavidCa a écrit :
| Bonjour,

Bonjour,

| je ne sais pas si vous faites vous même vos noyaux,
| mais le problème peut venir de la sélection de "Subarchitecture Type".
| Il faut sélectionner Xen-compatible au lieu de PC-compatible ...
| Si les sources du noyau contiennent le nécessaire pour activer Xen bien sûr.

L'essai que j'avais fait utilisait le noyau et l'hyperviseur provenant
de l'archive Debian, rien de perso.
J'ai laissé tomber Xen et Lenny, je suis de retour sous Etch après un
downgrade assez mal négocié, la suppression de manière aléatoire de
beaucoup de paquets, j'ai remis ma machine en état après quelques jours
de manipulations.

Xen fonctionne sous Etch mais ma carte réseau Broadcom (module b44) ne
fonctionne pas. J'ai trouvé un patch pour le noyau (récupéré par un
utilisateur de Debian depuis les sources des noyaux Fedora). J'avance
lentement sur le sujet au fur et à mesure que je trouve du temps.

Merci en tout cas.

Seb

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme