XL 2002 - NBVAL et SOUS.TOTAL

Le
Congelator
Salut tout le monde,
Est-ce que qqn saurait comment lier SOUS.TOTAL ET NBVAL dans une même
formule ? Concrètement :
j'ai une colonne (H) qui contient des données. J'applique un filtre pour
n'afficher que certaines et de là j'ai besoin, en H2, de savoir combien de
données sont affichées afin de pouvoir reprendre ce chiffre dans une autre
cellule d'un autre onglet.
Merci d'avance.
--
Céd / Lausanne
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Misange
Le #4512131
Bonjour,
Tu utilises simplement
=sous.total(2; ta-plage-de-données)
ta plage de données fait référence à la plage avant filtration. Le
résultats te donne le nombre de valeurs après filtration.

Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

Salut tout le monde,
Est-ce que qqn saurait comment lier SOUS.TOTAL ET NBVAL dans une même
formule ? Concrètement :
j'ai une colonne (H) qui contient des données. J'applique un filtre pour
n'afficher que certaines et de là j'ai besoin, en H2, de savoir combien de
données sont affichées afin de pouvoir reprendre ce chiffre dans une autre
cellule d'un autre onglet.
Merci d'avance.


Congelator
Le #4512081
Salut Misange,

Merci pour le coup de main, c'est bien ça (mis à part que c'était 3 au lieu
de 2 - =SOUS.TOTAL(3;H9:H1000) - mais ce n'est pas grave ;-). Ayant
toujours utilisé 9, je n'ai même pas pensé à aller voir les autres
possibilités... Un mauvais point pour moi.

encore merci
-
Céd / Lausanne



Bonjour,
Tu utilises simplement
=sous.total(2; ta-plage-de-données)
ta plage de données fait référence à la plage avant filtration. Le
résultats te donne le nombre de valeurs après filtration.

Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

Salut tout le monde,
Est-ce que qqn saurait comment lier SOUS.TOTAL ET NBVAL dans une même
formule ? Concrètement :
j'ai une colonne (H) qui contient des données. J'applique un filtre pour
n'afficher que certaines et de là j'ai besoin, en H2, de savoir combien de
données sont affichées afin de pouvoir reprendre ce chiffre dans une autre
cellule d'un autre onglet.
Merci d'avance.





JB
Le #4511831
Bonjour,


Exemple pour compter sur une zone filtrée: on veut compter le nombre
de nombres 0 dans la zone filtrée

=SOMMEPROD((SOUS.TOTAL(3;INDIRECT("D"&LIGNE(D2:D1000)))*(D2:D10000)))

http://boisgontierjacques.free.fr/fichiers/Filtre/CompteZoneFiltree.xls

Somme sur une zone filtrée:

=SOMMEPROD((SOUS.TOTAL(9;INDIRECT("b"&LIGNE(B2:B1000)))*(A2:A1000="Eur" )))

http://boisgontierjacques.free.fr/fichiers/Filtre/FiltreSommeZoneFiltree.xls

Cordialement JB

On 15 mai, 08:28, Congelator wrote:
Salut tout le monde,
Est-ce que qqn saurait comment lier SOUS.TOTAL ET NBVAL dans une même
formule ? Concrètement :
j'ai une colonne (H) qui contient des données. J'applique un filtre pour
n'afficher que certaines et de là j'ai besoin, en H2, de savoir combien de
données sont affichées afin de pouvoir reprendre ce chiffre dans une autre
cellule d'un autre onglet.
Merci d'avance.
--
Céd / Lausanne


Congelator
Le #4532081
Salut JB,

Merci pour l'info, je vais aussi pouvoir l'utiliser dans un autre fichier.
Que ferait-on sans ce forum et ces utilisateurs...?!?!
Encore merci et a+
--
Céd / Lausanne



Bonjour,


Exemple pour compter sur une zone filtrée: on veut compter le nombre
de nombres 0 dans la zone filtrée

=SOMMEPROD((SOUS.TOTAL(3;INDIRECT("D"&LIGNE(D2:D1000)))*(D2:D10000)))

http://boisgontierjacques.free.fr/fichiers/Filtre/CompteZoneFiltree.xls

Somme sur une zone filtrée:

=SOMMEPROD((SOUS.TOTAL(9;INDIRECT("b"&LIGNE(B2:B1000)))*(A2:A1000="Eur")))

http://boisgontierjacques.free.fr/fichiers/Filtre/FiltreSommeZoneFiltree.xls

Cordialement JB

On 15 mai, 08:28, Congelator wrote:
Salut tout le monde,
Est-ce que qqn saurait comment lier SOUS.TOTAL ET NBVAL dans une même
formule ? Concrètement :
j'ai une colonne (H) qui contient des données. J'applique un filtre pour
n'afficher que certaines et de là j'ai besoin, en H2, de savoir combien de
données sont affichées afin de pouvoir reprendre ce chiffre dans une autre
cellule d'un autre onglet.
Merci d'avance.
--
Céd / Lausanne







Publicité
Poster une réponse
Anonyme