xml CDATA et problème cosmétique

Le
unbewusst.sein
après interrogation d'une base de données, je crée, en PHP5, une string
xml du genre :

<?xml version='1.0' encoding='utf-8' ?><root>
<destination zone="item" mode="replace"/>
<data><![CDATA[
<!-- le contenu HTML à insérrer dans "item" -->
]]></data>

tout cela sans aucun "", j'ai trois destinations possibles
simultanément : categories, items et item.

Le problème "cosmétique", quand je débug, j'envoie ce xml directement
sur le navigateur et, dans la partie <data></data>, sur le navigateur
(Google Chrome), j'obtiens un affichage :
<![CDATA[
<span class='content' id='title'><a
href='http://forum.xfce.org/viewtopic.php?pid#852#p23852'>XSet<img
src='img/world
]]>
<![CDATA[
.png' alt='' /></a></span></p><p class='row'><span class='legend'>Notes
:</span>
]]>

càd qu'une -même- partie de CDATA est coupée en 2 ou en 3, mais pas du
tout sur les autres navigateurs testés (Safari, Firefox Nightly et Opera
Next).

c'est juste génant, car fonctionnellement, je n'affiche le xml que pour
tester, en réalité j'extrais les CDATA et je mets ça dans le truc d'id
destination, et ça roule.

c'est visible là :
<http://82.226.217.239/cli/cli-test.php>

la version "normale" (non-xml) est là :
<http://82.226.217.239/cli/index.html>

--
« Mesdames, un conseil. Si vous cherchez un homme beau,
riche et intelligent prenez-en trois ! »
(Coluche)
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
MELMOTH
Le #24013571
Ce cher mammifère du nom de Une Bévue nous susurrait, le mardi
29/11/2011, dans nos oreilles grandes ouvertes mais un peu sales tout
de même, et dans le message
suivants :

je crée, en PHP5, une *string*



Une _quoi_ ?...

--
Car avec beaucoup de science, il y a beaucoup de chagrin ; et celui qui
accroît sa science accroît sa douleur.
[Ecclésiaste, 1-18]
MELMOTH - souffrant
rm
Le #24014101
Salut,
Le mardi 29 novembre 2011 à 10:03, Une Bévue a écrit :

après interrogation d'une base de données, je crée, en PHP5, une string
xml du genre :



peut-être que le groupe fr.comp.infosystemes.www.auteurs serait plus adapté
?

c'est visible là :



d'autant plus qu'avec n'importe quel navigateur web, j'obtiens :

"502 Bad Gateway
nginx"

à cette adresse...

@+
--
rm
Publicité
Poster une réponse
Anonyme