XML et UTF8

Le
Sam.G.
Bonjour,

Je suis sur un casse tête lié à l'encodage des caractères. J'interroge
via HTTP un serveur qui me renvoi du XML contenant des chaines en UTF8.

Là où ça se gâte, c'est lorsqu'il faut décoder tout ceci, et qu'il y a
des caractères accentués dans le XML. Attention, je ne parle pas de
caractères UTF8, mais bien d'un encodage supplémentaire effectué lors de
la construction de la structure XML (le genre de truc qui transforme les
< > etc). Du coup je me retrouve avec ce genre de chose :
&#224;&#231;&#233 (correspondant à un test avec "àçé").

Cela n'a rien d'anormal, mais comment décoder cela sous Windev 10 (si
c'est possible) ?

Merci d'avance.
Sam.
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JeAn-PhI
Le #14581551
Sam.G. a couché sur son écran :
Bonjour,

Je suis sur un casse tête lié à l'encodage des caractères. J'interroge via
HTTP un serveur qui me renvoi du XML contenant des chaines en UTF8.

Là où ça se gâte, c'est lorsqu'il faut décoder tout ceci, et qu'il y a des
caractères accentués dans le XML. Attention, je ne parle pas de caractères
UTF8, mais bien d'un encodage supplémentaire effectué lors de la construction
de la structure XML (le genre de truc qui transforme les < > etc...). Du coup
je me retrouve avec ce genre de chose : &#224;&#231;&#233 (correspondant à un
test avec "àçé").

Cela n'a rien d'anormal, mais comment décoder cela sous Windev 10 (si c'est
possible...) ?

Merci d'avance.
Sam.



XMLVersTexte et la réciproque ne fonctionne pas ?

--
Cordialement JeAn-PhI
Sam.G.
Le #14581541
JeAn-PhI a écrit :
XMLVersTexte et la réciproque ne fonctionne pas ?



Non, ces fonctions ne traitent pas ces cas. Seulement ce qui peut entrer
en conflit avec la structure du XML comme <, >, ...
Sam.G.
Le #14581521
Sam.G. a écrit :
JeAn-PhI a écrit :
XMLVersTexte et la réciproque ne fonctionne pas ?



Non, ces fonctions ne traitent pas ces cas. Seulement ce qui peut entrer
en conflit avec la structure du XML comme <, >, ...




Je me suis laissé égaré par l'UTF8. C'est beaucoup plus simple : c'est
un encodage *normalisé* utilisé depuis longtemps en HTML et en XML. Le
code est invariant que ce soit UTF8 ou ISO-8859-1 ou autre. En tout cas
il est clair que c'est de l'XML parfaitement valide et on ne peut plus
propre.

La fonction XMLVersTexte (WD10) est tout simplement une grosse fainéante
qui ne fait pas son boulot correctement... et j'en suis au même point
quoique j'ai qq pistes pour contourner. J'ai aussi pu rater une
fonctions dans l'aide à ce sujet, mais j'en doute.

En tout cas rien de mentionné comme amélioration dans la "XII" à ce
sujet. Ou alors je suis mauvaise langue et cela est déjà implémenté
correctement dans la XI.
Publicité
Poster une réponse
Anonyme