XOrg.conf avec une ATI Mobility Radeon X600

Le
David BERCOT
--Sig_/W_7JcFo=yiyM=7rovyay4Q5
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

Bonjour,

Bon, avant de régler mon problème Compiz, il faudrait d'abord que=
ma
carte graphique marche correctement. Et là, ce n'est pas le cas ;-)

J'ai donc une ATI Mobility Radeon X600 pour laquelle je viens de passer
2 heures à faire plein d'essais : drivers de base, drivers proprio ATI
(v8.42.3 téléchargé depuis chez eux), drivers fglrx, sans su=
ccès !!!
Je fais des modifications dans la section "Module", etc, etc,
sans résultat. J'ai toujours :
glxinfo | grep direct
direct rendering: No (If you want to find out why, try setting
LIBGL_DEBUG=verbose)

Est-ce qu'une âme charitable aurait la patience de m'éclairer 2
secondes ?

Merci d'avance.

David.

--Sig_/W_7JcFo=yiyM=7rovyay4Q5
Content-Type: application/pgp-signature; name=signature.asc
Content-Disposition: attachment; filename=signature.asc

--BEGIN PGP SIGNATURE--
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFHKecnvSnthbGI8ygRAhusAJ0bL7+PqN7hxn9i710lyB2awpWYOQCeJ1oH
ArzTYVNFJfN+4GKaNIIOQbM=
½Dv
--END PGP SIGNATURE--

--Sig_/W_7JcFo=yiyM=7rovyay4Q5--


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Hugues LARRIVE
Le #9614971
This is an OpenPGP/MIME signed message (RFC 2440 and 3156)
--------------enigD6B227016C6BFF3D26A220CD
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

David BERCOT a écrit :
Bonjour,

Bon, avant de régler mon problème Compiz, il faudrait d'abord que ma
carte graphique marche correctement. Et là, ce n'est pas le cas ;- )

J'ai donc une ATI Mobility Radeon X600 pour laquelle je viens de passer
2 heures à faire plein d'essais : drivers de base, drivers proprio ATI
(v8.42.3 téléchargé depuis chez eux), drivers fglrx, san s succès !!!
Je fais des modifications dans la section "Module", etc..., etc...,
sans résultat. J'ai toujours :
glxinfo | grep direct
direct rendering: No (If you want to find out why, try setting
LIBGL_DEBUG=verbose)

Est-ce qu'une âme charitable aurait la patience de m'éclairer 2
secondes ?

Merci d'avance.

David.



Chez moi ça fonctionne en dual-screen avec une Radeon RV100 et drive r
libre (jamais réussi avec le proprio).
Pour les détails concernant la configuration du driver : man radeon
Voilà mon xorg.conf si tu veux t'en inspirer (pas très propre v u que
j'avais pas réussi du premier coup et qu'une fois que ça foncti onne...) :

Section "Files"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/X11R6/lib/X11/fonts/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dbe"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
Option "XkbVariant" "latin9"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
EndSection

Section "Device"
Identifier "ATI head 1"
Driver "radeon"
BusID "PCI:1:0:0"
#ChipID 0x5159
VideoRAM 32768
Screen 0
Option "DPMS" "true"
Option "BusType" "AGP"
Option "AGPMode" "4"
Option "AGPSize" "64"
Option "AGPFastWrite" "true"
Option "DDCMode" "true"
Option "DynamicClocks" "true"
Option "XaaNoOffscreenPixmaps"
Option "AccelMethod" "XAA"
Option "ColorTiling" "true"
Option "BufferSize" "2"
Option "RingSize" "8"
Option "EnablePageFlip" "true"
Option "DynamicClocks" "on"
Option "mtrr" "on"
Option "VideoOverlay" "on"
Option "OpenGLOverlay" "off"
Option "EnableDepthMoves" "true"
Option "RenderAccel" "true"
Option "BackingStore" "true"


# Dual head config
Option "MonitorLayout" "CRT, CRT2"
Option "MergedFB" "true"
Option "CRT2Position" "RightOf"
Option "MergedXineramaCRT2IsScreen0" "False"
#Option "MergedXinerama" "true"
Option "MetaModes" "1024x768-1024x768"

EndSection
Section "Monitor"
Identifier "Moniteur gauche"
Option "DPMS"
HorizSync 30-70
VertRefresh 50-160
ModeLine "1024x768" 78.75 1024 1040 1136 1312 768 769 772
800 +hsync +vsync
EndSection

Section "Screen"
Identifier "Ecran gauche"
Device "ATI head 1"
Monitor "Moniteur gauche"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
#Option "Xinerama" "true"
Option "AIGLX" "true"
Screen "Ecran gauche" 0 0
#Screen "Ecran droit" RightOf "Ecran gauche"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection

Section "Extensions"
Option "Composite" "true"
EndSection



J'utilise compiz 0.3.6-1 sous etch car avec la version 0.2.2 les
fenêtres se maximisaient sur les 2 écrans...
@+


--------------enigD6B227016C6BFF3D26A220CD
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFHKfN8NdTZuHWpgVIRAl1FAJ0SICp9tIb5YrY7toJmPBRRDL5wrwCfQ5Sw
ZRKn1oa+EbyePPI47XuTIhs =LqgX
-----END PGP SIGNATURE-----

--------------enigD6B227016C6BFF3D26A220CD--


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
fabrice régnier
Le #9748931
salut,

:~$ lspci | grep ATI
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility
X700 (PCIE)

:~$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI MOBILITY RADEON X700
OpenGL version string: 2.0.6747 (8.40.4)

:~$ dpkg -al| grep fglrx
ii fglrx-control 8.40.4-2
ii fglrx-driver 8.40.4-2
ii fglrx-driver-dev 8.40.4-2
ii fglrx-kernel-2.6.22-2-686
ii fglrx-kernel-src

construction du module fglrx avec module-assistant

:~$ cat /etc/X11/xorg.conf
Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "Synaptics Touchpad"
EndSection

Section "ServerFlags"
Option "AIGLX" "off"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
EndSection

Section "Monitor"
Identifier "Écran générique"
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 160.0
Option "DPMS"
EndSection

Section "Device"
Identifier "ATI Technologies Inc Radeon Mobility X700 (PCIE)"
Driver "fglrx"
Option "TVFormat" "PAL-N"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "ATI Technologies Inc Radeon Mobility X700 (PCIE)"
Monitor "Écran générique"
DefaultDepth 24
SubSection "Display"
Modes "1280x800" "800x600"
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection

Section "Extensions"
Option "Composite" "Disable"
Option "RENDER" "Enable"
EndSection


:~$ glxinfo | grep direct
direct rendering: Yes

euh quoi d'autre ?

Si je me rappelle bien, pour faire tourner compiz, il faut utiliser le
driver libre plutôt que fglrx.

En espèrant que ça aide ;)

a+

f.


David BERCOT wrote:
Bonjour,

Bon, avant de régler mon problème Compiz, il faudrait d'abord que ma
carte graphique marche correctement. Et là, ce n'est pas le cas ;-)

J'ai donc une ATI Mobility Radeon X600 pour laquelle je viens de passer
2 heures à faire plein d'essais : drivers de base, drivers proprio ATI
(v8.42.3 téléchargé depuis chez eux), drivers fglrx, sans succès !!!
Je fais des modifications dans la section "Module", etc..., etc...,
sans résultat. J'ai toujours :
glxinfo | grep direct
direct rendering: No (If you want to find out why, try setting
LIBGL_DEBUG=verbose)

Est-ce qu'une âme charitable aurait la patience de m'éclairer 2
secondes ?

Merci d'avance.

David.




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
David BERCOT
Le #9748761
--Sig_/_5D5wp57cDlIrl1IGK=IH27
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

Bonjour,

Merci aussi aux autres pour leurs suggestions ;-)
3 jours dessus et toujours pas de résultat !!!

En gros, j'ai maintenant à peu près la même version que toi sans :
Section "ServerFlags"
Option "AIGLX" "off"
EndSection



OK. Ca, ça marche aussi :
:~$ glxinfo | grep direct
direct rendering: Yes

Si je me rappelle bien, pour faire tourner compiz, il faut utiliser
le driver libre plutôt que fglrx.



Ben je ne sais pas, mais là, je n'y arrive vraiment pas...
Quand je lance fusion-icon, je n'ai pas de titre de fenêtre (bien que
j'ai coché l'option "décoration des fenêtres), et si je lanc e un compiz
--replace en ligne de commande, j'ai un joli :
compiz (core) - Fatal: GLX_EXT_texture_from_pixmap is missing
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0

Même en rajoutant
Option "AllowGLXWithComposite" "true"
ça ne change rien...

Bref, je commence vraiment à me demander si ça peut marcher
correctement sur ma machine...

J'ai mis un Ubuntu sur un autre poste (avec une NVidia 6600 je crois),
et Compiz tourne aux petits oignons...

Allez, je vais me coucher et peut être attendre (sauf si quelqu'un a
une super idée ;-))).

Encore merci.

David.

--Sig_/_5D5wp57cDlIrl1IGK=IH27
Content-Type: application/pgp-signature; name=signature.asc
Content-Disposition: attachment; filename=signature.asc

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFHLPsXvSnthbGI8ygRAogOAJ48wL3j/yH8jp0ju9s1QzKH/5cV9QCdFjMx
KD7Sv6umFyFScQpOzi3tyt4 ©YM
-----END PGP SIGNATURE-----

--Sig_/_5D5wp57cDlIrl1IGK=IH27--


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme