XOrg figé (Utilisation CPU 99,9 %)

Le
Le Souricier Gris
Je suis confronté à un problème bizarre, de manière aléatoire le
serveur XOrg se fige en utilisant toute la CPU disponible.

Il m'est alors possible de tuer le processus XORG par un kill -9 (kill
tout seul ne suffit pas) via une autre machine sur le réseau.

J'avoue ne plus trop savoir comment faire pour trouver d'où vient le
problème. Une idée permettant un débugging efficace ?

Je suis sur Debian 4.0 (etch). Précédemment sous Fedora, aucun
problème rencontré.

Mes recherches m'incite à passer en Testing mais j'aimerai plutôt
corrigé.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
yamo'
Le #16701991
Salut,
Le Souricier Gris a tapoté , le 02.09.2008 15:34:
Je suis confronté à un problème bizarre, de manière aléatoire le
serveur XOrg se fige en utilisant toute la CPU disponible.




Pour redémarrer le serveur X en étant sur la machine sur Ubuntu
j'utilise : Ctrl Alt Backspace mais je ne sais pas si ça fonctionne sur
toutes les distributions ; sous CentOx 4.5 sur VMWARE/XP cette commande
ne fonctionne pas.

Sinon pour le processus à 100% je n'ai aucune idée.


Stéphane
--
Il s'est sans doute laissé impressionner par les cris d'orfraie du
quarteron de fufopithèques en furie.
-+- MB in: Guide du Cabaliste Usenet - Bien configurer son MB -+-
Jean-Pierre
Le #16703721
Le Souricier Gris wrote:

Je suis confronté à un problème bizarre, de manière aléatoire le
serveur XOrg se fige en utilisant toute la CPU disponible.

Il m'est alors possible de tuer le processus XORG par un kill -9 (kill
tout seul ne suffit pas) via une autre machine sur le réseau.

J'avoue ne plus trop savoir comment faire pour trouver d'où vient le
problème. Une idée permettant un débugging efficace ?

Je suis sur Debian 4.0 (etch). Précédemment sous Fedora, aucun
problème rencontré.

Mes recherches m'incite à passer en Testing mais j'aimerai plutôt
corrigé.



j'ai déjà eu le problème sous debian etch et en procédant par élimination
successive (je désactivais à chaque fois un seul programme au démarrage de
mon kde et j'attendais de voir ce que ça donne) je me suis aperçu que
c'était superkaramba qui mettait le bazar; donc si tu ne l'utilises pas je
ne vois évidemment pas d'où ça peut venir!
Par contre je t'incite à passer en lenny qui marche à merveille en tout cas
chez moi (depuis un an) et je ne dois pas être le seul! D'autant qu'elle ne
devrait pas tarder à être finaliser! Par contre je pense qu'il ne faut pas
faire trop souvent de mises à jour car de temps en temps c'est un peu le
bazar mais bon rien que de très normal pour une version de test.

bon courage!
--

Ah l'informatique! Ou pourquoi faire simple quand on peut faire
compliqué!...

Jean-Pierre.
Le Souricier Gris
Le #16713241
On 3 sep, 03:03, Jean-Pierre
Le Souricier Gris wrote:
> Je suis confronté à un problème bizarre, de manière aléatoire le
> serveur XOrg se fige en utilisant toute la CPU disponible.

> Il m'est alors possible de tuer le processus XORG par un kill -9 (kill
> tout seul ne suffit pas) via une autre machine sur le réseau.

> J'avoue ne plus trop savoir comment faire pour trouver d'où vient le
> problème. Une idée permettant un débugging efficace ?

> Je suis sur Debian 4.0 (etch). Précédemment sous Fedora, aucun
> problème rencontré.

> Mes recherches m'incite à passer en Testing mais j'aimerai plutôt
> corrigé.

j'ai déjà eu le problème sous debian etch et en procédant par é limination
successive (je désactivais à chaque fois un seul programme au démar rage de
mon kde et j'attendais de voir ce que ça donne) je me suis aperçu que
c'était superkaramba qui mettait le bazar; donc si tu ne l'utilises pas je
ne vois évidemment pas d'où ça peut venir!
Par contre je t'incite à passer en lenny qui marche à merveille en to ut cas
chez moi (depuis un an) et je ne dois pas être le seul! D'autant qu'ell e ne
devrait pas tarder à être finaliser! Par contre je pense qu'il ne fau t pas
faire trop souvent de mises à jour car de temps en temps c'est un peu l e
bazar mais bon rien que de très normal pour une version de test.

bon courage!
--

Ah l'informatique! Ou pourquoi faire simple quand on peut faire
compliqué!...

Jean-Pierre.



Je vais répondre aux 2 réponses :
1- Control Alt Backspace ne fonctionne
2- Je suis sous Gnome

Je vais tenter le passage sous Lenny.
Jean-Pierre
Le #16731521
Le Souricier Gris wrote:

On 3 sep, 03:03, Jean-Pierre
Le Souricier Gris wrote:
> Je suis confronté à un problème bizarre, de manière aléatoire le
> serveur XOrg se fige en utilisant toute la CPU disponible.

> Il m'est alors possible de tuer le processus XORG par un kill -9 (kill
> tout seul ne suffit pas) via une autre machine sur le réseau.

> J'avoue ne plus trop savoir comment faire pour trouver d'où vient le
> problème. Une idée permettant un débugging efficace ?

> Je suis sur Debian 4.0 (etch). Précédemment sous Fedora, aucun
> problème rencontré.

> Mes recherches m'incite à passer en Testing mais j'aimerai plutôt
> corrigé.

j'ai déjà eu le problème sous debian etch et en procédant par élimination
successive (je désactivais à chaque fois un seul programme au démarrage
de mon kde et j'attendais de voir ce que ça donne) je me suis aperçu que
c'était superkaramba qui mettait le bazar; donc si tu ne l'utilises pas
je ne vois évidemment pas d'où ça peut venir!
Par contre je t'incite à passer en lenny qui marche à merveille en tout
cas chez moi (depuis un an) et je ne dois pas être le seul! D'autant
qu'elle ne devrait pas tarder à être finaliser! Par contre je pense qu'il
ne faut pas faire trop souvent de mises à jour car de temps en temps
c'est un peu le bazar mais bon rien que de très normal pour une version
de test.

bon courage!
--

Ah l'informatique! Ou pourquoi faire simple quand on peut faire
compliqué!...

Jean-Pierre.



Je vais répondre aux 2 réponses :
1- Control Alt Backspace ne fonctionne
2- Je suis sous Gnome

Je vais tenter le passage sous Lenny.



ah j'ai oublié de demander quelle carte graphique tu utilises et si oui avec
ou sans pilote propriétaire?

--

Ah l'informatique! Ou pourquoi faire simple quand on peut faire
compliqué!...

Jean-Pierre.
David Boucher
Le #16779911
Le Thu, 04 Sep 2008 00:21:52 -0700, Le Souricier Gris a écrit :

On 3 sep, 03:03, Jean-Pierre
Le Souricier Gris wrote:
> Je suis confronté à un problème bizarre, de manière aléatoire le
> serveur XOrg se fige en utilisant toute la CPU disponible.

> Il m'est alors possible de tuer le processus XORG par un kill -9
> (kill tout seul ne suffit pas) via une autre machine sur le réseau.

> J'avoue ne plus trop savoir comment faire pour trouver d'où vient le
> problème. Une idée permettant un débugging efficace ?

> Je suis sur Debian 4.0 (etch). Précédemment sous Fedora, aucun
> problème rencontré.

> Mes recherches m'incite à passer en Testing mais j'aimerai plutôt
> corrigé.

j'ai déjà eu le problème sous debian etch et en procédant par
élimination successive (je désactivais à chaque fois un seul programme
au démarrage de mon kde et j'attendais de voir ce que ça donne) je me
suis aperçu que c'était superkaramba qui mettait le bazar; donc si tu
ne l'utilises pas je ne vois évidemment pas d'où ça peut venir! Par
contre je t'incite à passer en lenny qui marche à merveille en tout cas
chez moi (depuis un an) et je ne dois pas être le seul! D'autant
qu'elle ne devrait pas tarder à être finaliser! Par contre je pense
qu'il ne faut pas faire trop souvent de mises à jour car de temps en
temps c'est un peu le bazar mais bon rien que de très normal pour une
version de test.

bon courage!
--

Ah l'informatique! Ou pourquoi faire simple quand on peut faire
compliqué!...

Jean-Pierre.



Je vais répondre aux 2 réponses :
1- Control Alt Backspace ne fonctionne 2- Je suis sous Gnome

Je vais tenter le passage sous Lenny.



J'ai eu ce problème il y a quelques temps, j'avais une carte nVidia
GeForce et le driver propriétaire d'installé.

J'avais essayé avec le driver libre de xorg, le problème était moins
fréquent mais arrivait quand même.

La solution a été d'ajouter noapic comme argument lors du chargement du
noyau dans mon fichier de configuration de grub.

Voilà qui peut peut-être t'aider !

David.
Publicité
Poster une réponse
Anonyme