xorg installé startx non fonction

Le
sayane01
Bonjour,
nouveau sur freebsd, je tente une installation depuis trois jours sans
succès. je suis parvenu jusqu'à xorg. Là, ça bloque. j'ai tenté m=
ille
et une choses sur xorg.conf.new, eh bien ça ne marche pas. Bien que
j'ai réussi à avoir le xterm avant la mise à jour de xorg passant de
6.9 à 7.2. depuis c'est bloqué. le /var/log/Xorg.0.log me donne: fatal
server error, could not open default font fixed. est-ce un pb de
police de caractères ? de modeline? j'ai tenté bcp de choses. je reste
bloqué.
notez que j'ai en main tout le temps le manuel.
cd /usr/X11R6/lib/X11/fonts/URW ou freetype me donne :unable to open
display.
merci de votre aide!
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
kavanier
Le #898520
Bonjour,
bonjour

la mise à jour de xorg passant de
6.9 à 7.2. depuis c'est bloqué.


Amha c'est l'upgrade qui est mal faite , avez vous lu ceci
/usr/ports/UPDATING ?

les explications pour faire une bonne upgrade de Xorg sont dans ce
document , vous pouvez aussi lire le post qui parle de cette même
upgrade , (sur ce serveur) .





kevin.vanier

sayane01
Le #898518
On Jul 24, 3:36 am, kavanier
a écrit :> Bonjour,

bonjour
la mise à jour de xorg passant de

6.9 à 7.2. depuis c'est bloqué.


Amha c'est l'upgrade qui est mal faite , avez vous lu ceci
/usr/ports/UPDATING ?

les explications pour faire une bonne upgrade de Xorg sont dans ce
document , vous pouvez aussi lire le post qui parle de cette même
upgrade , (sur ce serveur) .

kevin.vanier


Merci de ta reponse! ça m'encourage d'aller encore plus loin dans Unix-
la liberté; Mais bon voilà, c'est plus compliqué que prévu!
J'ai fait cette Maj parce que certains fichiers de du packages étaient
inexistants, donc avec cvsup portmanager et pkgdb -F, j'ai réussi à
les rassembler. Mais à présent, et c'est de quoi de rire: xorg meta
port est à 6.9.0 certains comme fonts truetype sont à la 7.2.0. C'est
pourquoi, il me faut vraient de l'aide.
J'ai tenté la suppression de xorg 6.9.0 dans l'espoir de l'obtenir en
version 7 par pkg_add, eh bien, non ça me redonne la 6.9;
Je vais tenter de compiler le dernier driver de nvidia car j'ai nv à
présent, puis la lecture de /usr/ports/Updating. on verra, ensuite.
Enfin je suis tout content de trouver un site en français. j'ai lu
d'autres topics, mais là c'est plus compliqué.
A+


Eric Masson
Le #898517
""
'Lut,

J'ai tenté la suppression de xorg 6.9.0 dans l'espoir de l'obtenir en
version 7 par pkg_add, eh bien, non ça me redonne la 6.9;


La solution est de lire /usr/ports/UPDATING.

Si la procédure n'a pas été suivie, le système de ports doit être dans
un état un tantinet étrange. le plus simple va consister à virer tous
les ports :
rm -rf /usr/local
rm -rf /usr/X11R6
rm -rf /var/db/pkg
rm -rf /var/db/ports

Partant de là une réinstallation via les packages ou les ports, avec un
arbre à jour devrait se passer sans encombres.

(Il est préférable de sauvegarder les données importantes au préalable)

--
Je suis quelqu'un de sensé .. et pourtant depuis quelque temps "c'est
comme si on m'avait jeté un sort ..." Quelqu'un peut-il me parler de
celà ? Cà a l'air débile, et pourtant .. il y vraiment trop de trucs !
-+- in:
kavanier
Le #898516
oui ou sinon , si ton install est fraiche tu reinstall FreeBSD ,

install minimum -> cvsup des ports -> install de xorg directement en 7x
sans faire d'upgrade !

je pense que c'est viable .


Kevin Vanier
Marc Fonvieille
Le #898515
On Mon, 23 Jul 2007 14:57:36 -0700,
Bonjour,
nouveau sur freebsd, je tente une installation depuis trois jours sans
succès. je suis parvenu jusqu'à xorg. Là, ça bloque. j'ai tenté mille
et une choses sur xorg.conf.new, eh bien ça ne marche pas. Bien que
j'ai réussi à avoir le xterm avant la mise à jour de xorg passant de
6.9 à 7.2. depuis c'est bloqué. le /var/log/Xorg.0.log me donne: fatal
server error, could not open default font fixed. est-ce un pb de
police de caractères ? de modeline? j'ai tenté bcp de choses. je reste
bloqué.
[...]


Il faut installer x11-fonts/font-alias

--
Marc

Marc Fonvieille
Le #898514
On 24 Jul 2007 12:45:48 GMT, Marc Fonvieille
On Mon, 23 Jul 2007 14:57:36 -0700,
Bonjour,
nouveau sur freebsd, je tente une installation depuis trois jours sans
succès. je suis parvenu jusqu'à xorg. Là, ça bloque. j'ai tenté mille
et une choses sur xorg.conf.new, eh bien ça ne marche pas. Bien que
j'ai réussi à avoir le xterm avant la mise à jour de xorg passant de
6.9 à 7.2. depuis c'est bloqué. le /var/log/Xorg.0.log me donne: fatal
server error, could not open default font fixed. est-ce un pb de
police de caractères ? de modeline? j'ai tenté bcp de choses. je reste
bloqué.
[...]


Il faut installer x11-fonts/font-alias



J'oublie également la réinstallation de x11-fonts/font-cursor-misc et
x11-fonts/font-misc-misc

--
Marc


sayane01
Le #895885
On Jul 24, 2:50 pm, Marc Fonvieille
On 24 Jul 2007 12:45:48 GMT, Marc Fonvieille
On Mon, 23 Jul 2007 14:57:36 -0700,
Bonjour,
nouveau sur freebsd, je tente une installation depuis trois jours sans
succès. je suis parvenu jusqu'à xorg. Là, ça bloque. j'ai tent é mille
et une choses sur xorg.conf.new, eh bien ça ne marche pas. Bien que
j'ai réussi à avoir le xterm avant la mise à jour de xorg passa nt de
6.9 à 7.2. depuis c'est bloqué. le /var/log/Xorg.0.log me donne: f atal
server error, could not open default font fixed. est-ce un pb de
police de caractères ? de modeline? j'ai tenté bcp de choses. je r este
bloqué.
[...]


Il faut installer x11-fonts/font-alias


J'oublie également la réinstallation de x11-fonts/font-cursor-misc et
x11-fonts/font-misc-misc

--
Marc


Bonjour a tous
hormis le clavier tout va bien et je n'arrive pas a le faire depuis
sysinstall bien que j'y passe. je poste depuis donc firefox freeBsd.
Assez content de me mettre serieusement a Unix. J'ai fini par regarder
en haut du premier message de Marc pour comprendre qu'il est l'un des
traducteurs du manuel.
Pour mon install (xorg surtout)
En fait il ne fallait pas necessairement upgrader x11 et xorg,
xorg-6.9.0 suffit amplement. Mon erreur fut de suivre Marc et
Christopher Shumway a la lettre dans le manuel. Au lieu de preceder
automatiquement xorg.conf.new de /root, j'ai omis de le faire. Or,
Xorg -configure genere /root/xorg.conf.new. et non xorg.conf.new. En
fin de construction de /etc/xorg.conf, on doit copier de /root/
xorg.conf.new. Tout le reste est facile.
Evide;;ent, je me base sur le manuel.
Les premieres etapes sont legers differentes de celles que j'ai du
suivre. j'en ferai un compte-rendu plus tard, pour une petite
critique.
Autre etonnement alors que je m'appretait a installer firefox, le
voila, le tigre, compris dans kde, il faut le signaler cela aussi.
Salut a tous.



Marc Fonvieille
Le #895883
On Sat, 28 Jul 2007 09:18:17 -0700,
On Jul 24, 2:50 pm, Marc Fonvieille
On 24 Jul 2007 12:45:48 GMT, Marc Fonvieille
On Mon, 23 Jul 2007 14:57:36 -0700,
Bonjour,
nouveau sur freebsd, je tente une installation depuis trois jours sans
succès. je suis parvenu jusqu'à xorg. Là, ça bloque. j'ai tenté mille
et une choses sur xorg.conf.new, eh bien ça ne marche pas. Bien que
j'ai réussi à avoir le xterm avant la mise à jour de xorg passant de
6.9 à 7.2. depuis c'est bloqué. le /var/log/Xorg.0.log me donne: fatal
server error, could not open default font fixed. est-ce un pb de
police de caractères ? de modeline? j'ai tenté bcp de choses. je reste
bloqué.
[...]


Il faut installer x11-fonts/font-alias


J'oublie également la réinstallation de x11-fonts/font-cursor-misc et
x11-fonts/font-misc-misc

--
Marc


Bonjour a tous
hormis le clavier tout va bien et je n'arrive pas a le faire depuis
sysinstall bien que j'y passe. je poste depuis donc firefox freeBsd.
Assez content de me mettre serieusement a Unix. J'ai fini par regarder
en haut du premier message de Marc pour comprendre qu'il est l'un des
traducteurs du manuel.
Pour mon install (xorg surtout)
En fait il ne fallait pas necessairement upgrader x11 et xorg,
xorg-6.9.0 suffit amplement. Mon erreur fut de suivre Marc et
Christopher Shumway a la lettre dans le manuel.


S'il y a des erreurs ce n'est pas la faute de Christopher mais la
mienne, je suis responsable de la mise à jour pour Xorg du texte de
Christopher.

Au lieu de preceder
automatiquement xorg.conf.new de /root, j'ai omis de le faire. Or,
Xorg -configure genere /root/xorg.conf.new. et non xorg.conf.new. En
fin de construction de /etc/xorg.conf, on doit copier de /root/
xorg.conf.new. Tout le reste est facile.
Evide;;ent, je me base sur le manuel.


Le Handbook précise bien:

---
# Xorg -configure

This will generate an X11 configuration skeleton file in the /root
directory called xorg.conf.new (whether you su(1) or do a direct login
affects the inherited supervisor $HOME directory variable).
---

On suppose donc que les utilisateurs prendront en compte ce détail.

Les premieres etapes sont legers differentes de celles que j'ai du
suivre. j'en ferai un compte-rendu plus tard, pour une petite
critique.


Cela m'intéresse.

Autre etonnement alors que je m'appretait a installer firefox, le
voila, le tigre, compris dans kde, il faut le signaler cela aussi.


? Que veux-tu dire?

--
Marc




sayane01
Le #895878

S'il y a des erreurs ce n'est pas la faute de Christopher mais la
mienne, je suis responsable de la mise à jour pour Xorg du texte de
Christopher.

Au lieu de preceder
automatiquement xorg.conf.new de /root, j'ai omis de le faire. Or,
Xorg -configure genere /root/xorg.conf.new. et non xorg.conf.new. En
fin de construction de /etc/xorg.conf, on doit copier de /root/
xorg.conf.new. Tout le reste est facile.
Evide;;ent, je me base sur le manuel.


Le Handbook précise bien:

---
# Xorg -configure

This will generate an X11 configuration skeleton file in the /root
directory called xorg.conf.new (whether you su(1) or do a direct login
affects the inherited supervisor $HOME directory variable).
---

On suppose donc que les utilisateurs prendront en compte ce détail.

Les premières etapes sont legerement differentes de celles que j'ai dû
suivre. j'en ferai un compte-rendu plus tard, pour une petite
critique.
Cela m'intéresse.

Autre etonnement alors que je m'appretait a installer firefox, le
voila, le tigre, compris dans kde, il faut le signaler cela aussi.


? Que veux-tu dire?

Marc


Comme je l'écris plus haut, le texte traduit est parfaitement lisible,
facile d'accès. C'est par rapport aux étapes d'installation que j'ai
trouvé une légère différence. J'ai dû remarquer que deux ou trois
petites inversions au niveau chronologique.
Le fauseau horaire, à la fin, bien après la sélection de la souris. Je
détaillerai plus tard.
Ma préoccupation majeure à présent est l'appentissage de freebsd.
J'ai travaillé avec l'ouvrage de Dave Taylor, Unix, colection "Le tout
en poche", chez CampusPress.
Puis le manuel de FreeBSD. Auparavant, je m'étais documenté avec les
ouvrages de SUSE. Distribution que j'ai toujours sur mon portable.
Pour Firefox, je croyais devoir l'installer moi-même, or, je l'ai
trouvé intégré dans kde. En revanche thunderbird n'y est pas.
Seulement disponible dans les packages.

A présent, J'ai un problème que je n'arrive pas à identifier
correctement.
Quand je tente de configurer une clé usb, bien que le /var/log
m'annonce la connection de umass. message correcte, quand je fais
mount -t msdosfs /dev/da0s1 /umass, en réponse, j'ai no such file or
directory.
Idem, bien que cups est présent dans /usr/ports/print avec ses sous
répertoires, je l'ai installé deux fois par sysinstall et par make
install clean via son port, dans kde, il ne fonctionne pas.
Sincérement j'ai jeté un coup d'oeil au chapitre consacré à print d ans
le manuel en anglais, je préfère cups auquel je suis habitué. Kde
print ne voit même pas mon imprimante, même si le var log montre bien
que mon imprimante est branché (usb , Hp 5610, machine assez courante
d'ailleurs). Le lein entre les deux chose s est clair, les sont des
usb, ad0 est ulpt0.
Merci!


Paul Gaborit
Le #895875
À (at) Mon, 30 Jul 2007 06:30:01 -0700,
""
Quand je tente de configurer une clé usb, bien que le /var/log
m'annonce la connection de umass. message correcte, quand je fais
mount -t msdosfs /dev/da0s1 /umass, en réponse, j'ai no such file or
directory.


Le répertoire /umass existe-t-il ?

Idem, bien que cups est présent dans /usr/ports/print avec ses sous
répertoires, je l'ai installé deux fois par sysinstall et par make
install clean via son port, dans kde, il ne fonctionne pas.


À ma connaissance, cups fonctionne correctement.

Sincérement j'ai jeté un coup d'oeil au chapitre consacré à print dans
le manuel en anglais, je préfère cups auquel je suis habitué. Kde
print ne voit même pas mon imprimante, même si le var log montre bien
que mon imprimante est branché (usb , Hp 5610, machine assez courante
d'ailleurs). Le lein entre les deux chose s est clair, les sont des
usb, ad0 est ulpt0.


La mienne (une Canon iP4000) est aussi reconnue en tant qu'imprimante
USB (ulpt0). Mais ce n'est pas pour autant que le driver pour la gérer
existent (il n'existe qu'en version payante ou dégradée pour Linux).

--
Paul Gaborit -
Publicité
Poster une réponse
Anonyme