xserver-xorg-video-intel avec KMS_écran noir au boot

Le
maderios
Bonjour
Dans Squeeze fin octobre, UMS a été retiré de xserver-xorg-video-intel
au profit de KMS (kernel mode setting):

Le Changelog qui a foutu le bazar:
xserver-xorg-video-intel (2:2.12.0+shadow-2) unstable; urgency=low

* UMS is gone, this means Linux-only (closes: 597845).

-- Julien Cristau <jcristau@debian.org> Thu, 23 Sep 2010 16:40:26 +0200

Matériel concerné: chipset i915 sur carte mère Intel (sur un portable)
noyau compilé à partir du paquet source debian/Squeeze 2.6.32-27

Très bien, mais tout cela donne un bel écran noir lors du boot.
Si je ne veux pas de cet écran noir, je ne compile pas le noyau avec le
module i915.
Dans ce cas j'obtiens en essayant de lancer X
'module i915 not found'

Ce que dit la doc du paquet Debian:
xserver-xorg-video-intel (2:2.9.1-2) unstable; urgency=low
Starting with this version, the intel driver enables kernel mode setting
(KMS) by default for 830 and later chips. This comes with a framebuffer
driver which enables native resolution on the console. KMS also allows
faster VT switching and mode changes, as well as e.g. DisplayPort
support.
In case of trouble KMS can be disabled with the 'nomodeset' kernel command
line parameter, or by editing /etc/modprobe.d/i915-kms.conf.


J'ai essayé de mettre dans /etc/modprobe.d/i915-kms.conf
'options i915 modeset=0' au lieu de 1
ou de passer l'option 'nomodeset' à la fin de la ligne concernant le
boot/kernel dans grub
Aucun résultat
Quelqu'un a-t-il rencontré le même problème ?
Merci d'avance pour toute piste/lien
M

PS: bizarre d'introduire un changement majeur dans X alors que Squeeze
est gelée

Liens:
http://www.mail-archive.com/debian-x@lists.debian.org/msg101297.html
http://wiki.debian.org/KernelModesetting
http://forums.debian.net/viewtopic.php?f=5&tV550
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug`1558
http://wiki.archlinux.fr/xorg/intel/i910

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/4CD569C1.5090305@gmail.com
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
maderios
Le #22772291
Etat des lieux
J'ai essayé différentes compilations kernel avec toutes les config
imaginables, vga grub, etc...) sans aucun résultat. Il s'agirait plutôt
d'un bug affectant le driver pour les chipset 915GM (mon cas) avec le
passage au KMS .
http://bugs.debian.org/cgi-bin/pkgreport.cgi?pkg=xserver-xor(...)
Je me suis donc replié sur le driver vesa qui marche plus ou moins bien
(il perturbe le mode console) puis sur une version antérieure disponible
ici qui fonctionne très bien avec Squeeze:
http://snapshot.debian.org/package/xserver-xorg-video-intel/(...)



On 06/11/2010 15:44, maderios wrote:
Bonjour
Dans Squeeze fin octobre, UMS a été retiré de xserver-xorg-video-intel
au profit de KMS (kernel mode setting):

Le Changelog qui a foutu le bazar:
xserver-xorg-video-intel (2:2.12.0+shadow-2) unstable; urgency=low

* UMS is gone, this means Linux-only (closes: 597845).

-- Julien Cristau
Matériel concerné: chipset i915 sur carte mère Intel (sur un portable)
noyau compilé à partir du paquet source debian/Squeeze 2.6.32-27

Très bien, mais tout cela donne un bel écran noir lors du boot.
Si je ne veux pas de cet écran noir, je ne compile pas le noyau avec le
module i915.
Dans ce cas j'obtiens en essayant de lancer X
'module i915 not found'

Ce que dit la doc du paquet Debian:
xserver-xorg-video-intel (2:2.9.1-2) unstable; urgency=low
Starting with this version, the intel driver enables kernel mode setting
(KMS) by default for 830 and later chips. This comes with a framebuffer
driver which enables native resolution on the console. KMS also allows
faster VT switching and mode changes, as well as e.g. DisplayPort support.
In case of trouble KMS can be disabled with the 'nomodeset' kernel command
line parameter, or by editing /etc/modprobe.d/i915-kms.conf.


J'ai essayé de mettre dans /etc/modprobe.d/i915-kms.conf
'options i915 modeset=0' au lieu de 1
ou de passer l'option 'nomodeset' à la fin de la ligne concernant le
boot/kernel dans grub
Aucun résultat
Quelqu'un a-t-il rencontré le même problème ?
Merci d'avance pour toute piste/lien
M

PS: bizarre d'introduire un changement majeur dans X alors que Squeeze
est gelée

Liens:
http://www.mail-archive.com//msg101297.html
http://wiki.debian.org/KernelModesetting
http://forums.debian.net/viewtopic.php?f=5&tV550
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug`1558
http://wiki.archlinux.fr/xorg/intel/i910




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Christophe Gallaire
Le #23029671
maderios a dit dans un souffle :
Etat des lieux
J'ai essayé différentes compilations kernel avec toutes les config
imaginables, vga grub, etc...) sans aucun résultat. Il s'agirait
plutôt d'un bug affectant le driver pour les chipset 915GM (mon cas)
avec le passage au KMS .
http://bugs.debian.org/cgi-bin/pkgreport.cgi?pkg=xserver-xor(...)
Je me suis donc replié sur le driver vesa qui marche plus ou moins
bien (il perturbe le mode console) puis sur une version antérieure
disponible ici qui fonctionne très bien avec Squeeze:
http://snapshot.debian.org/package/xserver-xorg-video-intel/(...)



Bonjour,

Quelle version tu utilises exactement ? Celle-ci :

http://snapshot.debian.org/package/xserver-xorg-vidéo-intel/2%3A2.13.0-5/

Parce que j'ai moi aussi ce problème d'écran noir et j'ai moi-même essayé toutes
les compilations possibles et imaginables. J'utilise le module "vesa" mais
l'affichage n'est vraiment pas top.

@+

Christophe
--
Christophe Gallaire

Attention ! Suppression des mails entrants dont la taille est supérieure à 2Mo !
N'envoyez, s'il vous plaît, que des pièces jointes en formats ouverts.
---------------
Nouveau carnet de route : http://www.road2mayotte.org/blook
---------------
Linux On The Root : http://ubunteros.tuxfamily.org/
---------------
Clé de chiffrement : 34AA23BB

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
maderios
Le #23031831
On 01/17/2011 06:45 PM, Christophe Gallaire wrote:
maderios a dit dans un souffle :
Etat des lieux
J'ai essayé différentes compilations kernel avec toutes les config
imaginables, vga grub, etc...) sans aucun résultat. Il s'agirait
plutôt d'un bug affectant le driver pour les chipset 915GM (mon cas)
avec le passage au KMS .
http://bugs.debian.org/cgi-bin/pkgreport.cgi?pkg=xserver-xor(...)
Je me suis donc replié sur le driver vesa qui marche plus ou moins
bien (il perturbe le mode console) puis sur une version antérieure
disponible ici qui fonctionne très bien avec Squeeze:
http://snapshot.debian.org/package/xserver-xorg-video-intel/(...)



Bonjour,

Quelle version tu utilises exactement ? Celle-ci :

http://snapshot.debian.org/package/xserver-xorg-vidéo-intel/2%3A2.13.0-5/

Parce que j'ai moi aussi ce problème d'écran noir et j'ai moi-même
essayé toutes
les compilations possibles et imaginables. J'utilise le module "vesa" mais
l'affichage n'est vraiment pas top.

@+

Christophe


Bonjour
Le problème a été résolu lors d'une mise à jour de Squeeze
Bonne journée
M

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Christophe Gallaire
Le #23032041
maderios a dit dans un souffle :
On 01/17/2011 06:45 PM, Christophe Gallaire wrote:
maderios a dit dans un souffle :
Etat des lieux
J'ai essayé différentes compilations kernel avec toutes les config
imaginables, vga grub, etc...) sans aucun résultat. Il s'agirait
plutôt d'un bug affectant le driver pour les chipset 915GM (mon cas)
avec le passage au KMS .
http://bugs.debian.org/cgi-bin/pkgreport.cgi?pkg=xserver-xor(...)
Je me suis donc replié sur le driver vesa qui marche plus ou moins
bien (il perturbe le mode console) puis sur une version antérieure
disponible ici qui fonctionne très bien avec Squeeze:
http://snapshot.debian.org/package/xserver-xorg-video-intel/(...)



Bonjour,

Quelle version tu utilises exactement ? Celle-ci :

http://snapshot.debian.org/package/xserver-xorg-vidéo-intel/2%3A2.13.0-5/

Parce que j'ai moi aussi ce problème d'écran noir et j'ai moi-même
essayé toutes
les compilations possibles et imaginables. J'utilise le module "vesa" mais
l'affichage n'est vraiment pas top.

@+

Christophe


Bonjour
Le problème a été résolu lors d'une mise à jour de Squeeze
Bonne journée
M



Bonsoir,

Tu parles de quelle mise à jour, la dernière ? Parce que je n'ai pas de mise à
jour pour xserver-xorg-vidéo-intel qui patiente. Et, de mon côté, avec la
version ci-dessus, c'est un bel écran noir que j'obtiens au boot.

@+

Christophe
--
Christophe Gallaire

Attention ! Suppression des mails entrants dont la taille est supérieure à 2Mo !
N'envoyez, s'il vous plaît, que des pièces jointes en formats ouverts.
---------------
Nouveau carnet de route : http://www.road2mayotte.org/blook
---------------
Linux On The Root : http://ubunteros.tuxfamily.org/
---------------
Clé de chiffrement : 34AA23BB

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
maderios
Le #23033571
Tu parles de quelle mise à jour, la dernière ?


apt-get update
Il faut évidemment que le driver i915 soit chargé en module ou compilé
en dur dans le noyau.
Sinon, revois ta conf
/etc/modprobe.d/i915-kms.conf
options i915 modeset=1

M

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme