XUbuntu et scanner USB partagé par iMac

Le
Une Bévue
dans le même LAN, j'ai deux ordis : un Imac et un portable PC sous
Xubuntu 11.04.
Mon scanner est connecté en USB à mon iMac et j'ai activé le partage
scanner et j'ai vérifié aussi que depuis mon iMac je pouvais scanner
avec SANE.

le scanner n'est pas vu par xubuntu, comment régler ça ?
j'ai suivi les instructions de la page :
<https://help.ubuntu.com/community/ScanningHowTo#server>
mais mes essais, me renvoient à RTFM )))

les essais :
yt@D620:~$ sudo -s
root@D620:~# su -s /bin/bash saned
saned@D620:/home/yt$ scanimage -L

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).
saned@D620:/home/yt$


yt@D620:~$ sudo sane-find-scanner

# sane-find-scanner will now attempt to detect your scanner. If the
# result is different from what you expected, first make sure your
# scanner is powered up and properly connected to your computer.

# No SCSI scanners found. If you expected something different, make
sure that
# you have loaded a kernel SCSI driver for your SCSI adapter.

# No USB scanners found. If you expected something different, make
sure that
# you have loaded a kernel driver for your USB host controller and
have setup
# the USB system correctly. See man sane-usb for details.

# Not checking for parallel port scanners.

# Most Scanners connected to the parallel port or other proprietary ports
# can't be detected by this program.
yt@D620:~$


Bon là, apparemment, il n'y a pas de scan pour les scanners connectés.
le mien est à l'IP : 192.168.0.10.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Paul Gaborit
Le #24041001
À (at) Wed, 07 Dec 2011 09:07:20 +0100,
Une Bévue
dans le même LAN, j'ai deux ordis : un Imac et un portable PC sous
Xubuntu 11.04.
Mon scanner est connecté en USB à mon iMac et j'ai activé le partage
scanner et j'ai vérifié aussi que depuis mon iMac je pouvais scanner
avec SANE.

le scanner n'est pas vu par xubuntu, comment régler ça ?


[...]

Bon là, apparemment, il n'y a pas de scan pour les scanners connectés.
le mien est à l'IP : 192.168.0.10.



Est-ce que la page ci-dessous aide (en ne suivant que la partie
«client») ?


Sinon, toujours avec cette même doc, cela doit pouvoir marcher en
faisant l'inverse : scanner connecté à Xubuntu et Mac OS X qui y accède
au scanner via le réseau...

--
Paul Gaborit -
yamo
Le #24040971
Salut,

Le Wed, 07 Dec 2011 09:07:20 +0100, Une Bévue a écrit :

dans le même LAN, j'ai deux ordis : un Imac et un portable PC sous
Xubuntu 11.04.
Mon scanner est connecté en USB à mon iMac et j'ai activé le partage
scanner et j'ai vérifié aussi que depuis mon iMac je pouvais scanner
avec SANE.

le scanner n'est pas vu par xubuntu, comment régler ça ?
j'ai suivi les instructions de la page :
mais mes essais, me renvoient à RTFM )))



Apparemment c'est le bon tutoriel mais comme je n'ai jamais fait ça, le
retour d'expérience m'intéresse!

J'ai trouvé ces liens qui peuvent t'intéresser, le premier tu as du déjà
le lire mais le relire peut être utile!

<https://help.ubuntu.com/community/
ScanningHowTo#Sharing_a_Scanner_Over_a_Network>







--
Stéphane L'Homme animé par l'esprit scientifique désire sans doute savoir,
mais c'est aussitôt pour mieux interroger.
-+- Gaston Bachelard -+-
unbewusst.sein
Le #24041321
yamo
Apparemment c'est le bon tutoriel mais comme je n'ai jamais fait ça, le
retour d'expérience m'intéresse!

J'ai trouvé ces liens qui peuvent t'intéresser, le premier tu as du déjà
le lire mais le relire peut être utile!

<https://help.ubuntu.com/community/
ScanningHowTo#Sharing_a_Scanner_Over_a_Network>





OK, merci beaucoup pour tous ces URLs !!!
Bon, j'ai - un peu progressé - déjà au paragraphe 3. Sur le client (donc
xubuntu dans mon cas) il est dit :
Commencer par installez le paquet xsane. xSane (commande xsane), est le
logiciel qui vous permettra d'accéder au scanner distant. Vous pouvez
également installer un autre logiciel de scanner (voir la pagescanner).

Ce que je viens de faire...

reste à configurer...

je reposte dès que ça roule ;-)

Notes bien que mon vieux scanner Lide 30 est reconnu maintenant sur le
sane de mon iMac, ça marche "pas trop" mal MAIS enfin, c'est nettement
moins bien que vuescan...

--
« Ne craignez pas d'avancer lentement, craignez seulement
de rester sur place. »
(Proverbe chinois)
unbewusst.sein
Le #24041331
Paul Gaborit
Est-ce que la page ci-dessous aide (en ne suivant que la partie
«client») ?




Oui et non, enfin, c'est une des pages que j'avais utilisées, mais bon
en relisant je suis allé sur :
car j'ai appris que XSane n'est pas installé par défaut mais simplescan
ou qqc du genre...

Sinon, toujours avec cette même doc, cela doit pouvoir marcher en
faisant l'inverse : scanner connecté à Xubuntu et Mac OS X qui y accède
au scanner via le réseau...



Ben là, non, XUbuntu est sur mon portable qui se balade...
En tk merci pour m'avoir fait relire la docum...
--
« Ne craignez pas d'avancer lentement, craignez seulement
de rester sur place. »
(Proverbe chinois)
unbewusst.sein
Le #24041311
Une Bévue
reste à configurer...



Bon, j'ai commencé par :
:~$ sudo pico /etc/sane.d/net.conf



:~$ cat /etc/sane.d/net.conf
# This is the net backend config file.

## net backend options
# Timeout for the initial connection to saned. This will prevent the
backend
# from blocking for several minutes trying to connect to an unresponsive
# saned host (network outage, host down, ...). Value in seconds.
# Modifications du 7 décembre 2011 à 11:38
connect_timeout = 60

## saned hosts
192.168.0.10
# FIN Modifications du 7 décembre 2011 à 11:38
# Each line names a host to attach to.
# If you list "localhost" then your backends can be accessed either
# directly or through the net backend. Going through the net backend
# may be necessary to access devices that need special privileges.
# localhost
:~$


(donc après l'install de XSane)

et je n'obtiens pas de périph-by-net, pour l'instant :
<http://cjoint.com/11dc/ALhlTSB89ay_11-12-07--11-41--XSane_Aucun_periphe
rique_disponible.png>

à suivre donc...
--
« Ne craignez pas d'avancer lentement, craignez seulement
de rester sur place. »
(Proverbe chinois)
Paul Gaborit
Le #24041661
À (at) Wed, 7 Dec 2011 11:49:15 +0100,
(Une Bévue) écrivait (wrote):

Paul Gaborit
Est-ce que la page ci-dessous aide (en ne suivant que la partie
«client») ?




Oui et non, enfin, c'est une des pages que j'avais utilisées, mais bon
en relisant je suis allé sur :
car j'ai appris que XSane n'est pas installé par défaut mais simplescan
ou qqc du genre...



Effectivement, vous devez installer xsane vous-même pour pouvoir
l'utiliser.

Mais ce n'est pas xsane qui recherche un scanner sur le réseau. C'est la
bibliothèque sous-jacente (libsane). Pour configurer cette bibliothèque
afin qu'elle sache se connecter au Mac qui partage le scanner, c'est
bien mon premier lien qu'il faut utiliser. Et pour être plus précis,
c'est la section suivante :


En résumé, il suffit d'ajouter l'adresse IP du Mac dans le fichier
'/etc/sane.d/net.conf'.

L'avez-vous fait ? Cela marche-t-il ?

--
Paul Gaborit -
Une Bévue
Le #24041681
Le 07/12/2011 10:32, yamo a écrit :
J'ai trouvé ces liens qui peuvent t'intéresser, le premier tu as du déjà
le lire mais le relire peut être utile!

<https://help.ubuntu.com/community/
ScanningHowTo#Sharing_a_Scanner_Over_a_Network>






Bon j'ai encore progressé, mais sans véritable résultat car mon scanner
n'est tjs pas détecté, ce que j'ai fait :

dans /etc/sane.d/net.conf

j'ai déplacé la ligne :
192.168.0.10

tout à la fin...

dans /etc/default/saned
j'ai mis :
RUN=yes (au lieu du "no" précédent)

j'ai jeté un oeil au script /etc/init.d/saned
bizarement la ligne 24 est à :
RUN=no

mais c'est peut-être normal à ce point-là dans ce script.


du coup, j'ai fait un :
:~$ sudo /etc/init.d/saned restart
Restarting SANE network scanner server: saned.

donc là je sais que sun est running, je l'ai d'ailleurs vérifié par top...


MALHEUREUSEMENT, j'ai tjs :
:~$ sudo sane-find-scanner

# sane-find-scanner will now attempt to detect your scanner. If the
# result is different from what you expected, first make sure your
# scanner is powered up and properly connected to your computer.

# No SCSI scanners found. If you expected something different, make
sure that
# you have loaded a kernel SCSI driver for your SCSI adapter.

# No USB scanners found. If you expected something different, make
sure that
# you have loaded a kernel driver for your USB host controller and
have setup
# the USB system correctly. See man sane-usb for details.

# Not checking for parallel port scanners.

# Most Scanners connected to the parallel port or other proprietary ports
# can't be detected by this program.
:~$


:~$ sudo sane-find-scanner

# sane-find-scanner will now attempt to detect your scanner. If the
# result is different from what you expected, first make sure your
# scanner is powered up and properly connected to your computer.

# No SCSI scanners found. If you expected something different, make
sure that
# you have loaded a kernel SCSI driver for your SCSI adapter.

# No USB scanners found. If you expected something different, make
sure that
# you have loaded a kernel driver for your USB host controller and
have setup
# the USB system correctly. See man sane-usb for details.

# Not checking for parallel port scanners.

# Most Scanners connected to the parallel port or other proprietary ports
# can't be detected by this program.
:~$

...
unbewusst.sein
Le #24042231
Paul Gaborit
En résumé, il suffit d'ajouter l'adresse IP du Mac dans le fichier
'/etc/sane.d/net.conf'.



J'ai pensé à un "truc" le port 6566 est il ouvert ?
donc j'ai réalisé une redirection de ce port, sur le routeur de la FB
vers l'IPV4 de mon iMac.
Ensuite je vérifie sur xubuntu si ce port est ouvert, enfin, s'il y a
qq'un derrière, ben le résultat est, pour l'instant NEGATIF puisque mon
port scan, depuis xubuntu, passe de 5842 à 49152 ouverts sans voir le
6566 que m'a indiqué :
:~$ cat /etc/services|grep san
sane-port 6566/tcp sane saned # SANE network scanner
daemon

Je suis sûr pourtant que mon scanner est partagé...

je ne pense pas qu'il faille redémarrer mon iMac...

peut-être que le port utilisé sur Imac / Lion est différent d'ubuntu ???

à la page :
on parle aussi des ports 45745 et 47342 sans que cela sous justifié...

mais bon là je sais déjàoù chercher puisque d'un côté on est en 6566 et
de l'autre il n'y a rien...

--
« Ne craignez pas d'avancer lentement, craignez seulement
de rester sur place. »
(Proverbe chinois)
gilbert.olivier
Le #24042441
Une Bévue

peut-être que le port utilisé sur Imac / Lion est différent d'ubuntu ???



Ce serait bien surprenant je pense pour un port assigné.

à la page :
on parle aussi des ports 45745 et 47342 sans que cela sous justifié...



Pour ceux là (undaasigned) tout "bricolage" est possible...

--
Gilbert
unbewusst.sein
Le #24042491
Gilbert OLIVIER
Ce serait bien surprenant je pense pour un port assigné.



bon, ben c'est donc bien 6566 sur ubuntu c'est spécifié en tcp.

ce ne serait pas en UDP par hazard sur mac ?
sur ma freebox je n'ai ouvert que 6566/TCP ...

--
« Ne craignez pas d'avancer lentement, craignez seulement
de rester sur place. »
(Proverbe chinois)
Publicité
Poster une réponse
Anonyme