zipCrée en mode TSE

Le
pyfux
Bonjour,

J'ai écrit une petite procédure de zip de fichiers de données qui
fonctionne très bien sauf sur un PC qui lance l'appli en TSE.

Après ajout d'info de trace, je constate que l'application se "bloque"
sur l'appel à la fonction zipCrée.

En fait elle rend la main à la procédure appelante sans générer d'erreur !

Qui a déjà rencontré ce problème, y a t-il une solution ?


Code:
SI EnModeTSE() ALORS
Trace("Création de l'archives à partir de:" + sDossier)
FIN

ResCréation = zipCrée(sNomArchive,sDossier + "" + sNomArchive +
".zip") //BUG en mode TSE
SI ResCréation = 0 ALORS

SI EnModeTSE() ALORS
Trace("Début liste des fichiers")
FIN


sFichiers est chaîne
sFiltre est une chaîne
POUR TOUT CHAINE sFiltre DE sFiltreFichier SEPAREE PAR ";"

sFichiers=fListeFichier(sDossier + "" + sFiltre)

sFichier est une chaîne
POUR TOUT CHAINE sFichier DE sFichiers SEPAREE PAR RC

ResAjoutZip=zipAjouteFichier(sNomArchive,sFichier,zipAucun)
SI EnModeTSE() ALORS
Trace("Ajout du fichier: " + sFichier)
FIN

FIN

FIN


SINON
SI EnModeTSE() ALORS
Trace("échec ouverture zip! " + NumériqueVersChaîne(ResCréation) )
FIN
RENVOYER ""
FIN


On n'obtient sur la trace que le message:
"Création de l'archives à partir de:"

Merci pour vos réponses,
Pyfux
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Emmanuel Haefelé
Le #21292711
"pyfux"
Bonjour,

On n'obtient sur la trace que le message:
"Création de l'archives à partir de:"



D'après ce que tu dis, ResCréation doit être <> 0, donc quelle est sa
valeur et que raconte zipMsgErreur ?


Cordialement,

Emmanuel Haefelé.
pyfux
Le #21302211
Le 01/03/2010 14:08, Emmanuel Haefelé a écrit :
"pyfux"
Bonjour,

On n'obtient sur la trace que le message:
"Création de l'archives à partir de:"



D'après ce que tu dis, ResCréation doit être <> 0, donc quelle est sa
valeur et que raconte zipMsgErreur ?


Cordialement,

Emmanuel Haefelé.



Bonjour,

Je ne peux pas récupérer la valeur de ResCréation, la clause "sinon"
n'est pas exécuté!

je n'ai aucune trace, le sous programme qui contient le code rend la
main à la procédure appelante et c'est tout!

Qui a réalisé un test sur un serveur TSE ?

Help.

Pyfux
pyfux
Le #21302201
Le 01/03/2010 14:08, Emmanuel Haefelé a écrit :
"pyfux"
Bonjour,

On n'obtient sur la trace que le message:
"Création de l'archives à partir de:"



D'après ce que tu dis, ResCréation doit être <> 0, donc quelle est sa
valeur et que raconte zipMsgErreur ?


Cordialement,

Emmanuel Haefelé.



Bonjour,

Je ne peux pas récupérer la valeur de ResCréation, la clause "sinon"
n'est pas exécuté!

je n'ai aucune trace, le sous programme qui contient le code rend la
main à la procédure appelante et c'est tout!

Qui a réalisé un test sur un serveur TSE ?

Help.

Pyfux
VPSoft
Le #21307031
"pyfux"
Le 01/03/2010 14:08, Emmanuel Haefelé a écrit :
"pyfux"
Bonjour,

On n'obtient sur la trace que le message:
"Création de l'archives à partir de:"



D'après ce que tu dis, ResCréation doit être <> 0, donc quelle est sa
valeur et que raconte zipMsgErreur ?


Cordialement,

Emmanuel Haefelé.



Bonjour,

Je ne peux pas récupérer la valeur de ResCréation, la clause "sinon" n'est
pas exécuté!

je n'ai aucune trace, le sous programme qui contient le code rend la main
à la procédure appelante et c'est tout!

Qui a réalisé un test sur un serveur TSE ?

Help.

Pyfux



Bonjour,

J'ai un prog qui le fait et qui tourne sous Tse.
Je n'ai pas bien lu tout ton code, mais si ça fonctionne en local et pas
sous Tse, il faudrait peut être diriger tes recherches vers les Droits et
les Noms de dossiers avec espaces.
Victor
Publicité
Poster une réponse
Anonyme