zsh

Le
Thomas
bonjour :-)


je passe prendre des nouvelles de zsh,
ce fs fabuleux qui était censé être accessible au public dans mac os x
10.5 (non ?) :-)

--
Téléassistance / Télémaintenance
http://www.portparallele.com/ThomasDECONTES/
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Frederic Bezies
Le #16480821
Le 05.08.2008 13:40, Thomas a écrit :

bonjour :-)


je passe prendre des nouvelles de zsh,
ce fs fabuleux qui était censé être accessible au public dans mac os x
10.5 (non ?) :-)




C'est Zfs, et il semble à peine disponible sur les Solaris, open ou pas.
Attendons pour voir ;)
Erwan David
Le #16481081
Frederic Bezies
Le 05.08.2008 13:40, Thomas a écrit :

bonjour :-)


je passe prendre des nouvelles de zsh,
ce fs fabuleux qui était censé être accessible au public dans mac os x
10.5 (non ?) :-)




C'est Zfs, et il semble à peine disponible sur les Solaris, open ou
pas. Attendons pour voir ;)



Il est disponible aussi sous freebsd.

Cela dit zsh est un shell fabuleux disponible sous MacOS X, via
macports ou fink.


--
Le travail n'est pas une bonne chose. Si ça l'était,
les riches l'auraient accaparé
Erwan David
Le #16485461
Che Averell
Erwan David
Cela dit zsh est un shell fabuleux disponible sous MacOS X, via
macports ou fink.



Zsh est livré de série il me semble. En tout cas, c'était le cas
avec mon vieux tiger et son prédecesseur... Maintenant, pour leopard,
je sais pas, j'ai pas migré.



Euh oui. Mais un vieux zsh qui ne supporte pas utf-8. Voilà pourquoi
j'ai pris celui des macports...

--
Le travail n'est pas une bonne chose. Si ça l'était,
les riches l'auraient accaparé
Eric Levenez
Le #16485411
Le 05/08/08 13:40, dans

je passe prendre des nouvelles de zsh,
ce fs fabuleux qui était censé être accessible au public dans mac os x
10.5 (non ?) :-)



Tu confonds zsh, un shell unix adoré par certains, et ZFS un système de
fichier de SUN. zsh est disponible est standard sur Mac OS X 10.5 et ZFS
aussi, mais en version lecture seule.

--
Éric Lévénez -- Unix is not only an OS, it's a way of life.
Erwan David
Le #16484041
(Jacques Foucry) écrivait :

Erwan David
Euh oui. Mais un vieux zsh qui ne supporte pas utf-8. Voilà pourquoi
j'ai pris celui des macports...



Comment ça il ne supporte par utf-8 ?



Enfin partiellement seulement.

Et comment testes-tu ?



- lecture de la doc des features chez zsh en fonction du numéro de version

- édition de la la ligne de commande en avant et en arrière avec des
caractères accentués, s'il y a des décalages => pas bon.

Pour commencer.

--
Le travail n'est pas une bonne chose. Si ça l'était,
les riches l'auraient accaparé
Vincent Lefevre
Le #16487141
Dans l'article Jacques Foucry
Via macosx aussi. Nul besoin de le réinstaller, il est déjà présent



% whereis zsh
/bin/zsh



Sous Tiger, c'est une très vieille version:

zsh 4.2.3 (powerpc-apple-darwin8.0)

--
Vincent Lefèvre 100% accessible validated (X)HTML - Blog: Work: CR INRIA - computer arithmetic / Arenaire project (LIP, ENS-Lyon)
Jerome Lambert
Le #16487241
Vincent Lefevre a écrit :
Dans l'article Jacques Foucry
Via macosx aussi. Nul besoin de le réinstaller, il est déjà présent



% whereis zsh
/bin/zsh



Sous Tiger, c'est une très vieille version:

zsh 4.2.3 (powerpc-apple-darwin8.0)



La stable officielle est la 4.2.7. Il y a tant de différences entre les 2?
Erwan David
Le #16487331
Jerome Lambert
Vincent Lefevre a écrit :
Dans l'article Jacques Foucry
Via macosx aussi. Nul besoin de le réinstaller, il est déjà présent



% whereis zsh
/bin/zsh



Sous Tiger, c'est une très vieille version:

zsh 4.2.3 (powerpc-apple-darwin8.0)



La stable officielle est la 4.2.7. Il y a tant de différences entre les 2?



Pour le support complet de utf-8 il faut la version de développement
(complètement stable par ailleurs)

--
Le travail n'est pas une bonne chose. Si ça l'était,
les riches l'auraient accaparé
Vincent Lefevre
Le #16515121
Dans l'article Jerome Lambert
La stable officielle est la 4.2.7. Il y a tant de différences entre les 2?



La 4.2.7 est une très vieille version.

--
Vincent Lefèvre 100% accessible validated (X)HTML - Blog: Work: CR INRIA - computer arithmetic / Arenaire project (LIP, ENS-Lyon)
Erwan David
Le #16515541
Vincent Lefevre
Dans l'article Jerome Lambert
La stable officielle est la 4.2.7. Il y a tant de différences entre les 2?



La 4.2.7 est une très vieille version.



Par contre Léopard fournin 4.3.4
Donc pas vraiment de raison d'utiliser le zsh des ports.

--
Le travail n'est pas une bonne chose. Si ça l'était,
les riches l'auraient accaparé
Publicité
Poster une réponse
Anonyme