Aide sur une formule

Le
Marc Dayde
Bonjour
J'ai la formule suivante :=SI((E22>0);RECHERCHEV(E22;'TABLE DONNEES
CEREALES'!B24:E41;3;FAUX);SI(E21>0;(E25+E26+E30-E32);SI(E20>0;(E25+E26+E30-E
32)))) qui marche tellement bien que le résultat ( qui n'est qu'un chiffre )
peut être négatif . Ce que je voudrais, dés que le chiffre est négatif, que
le résultat soit 0 . Merci d'avance.
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Philippe.R
Le #1275756
Bonsoir Marc,
=si(SI((E22>0);RECHERCHEV(E22;'TABLE DONNEES
CEREALES'!B24:E41;3;FAUX);SI(E21>0;(E25+E26+E30-E32);SI(E20>0;(E25+E26+E30-E32))))<0;0;SI((E22>0);RECHER
CHEV(E22;'TABLE DONNEES CEREALES'!B24:E41;3;FAUX);SI(E21>0;(E25+E26+E30-E32);SI(E20>0;(E25+E26+E30-E
32)))))
Convaincu que les plus courtes ne sont pas forcément les meilleures ;o))
--
Amicales Salutations
Retirer A_S_ pour répondre.
XL 97 / 2000 / 2002

"Marc Dayde" news:c5h3ml$1po$
Bonjour
J'ai la formule suivante :=SI((E22>0);RECHERCHEV(E22;'TABLE DONNEES
CEREALES'!B24:E41;3;FAUX);SI(E21>0;(E25+E26+E30-E32);SI(E20>0;(E25+E26+E30-E
32)))) qui marche tellement bien que le résultat ( qui n'est qu'un chiffre )
peut être négatif . Ce que je voudrais, dés que le chiffre est négatif, que
le résultat soit 0 . Merci d'avance.




Claude-Alain
Le #1242180
Je te propose ceci : =max(0;"ta formule à rallonge, sans
le =")

Meilleures salutations




-----Message d'origine-----
Bonjour
J'ai la formule suivante :=SI((E22>0);RECHERCHEV
(E22;'TABLE DONNEES

CEREALES'!B24:E41;3;FAUX);SI(E21>0;(E25+E26+E30-E32);SI
(E20>0;(E25+E26+E30-E

32)))) qui marche tellement bien que le résultat ( qui
n'est qu'un chiffre )

peut être négatif . Ce que je voudrais, dés que le
chiffre est négatif, que

le résultat soit 0 . Merci d'avance.


.



Publicité
Poster une réponse
Anonyme