Carte Wifi noname chipset rt2400 ou 2460

Le
Nicolas
Bonjour,

ma config est sous Mandrake 10.0 community truc, et je tente de faire
fonctionner une carte wifi avec un chipset type rt2400 de Ralink qui est
du 802.11b (11Mb), mais rien à faire.

Ma démarche : j'ai sur le cd des binaires censés marcher uniquement sous
red hat et eventuellement Mdk (basé sur red hat?), je me dis que ça vaut
bien un essai:

- je lance le script d'install
- il me demande ou sont les sources noyau, pas de pb je lui donne
usr/src/mdkquelquechose et il est content (a priori, ce doit être pour
détecter ma version de noyau ou les en-têtes de compil?).

- il me dit que le driver rt2400.o a été copié dans /drivers/net/..
- je tente de charger le module : insmod rt2400 ou rt2400.o ou l'adresse
complète, mais rien à faire, soit le module n'est pas trouvé, soit il
n'est pas au bon format

Comme je suis complètement newbie (mais j'aime ça ;-) je me dis que je
fais ptet une erreur de base?

Ceci dit, j'ai aussi essayé les sources qui viennent du site
www.minitar.com, je compile, et la, plein de pb à la compil, donc je
dois avoir une mauvaise version de gcc ou des sourcesGCC me dit que
j'qi des erreurs de compilation dues à un fichier nommé asm, il me
semble que c'est l'assembleur? un peu incompréhensible :-(

PS mon dernier truc : je ne vois que des .ko dans les rép de drivers,
est-ce normal d'avoir un driver rt2400.o

Merci de vos contrib, étant donné le faible coûts de ces chip, je pense
que ça peut intéresser beaucoup de gens.

Nicolas
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Vincent RIEDWEG
Le #1522275
"Nicolas" news:408cddad$0$17495$
Bonjour,


Bonjour,

ma config est sous Mandrake 10.0 community truc, et je tente de faire
fonctionner une carte wifi avec un chipset type rt2400 de Ralink qui est
du 802.11b (11Mb), mais rien à faire.

Ma démarche : j'ai sur le cd des binaires censés marcher uniquement sous
red hat et eventuellement Mdk (basé sur red hat?), je me dis que ça vaut
bien un essai:

- je lance le script d'install
- il me demande ou sont les sources noyau, pas de pb je lui donne
usr/src/mdkquelquechose et il est content (a priori, ce doit être pour
détecter ma version de noyau ou les en-têtes de compil?).

- il me dit que le driver rt2400.o a été copié dans .../drivers/net/..
- je tente de charger le module : insmod rt2400 ou rt2400.o ou l'adresse
complète, mais rien à faire, soit le module n'est pas trouvé, soit il
n'est pas au bon format...

Comme je suis complètement newbie (mais j'aime ça ;-) je me dis que je
fais ptet une erreur de base?

Ceci dit, j'ai aussi essayé les sources qui viennent du site
www.minitar.com, je compile, et la, plein de pb à la compil, donc je
dois avoir une mauvaise version de gcc ou des sources...GCC me dit que
j'qi des erreurs de compilation dues à un fichier nommé asm, il me
semble que c'est l'assembleur? un peu incompréhensible :-(

PS mon dernier truc : je ne vois que des .ko dans les rép de drivers,
est-ce normal d'avoir un driver rt2400.o

Merci de vos contrib, étant donné le faible coûts de ces chip, je pense
que ça peut intéresser beaucoup de gens.


Un collègue a acheté la même carte... J'ai réussi à la faire tourner sous
Mandrake 9.2 (j'étais apparament le premier:)

J'ai donc posté un article sur le forum minitar. Cet article a été déplacé
dans la faq...

Va y faire un tour, ca peut t'aider je pense...

Vincent.

Nicolas
Le #1522271

"Nicolas" news:408cddad$0$17495$

Bonjour,



Bonjour,


ma config est sous Mandrake 10.0 community truc, et je tente de faire
fonctionner une carte wifi avec un chipset type rt2400 de Ralink qui est
du 802.11b (11Mb), mais rien à faire.

Ma démarche : j'ai sur le cd des binaires censés marcher uniquement sous
red hat et eventuellement Mdk (basé sur red hat?), je me dis que ça vaut
bien un essai:

- je lance le script d'install
- il me demande ou sont les sources noyau, pas de pb je lui donne
usr/src/mdkquelquechose et il est content (a priori, ce doit être pour
détecter ma version de noyau ou les en-têtes de compil?).

- il me dit que le driver rt2400.o a été copié dans .../drivers/net/..
- je tente de charger le module : insmod rt2400 ou rt2400.o ou l'adresse
complète, mais rien à faire, soit le module n'est pas trouvé, soit il
n'est pas au bon format...

Comme je suis complètement newbie (mais j'aime ça ;-) je me dis que je
fais ptet une erreur de base?

Ceci dit, j'ai aussi essayé les sources qui viennent du site
www.minitar.com, je compile, et la, plein de pb à la compil, donc je
dois avoir une mauvaise version de gcc ou des sources...GCC me dit que
j'qi des erreurs de compilation dues à un fichier nommé asm, il me
semble que c'est l'assembleur? un peu incompréhensible :-(

PS mon dernier truc : je ne vois que des .ko dans les rép de drivers,
est-ce normal d'avoir un driver rt2400.o

Merci de vos contrib, étant donné le faible coûts de ces chip, je pense
que ça peut intéresser beaucoup de gens.



Un collègue a acheté la même carte... J'ai réussi à la faire tourner sous
Mandrake 9.2 (j'étais apparament le premier:)

J'ai donc posté un article sur le forum minitar. Cet article a été déplacé
dans la faq...

Va y faire un tour, ca peut t'aider je pense...

Vincent.


Merci!
Je vais tester ça ce soir. Ya pas de raison que ça ne marche pas. Par
contre, la question reste ouverte pour la mdk10.0

Pour ceux qui suivent po, le lien est le suivant :
http://www.minitar.com/forums/index.php?showtopic44

et le lien pour le patch est moisi, c'est en fait :
http://home.austarnet.com.au/screwball/rt2400_linux-1.1.0-kmalloc.patch

Voila voila.
Je teste tout ça sur la 10.0 et je vous tien au courant.

Nicolas


Publicité
Poster une réponse
Anonyme