compilation noyau 2.6 et liens manquants (?)

Le
Kevin
Bonjour
je suis en train de me mettre a compiler un noyau 2.6

Je suis sous slack, j'installe tous les paquets necessaires a la
compilation (gcc, make, etc..)
Je mets les sources, je lance un make menuconfig mais j'ai une succession
d'erreur comme quoi il lui manque pleins de fichiers d'include.
Ca n'est qu'une histoire de liens symboliques a mettre en fait
genre /usr/include/asm qui doit pointer vers /usr/src/linux/include/asm-i386
etc..
J'ai deux questions:
Comment se fait il que ca ne se fasse pas automatiquement?
C'est du a slack ou a moi?

Merci.
--
Kevin
Comment ca, ca n'etait pas la copie?
-+- Les 100 choses que vous n'aimez pas entendre de la part du sysadmin -+-

--
Pour contacter l'équipe de modération : moderateurs-fcolm@efrei.fr
ATTENTION: Postez DIRECTEMENT vos articles dans le groupe, PAS dans
la liste de distribution des modérateurs.
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Antoine Bellot
Le #7144141
Kevin DENIS wrote:

genre /usr/include/asm qui doit pointer vers /usr/src/linux/include/asm-i386



Si tu télécharges le kernel 2.6.5 sur ftp.kernel.org et que tu le
décompresses dans ton homedir, puis que tu vas dans le répertoire créé
(normalement ~/linux-2.6.5) et que tu fais tout simplement make (sans
rien essayer avant), tu verras :

[ linux-2.6.5]$ make
Makefile:405: .config: Aucun fichier ou répertoire de ce type
CHK include/linux/version.h
UPD include/linux/version.h
SYMLINK include/asm -> include/asm-i386
^C

ça correspond aux lignes 644-647 de ~/linux-2.6.5/Makefile

include/asm:
@echo ' SYMLINK $@ -> include/asm-$(ARCH)'
$(Q)if [ ! -d include ]; then mkdir -p include; fi;
@ln -fsn asm-$(ARCH) $@

Donc, en théorie, ~/linux-2.6.5/include/asm est supposé être un lien
vers ~linux-2.6.5/include/asm-i386 (pour Intel)

à partir de là, comme je ne connais pas Slack et que je ne sais pas d'où
viennent tes sources.... : que dit ton propre build ?

Ne faudrait-il pas en plus télécharger un paquetages genre
kernel-2.6.x-headers ?

> Comment ca, ca n'etait pas la copie?

--
Pour contacter l'équipe de modération :
ATTENTION: Postez DIRECTEMENT vos articles dans le groupe, PAS dans
la liste de distribution des modérateurs.
zebul666
Le #7144131
Kevin DENIS wrote:
Comment se fait il que ca ne se fasse pas automatiquement?
C'est du a slack ou a moi?



Quel version de slack ?

sur ma slackware 9.1 /usr/include/asm est un lien symbolique
vers /usr/include/asm-i386

et je n'ai eu aucun problème pour compiler le dernier 2.6.5

--
Pour contacter l'équipe de modération :
ATTENTION: Postez DIRECTEMENT vos articles dans le groupe, PAS dans
la liste de distribution des modérateurs.
Kevin
Le #7143921
Le 06 Apr 2004 07:35:54 GMT, zebul666 a ecrit:
|> Comment se fait il que ca ne se fasse pas automatiquement?
|> C'est du a slack ou a moi?
|
| Quel version de slack ?
|
zipslack 8.1 upgrade avec swaret en -current

| sur ma slackware 9.1 /usr/include/asm est un lien symbolique
| vers /usr/include/asm-i386
|
| et je n'ai eu aucun problème pour compiler le dernier 2.6.5
|
Bah oui, faudrait que je voie dans le Manifest si ces liens existent
et pourquoi ils ne sont pas fait, c'est curieux.

--
Kevin
La sauvegarde a bien marchee. Par contre, pour restaurer, c'est plus difficile.
-+- Les 100 choses que vous n'aimez pas entendre de la part du sysadmin -+-

--
Pour contacter l'équipe de modération :
ATTENTION: Postez DIRECTEMENT vos articles dans le groupe, PAS dans
la liste de distribution des modérateurs.
Publicité
Poster une réponse
Anonyme