Fusionner par rapport à la colonne A

Le
Laurent
Bonjour.
Comment faire comprendre cela à Excel.
Sur la feuil1
j'ai une colonne A avec des chiffres
j'ai une colonne B appelée Base en rapport avec la colonne A

Sur la feuil2
j'ai une colonne A avec des chiffres
j'ai une colonne B appelée Info en rapport avec la colonne A

Soit
Ex : en feuil1 1 . alpha en feuil2 1 . maman
3 . beta 2 . papa
4. charly 4 . toto

Voilà ce que je souhaite obtenir en feuil3

En feuil3 : 1 alpha maman
2 papa
3 beta
4 charly toto
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Philippe.R
Le #1392064
Bonjour Laurent,

En nommant chif1 la plage contenant les nombres de la feuille 1, noms1 la plage des noms, chif2 et noms2
les plages correspondantes de la feuille 2, en feuille 3, tu peux avoir sur une colonne les noms
concaténés ainsi :

=SI(ESTNA(INDEX(noms1;EQUIV(A1;chif1;0)));"";INDEX(noms1;EQUIV(A1;chif1;0))&"
")&SI(ESTNA(INDEX(noms2;EQUIV(A1;chif2;0)));"";INDEX(noms2;EQUIV(A1;chif2;0)))
ou bien sur 2 colonnes, la 1ère avec
=SI(ESTNA(INDEX(noms1;EQUIV(A1;chif1;0)));"";INDEX(noms1;EQUIV(A1;chif1;0)))
la 2ème avec
=SI(ESTNA(INDEX(noms2;EQUIV(A1;chif2;0)));"";INDEX(noms2;EQUIV(A1;chif2;0)))

--
Amicales Salutations
Retirer A_S_ pour répondre.
XL 97 / 2000 / 2002

"Laurent" news:
Bonjour.
Comment faire comprendre cela à Excel.
Sur la feuil1
j'ai une colonne A avec des chiffres
j'ai une colonne B appelée Base en rapport avec la colonne A

Sur la feuil2
j'ai une colonne A avec des chiffres
j'ai une colonne B appelée Info en rapport avec la colonne A

Soit
Ex : en feuil1 1 . alpha en feuil2 1 . maman
3 . beta 2 . papa
4. charly 4 . toto

Voilà ce que je souhaite obtenir en feuil3

En feuil3 : 1 alpha maman
2 papa
3 beta
4 charly toto




Laurent
Le #1392058
Bonjour Philippe,
Désolé, je n'arrive pas à faire fonctionner les formules.
Puis-je t'envoyer un exemple en bal perso
Laurent

"Philippe.R" news:
Bonjour Laurent,

En nommant chif1 la plage contenant les nombres de la feuille 1, noms1 la
plage des noms, chif2 et noms2

les plages correspondantes de la feuille 2, en feuille 3, tu peux avoir
sur une colonne les noms

concaténés ainsi :


=SI(ESTNA(INDEX(noms1;EQUIV(A1;chif1;0)));"";INDEX(noms1;EQUIV(A1;chif1;0))&

"

")&SI(ESTNA(INDEX(noms2;EQUIV(A1;chif2;0)));"";INDEX(noms2;EQUIV(A1;chif2;0)

))
ou bien sur 2 colonnes, la 1ère avec

=SI(ESTNA(INDEX(noms1;EQUIV(A1;chif1;0)));"";INDEX(noms1;EQUIV(A1;chif1;0)))

la 2ème avec

=SI(ESTNA(INDEX(noms2;EQUIV(A1;chif2;0)));"";INDEX(noms2;EQUIV(A1;chif2;0)))


--
Amicales Salutations
Retirer A_S_ pour répondre.
XL 97 / 2000 / 2002

"Laurent" news:
Bonjour.
Comment faire comprendre cela à Excel.
Sur la feuil1
j'ai une colonne A avec des chiffres
j'ai une colonne B appelée Base en rapport avec la colonne A

Sur la feuil2
j'ai une colonne A avec des chiffres
j'ai une colonne B appelée Info en rapport avec la colonne A

Soit
Ex : en feuil1 1 . alpha en feuil2 1 . maman
3 . beta 2 . papa
4. charly 4 . toto

Voilà ce que je souhaite obtenir en feuil3

En feuil3 : 1 alpha maman
2 papa
3 beta
4 charly toto








Philippe.R
Le #1392057
Ok Laurent,
Tu n'oublies pas de retirer A_S_ de mon adresse.
--
Amicales Salutations

"Laurent" news:
Bonjour Philippe,
Désolé, je n'arrive pas à faire fonctionner les formules.
Puis-je t'envoyer un exemple en bal perso
Laurent

"Philippe.R" news:
Bonjour Laurent,

En nommant chif1 la plage contenant les nombres de la feuille 1, noms1 la
plage des noms, chif2 et noms2

les plages correspondantes de la feuille 2, en feuille 3, tu peux avoir
sur une colonne les noms

concaténés ainsi :


=SI(ESTNA(INDEX(noms1;EQUIV(A1;chif1;0)));"";INDEX(noms1;EQUIV(A1;chif1;0))&

"

")&SI(ESTNA(INDEX(noms2;EQUIV(A1;chif2;0)));"";INDEX(noms2;EQUIV(A1;chif2;0)

))
ou bien sur 2 colonnes, la 1ère avec

=SI(ESTNA(INDEX(noms1;EQUIV(A1;chif1;0)));"";INDEX(noms1;EQUIV(A1;chif1;0)))

la 2ème avec

=SI(ESTNA(INDEX(noms2;EQUIV(A1;chif2;0)));"";INDEX(noms2;EQUIV(A1;chif2;0)))


--
Amicales Salutations
Retirer A_S_ pour répondre.
XL 97 / 2000 / 2002

"Laurent" news:
Bonjour.
Comment faire comprendre cela à Excel.
Sur la feuil1
j'ai une colonne A avec des chiffres
j'ai une colonne B appelée Base en rapport avec la colonne A

Sur la feuil2
j'ai une colonne A avec des chiffres
j'ai une colonne B appelée Info en rapport avec la colonne A

Soit
Ex : en feuil1 1 . alpha en feuil2 1 . maman
3 . beta 2 . papa
4. charly 4 . toto

Voilà ce que je souhaite obtenir en feuil3

En feuil3 : 1 alpha maman
2 papa
3 beta
4 charly toto












Pascal Engelmajer
Le #1392053
Salut,
en vba ?
salut,
Sub appareiller()
Dim cell1 As Range
Dim cell2 As Range
Dim cell3 As Range ' cellule A1 feuille 3
With Sheets(1)
Set cell1 = .Range("A1")
End With
With Sheets(2)
Set cell2 = .Range("A1")
End With
With Sheets(3)
Set cell3 = .Range("A1")
End With
Do
If cell1.Value = cell2.Value Then
With cell3
.Value = cell1.Value
.Offset(0, 1) = cell1.Offset(0, 1).Value
.Offset(0, 2) = cell2.Offset(0, 1).Value
End With
Set cell3 = cell3.Offset(1, 0) ' on avance d'une ligne
Set cell2 = cell2.Offset(1, 0) ' on avance d'une ligne
Set cell1 = cell1.Offset(1, 0) ' on avance d'une ligne
ElseIf cell1.Value < cell2.Value Or IsEmpty(cell2) Then
With cell3
.Value = cell1.Value
.Offset(0, 1) = cell1.Offset(0, 1).Value
End With
Set cell3 = cell3.Offset(1, 0) ' on avance d'une ligne
Set cell1 = cell1.Offset(1, 0) ' on avance d'une ligne
ElseIf cell1.Value > cell2.Value Or IsEmpty(cell1) Then
With cell3
.Value = cell2.Value
.Offset(0, 1) = cell2.Offset(0, 1).Value
End With
Set cell3 = cell3.Offset(1, 0) ' on avance d'une ligne
Set cell2 = cell2.Offset(1, 0) ' on avance d'une ligne
End If
Loop Until IsEmpty(cell1) And IsEmpty(cell2)
End Sub

--
Amicalement.
Pascal
"il n'y a pas de vent favorable pour celui qui ne sait pas ou il va."
Sénèque.
http://www.ilyapa.net/excel
"Laurent"
Bonjour.
Comment faire comprendre cela à Excel.
Sur la feuil1
j'ai une colonne A avec des chiffres
j'ai une colonne B appelée Base en rapport avec la colonne A

Sur la feuil2
j'ai une colonne A avec des chiffres
j'ai une colonne B appelée Info en rapport avec la colonne A

Soit
Ex : en feuil1 1 . alpha en feuil2 1 . maman
3 . beta 2 . papa
4. charly 4 . toto

Voilà ce que je souhaite obtenir en feuil3

En feuil3 : 1 alpha maman
2 papa
3 beta
4 charly toto




Laurent
Le #1392052
Bonjour Pascal
En fait il faudrait qu'à la fin il y ait qu'un chiffre commun sans doublon.
Merci beaucoup
Laurent

"Pascal Engelmajer" message de news:
Salut,
en vba ?
salut,
Sub appareiller()
Dim cell1 As Range
Dim cell2 As Range
Dim cell3 As Range ' cellule A1 feuille 3
With Sheets(1)
Set cell1 = .Range("A1")
End With
With Sheets(2)
Set cell2 = .Range("A1")
End With
With Sheets(3)
Set cell3 = .Range("A1")
End With
Do
If cell1.Value = cell2.Value Then
With cell3
.Value = cell1.Value
.Offset(0, 1) = cell1.Offset(0, 1).Value
.Offset(0, 2) = cell2.Offset(0, 1).Value
End With
Set cell3 = cell3.Offset(1, 0) ' on avance d'une ligne
Set cell2 = cell2.Offset(1, 0) ' on avance d'une ligne
Set cell1 = cell1.Offset(1, 0) ' on avance d'une ligne
ElseIf cell1.Value < cell2.Value Or IsEmpty(cell2) Then
With cell3
.Value = cell1.Value
.Offset(0, 1) = cell1.Offset(0, 1).Value
End With
Set cell3 = cell3.Offset(1, 0) ' on avance d'une ligne
Set cell1 = cell1.Offset(1, 0) ' on avance d'une ligne
ElseIf cell1.Value > cell2.Value Or IsEmpty(cell1) Then
With cell3
.Value = cell2.Value
.Offset(0, 1) = cell2.Offset(0, 1).Value
End With
Set cell3 = cell3.Offset(1, 0) ' on avance d'une ligne
Set cell2 = cell2.Offset(1, 0) ' on avance d'une ligne
End If
Loop Until IsEmpty(cell1) And IsEmpty(cell2)
End Sub

--
Amicalement.
Pascal
"il n'y a pas de vent favorable pour celui qui ne sait pas ou il va."
Sénèque.
http://www.ilyapa.net/excel
"Laurent"
Bonjour.
Comment faire comprendre cela à Excel.
Sur la feuil1
j'ai une colonne A avec des chiffres
j'ai une colonne B appelée Base en rapport avec la colonne A

Sur la feuil2
j'ai une colonne A avec des chiffres
j'ai une colonne B appelée Info en rapport avec la colonne A

Soit
Ex : en feuil1 1 . alpha en feuil2 1 . maman
3 . beta 2 . papa
4. charly 4 . toto

Voilà ce que je souhaite obtenir en feuil3

En feuil3 : 1 alpha maman
2 papa
3 beta
4 charly toto








Pascal Engelmajer
Le #1392622
Salut,
comment sont les feuilles au départ ? avec des doublons ?

--
Amicalement.
Pascal
"il n'y a pas de vent favorable pour celui qui ne sait pas ou il va."
Sénèque.
http://www.ilyapa.net/excel
"Laurent" evycd$
Bonjour Pascal
En fait il faudrait qu'à la fin il y ait qu'un chiffre commun sans
doublon.

Merci beaucoup
Laurent

"Pascal Engelmajer" message de news:
Salut,
en vba ?
salut,
Sub appareiller()
Dim cell1 As Range
Dim cell2 As Range
Dim cell3 As Range ' cellule A1 feuille 3
With Sheets(1)
Set cell1 = .Range("A1")
End With
With Sheets(2)
Set cell2 = .Range("A1")
End With
With Sheets(3)
Set cell3 = .Range("A1")
End With
Do
If cell1.Value = cell2.Value Then
With cell3
.Value = cell1.Value
.Offset(0, 1) = cell1.Offset(0, 1).Value
.Offset(0, 2) = cell2.Offset(0, 1).Value
End With
Set cell3 = cell3.Offset(1, 0) ' on avance d'une ligne
Set cell2 = cell2.Offset(1, 0) ' on avance d'une ligne
Set cell1 = cell1.Offset(1, 0) ' on avance d'une ligne
ElseIf cell1.Value < cell2.Value Or IsEmpty(cell2) Then
With cell3
.Value = cell1.Value
.Offset(0, 1) = cell1.Offset(0, 1).Value
End With
Set cell3 = cell3.Offset(1, 0) ' on avance d'une ligne
Set cell1 = cell1.Offset(1, 0) ' on avance d'une ligne
ElseIf cell1.Value > cell2.Value Or IsEmpty(cell1) Then
With cell3
.Value = cell2.Value
.Offset(0, 1) = cell2.Offset(0, 1).Value
End With
Set cell3 = cell3.Offset(1, 0) ' on avance d'une ligne
Set cell2 = cell2.Offset(1, 0) ' on avance d'une ligne
End If
Loop Until IsEmpty(cell1) And IsEmpty(cell2)
End Sub

--
Amicalement.
Pascal
"il n'y a pas de vent favorable pour celui qui ne sait pas ou il va."
Sénèque.
http://www.ilyapa.net/excel
"Laurent"
Bonjour.
Comment faire comprendre cela à Excel.
Sur la feuil1
j'ai une colonne A avec des chiffres
j'ai une colonne B appelée Base en rapport avec la colonne A

Sur la feuil2
j'ai une colonne A avec des chiffres
j'ai une colonne B appelée Info en rapport avec la colonne A

Soit
Ex : en feuil1 1 . alpha en feuil2 1 . maman
3 . beta 2 . papa
4. charly 4 . toto

Voilà ce que je souhaite obtenir en feuil3

En feuil3 : 1 alpha maman
2 papa
3 beta
4 charly toto












Publicité
Poster une réponse
Anonyme