[gentoo-user-fr] Dépendance des services

Le
Michael Alves
Bonjour à tous,

Je m'adresse à vous après avoir exposé mon problème sur le forum gentoo
qui ne m'a pas trop dépanné.
(http://forums.gentoo.org/viewtopic-t-464127.html)

Si je suis si insistant c'est que j'ai besoin de ma machine pour finir
de développer un projet pour un examen dans 3 semaines et que le temps
presse.

Pour résumer mon problème, lorsque je tente de démarrer le service
Apache (/etc/init.d/apache) il me fait une erreur: "eth1 does not exist".

Le problème c'est que mon interface réseau se trouve sur eth0 donc
pourquoi le service Apache (et bien d'autres) ont comme dépendance
"eth1". ? Et surtout comment changer ça !

Merci de m'aider.

--
Michael Alves
Alpha Centauri


--
gentoo-user-fr@gentoo.org mailing list
Vos réponses Page 1 / 2
Trier par : date / pertinence
Thomas de Grenier de Latour
Le #7589551
On Thu, 25 May 2006 12:07:38 +0200,
Michael Alves
Pour résumer mon problème, lorsque je tente de démarrer le service
Apache (/etc/init.d/apache) il me fait une erreur: "eth1 does not
exist".

Le problème c'est que mon interface réseau se trouve sur eth0 donc
pourquoi le service Apache (et bien d'autres) ont comme dépendance
"eth1". ? Et surtout comment changer ça !



Dans /etc/conf.d/rc, quelle est la valeur de RC_NET_STRICT_CHECKING ?
Si c'est "yes", ceci explique celà. Essaye avec "lo", qui permet de
démarrer les services du style apache dès lors que l'interface loopback
(127.0.0.1) est prête.

--
TGL.
--
mailing list
Michael Alves
Le #7589541
>Dans /etc/conf.d/rc, quelle est la valeur de RC_NET_STRICT_CHECKING ?
Si c'est "yes", ceci explique celà. Essaye avec "lo", qui permet de
démarrer les services du style apache dès lors que l'interface loopback
(127.0.0.1) est prête.




Merci pour ta réponse rapide !

Ma variable RC_NET_STRICT_CHECKING est à "no". Quand tu me dis d'essayer
avec "lo" tu veux dire que je change mon "need net" par "need lo" ? Si
c'est ce que tu voulais me faire faire cela ne marche pas plus, lors du
démarage du service il essaye de lancer eth1 ...

--
Michael Alves
Alpha Centauri


--
mailing list
Boris Fersing
Le #7589531
2006/5/25, Michael Alves

>Dans /etc/conf.d/rc, quelle est la valeur de RC_NET_STRICT_CHECKING ?
>Si c'est "yes", ceci explique celà. Essaye avec "lo", qui permet de
>démarrer les services du style apache dès lors que l'interface loopback
>(127.0.0.1) est prête.
>
>
Merci pour ta réponse rapide !

Ma variable RC_NET_STRICT_CHECKING est à "no". Quand tu me dis d'essayer
avec "lo" tu veux dire que je change mon "need net" par "need lo" ? Si
c'est ce que tu voulais me faire faire cela ne marche pas plus, lors du
démarage du service il essaye de lancer eth1 ...



Non, il ne faut pas toucher a "need net" ...

Bon comme j'ai pas un max d'infos là, je vais te demander 2 3 trucs
(les sorties de commandes suivantes) :

# eselect rc show
# ifconfig -a

Merci,

Boris.


--
Michael Alves
Alpha Centauri


--
mailing list






--
Quiconque me parle de Dieu en veut à ma bourse ou à ma liberté.

--
mailing list
Thomas de Grenier de Latour
Le #7589521
On Thu, 25 May 2006 13:09:14 +0200,
Michael Alves
Quand tu me dis d'essayer avec "lo" tu veux dire que je change mon
"need net" par "need lo" ?



Non non, je voulais dire, dans /etc/conf.d/rc:
RC_NET_STRICT_CHECKING="lo"
C'est censé faire en sorte que les dépendances "need net" se comportent
comme des "need net.lo", bref en sorte que les services réseau puissent
démarrer dès lors que loopback est disponible, et sans se préocuper
des autres "net.ethX" ou assimilé.

Quant à RC_NET_STRICT_CHECKING="no" comme chez toi, bah je ne sais pas
exactement comment c'est censé se comporter: la description dit que
ça implique une dépendance sur au moins une "vraie" interface, une ethX,
en plus du loopback, mais je ne sais pas ce qui le ferait préférer eth0
à eth1, ou le contraire.

--
TGL.
--
mailing list
Michael Alves
Le #7589511
>
Non, il ne faut pas toucher a "need net" ...

Bon comme j'ai pas un max d'infos là, je vais te demander 2 3 trucs
(les sorties de commandes suivantes) :

# eselect rc show
# ifconfig -a

Merci,

Boris.



Donc en ce qui concerne la sortie de eslect:

bonobo ~ # eselect rc show
Status of init scripts in runlevel default
alsasound [started]
apache2 [stopped]
coldplug [started]
domainname [started]
mysql [started]
net.eth1 [stopped]
sshd [stopped]
syslog-ng [started]
vixie-cron [started]
xdm [started]

et la sortie de ifconfig:

bonobo ~ # ifconfig -a
eth0 Lien encap:Ethernet HWaddr 00:13:D3:DE:7B:AB
inet adr:192.168.1.101 Bcast:192.168.1.255 Masque:255.255.255.0
adr inet6: fe80::213:d3ff:fede:7bab/64 Scope:Lien
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:136 errors:0 dropped:0 overruns:0 frame:0
TX packets:77 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:91907 (89.7 Kb) TX bytes:6962 (6.7 Kb)
Interruption:18 Adresse de base:0xe000

lo Lien encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
adr inet6: ::1/128 Scope:Hôte
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:8 errors:0 dropped:0 overruns:0 frame:0
TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
RX bytes:400 (400.0 b) TX bytes:400 (400.0 b)

sit0 Lien encap:IPv6-dans-IPv4
NOARP MTU:1480 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

Ca te parle ?

En meme temps voici l'erreur lors du lancement du service apache:

bonobo ~ # /etc/init.d/apache2 start
* Re-caching dependency info (mtimes differ)...
* Re-caching dependency info (mtimes differ)...
* Starting eth1
* Bringing up eth1
* dhcp
* eth1 does not
exist
[ !! ]
* Re-caching dependency info (mtimes differ)...
* ERROR: Problem starting needed services.
* "apache2" was not started.



--
mailing list
Michael Alves
Le #7589501
Thomas de Grenier de Latour a écrit :

On Thu, 25 May 2006 13:09:14 +0200,
Michael Alves


Quand tu me dis d'essayer avec "lo" tu veux dire que je change mon
"need net" par "need lo" ?





Non non, je voulais dire, dans /etc/conf.d/rc:
RC_NET_STRICT_CHECKING="lo"




Oui désolé je n'avais pas lus le commentaire sous la ligne en question
désolé !
J'ai testé avec "lo" comme valeur mais ça ne change rien je craque ! :(



--
Michael Alves
Alpha Centauri


--
mailing list
Boris Fersing
Le #7589491
2006/5/25, Michael Alves

>
> Non, il ne faut pas toucher a "need net" ...
>
> Bon comme j'ai pas un max d'infos là, je vais te demander 2 3 trucs
> (les sorties de commandes suivantes) :
>
> # eselect rc show
> # ifconfig -a
>
> Merci,
>
> Boris.
>
Donc en ce qui concerne la sortie de eslect:

bonobo ~ # eselect rc show
Status of init scripts in runlevel default
alsasound [started]
apache2 [stopped]
coldplug [started]
domainname [started]
mysql [started]
net.eth1 [stopped]
sshd [stopped]
syslog-ng [started]
vixie-cron [started]
xdm [started]

et la sortie de ifconfig:

bonobo ~ # ifconfig -a
eth0 Lien encap:Ethernet HWaddr 00:13:D3:DE:7B:AB
inet adr:192.168.1.101 Bcast:192.168.1.255 Masque:255.255.255.0
adr inet6: fe80::213:d3ff:fede:7bab/64 Scope:Lien
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:136 errors:0 dropped:0 overruns:0 frame:0
TX packets:77 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:91907 (89.7 Kb) TX bytes:6962 (6.7 Kb)
Interruption:18 Adresse de base:0xe000

lo Lien encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
adr inet6: ::1/128 Scope:Hôte
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:8 errors:0 dropped:0 overruns:0 frame:0
TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
RX bytes:400 (400.0 b) TX bytes:400 (400.0 b)

sit0 Lien encap:IPv6-dans-IPv4
NOARP MTU:1480 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

Ca te parle ?



Oui ca me parle ;) eth1 n'existe pas du tout, fais :

# eselect rc delete net.eth1
# cd /etc/init.d
# rm net.eth1
# ln -s net.lo net.eth0
# eselect rc add net.eth0

ca devrait le faire !

Boris.

En meme temps voici l'erreur lors du lancement du service apache:

bonobo ~ # /etc/init.d/apache2 start
* Re-caching dependency info (mtimes differ)...
* Re-caching dependency info (mtimes differ)...
* Starting eth1
* Bringing up eth1
* dhcp
* eth1 does not
exist
[ !! ]
* Re-caching dependency info (mtimes differ)...
* ERROR: Problem starting needed services.
* "apache2" was not started.



--
mailing list






--
Quiconque me parle de Dieu en veut à ma bourse ou à ma liberté.

--
mailing list
Guillaume Pujol
Le #7589481
oops, Boris a été plus rapide que moi ... :)

2006/5/25, Guillaume Pujol
Salut,
Apparemment tu as un init script "net.eth1" alors que cette interface
n'existe pas.

Essaie ça:
rc-update del net.eth0
mv /etc/init.d/net.eth1 /etc/init.d/net.eth0
rc-update add net.eth0 default
/etc/init.d/apache2 start

Cordialement,
Guillaume




--
mailing list
Thomas de Grenier de Latour
Le #7589471
On Thu, 25 May 2006 13:52:00 +0200,
Michael Alves
J'ai testé avec "lo" comme valeur mais ça ne change rien je
craque ! :(



Bizarre... Par curiosité, c'est quoi ta version de baselayout ?

Enfin bon, de toute façon, si tu as seulement un net.eth0, qui marche,
et pas de net.eth1 foireux qui s'en mêle, alors un "no", ou même un
"yes", devrait le faire aussi. Le petit nettoyage que propose Borris me
semble très raisonnable, et prometteur.

--
TGL.
--
mailing list
Guillaume Pujol
Le #7589461
Salut,
Apparemment tu as un init script "net.eth1" alors que cette interface
n'existe pas.

Essaie ça:
rc-update del net.eth0
mv /etc/init.d/net.eth1 /etc/init.d/net.eth0
rc-update add net.eth0 default
/etc/init.d/apache2 start

Cordialement,
Guillaume

--
mailing list
Publicité
Poster une réponse
Anonyme