Le jour ou la nuite (date / heure)

Le
Petipeton
Bonjour à tous !!!

Tout d'abord, merci à tous et toutes pour les réponses diverses et efficaces que je reçois à chacune de mes questions

Ensuite, mon pb

Colonne A, des heures (format heure 13:35). Par exemple
00:1
13:5
22:3

Colonne B, j'aimerais qu'il me dise s'il s'agit d'heures NUIT ou JOUR d'après critère suivant : la nuit c'est de 20 h à 8 h

J'ai tenté =SI(ET(A4>=8;A4< );"Jour";"Nuit"), sans succès (me donne que des nuits)

Merci molto molto !!!!

Petipeton
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Asterix
Le #1326048
bonjour,

J'ai tenté =SI(ET(A4>=8;A4< );"Jour";"Nuit"), sans succès (me donne que
des nuits).

essayes plutot
J'ai tenté =SI(ET(HEURE(A4)>=8;HEURE(A4)< );"Jour";"Nuit"), sans succès
(me donne que des nuits).

bon courage

Astérix

Techniciel
Le #1326043
Bonjour à tous et en particulier à toi,

Voilà la solution
=SI(ET(A1>=8/24;A1<20/24);"jour";"nuit")

En effet, une heure est une fraction de jour : 1:00 = 1/24 = 0,041666667
Cordialement
Pascal

"Petipeton" news:
Bonjour à tous !!!!

Tout d'abord, merci à tous et toutes pour les réponses diverses et
efficaces que je reçois à chacune de mes questions.


Ensuite, mon pb :

Colonne A, des heures (format heure 13:35). Par exemple :
00:19
13:55
22:34

Colonne B, j'aimerais qu'il me dise s'il s'agit d'heures NUIT ou JOUR
d'après critère suivant : la nuit c'est de 20 h à 8 h.


J'ai tenté =SI(ET(A4>=8;A4< );"Jour";"Nuit"), sans succès (me donne que
des nuits).


Merci molto molto !!!!!

Petipeton


Petipeton
Le #1326042
Merci, j'aurais dû y penser moi-même... c'est ça d'être toujours pressée et de pas avoir le temps de chercher soi-même

Merci encore..

----- Asterix a écrit : ----

bonjour

J'ai tenté =SI(ET(A4>=8;A4< );"Jour";"Nuit"), sans succès (me donne qu
des nuits)

essayes pluto
J'ai tenté =SI(ET(HEURE(A4)>=8;HEURE(A4)< );"Jour";"Nuit"), sans succè
(me donne que des nuits)

bon courag

Astéri

Petipeton
Le #1326040
Ah, pas mal non plus cette solution

Merci à toi aussi. Entre toi et Astérix, j'ai eu mon comptant de réponses intéressantes

Petipeto

----- Techniciel a écrit : ----

Bonjour à tous et en particulier à toi

Voilà la solutio
=SI(ET(A1>=8/24;A1<20/24);"jour";"nuit"

En effet, une heure est une fraction de jour : 1:00 = 1/24 = 0,04166666
Cordialemen
Pasca

"Petipeton" news:
Bonjour à tous !!!
Tout d'abord, merci à tous et toutes pour les réponses diverses e
efficaces que je reçois à chacune de mes questions


Ensuite, mon pb
Colonne A, des heures (format heure 13:35). Par exemple
00:1

13:5
22:3
Colonne B, j'aimerais qu'il me dise s'il s'agit d'heures NUIT ou JOU
d'après critère suivant : la nuit c'est de 20 h à 8 h


J'ai tenté =SI(ET(A4>=8;A4< );"Jour";"Nuit"), sans succès (me donne qu
des nuits)


Merci molto molto !!!!
Petipeto




Publicité
Poster une réponse
Anonyme