Mandrake et noyau 2.6

Le
Stéphane Thomas
Bonjour,

Mon système est une mandrake 9.1 installée depuis les CD, j'ai voulu
mettre à jour vers la 10.0 en changeant urpmi.cfg

Maintenant je me retrouve avec une distrib bancale (9.1 mixé avec 10.0)
j'ai donc plein de probleme de libs m'enfin ça c'etait à prévoir

Le gros probleme que j'ai c'est en remplaçant le noyau 2.4.21 par le 2.6.3

Le 2.6.3 boot nickel cependant je ne peux pas utiliser X en user

# startx& => pas de probleme
$ startx& => le serveur se lance mais se coupe aussitot


de plus pour que X fonctionne j'ai besoin des modules i810 vgavga16fb
agpgart intel-agp et i830, bien que ces modules soient indiqués dans
/etc/modules il ne se chargent pas au démarrage (pourtant je peux les
charger "à la main" sans probleme)


Si quelqu'un vois.. parce que moi je suis perdu là.


Merci,


Stéphane
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Stéphane Thomas
Le #1063526
Stéphane Thomas wrote:
Bonjour,

de plus pour que X fonctionne j'ai besoin des modules i810 vgavga16fb
agpgart intel-agp et i830, bien que ces modules soient indiqués dans
/etc/modules il ne se chargent pas au démarrage (pourtant je peux les
charger "à la main" sans probleme)



utiliser /etc/modprobe.conf plutôt que /etc/modules ça aide :)

bon faut que je repare gnome2 maintenant mais je suis quand même soulagé
de pouvoir uiliser un kernel 2.6...

viphakoneniko
Le #1518168
Pour info, sous le 2.6, ce n'est plus /etc/modules ou
/etc/modules.conf qui sont utilisés, mais /etc/modprobe.conf et
/etc/modprobe.preload

En plus, les mises à jour sont toujours merdique.
Donc, tu réinstalles une 10.0 en ne gardant que ton /home et les
partitions de stockages que tu utilise, et tu vire /boot , /, etc....
Stéphane Thomas
Le #1518156
Nikoo wrote:
Pour info, sous le 2.6, ce n'est plus /etc/modules ou
/etc/modules.conf qui sont utilisés, mais /etc/modprobe.conf et
/etc/modprobe.preload

En plus, les mises à jour sont toujours merdique.
Donc, tu réinstalles une 10.0 en ne gardant que ton /home et les
partitions de stockages que tu utilise, et tu vire /boot , /, etc....


Tu veux dire, je grave l'iso de la 10.0, je reinstalle tout ? C'est
bourrin...

Je me disais que peut-être j'ai oublié d'upgrader un package important
de la mandrake je ne sais pas...

Là j'ai pas grand chose qui fonctionne, je ne peux plus ouvrir un
terminal sous X, que ce soit xterm,aterm,kterm et consors. J'ai plus
d'icône sous gnome2...
Sinon pour avoir les distribs mandrake avec urpmi, fr2.rpmfind.net c
bien d'apres vous ?

++

mna
Le #1518119

Nikoo wrote:
Pour info, sous le 2.6, ce n'est plus /etc/modules ou
/etc/modules.conf qui sont utilisés, mais /etc/modprobe.conf et
/etc/modprobe.preload

En plus, les mises à jour sont toujours merdique.
Donc, tu réinstalles une 10.0 en ne gardant que ton /home et les
partitions de stockages que tu utilise, et tu vire /boot , /, etc....


Tu veux dire, je grave l'iso de la 10.0, je reinstalle tout ? C'est
bourrin...

Je me disais que peut-être j'ai oublié d'upgrader un package important
de la mandrake je ne sais pas...

Là j'ai pas grand chose qui fonctionne, je ne peux plus ouvrir un
terminal sous X, que ce soit xterm,aterm,kterm et consors. J'ai plus
d'icône sous gnome2...
Sinon pour avoir les distribs mandrake avec urpmi, fr2.rpmfind.net c
bien d'apres vous ?

++
salut

pour info :
http://lea-linux.org/trucs/item.438.html
pour créer les sources réseau qui vont bien avec les comandes à passer :
http://urpmi.org/easyurpmi/index.php

voilà avec ces sources d'infos j'ai fait différents upgrades
sans soucis.

A+


viphakoneniko
Le #1067284
Stéphane Thomas
Nikoo wrote:
Pour info, sous le 2.6, ce n'est plus /etc/modules ou
/etc/modules.conf qui sont utilisés, mais /etc/modprobe.conf et
/etc/modprobe.preload

En plus, les mises à jour sont toujours merdique.
Donc, tu réinstalles une 10.0 en ne gardant que ton /home et les
partitions de stockages que tu utilise, et tu vire /boot , /, etc....


Tu veux dire, je grave l'iso de la 10.0, je reinstalle tout ? C'est
bourrin...


Si tu gardes ton /home, toutes tes préférences seront conservées.
C ce que j'ai fait avec la 10.0 RC1 l'époque. c t impec


Stéphane Thomas
Le #1067112
mna wrote:

salut
pour info :
http://lea-linux.org/trucs/item.438.html
pour créer les sources réseau qui vont bien avec les comandes à passer :
http://urpmi.org/easyurpmi/index.php

voilà avec ces sources d'infos j'ai fait différents upgrades
sans soucis.

A+



Je connaissai déjà easyurpmi.

Je n'ai dans mon urpmi.cfg que les sources de la 10.0 j'ai mis à jour a
peu près tout ce que je pouvais cependant lors du boot j'ai toujours un
message "Welcome on Mandrake GNU/Linux 9.2". Quel package dois-je mettre
à jour pour avoir "Welcome on Mandrake GNU/Linux 10.0" ?


Stéphane

Stéphane Thomas
Le #1067109
Stéphane Thomas wrote:

Je viens de découvrir l'option --auto-select de urpmi...

Sinon pour le noyau je suis retourné sur le 2.4.21 car avec le 2.6
devfsd semble avoir un peu de mal : il ne me creer pas de /dev/pty*
TiChou
Le #1067108
Dans le message *Stéphane Thomas* tapota sur f.c.o.l.configuration :

Je n'ai dans mon urpmi.cfg que les sources de la 10.0 j'ai mis à jour a
peu près tout ce que je pouvais cependant lors du boot j'ai toujours un
message "Welcome on Mandrake GNU/Linux 9.2". Quel package dois-je mettre
à jour pour avoir "Welcome on Mandrake GNU/Linux 10.0" ?


Le message de bienvenue qui affiche la version de la distribution avant le
lancement des initscripts, est lié au contenu du fichier
/etc/mandrake-release.
Ce fichier est mis à jour avec le paquetage mandrake-release.
Pour la Mandrake 10 officielle il s'agit du rpm
mandrake-release-10.0-3mdk.i586.rpm.

--
TiChou

mna
Le #1067107

mna wrote:
[...]


Je n'ai dans mon urpmi.cfg que les sources de la 10.0 j'ai mis à jour a
peu près tout ce que je pouvais cependant lors du boot j'ai toujours un
message "Welcome on Mandrake GNU/Linux 9.2". Quel package dois-je mettre
à jour pour avoir "Welcome on Mandrake GNU/Linux 10.0" ?


Stéphane


je pense que c'est codé en dur dans :
/etc/rc.d/rc.local ou
/etc/rc.d/rc.sysinit
l'info provenant de /etc/mandrake-release

si tu as l'ancien message c'est que le fichier /etc/mandrake-release
n'est pas à jour, je pense que tu as un fichier avec l'extension
rpmnew dans le répertoire /etc,
l'utilitaire urpmi n'ayant pas changé le fichiers d'origine par les
nouveaux.

si ce n'est pas le cas :
modif à la main du fichier /etc/mandrake-release

sinon c'est le package initscripts qui gère les scripts et variables
de démarrage de la mdk.

attention si tu as modifié tes scripts de boot, tu devras remettre
tes modifs après l'upgrade.

A+

Publicité
Poster une réponse
Anonyme