[MDK10.0-HELP] linux + xp = plus de windows - explications supplémentaires

Le
Jean-Patrick Pommier
bonjour,

Comme dans un fil de discussion précédent, le boot dans windows xp echoue
(écran noir + curseur clignotant et rien).

Mon disque est organisé ainsi:

hda5 : partition NTFS 5,8 Go
hda2 : partition ext3 7 Go
hda6 : swap
hda7 : ext3
hda8 : fat32 250Mo

J'ai modifié lilo.conf pour avoir windows dans la liste des OS

other=/dev/hda5
label="windows"
boot-as=0x80
pour ce dernier champ, j'ai recopié servilement le modèle ds man lilo.conf

J'ai vu que la solution pour régler le pb etait de faire :

diskdrake --change-geometry=xxx%5,63

avec dans mon cas xxx=/dev/hda5
et plus mystérieux "255,63" à adapter à son "drive LBA emulation" et pour
cela il faut voir "what geometry your bios gives when forcing LBA
emulation" eh ben me v'la bien.

Est-ce que la commande "diskdrake --change-geometry=xxx%5,63" est la seule
méthode ? (J'ai aussi vu qu'il fallait "bricoler" le bios)
Si oui, comment (qu'est-ce que l'on doit taper comme commande) force t'on
l'emulation LBA pour avoir ce parametre "geometry" et comment adapte-t'on
les valeurs "255,63" ?

merci

jean-patrick pommier

--
Retirer "PourrieL" de "jeanpat.pommierPourrieL@free.fr" pour m'écrire.

Remove "PourrieL from "jeanpat.pommierPourrieL@free.fr" to answer.
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jerome Lambert
Le #1040720
Le Mon, 12 Apr 2004 17:14:41 +0200, Jean-Patrick Pommier a écrit :

bonjour,

Comme dans un fil de discussion précédent, le boot dans windows xp echoue
(écran noir + curseur clignotant et rien).


(snip le bricolage pour émuler quelque chose qu'on peut faire directement)

Solution:
- Aller dans le BIOS
- Modifier les paramètres du disque dur et le passer de Auto aux
valeurs réelles + mettre en LBA
- Redémarrer
- Booter sur le CD, prendre la procédure d'urgence pour restaurer lilo
C'est tout.

Jean-Patrick Pommier
Le #1040329
merci pour votre aide

Jerome Lambert wrote:


bonjour,

Comme dans un fil de discussion précédent, le boot dans windows xp echoue
(écran noir + curseur clignotant et rien).


(snip le bricolage pour émuler quelque chose qu'on peut faire directement)

Solution:
- Aller dans le BIOS


ok, touche del au boot --> AMIBIOS

- Modifier les paramètres du disque dur et le passer de Auto aux
valeurs réelles


Il y a plusieurs menus, dans Standard CMOS Setup:

Pri Master type=(Auto/Not Installed) Mode=(on/off)
Sec Master type=(Auto/Not Installed) Mode=(on/off)

par defaut on a
Pri Master type=Auto Mode=on
Sec Master type=Auto Mode=on

et le passer de Auto aux valeurs réelles


On ne peut rien écrire, juste basculer d'un mode à l'autre

+ mettre en LBA


Ce champ n'est pas accessible avec les fleches

- Redémarrer


J'ai essayé avec la config suivante:
Pri Master type= Mode Sec Master type= Mode
et évidemment ça ne boote plus

- Booter sur le CD, prendre la procédure d'urgence pour restaurer lilo
C'est tout.


Sans autre solution, je crois que je suis coincé.

Pour reccupérer un boot windows, pourrait-on:
booter depuis une mdk 9.1
effacer les partions linux (ext3) sans toucher à la partitions windows
refaire de nouvelles partitions
faire une install minimale de la mdk 9.1
rebooter avec une mdk 10.0
faire une mise à jour vers la mdk 10.0 sans toucher au partitions.
configurer lilo.conf depuis l'installeur ou bien à la main sous linux


jean-patrick pommier
--
Retirer "PourrieL" de "" pour m'écrire.

Remove "PourrieL from "" to answer.


Jerome Lambert
Le #1040326
Le Mon, 12 Apr 2004 21:50:07 +0200, Jean-Patrick Pommier a écrit :
Solution:
- Aller dans le BIOS


ok, touche del au boot --> AMIBIOS


Chez moi, AMI BIOS Utility v 1.21.06 (sur un Athlon XP 1700+)

- Modifier les paramètres du disque dur et le passer de Auto aux
valeurs réelles


Il y a plusieurs menus, dans Standard CMOS Setup:

Pri Master type=(Auto/Not Installed) Mode=(on/off)
Sec Master type=(Auto/Not Installed) Mode=(on/off)

par defaut on a
Pri Master type=Auto Mode=on
Sec Master type=Auto Mode=on


Normal

- Se positionner sur Auto
- Avec PageUp et PageDown, on peut passer des valeurs Auto à None et User
- Choisir User
- Appuyer sur Enter. Le Bios détecte les paramètres du disque. Vérifier
que LBA est bien sur ON ;-)
- Quitter et sauvegarder les valeurs.

Pour reccupérer un boot windows, pourrait-on:
booter depuis une mdk 9.1
effacer les partions linux (ext3) sans toucher à la partitions windows
refaire de nouvelles partitions
faire une install minimale de la mdk 9.1 rebooter avec une mdk 10.0
faire une mise à jour vers la mdk 10.0 sans toucher au partitions.
configurer lilo.conf depuis l'installeur ou bien à la main sous linux


(Pas tout compris)

Plus simple: démarrer sur le CD d'installation de Windows, et choisir
l'option "réparer une installation endommagée". Windows reviendra comme
un grand...

Autre solution, maintenant que le LBA est bien activé, installer la MDK
10 comme prévu initialement...


Jean-Patrick Pommier
Le #1528104
Jerome Lambert wrote:

Solution:
- Aller dans le BIOS


ok, touche del au boot --> AMIBIOS


Chez moi, AMI BIOS Utility v 1.21.06 (sur un Athlon XP 1700+)


ici AMIBIOS HIFLEX SETUP UTILITY 1.55

- Modifier les paramètres du disque dur et le passer de Auto aux
valeurs réelles


Il y a plusieurs menus, dans Standard CMOS Setup:

Pri Master type=(Auto/Not Installed) Mode=(on/off)
Sec Master type=(Auto/Not Installed) Mode=(on/off)

par defaut on a
Pri Master type=Auto Mode=on
Sec Master type=Auto Mode=on


Normal

- Se positionner sur Auto
- Avec PageUp et PageDown, on peut passer des valeurs Auto à None et User


ici il n'y a le choix qu'entre auto detect et not installed pas d'option
user
- Choisir User
- Appuyer sur Enter. Le Bios détecte les paramètres du disque. Vérifier
que LBA est bien sur ON ;-)


il y a bien une colonne LBA mode mais elle n'est pas accessible (et le champ
est vide=off?), avec les flèche on passe directement de la colonne type
(auto/not installed) à la colonne 32bit Mode (on/off).

- Quitter et sauvegarder les valeurs.

Pour reccupérer un boot windows, pourrait-on:
booter depuis une mdk 9.1
le cdrom d'install pour utiliser diskdrake avec un kernel 2.4


effacer les partions linux (ext3) sans toucher à la partitions windows
refaire de nouvelles partitions
faire une install minimale de la mdk 9.1 rebooter avec une mdk 10.0
faire une mise à jour vers la mdk 10.0 sans toucher au partitions.
configurer lilo.conf depuis l'installeur ou bien à la main sous linux


(Pas tout compris)


L'idée est de créer des partitions linux sur le disque depuis le cdrom
d'install d'une mdk 9.1, qui fait appel à un kernel 2.4.21, de manière à ce
que les "paramètres" de la MBR soient corrects et que lilo puisse lancer
windows ou linux. Puis upgrader d'une mdk9.1 à la mdk10.0 sans toucher à la
partition (puisque le kernel 2.6 est responsable des paramètres erronés qui
empèchent de choisir windows depuis lilo)








Plus simple: démarrer sur le CD d'installation de Windows, et choisir
l'option "réparer une installation endommagée". Windows reviendra comme
un grand...



d'accord, mais plus de lilo et plus de linux ?

Autre solution, maintenant que le LBA est bien activé, installer la MDK
10 comme prévu initialement...


--
Retirer "PourrieL" de "" pour m'écrire.

Remove "PourrieL from "" to answer.



Jerome Lambert
Le #1528079
Le Tue, 13 Apr 2004 09:37:28 +0200, Jean-Patrick Pommier a écrit :
ici il n'y a le choix qu'entre auto detect et not installed pas d'option
user


Aie!!

Alors il faut chercher dans la documentation du BIOS pour savoir comment
on fait pour détecter "une fois pour toute" les disques.

Chez moi, c'est la touche F3 dans Standard CMOS Setup...

L'idée est de créer des partitions linux sur le disque depuis le
cdrom
d'install d'une mdk 9.1, qui fait appel à un kernel 2.4.21, de manière
à ce que les "paramètres" de la MBR soient corrects et que lilo puisse
lancer windows ou linux. Puis upgrader d'une mdk9.1 à la mdk10.0 sans
toucher à la partition (puisque le kernel 2.6 est responsable des
paramètres erronés qui empèchent de choisir windows depuis lilo)


Ca peut marcher, mais si le programme d'update met à jour le kernel, le
problème risque de revenir :-(

Plus simple: démarrer sur le CD d'installation de Windows, et choisir
l'option "réparer une installation endommagée". Windows reviendra
comme un grand...
d'accord, mais plus de lilo et plus de linux ?



Euh non, mais je croyais que vous vouliez récupérer Windows, mais pas
obligatoirement Mandrake. Sorry...


Jean-Patrick Pommier
Le #1528074
Jerome Lambert wrote:

ici il n'y a le choix qu'entre auto detect et not installed pas d'option
user


Aie!!

Alors il faut chercher dans la documentation du BIOS pour savoir comment
on fait pour détecter "une fois pour toute" les disques.

Chez moi, c'est la touche F3 dans Standard CMOS Setup...

L'idée est de créer des partitions linux sur le disque depuis le
cdrom
d'install d'une mdk 9.1, qui fait appel à un kernel 2.4.21, de manière
à ce que les "paramètres" de la MBR soient corrects et que lilo puisse
lancer windows ou linux. Puis upgrader d'une mdk9.1 à la mdk10.0 sans
toucher à la partition (puisque le kernel 2.6 est responsable des
paramètres erronés qui empèchent de choisir windows depuis lilo)


Ca peut marcher, mais si le programme d'update met à jour le kernel, le
problème risque de revenir :-(


En fait, après avoir installé de nouvelles partoches linux (boot en 1ere),
meme sous mdk9.1 impossible de booter windows en choisissant l'entrée
windows depuis lilo (ecran noir et rien).

Plus simple: démarrer sur le CD d'installation de Windows, et choisir
l'option "réparer une installation endommagée". Windows reviendra
comme un grand...
d'accord, mais plus de lilo et plus de linux ?



Euh non, mais je croyais que vous vouliez récupérer Windows, mais pas
obligatoirement Mandrake. Sorry...



en bootant sur le CD windows, j'ai essayer de réparer, option R, (la MBR ?)
mais j'accède seulement à une console. J'ai tout reformaté et réinstallé
windows xp (que c'est long ) et ça boot. la mbr devrait etre clean.

J'hésite à installé la mdk9.1, bien que je me dit que mdk 10 community
devait etre responsable de l'echec de l'install de la 9.1.



jean-patrick

PS J'ai une knoppix3.3 avec Qparted, tenteriez vous de redimensionner une
partition NTSf avec?
--
Retirer "PourrieL" de "" pour m'écrire.

Remove "PourrieL from "" to answer.



Jerome Lambert
Le #1528069
Le Tue, 13 Apr 2004 19:24:55 +0200, Jean-Patrick Pommier a écrit :
en bootant sur le CD windows, j'ai essayer de réparer, option R, (la MBR ?)
mais j'accède seulement à une console. J'ai tout reformaté et réinstallé
windows xp (que c'est long ) et ça boot. la mbr devrait etre clean.

J'hésite à installé la mdk9.1, bien que je me dit que mdk 10 community
devait etre responsable de l'echec de l'install de la 9.1.


Si la 9.1 s'est installée précédement, elle *devrait* pouvoir se
réinstaller ;-)

Maintenant, le problème de la MDK10 vient du fait que le BIOS est réglé
en auto-détect pour les disques durs. Tant que ce paramètre ne sera pas
changé, elle ne saura pas démarrer :-(

Si vous voulez absolument la MDK10, soit vous demandez à une personne
compétente de régler votre BIOS (si le BIOS permet cette option...),
soit vous attendez la sortie de la version officielle (en mai?) où le
problème *devrait* être réglé. :-)

jean-patrick


Jerome.

PS J'ai une knoppix3.3 avec Qparted, tenteriez vous de redimensionner une
partition NTSf avec?


Je ne connais pas Qparted, donc je ne peux vous aider :-(
Perso, je trouve que Partition Magic va très bien, mais il coute 85¤ :-(

Jean-Patrick Pommier
Le #1041705
Jerome Lambert wrote:

en bootant sur le CD windows, j'ai essayer de réparer, option R, (la MBR
?) mais j'accède seulement à une console. J'ai tout reformaté et
réinstallé windows xp (que c'est long ) et ça boot. la mbr devrait etre
clean.

J'hésite à installé la mdk9.1, bien que je me dit que mdk 10 community
devait etre responsable de l'echec de l'install de la 9.1.


Si la 9.1 s'est installée précédement, elle *devrait* pouvoir se
réinstaller ;-)


Je me suis mal expliqué, j'aurais du me relire. La mdk9.1 s'installera,
c'est sur, mais je ne suis pas sur d'avoir un double boot (linux, xp)
fonctionnel. En effet après l'install de la mdk10, j'ai installé la mdk9.1
(après avoir repartionné le disque (sans toucher la partoche NTFS)) avec
une entrée windows dans lilo mais impossible de booter dans windows. C'est
pour cette raison que je doute de la possibilité d'avoir un dual boot
windows/mdk9.1 meme après avoir reformater le disque et réinstaller
windows.

Maintenant, le problème de la MDK10 vient du fait que le BIOS est réglé
en auto-détect pour les disques durs. Tant que ce paramètre ne sera pas
changé, elle ne saura pas démarrer :-(

Si vous voulez absolument la MDK10, soit vous demandez à une personne
compétente de régler votre BIOS (si le BIOS permet cette option...),
soit vous attendez la sortie de la version officielle (en mai?) où le
problème *devrait* être réglé. :-)

jean-patrick


Jerome.

PS J'ai une knoppix3.3 avec Qparted, tenteriez vous de redimensionner une
partition NTSf avec?


Je ne connais pas Qparted, donc je ne peux vous aider :-(
Perso, je trouve que Partition Magic va très bien, mais il coute 85¤ :-(


--
Retirer "PourrieL" de "" pour m'écrire.

Remove "PourrieL from "" to answer.


Jerome Lambert
Le #1041701
Le Tue, 13 Apr 2004 21:33:29 +0200, Jean-Patrick Pommier a écrit :
Si la 9.1 s'est installée précédement, elle *devrait* pouvoir se
réinstaller ;-)


Je me suis mal expliqué, j'aurais du me relire. La mdk9.1 s'installera,
c'est sur, mais je ne suis pas sur d'avoir un double boot (linux, xp)
fonctionnel. En effet après l'install de la mdk10, j'ai installé la mdk9.1
(après avoir repartionné le disque (sans toucher la partoche NTFS)) avec
une entrée windows dans lilo mais impossible de booter dans windows. C'est
pour cette raison que je doute de la possibilité d'avoir un dual boot
windows/mdk9.1 meme après avoir reformater le disque et réinstaller
windows.


Une autre solution serait de lancer la Mandrake via une disquette de boot.

Lors de l'installation, votre Windows ne risque rien tant que LILO n'est
pas installé. L'idée est que, au moment ou le programme d'installation
demande l'endroit ou positionner Lilo, il faut lui dire de le mettre sur
une disquette (nécessite le mode expert smssb).

Dans ce cas, Windows démarrera toujours sauf si vous démarrez via la
disquette, qui elle lancera Linux...

L'autre solution est de régler (ou changer :-( ) ce ù$@#&é de BIOS ;-)

Jerome.


Jean-Patrick Pommier
Le #1041506
Jerome Lambert wrote:

Si la 9.1 s'est installée précédement, elle *devrait* pouvoir se
réinstaller ;-)


Je me suis mal expliqué, j'aurais du me relire. La mdk9.1 s'installera,
c'est sur, mais je ne suis pas sur d'avoir un double boot (linux, xp)
fonctionnel. En effet après l'install de la mdk10, j'ai installé la
mdk9.1 (après avoir repartionné le disque (sans toucher la partoche
NTFS)) avec une entrée windows dans lilo mais impossible de booter dans
windows. C'est pour cette raison que je doute de la possibilité d'avoir
un dual boot windows/mdk9.1 meme après avoir reformater le disque et
réinstaller windows.


Une autre solution serait de lancer la Mandrake via une disquette de boot.

Lors de l'installation, votre Windows ne risque rien tant que LILO n'est
pas installé. L'idée est que, au moment ou le programme d'installation
demande l'endroit ou positionner Lilo, il faut lui dire de le mettre sur
une disquette (nécessite le mode expert smssb).

Dans ce cas, Windows démarrera toujours sauf si vous démarrez via la
disquette, qui elle lancera Linux...



devinez quoi, portable sans lecteur de disquette ...

L'autre solution est de régler (ou changer :-( ) ce ù$@#&é de BIOS ;-)


En fait, je serais pret a virer windows pour de bon, si j'etais sur de
pouvoir installer les pilotes pour avoir l'acceleration 3D et
l'optimisation MPEG2 pour voir les DVD (carta video= VIA CLE266,
castlerockgraphic, il y a des choses sur viaarena.com, mais je subodore des
difficultés : install modules, recompilation du noyau ...)

Jean-pat

Jerome.


--
Retirer "PourrieL" de "" pour m'écrire.

Remove "PourrieL from "" to answer.



Publicité
Poster une réponse
Anonyme