Performances 3D avec une Radeon 8500

Le
Etienne Baudin
Bonjour,
j'ai installé récemment les pilotes officiels (propriétaires) fglrx ati pour
ma radeon 8500. L'opération s'est très bien passée, DRI est bien actif,
cependant je suis un peu déçu par les performances du résultat (1100FPS pr
glxgears). J'ai écrit quelques petites applis qui tournent 2x plus vite (en
terme de fps) sous windows que sous linux, avec les même options de
compilation. Bref, ma question est donc : est-ce normal ? (les drivers st
mons bien écrits ?) Y a t'il un truc foireux ds ma config ? Le fb n'est pas
activé, est-ce que ca pourrais venir de la (hors sujet?) ? Hors DRI/DRM, y a
t'il un composant spécial à activer ds le noyau linux ?

Bref, si vous avez des conseils, remarques, expériences . merci de m'en
faire part.

Etienne Baudin
grosso modo ma config ressemble à ça : Gentoo 1.4, Celeron 700MHz, Hercules
3d prophet 8500 LE.
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
houba
Le #1011153
bonsoir ,

"Etienne Baudin" 4044ee7c$0$28637$
Bonjour,
j'ai installé récemment les pilotes officiels (propriétaires) fglrx ati
pour

ma radeon 8500. L'opération s'est très bien passée, DRI est bien actif,
cependant je suis un peu déçu par les performances du résultat (1100FPS pr
glxgears). J'ai écrit quelques petites applis qui tournent 2x plus vite
(en

terme de fps) sous windows que sous linux, avec les même options de
compilation. Bref, ma question est donc : est-ce normal ? (les drivers st
mons bien écrits ?) Y a t'il un truc foireux ds ma config ? Le fb n'est
pas

activé, est-ce que ca pourrais venir de la (hors sujet?) ? Hors DRI/DRM, y
a

t'il un composant spécial à activer ds le noyau linux ?

Bref, si vous avez des conseils, remarques, expériences .... merci de m'en
faire part.

Etienne Baudin
grosso modo ma config ressemble à ça : Gentoo 1.4, Celeron 700MHz,
Hercules

3d prophet 8500 LE.



j'ai la même carte que vous , j'ai essayé d'installer les pilotes
officiels fglrx ati comme vous mais ça pas l'air de marcher
UT2003 me fait des triangles dans tous les sens et plante au bout de
quelques secondes .
glxgears marche correctement ( semble t il ) même au bout de 4 , 5
secondes la machine bloque .
par contre j'ai bien verifié l'agp est activé. ( 3 )

je suis sous MDK 9.2

est ce que vous pouvez en fonction de votre experience me detailler de
maniere assez précise la procédure à suivre pour les installer correctement
du moins comme
vous l'avez réalisé . Je comprends pas grand chose au readme fournit avec
les pilotes donc j'avance pas trop .


merci.

MDK9.2 , xp1800+,512 , ,PC 8500 64Mo

Samuel Colin
Le #1011152
Dans l'article Etienne Baudin a tapoté :
Bonjour,
Bonsoir,


j'ai installé récemment les pilotes officiels (propriétaires) fglrx ati pour
ma radeon 8500. L'opération s'est très bien passée, DRI est bien actif,
cependant je suis un peu déçu par les performances du résultat (1100FPS pr
glxgears).


Ma config : Athlon 2000+, Radeon 8500, Debian sarge, drivers DRI de M.
Daenzer (deb http://people.debian.org/~daenzer/dri-trunk-sid/ ./)
:~$ glxgears
8555 frames in 5.0 seconds = 1711.000 FPS
9268 frames in 5.0 seconds = 1853.600 FPS
9270 frames in 5.0 seconds = 1854.000 FPS

[petit déplacement de texte]
grosso modo ma config ressemble à ça : Gentoo 1.4, Celeron 700MHz, Hercules
3d prophet 8500 LE.
Bref, ma question est donc : est-ce normal ? (les drivers st
mons bien écrits ?) Y a t'il un truc foireux ds ma config ? Le fb n'est pas
activé, est-ce que ca pourrais venir de la (hors sujet?) ? Hors DRI/DRM, y a
t'il un composant spécial à activer ds le noyau linux ?

Alors dans l'ordre:

- Oui, ce sont des performances tout à fait honnêtes
- Les drivers windows ont moins de couches logicielles à traverser, ce qui
fait que ça peut être plus rapide sous Windows (pas vrai si la carte est
conçue avec une API opengl dans l'idée et pas DirectX)
- A priori non.
- Tu peux essayer de l'activer, mais si j'en crois la doc du noyau ça
n'agira pas sur la 3D, uniquement sur la communication avec certains
composants matériels, et non ce n'est pas hors-sujet (le framebuffer sous
Linux est un peu particulier, AFAIK)
- Le support de l'agp, juste avant les options DRM du noyau, pour les
composants de ta carte mère.

--
Des orangs-outangs, et moults autres miracles, sur http://sjdcolin.free.fr

Etienne Baudin
Le #1010465
est ce que vous pouvez en fonction de votre experience me detailler de
maniere assez précise la procédure à suivre pour les installer
correctement

du moins comme
vous l'avez réalisé . Je comprends pas grand chose au readme fournit avec
les pilotes donc j'avance pas trop .


Est-ce qu'un "glxinfo" indique que dri est actif ?
Sinon j'ai tout betement suivi la procedure décrite ici =>
http://lea-linux.org/hardware/atidriver.php3 (en utilisant rpm2cpio pour
décompresser le rpm, au lieu de rpm2targz)
Ca a marché du premier coup . Pour la config du fichier XF86config-4 (dans
/etc/X11), ca peut être réalisé simplement en utilisant l'utilitaire fourni
avec le pilote : fglrxconfig.
Pour info, j'ai xfree 4.3, et le support DRM 4.1 (général) activé dans le
noyau (mais pas le module pour radeon)

Voila, bonne chance

Publicité
Poster une réponse
Anonyme