probleme de compilation xmms

Le
alex
salut tout le monde.
j'ai un probleme en voulant compiler xmms-1.2.10.tar.gz.
bon tout d'abord il me demande la librairie glib 1.2.2 ou plus
--> checking for GLIB - version >= 1.2.2 no
ok donc je l'installe, comme dependance la glib me demande pkgconfig, ok
j'installe donc leurs tarballs les plus recent:
glib-2.4.0.tar.gz
pkgconfig-0.15.0
l'installation reussi bien avec un
./configure --prefix=/usr && make && make install
c'est good, je peux enfin installer xmms.
je refait un
./configure
et la
*** The glib-config script installed by GLIB could not be found
*** If GLIB was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GLIB_CONFIG environment variable to the
*** full path to glib-config.
ok alors je fait un
find / -name "glib-config"
qui me retourne
/home/alex/src/pkgconfig-0.15.0/glib-1.2.8/glib-config
ok ca roule je fait alors un
export GLIB_CONFIG=/home/alex/src/pkgconfig-0.15.0/glib-1.2.8/glib-config
et je retente un ./configure
et la encore
checking for glib-config /home/alex/src/pkgconfig-0.15.0/glib-1.2.8/glib-config
checking for GLIB - version >= 1.2.2 no
*** Could not run GLIB test program, checking why
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB was incorrectly installed
*** or that you have moved GLIB since it was installed. In the latter case, you
*** may want to edit the glib-config script: /home/alex/src/pkgconfig-0.15.0/glib-1.2.8/glib-config
configure: error: *** GLIB >= 1.2.2 not installed - please install first ***

si quelq'un peut me donner un coup de main svp?

alex
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Cem
Le #1034035
Le 06-04-2004, alex
salut tout le monde.
bonjour

j'ai un probleme en voulant compiler xmms-1.2.10.tar.gz.
bon tout d'abord il me demande la librairie glib 1.2.2 ou plus
--> checking for GLIB - version >= 1.2.2... no
ok donc je l'installe, comme dependance la glib me demande pkgconfig, ok
j'installe donc leurs tarballs les plus recent:
glib-2.4.0.tar.gz
pkgconfig-0.15.0
Non. Ce n'est pas la glib-2 qu'il faut installer mais la glib-1.

Dernière version stable = glib-1.2.10
je refait un
./configure
et la
*** The glib-config script installed by GLIB could not be found
*** If GLIB was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GLIB_CONFIG environment variable to the
*** full path to glib-config.
Installer glib-1.2.10 qui fournit un $prefix/bin/glib-config

et tout devrait fonctionner

Qq bonnes docs si vous voulez installer à partir des sources
http://www.linuxfromscratch.org/blfs/view/cvs/general/glib.html
http://www.linuxfromscratch.org/blfs/view/cvs/multimedia/xmms.html

alex
Le #1035538
On Tue, 06 Apr 2004 15:07:05 +0000, Cem wrote:

Le 06-04-2004, alex
salut tout le monde.
bonjour

j'ai un probleme en voulant compiler xmms-1.2.10.tar.gz.
bon tout d'abord il me demande la librairie glib 1.2.2 ou plus
--> checking for GLIB - version >= 1.2.2... no
ok donc je l'installe, comme dependance la glib me demande pkgconfig, ok
j'installe donc leurs tarballs les plus recent:
glib-2.4.0.tar.gz
pkgconfig-0.15.0
Non. Ce n'est pas la glib-2 qu'il faut installer mais la glib-1.

Dernière version stable = glib-1.2.10
je refait un
./configure
et la
*** The glib-config script installed by GLIB could not be found
*** If GLIB was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GLIB_CONFIG environment variable to the
*** full path to glib-config.
Installer glib-1.2.10 qui fournit un $prefix/bin/glib-config

et tout devrait fonctionner

Qq bonnes docs si vous voulez installer à partir des sources
http://www.linuxfromscratch.org/blfs/view/cvs/general/glib.html
http://www.linuxfromscratch.org/blfs/view/cvs/multimedia/xmms.html


oui effectivement c'etait bien ça, me manquait la glib-1 :/
merci aussi pour les liens tres eplicatifs.
je vais enfin pouvoir me réecouter mes ch'tites radios :)

alex


Publicité
Poster une réponse
Anonyme