où trouver glib 2 ?

Le
Vincent Schmid
Bonjour à tous,

J'ai voulu installer XFCE 4.0.5 sur Fedora Core 1, mais apparement il me
manque un truc nommé glib 2. Je n'ai aucune idée de ce que c'est, mais çà
n'a surement rien à voir avec glib.org, et je ne l'ai pas trouvé sur
rpmfind.net Et oui, les débuts sous Linux sont durs lorsqu'on vient du
système innomable Mais il y aura bien quelqu'un pour m'aiguiller,
n'est-ce pas ;-) ?

Merci d'avance,
Vincent
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Tbo
Le #1062459
Vincent Schmid
Bonjour à tous,

J'ai voulu installer XFCE 4.0.5 sur Fedora Core 1, mais apparement il me
manque un truc nommé glib 2. Je n'ai aucune idée de ce que c'est, mais çà
n'a surement rien à voir avec glib.org, et je ne l'ai pas trouvé sur
rpmfind.net... Et oui, les débuts sous Linux sont durs lorsqu'on vient du
système innomable... Mais il y aura bien quelqu'un pour m'aiguiller,
n'est-ce pas ;-) ?

Merci d'avance,
Vincent



hi,


ne serait-ce pas la glibc2 ?
si oui google http://www.freenix.fr/unix/linux/HOWTO/Glibc2-HOWTO.html

A+

Tbo
Le #1062290
Vincent Schmid
Bonjour à tous,

J'ai voulu installer XFCE 4.0.5 sur Fedora Core 1, mais apparement il me
manque un truc nommé glib 2. Je n'ai aucune idée de ce que c'est, mais çà
n'a surement rien à voir avec glib.org, et je ne l'ai pas trouvé sur
rpmfind.net... Et oui, les débuts sous Linux sont durs lorsqu'on vient du
système innomable... Mais il y aura bien quelqu'un pour m'aiguiller,
n'est-ce pas ;-) ?

Merci d'avance,
Vincent



sinon, si il s'agit bien de la glib 2, mais il y en a d'autres

http://rpmfind.net/linux/RPM/ASP/i386/RPMS.9/glib2-2.2.1-1.i386.html

Kevin
Le #1062288
Le Tue, 4 May 2004 19:28:09 +0200, Vincent Schmid a ecrit:
|
| J'ai voulu installer XFCE 4.0.5 sur Fedora Core 1, mais apparement il me
| manque un truc nommé glib 2. Je n'ai aucune idée de ce que c'est, mais çà
| n'a surement rien à voir avec glib.org, et je ne l'ai pas trouvé sur
| rpmfind.net...

et sur les CD d'installs, tout simplement?
Un truc qui s'appelerait glib2.blabla.rpm ?

--
Kevin
Ne lis pas ces messages d'erreurs. Ca ne sert a rien.
-+- Les 100 choses que vous n'aimez pas entendre de la part du sysadmin -+-
Basile Starynkevitch [news]
Le #1062287
Le 04-05-2004, Vincent Schmid
J'ai voulu installer XFCE 4.0.5 sur Fedora Core 1, mais apparement il me
manque un truc nommé glib 2.


C'est peut-être la glib 2 qui fait partie de gtk et qu'on trouve (avec
gtk et atk et pango) sur www.gtk.org - vous avez probablemnt gtk2 déjà
installé sur votre système (car c'est utilisé par gnome).

Sur ma Debian/Sid j'ai un paquet libxfcegui4-1 qui contient
/usr/lib/libxfcegui4.so.1 dont les dépendances sont

# ldd /usr/lib/libxfcegui4.so.1
libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0x40057000)
libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0x40328000)
libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0x40399000)
libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0x403b3000)
libm.so.6 => /lib/tls/libm.so.6 (0x403c8000)
libpangoxft-1.0.so.0 => /usr/lib/libpangoxft-1.0.so.0 (0x403eb000)
libpangox-1.0.so.0 => /usr/lib/libpangox-1.0.so.0 (0x403f0000)
libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0x403fc000)
libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0x40432000)
libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0x4046b000)
libdl.so.2 => /lib/tls/libdl.so.2 (0x4046f000)
libxfce4util.so.1 => /usr/lib/libxfce4util.so.1 (0x40472000)
libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0x40476000)
libSM.so.6 => /usr/X11R6/lib/libSM.so.6 (0x404f5000)
libICE.so.6 => /usr/X11R6/lib/libICE.so.6 (0x404ff000)
libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x40516000)
libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x405dd000)
libc.so.6 => /lib/tls/libc.so.6 (0x405eb000)
libXrandr.so.2 => /usr/X11R6/lib/libXrandr.so.2 (0x40726000)
libXi.so.6 => /usr/X11R6/lib/libXi.so.6 (0x4072a000)
libXft.so.2 => /usr/lib/libXft.so.2 (0x40733000)
libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x40745000)
libz.so.1 => /usr/lib/libz.so.1 (0x407b2000)
libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x407c3000)
libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0x407ea000)
libXrender.so.1 => /usr/lib/libXrender.so.1 (0x407f3000)
/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x80000000)
libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0x407fc000)
libexpat.so.1 => /usr/lib/libexpat.so.1 (0x40821000)

--
Basile STARYNKEVITCH http://starynkevitch.net/Basile/
email: basile<at>starynkevitch<dot>net
aliases: basile<at>tunes<dot>org = bstarynk<at>nerim<dot>net
8, rue de la Faïencerie, 92340 Bourg La Reine, France

Vincent Schmid
Le #1062809
Merci à tous pour les réponses :-) j'ai chargé glib-2.4.1 sur www.gtk.org et
je l'ai installé (configure, make, make install sans problème)

En essayant de compiler le premier module pour XFCE, la commande ./configure
s'arrête toujours, car elle ne trouve pas "glib-2.0 >= 2.0.0".

Je n'y comprends plus rien ...

Vincent




"Basile Starynkevitch [news]" le message de news:

J'ai voulu installer XFCE 4.0.5 sur Fedora Core 1, mais apparement il me
manque un truc nommé glib 2.


C'est peut-être la glib 2 qui fait partie de gtk et qu'on trouve (avec
gtk et atk et pango) sur www.gtk.org - vous avez probablemnt gtk2 déjà
installé sur votre système (car c'est utilisé par gnome).

Sur ma Debian/Sid j'ai un paquet libxfcegui4-1 qui contient
/usr/lib/libxfcegui4.so.1 dont les dépendances sont

# ldd /usr/lib/libxfcegui4.so.1
libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0
(0x40057000)

libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0x40328000)
libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0x40399000)
libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0
(0x403b3000)

libm.so.6 => /lib/tls/libm.so.6 (0x403c8000)
libpangoxft-1.0.so.0 => /usr/lib/libpangoxft-1.0.so.0 (0x403eb000)
libpangox-1.0.so.0 => /usr/lib/libpangox-1.0.so.0 (0x403f0000)
libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0x403fc000)
libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0x40432000)
libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0x4046b000)
libdl.so.2 => /lib/tls/libdl.so.2 (0x4046f000)
libxfce4util.so.1 => /usr/lib/libxfce4util.so.1 (0x40472000)
libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0x40476000)
libSM.so.6 => /usr/X11R6/lib/libSM.so.6 (0x404f5000)
libICE.so.6 => /usr/X11R6/lib/libICE.so.6 (0x404ff000)
libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x40516000)
libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x405dd000)
libc.so.6 => /lib/tls/libc.so.6 (0x405eb000)
libXrandr.so.2 => /usr/X11R6/lib/libXrandr.so.2 (0x40726000)
libXi.so.6 => /usr/X11R6/lib/libXi.so.6 (0x4072a000)
libXft.so.2 => /usr/lib/libXft.so.2 (0x40733000)
libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x40745000)
libz.so.1 => /usr/lib/libz.so.1 (0x407b2000)
libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x407c3000)
libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0x407ea000)
libXrender.so.1 => /usr/lib/libXrender.so.1 (0x407f3000)
/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x80000000)
libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0x407fc000)
libexpat.so.1 => /usr/lib/libexpat.so.1 (0x40821000)

--
Basile STARYNKEVITCH http://starynkevitch.net/Basile/
email: basile<at>starynkevitch<dot>net
aliases: basile<at>tunes<dot>org = bstarynk<at>nerim<dot>net
8, rue de la Faïencerie, 92340 Bourg La Reine, France



Kevin
Le #1063356
Le Wed, 5 May 2004 19:54:08 +0200, Vincent Schmid a ecrit:
| Merci à tous pour les réponses :-) j'ai chargé glib-2.4.1 sur www.gtk.org et
| je l'ai installé (configure, make, make install sans problème)
|
| En essayant de compiler le premier module pour XFCE, la commande ./configure
| s'arrête toujours, car elle ne trouve pas "glib-2.0 >= 2.0.0".
|
| Je n'y comprends plus rien ...
|
Je m'etais fait avoir aussi une fois. En fait, il faut un autre paquet
qui contienne le programme qui detecte les libs. En gros, la lib est
la, ./configure appelle un programme qui verifie la presence de la lib,
ce programme verificateur n'est pas la (meme si la lib y est) et le
./configure conclut (a tort donc) que la lib n'est pas la.
De memoire, je crois que sur ma slack le paquet s'appelle pkgconfig ou
pkg-config.

Si ce n'est pas ca, regarde le nom precis du programme dans le ./configure

--
Kevin
Les sprinklers, ca n'est pas suppose fuir, non?
-+- Les 100 choses que vous n'aimez pas entendre de la part du sysadmin -+-
Publicité
Poster une réponse
Anonyme