Utilisez-vous le même formulaire pour un nouvel enregistrement que pour les autres ?

Le
Bonsoir à tous,
A chacune de mes base de données sous Access comportant des formulaires de saisie je me pose la sempiternelle même question.
Dois je créer un formulaire pour l'ajout d'enregistrement et un autre très semblable pour la consultation modification des
enregistrements existants ?


Cette question se repose de manière important aujourd'hui pour moi où j'ai une petite base de données 18 Mo, et également 18 Mo
pour la base de manipulation des données (la base des requêtes, formulaires, modules) Ces deux bases sont compactées d'hier et
régulièrement. J'utilise cette base de données depuis deux ans et je saisie les données et j'améliore l'interface du mieux que je
peux. C'est pourquoi il a beaucoup d'objets dans la base de manipulation des données, d'où sans doute la taille démesurée par
rapport au données.
L'objet de la base est un formulaire principale et un table très importante par rapport aux autres
Et c'est sur ce formulaire que j'ouvre un enregistrement existant par choix d'un menu déroulant dans un formulaire d'accueil, là le
délai est raisonnable, pour une recherche sur 2500 enregistrement sur clé unique. Mais quand avec les deux mêmes formulaires j'ouvre
le formulaire en ajout d'un nouvel enregistrement, j'ai un délai assez important entre 2 et 5 secondes le code est le suivant :
docmd.openform "FormSaisie"
docmd.gotorecord acform, "FormSaisie", acnewrec

J'ai déjà réparé de nombreuse fois la base de données de manipulation des données et importer tous les objets vers une base toute
neuves une ou deux fois, la dernière fois en février.

Je ne comprend pas pourquoi ce délai qui est devenu important ces deux derniers mois seulement
WXP SP1 OFF XP2.
Merci de toute contribution.

Merci d'avoir lu jusque là.
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Le méruvien
Le #5033771
bonjour,
Non, tu peut utiliser le même formulaire,pour la saisie tu l'ouvre en mode
"ajout", et pour la consultation, tu l'ouvre en normal, selon le nom que tu
aura selectionné dans une liste ou un formulaire tableau, ou un nom que tu
aura tapez dasn un champs.
roger
"@pollo"

.desirable.laposte.net> a écrit dans le message de news:

Bonsoir à tous,
A chacune de mes base de données sous Access comportant des formulaires de
saisie je me pose la sempiternelle même question.

Dois je créer un formulaire pour l'ajout d'enregistrement et un autre très
semblable pour la consultation modification des

enregistrements existants ?


Cette question se repose de manière important aujourd'hui pour moi où j'ai
une petite base de données 18 Mo, et également 18 Mo

pour la base de manipulation des données (la base des requêtes,
formulaires, modules...) Ces deux bases sont compactées d'hier et

régulièrement. J'utilise cette base de données depuis deux ans et je
saisie les données et j'améliore l'interface du mieux que je

peux. C'est pourquoi il a beaucoup d'objets dans la base de manipulation
des données, d'où sans doute la taille démesurée par

rapport au données.
L'objet de la base est un formulaire principale et un table très
importante par rapport aux autres...

Et c'est sur ce formulaire que j'ouvre un enregistrement existant par
choix d'un menu déroulant dans un formulaire d'accueil, là le

délai est raisonnable, pour une recherche sur 2500 enregistrement sur clé
unique. Mais quand avec les deux mêmes formulaires j'ouvre

le formulaire en ajout d'un nouvel enregistrement, j'ai un délai assez
important entre 2 et 5 secondes le code est le suivant :

docmd.openform "FormSaisie"
docmd.gotorecord acform, "FormSaisie", acnewrec

J'ai déjà réparé de nombreuse fois la base de données de manipulation des
données et importer tous les objets vers une base toute

neuves une ou deux fois, la dernière fois en février.

Je ne comprend pas pourquoi ce délai qui est devenu important ces deux
derniers mois seulement...

WXP SP1 OFF XP2.
Merci de toute contribution.

Merci d'avoir lu jusque là.




Le #5032431
Bonjour à tous, bonjour et merci à toi le méruvien,
Bon j'avais pas pensé à la feuille de propriété, mais franchement je n'ai pas trouvé le mode ajout et le mode normal dans ma version
Xp, mais je vais creuser dans ce sens car j'ai trouvé la propriété allowAdditions qui est à oui par défaut mais bon...
En tout cas merci.
Compte tenu du nombre d'autres question depuis la mienne j'espère tout de même d'autres idées ou contributions.
Merci encore.
Merci d'avoir lu jusque là.
Publicité
Poster une réponse
Anonyme