wine-20040408 et mdk10.0

Le
LE DOARE Serge
Bonjour à tou(te)s !

Après moultes péripéties pour mes débuts avec le pingouin (winmodem,
puis non-reconnaissance de ma carte RNIS Gazell interne, puis galère
avec Fast800 Sagem adsl et mdk 9.1 puis 10.0, enfin résolu grâce au
pilote Eagle-usb), j'en viens à imaginer de pouvoir 'basculer' plus
complètement sur Linux.
Pour la bureautique : pas de problème. Cela fait déjà deux ans que
j'utilise OpenOffice.org. La dernière fois que j'ai réinstallé Windows
(après un virus :-( je n'ai même pas ré-installé une version d'origine
inavouable de MS-Office.
Restent trois logiciels qui tournent sur l'autre disque (Win Me) :
- Cerfipro, programme de comptabilité (avec Visual FoxPro)
- ma base de données "troupeau de vaches" avec Lotus Approach 97
- et ID-Mr 2000, programme antédiluvien sous DOS pour piloter
l'alimentation de mes vaches au distributeur automatique de concentrés.

J'ai donc essayé d'installer Wine pour accéder à ces trois programmes
depuis Linux. Et là, j'ai fait plusiers essais avec toujours le même
message d'erreur au même stade.
Sous "user", dans le répertoire "Wine-20040408-mdk", je fais
./tools/wineinstall. Au début, ça roule jusqu'au message (normal) :
"We need to install wine as root user, do you want us to build wine,
'su root' and install Wine? Enter 'no' to continue without installing
(yes/no) " Je réponds "yes" et ça roule à nouveau jusqu'au message
d'erreur suivant :
"Compilation failed, aborting install."
Voici les quelques lignes qui précèdent :

> make[1]: Leaving directory `/home/serge/tmp/wine-20040408/tools'
> ./tools/makedep -I. -I. -I./include -I./include -C.
> make[1]: Entering directory `/home/serge/tmp/wine-20040408/libs'
> make[2]: Entering directory `/home/serge/tmp/wine-20040408/libs/port'
> make[2]: Rien à faire pour « all ».
> make[2]: Leaving directory `/home/serge/tmp/wine-20040408/libs/port'
> make[2]: Entering directory `/home/serge/tmp/wine-20040408/libs/unicode'
> make[2]: Rien à faire pour « all ».
> make[2]: Leaving directory `/home/serge/tmp/wine-20040408/libs/unicode'
> make[2]: Entering directory `/home/serge/tmp/wine-20040408/libs/wine'
> make[2]: Rien à faire pour « all ».
> make[2]: Leaving directory `/home/serge/tmp/wine-20040408/libs/wine'
> make[2]: Entering directory `/home/serge/tmp/wine-20040408/libs/wpp'
> bison -y -ppp -d -t ./ppy.y
> make[2]: *** [y.tab.c] Broken pipe
> make[2]: Leaving directory `/home/serge/tmp/wine-20040408/libs/wpp'
> make[1]: *** [wpp] Erreur 2
> make[1]: Leaving directory `/home/serge/tmp/wine-20040408/libs'
> make: *** [libs] Erreur 2
>
> Compilation failed, aborting install.

J'ai cherché s'il y avait quelquechose du côté du 'Broken pipe'. J'ai lu
quelquepart que le 'bash' du 'shell' provoquait parfois cette erreur.
J'ai donc remplacé 'bash' par 'tcsh' dans /etc/passwd comme lu
quelquepart sur la toile, j'ai redémarrer et rebelote ! Toujours la
même erreur.
Si quelqu'un a une idée à me suggérer, je l'en remercie par avance.

Cordialement
Serge Le Doaré
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Tallion
Le #1518155
LE DOARE Serge wrote:
|| Bonjour à tou(te)s !
||
|| Après moultes péripéties pour mes débuts avec le pingouin (winmodem,
|| puis non-reconnaissance de ma carte RNIS Gazell interne, puis galère
|| avec Fast800 Sagem adsl et mdk 9.1 puis 10.0, enfin résolu grâce au
|| pilote Eagle-usb), j'en viens à imaginer de pouvoir 'basculer' plus
|| complètement sur Linux.
|| Pour la bureautique : pas de problème. Cela fait déjà deux ans que
|| j'utilise OpenOffice.org. La dernière fois que j'ai réinstallé
|| Windows (après un virus :-( je n'ai même pas ré-installé une
|| version d'origine inavouable de MS-Office.
|| Restent trois logiciels qui tournent sur l'autre disque (Win Me) :
|| - Cerfipro, programme de comptabilité (avec Visual FoxPro)
|| - ma base de données "troupeau de vaches" avec Lotus Approach 97
|| - et ID-Mr 2000, programme antédiluvien sous DOS pour piloter
|| l'alimentation de mes vaches au distributeur automatique de
|| concentrés.
||
|| J'ai donc essayé d'installer Wine pour accéder à ces trois programmes
|| depuis Linux. Et là, j'ai fait plusiers essais avec toujours le même
|| message d'erreur au même stade.
|| Sous "user", dans le répertoire "Wine-20040408-mdk", je fais
|| ./tools/wineinstall. Au début, ça roule jusqu'au message (normal) :
|| "We need to install wine as root user, do you want us to build wine,
|| 'su root' and install Wine? Enter 'no' to continue without
|| installing (yes/no) " Je réponds "yes" et ça roule à nouveau
|| jusqu'au message d'erreur suivant :
|| "Compilation failed, aborting install."
|| Voici les quelques lignes qui précèdent :
||
||| make[1]: Leaving directory `/home/serge/tmp/wine-20040408/tools'
||| ./tools/makedep -I. -I. -I./include -I./include -C.
||| make[1]: Entering directory `/home/serge/tmp/wine-20040408/libs'
||| make[2]: Entering directory
||| `/home/serge/tmp/wine-20040408/libs/port' make[2]: Rien à faire
||| pour « all ».
||| make[2]: Leaving directory `/home/serge/tmp/wine-20040408/libs/port'
||| make[2]: Entering directory
||| `/home/serge/tmp/wine-20040408/libs/unicode' make[2]: Rien à faire
||| pour « all ».
||| make[2]: Leaving directory
||| `/home/serge/tmp/wine-20040408/libs/unicode' make[2]: Entering
||| directory `/home/serge/tmp/wine-20040408/libs/wine' make[2]: Rien à
||| faire pour « all ».
||| make[2]: Leaving directory `/home/serge/tmp/wine-20040408/libs/wine'
||| make[2]: Entering directory `/home/serge/tmp/wine-20040408/libs/wpp'
||| bison -y -ppp -d -t ./ppy.y
||| make[2]: *** [y.tab.c] Broken pipe
||| make[2]: Leaving directory `/home/serge/tmp/wine-20040408/libs/wpp'
||| make[1]: *** [wpp] Erreur 2
||| make[1]: Leaving directory `/home/serge/tmp/wine-20040408/libs'
||| make: *** [libs] Erreur 2
|||
||| Compilation failed, aborting install.
||
|| J'ai cherché s'il y avait quelquechose du côté du 'Broken pipe'.
|| J'ai lu quelquepart que le 'bash' du 'shell' provoquait parfois
|| cette erreur. J'ai donc remplacé 'bash' par 'tcsh' dans /etc/passwd
|| comme lu quelquepart sur la toile, j'ai redémarrer et... rebelote !
|| Toujours la même erreur.
|| Si quelqu'un a une idée à me suggérer, je l'en remercie par avance.
||
|| Cordialement
|| Serge Le Doaré


Bonjour, je suis débutant également sur MDK 10 et j'ai quelques soucis pour
faire fonctionner ma connexion Internet avec un Olitec RNIS PCI (à base de
chipset Gazel) alors que cela fonctionnait parfaitement avec MDK 9.2, j'ai
le même problème avec un modem Alcatel Speedtouch ADSL chez un copain,
pouvez-vous me tuyauter ? Merci !
--
Tallion
Pour me répondre directement par E-mail, cliquez sur ce lien :
http://www.cerbermail.com/?Ks1LNtfOyM
LE DOARE Serge
Le #1064580
...
Bonjour, je suis débutant également sur MDK 10 et j'ai quelques soucis pour
faire fonctionner ma connexion Internet avec un Olitec RNIS PCI (à base de
chipset Gazel) alors que cela fonctionnait parfaitement avec MDK 9.2, j'ai
le même problème avec un modem Alcatel Speedtouch ADSL chez un copain,
pouvez-vous me tuyauter ? Merci !


Malheureusement, je n'ai jamais réussi à faire fonctionner ma carte RNIS
sous le pingouin :-(
Mais, rassure-toi, je suis loin d'être une référence ;-)

En espérant pouvoir t'être plus utile la prochaine fois...

TD
Le #1518121
J'ai récupéré wine en rpm à l'adresse : http://www.winehq.org/site/download

Il n'y a besoin que d'un seul fichier rpm qui installe tout et celà
marche très bien (il faut peut-être désinstaller les rpm wine qui sont
fournis avec la mandrake).

Cordialement,

Thomas Delarue
Publicité
Poster une réponse
Anonyme