Firefox 4 : le support PowerPC enterré

Le par  |  12 commentaire(s)
Firefox_Nouveau_Logo

La prochaine mouture majeure de Firefox ne sera proposée sous Mac OS qu'à destination des ordinateurs à architecture Intel. Croix est faite pour le support PowerPC avec Firefox 4.

Firefox_Nouveau_LogoPetite ironie du sort. Alors que le projet libre VideoLAN vient de publier une version 1.1.4.1 de VLC à destination des ordinateurs Mac à architecture PowerPC, Mozilla sonne le glas des prochaines versions majeures de Firefox pour ces machines. Ainsi, Firefox 4, que l'on attend d'ici la fin de l'année, ne sera proposé pour Mac OS X qu'en universal binaries pour i386 / x86-64.

Ce n'est pas une surprise, la décision avait déjà été prise en début de mois, au motif notamment que le nombre d'utilisateurs de Firefox sous OSX/PPC est actuellement très faible, et tend qui plus est à diminuer encore.

Si cette information refait surface aujourd'hui, c'est parce que Mozilla a mis en ligne de nouvelles versions préliminaires de Firefox 4 pour Mac OS X et donc uniquement pour les CPU Intel. Par défaut, elles s'exécutent en 32-bit pour Leopard ( 10.5 ) et 64-bit pour Snow Leopard ( 10.6 ).

Cet abandon de l'architecture PowerPC pour Firefox vient s'ajouter à la fin du support de Mac OS X 10.4, le minimum requis étant 10.5.

Complément d'information

Vos commentaires Page 1 / 2

Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Le #693141
C'est bien eux qui critiquaient qu'IE n'était pas dispo pour XP c'est ça ?
Le #693171
C'est un peu trop facile de dire qu'on abandonne la version powerPC à cause d'un trop petit nombre d'utilisateurs sur cette plate-forme quand on sait que Firefox 3 n'a jamais tourné sur OS X.3 ce qui empêche les possesseurs de mac Power PC d'installer ce dernier.
Heureusement Opera continue à distribuer des versions compatibles OS.X.3 ce qui permet de ne pas mettre à la poubelle ces machines tout à fait à niveau pour le casual surf.
Le #693251
et c'est bien m$ qui refuse ie9 aux utilisateurs de xp ,qui eux représente quand même plus de 65% sous cet os ?

Ah oui j'oubliais "forcer la vente de 7" ça c'est de la bonne pratique

**

Le #693381
Je pense que Mozilla a déjà fort à faire pour que FF4 fonctionne sur BSD, Linux, XP, Vista, Win7, Mac OSX que ce soit en 32bit ou en 64bit, pour qu'il s'intéresse à des versions obsolètes de Mac OS. A ce moment là pourquoi ne pas être supporter sur Win 98 ou en Win95...

Il y a quand même une grande mauvaise foi chez les partisans de IE9 qui lui ne propose d'être supporter sur uniquement Vista et Win7 (32 et 64 bit).

ça n'aurait pas demandé un gros efffort de faire une version allégée pour XP sans accélération graphique puisque c'est ça qui pose problème apparemment.
Anonyme
Le #693391
"C'est bien eux qui critiquaient qu'IE n'était pas dispo pour XP c'est ça ?"

Le "eux", il désigne Mozilla, qui distribue Firefox pour Windows/Mac/Linux ?

Le #693471
Salut,
@spamnco :
« Heureusement Opera continue à distribuer des versions compatibles OS.X.3 »
Opera ne supportera bientôt plus l'architecture PowerPC sur les plates-formes Mac et Linux, qui représentait 0.1% des déjà très rares utilisateurs d'Opera.
http://my.opera.com/desktopteam/blog/2010/08/30/tea

@gandalf79 :
« pourquoi ne pas être supporter sur Win 98 ou en Win95...»
Opera 10.62 permet toujours de surfer sur Windows 98 SE : http://files.getwebb.org/files/6c/68/52/a5e8a59e2969e7d4386a2eb6c7895dee48/source.png
Pour Windows 95, je n'ai pas testé

@+
--
Pierre
Le #693601
Faut il aussi rappeler que Mozilla ne vend pas son navigateur, ils ont donc tout intérêt de concentrer les équipes de développement sur les plateformes les plus utilisées.
Le #693701
@Remic :

« Faut il aussi rappeler que Mozilla ne vend pas son navigateur »


Ils ne vendent pas leur produit à l'utilisateur final. Mais ils le vendent quand même, sinon ils auraient un peu de mal à rémunérer leur staff de développeurs et responsables marketing


« ils ont donc tout intérêt de concentrer les équipes de développement sur les plateformes les plus utilisées. »


Ah, bon ? C'est pas, au contraire, une logique purement mercantile que de favoriser les clients à fortes parts de marché ?

@+
--
Pierre
Le #694101
"C'est bien eux qui critiquaient qu'IE n'était pas dispo pour XP c'est ça ?" Tellement vrai.

"et c'est bien m$ qui refuse ie9 aux utilisateurs de xp ,qui eux représente quand même plus de 65% sous cet os ?"

En même temps IE9 est une beta et Ms continue à maintenir les versions précédentes. De plus Ms passe pas son temps à donner des leçon de morale à tout va, ce qui n'est pas le cas des petits fachos gauchos usuels.

Pour le coup, ils sont dans la merde.
Suivre les commentaires
Poster un commentaire
Anonyme
:) ;) :D ^^ 8) :| :lol: :p :-/ :o :w00t: :roll: :( :cry: :facepalm:
:andy: :annoyed: :bandit: :alien: :ninja: :agent: :doh: :@ :sick: :kiss: :love: :sleep: :whistle: =]