Firefox 3.6 va vérifier si les plugins sont à jour

Le par  |  4 commentaire(s)
Firefox-Plugin-Detection

La prochaine mouture de Firefox indiquera à l'utilisateur si certains de ses plugins sont périmés.

Firefox-Plugin-DetectionAvec la dernière mise à jour de Firefox ( 3.5.3 et 3.0.14 ), la Fondation Mozilla s'est occupée du cas du plugin Flash. Au premier lancement du navigateur et seulement à ce moment là, la page What's New informe l'utilisateur s'il dispose de la version la plus à jour de Flash Player. Si ce n'est pas le cas, un lien lui permet de la rapatrier via le site d'Adobe.

Mozilla avait indiqué qu'il ne s'agissait que d'une première approche et que cette vérification serait étendue à d'autres plugins. D'anciennes versions de plugins peuvent en effet être la cause de problèmes de stabilité, sans compter le risque de sécurité pour une version éventuellement vulnérable. Firefox 3.6 dont une première version bêta est attendue pour la semaine prochaine, bénéficiera de ce travail autour des plugins.

L'équipe WebDev de Mozilla a récemment développé une page Web baptisée Plugin Check où une petite analyse des plugins présents dans Firefox est opérée afin de déterminer ceux qui ne sont pas à jour. Cette page va plus loin que l'actuelle page What's New en s'occupant non seulement du plugin Flash, mais aussi d'Adobe Reader, Java, RealPlayer... À terme le tour d'horizon devrait être le plus complet possible.

Ce mécanisme de vérification sera intégré dans Firefox 3.6 sans que pour autant l'utilisateur n'ait à se rendre manuellement sur la page Plugin Check. Au chargement d'une page Web qui sollicite un plugin périmé ( et donc plus uniquement au premier lancement du navigateur ), l'utilisateur sera directement averti via l'apparition d'une barre ( ci-dessous ). S'il le désire, un bouton sur cette barre le conduira sur la page Plugin Check d'où il pourra procéder à la mise à jour.

Firefox-plugin-notification

L'utilisateur sera également averti via l'onglet Plugins du gestionnaire des modules complémentaires où les plugins non à jour seront indiqués.

Complément d'information

Vos commentaires

Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Le #530171
"Potentialy vulnerable" et "safe" : aucun rapport avec le fait qu'un plugin soit à jour ou non... Après on parle de microsoft qui fait des truc abusif avec WGA, mais là c'est limite pire...

Un plugin qui n'est pas à jour ne veut pas dire qu'il possède des failles, simplement qu'il existe une version plus récente...
Le #530281
Pas trop d'accord avec toi, il y a un an et demi, il y a eu un concours de hacking... et le pc sous vista a été hacké a cause de ... flash player!
qui a été corrigé par la suite...
Donc oui, un plug in pas a jour ne possede pas forcemment de faille... (mais bon, tous possede plus ou moins une faille... c'est juste le fait qu'elle soit connu qui change)... donc un vieux plug in, a quand meme plus de chance de posseder des failles connus, et donc exploitable...

Le #530331
il me semblait ke c'étais fait depuis longtemps ! bizarre !
Le #530541
alucardx77>tu penses surement aux extensions non?
Suivre les commentaires
Poster un commentaire
Anonyme
:) ;) :D ^^ 8) :| :lol: :p :-/ :o :w00t: :roll: :( :cry: :facepalm:
:andy: :annoyed: :bandit: :alien: :ninja: :agent: :doh: :@ :sick: :kiss: :love: :sleep: :whistle: =]