4D 6.8.5 et Léopard ça le fait ?

Le
Gilles
J'utilise 4D 6.8.5 et 4D Write correspondant avec Tiger

Sans que ce soit parfait on va dire que ça marche


J'hésite a passer en Léopard de peur que tout ça ne fonctionne plus ?
Et je ne souhaite pas évoluer ( 4D ) par contre c'est vital pour la
gestion d'une petite entreprise.

Je sais qu'il convient de passer a la version 2004.11 ou qqch comme ça,
vu le prix des updates qui ne fonctionnent pas forcément correctement et
que je fais le minimum de maintenance sur ce soft

Quelques retours d'expérience ???

Merci..


--
La jeunesse c'est le temps d'étudier la sagesse et la vieillesse c'est
le temps de la pratiquer. (Jean-Jacques ROUSSEAU)
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Anonyme
Le #16456621
Gilles
J'utilise 4D 6.8.5 et 4D Write correspondant avec Tiger...

Sans que ce soit parfait on va dire que ça marche...


J'hésite a passer en Léopard de peur que tout ça ne fonctionne plus ?
Et je ne souhaite pas évoluer ( 4D ) par contre c'est vital pour la
gestion d'une petite entreprise.

Je sais qu'il convient de passer a la version 2004.11 ou qqch comme ça,
vu le prix des updates qui ne fonctionnent pas forcément correctement et
que je fais le minimum de maintenance sur ce soft

Quelques retours d'expérience ???




La 6.8, jamais testé sur Leopard, j'essaie de maintenir un minimum dans
les versions récentes de 4D. Mais j'ai des doutes.
2003 en leopard, pas trop de problème, juste parfois quelques surprises
à l'impression, mais rien de grave.
2004 en leopard, officiellement supporté, mais là encore, quelques
petites surprise à l'impression facilement contournables par contre.
v11 : tout baigne.

Mon avis. Prends les version démo et teste ton appli. Si tu peux passer
en v11 sans trop de problème, vas-y, ça vaut vraiment le coup. Si tu
n'as pas de sous-table et autres vieilles joyeusetés, les migrations
devraient se passer sans problème. (mais il est préférable de migrer
version par version, ce qui est faisable avec les versions démo)

--
Anonyme ( jayce <@> mosx.org )
********* MosX.org Ce message est sous licence Creative Commons "by-nc-sa-2.0"
Gilles
Le #16458671
Anonyme a écrit :

Mon avis. Prends les version démo et teste ton appli. Si tu peux passer
en v11 sans trop de problème, vas-y, ça vaut vraiment le coup. Si tu
n'as pas de sous-table et autres vieilles joyeusetés, les migrations
devraient se passer sans problème. (mais il est préférable de migrer
version par version, ce qui est faisable avec les versions démo)



Merci pour toutes ces précisions, quant tu dis 4D v11 tu parles bien de
4D v11 SQL ?

La première Base date de la V2 et la 2ème de la V3 ( de mémoire )...

Le problème est pas de savoir si ça marcherait avec Léopard en utilisant
la V11. Mais si je migre Leopard est-ce que mes 2 bases en 6.8.5
fonctionneront ?


--
La jeunesse c'est le temps d'étudier la sagesse et la vieillesse c'est
le temps de la pratiquer. (Jean-Jacques ROUSSEAU)
Gilles
Le #16458841
Anonyme a écrit :

Mon avis. Prends les version démo et teste ton appli. Si tu peux passer
en v11 sans trop de problème, vas-y, ça vaut vraiment le coup. Si tu
n'as pas de sous-table et autres vieilles joyeusetés, les migrations
devraient se passer sans problème. (mais il est préférable de migrer
version par version, ce qui est faisable avec les versions démo)



Merci pour toutes ces précisions, quant tu dis 4D v11 tu parles bien de
4D v11 SQL ?

La première Base date de la V2 et la 2ème de la V3 ( de mémoire )...
Et quelques sous-fiches ( a l'époque ) subsistent, de mémoire on nous
avait soutenu que ça serait maintenu...

Le problème est pas de savoir si ça marcherait avec Léopard en utilisant
la V11. Mais si je migre Leopard est-ce que mes 2 bases en 6.8.5
fonctionneront ?


--
La jeunesse c'est le temps d'étudier la sagesse et la vieillesse c'est
le temps de la pratiquer. (Jean-Jacques ROUSSEAU)
Anonyme
Le #16460821
Gilles
Anonyme a écrit :

> Mon avis. Prends les version démo et teste ton appli. Si tu peux passer
> en v11 sans trop de problème, vas-y, ça vaut vraiment le coup. Si tu
> n'as pas de sous-table et autres vieilles joyeusetés, les migrations
> devraient se passer sans problème. (mais il est préférable de migrer
> version par version, ce qui est faisable avec les versions démo)

Merci pour toutes ces précisions, quant tu dis 4D v11 tu parles bien de
4D v11 SQL ?



Oui.

La première Base date de la V2 et la 2ème de la V3 ( de mémoire )...
Et quelques sous-fiches ( a l'époque ) subsistent, de mémoire on nous
avait soutenu que ça serait maintenu...



Heu... Ca a été soutenu pendant près de 20 ans tout de même... Et lors
de la migration en v11, il convertit les sous tables si il n'y a qu'un
seul niveau de sous-table...

Le problème est pas de savoir si ça marcherait avec Léopard en utilisant
la V11. Mais si je migre Leopard est-ce que mes 2 bases en 6.8.5
fonctionneront ?



Comme je te l'ai dit, je n'ai pas testé. Je sais que la 6.8 se lance,
mais, connaissant 4d, tu risques d'avoir des surprises sur le
comportement de certaines fenêtres ou de dialogues d'impressions... Ca a
tout de même pas mal bougé depuis la 6.8...

--
Anonyme ( jayce <@> mosx.org )
********* MosX.org Ce message est sous licence Creative Commons "by-nc-sa-2.0"
Gilles
Le #16462491
Anonyme a écrit :

Comme je te l'ai dit, je n'ai pas testé. Je sais que la 6.8 se lance,
mais, connaissant 4d, tu risques d'avoir des surprises sur le
comportement de certaines fenêtres ou de dialogues d'impressions... Ca a
tout de même pas mal bougé depuis la 6.8...



J'ai qqs petits trucs, mais rien de bien méchant, par exemple l'ordre de
saisie qui se positionne sur une zone non saisissable, les combobox qui
s'ouvrent en fermant la palette...

En fait il faut que je fasse un essai sur une machine en Léopard, a la
rentré le HP de ma fille devrait être repris ( 4 retours SAV ) et elle
devrait passer au Mac...

Le problème avec Leopard c'est que je ne parviens pas a l'installer sur
un disque externe, donc difficile de faire un test...

Remarques si t'avais pu essayer ?

En tous cas merci, et il n'y a aucune urgence...

--
La jeunesse c'est le temps d'étudier la sagesse et la vieillesse c'est
le temps de la pratiquer. (Jean-Jacques ROUSSEAU)
Anonyme
Le #16479531
Gilles
Anonyme a écrit :

> Comme je te l'ai dit, je n'ai pas testé. Je sais que la 6.8 se lance,
> mais, connaissant 4d, tu risques d'avoir des surprises sur le
> comportement de certaines fenêtres ou de dialogues d'impressions... Ca a
> tout de même pas mal bougé depuis la 6.8...

J'ai qqs petits trucs, mais rien de bien méchant, par exemple l'ordre de
saisie qui se positionne sur une zone non saisissable, les combobox qui
s'ouvrent en fermant la palette...



Arf, tu as essayé 4D Tools avec la fonction de regénération des
formulaires ? (quoique, je ne suis pas sûr que l'option soit présente en
6.8)

En fait il faut que je fasse un essai sur une machine en Léopard, a la
rentré le HP de ma fille devrait être repris ( 4 retours SAV ) et elle
devrait passer au Mac...



Bonne nouvelle.

Le problème avec Leopard c'est que je ne parviens pas a l'installer sur
un disque externe, donc difficile de faire un test...



???? Il n'y a aucun soucis pour installer Leopard sur n'importe quel
disque...

Remarques si t'avais pu essayer ?

En tous cas merci, et il n'y a aucune urgence...



Je veux bien essayer, mais essayer quoi ? Si tu as encore plus de
problème qu'actuellement ? Je peux t'assurer que oui. :-)
Si les problèmes sont gênant ou pas ? Toi seul peut le dire.
Si il vaut mieux faire l'effort de migrer vers une 2004, voir même v11 ?
Je te l'assure... :-)

--
Anonyme ( jayce <@> mosx.org )
********* MosX.org Ce message est sous licence Creative Commons "by-nc-sa-2.0"
Roaringriri
Le #16479771
Anonyme a écrit :
Gilles
Anonyme a écrit :

Comme je te l'ai dit, je n'ai pas testé. Je sais que la 6.8 se lance,
mais, connaissant 4d, tu risques d'avoir des surprises sur le
comportement de certaines fenêtres ou de dialogues d'impressions... Ca a
tout de même pas mal bougé depuis la 6.8...


J'ai qqs petits trucs, mais rien de bien méchant, par exemple l'ordre de
saisie qui se positionne sur une zone non saisissable, les combobox qui
s'ouvrent en fermant la palette...



Arf, tu as essayé 4D Tools avec la fonction de regénération des
formulaires ? (quoique, je ne suis pas sûr que l'option soit présente en
6.8)

En fait il faut que je fasse un essai sur une machine en Léopard, a la
rentré le HP de ma fille devrait être repris ( 4 retours SAV ) et elle
devrait passer au Mac...



Bonne nouvelle.

Le problème avec Leopard c'est que je ne parviens pas a l'installer sur
un disque externe, donc difficile de faire un test...



???? Il n'y a aucun soucis pour installer Leopard sur n'importe quel
disque...

Remarques si t'avais pu essayer ?

En tous cas merci, et il n'y a aucune urgence...



Je veux bien essayer, mais essayer quoi ? Si tu as encore plus de
problème qu'actuellement ? Je peux t'assurer que oui. :-)
Si les problèmes sont gênant ou pas ? Toi seul peut le dire.
Si il vaut mieux faire l'effort de migrer vers une 2004, voir même v11 ?
Je te l'assure... :-)




Le problème c'est surtout les impressions.
On est en 2004.6, et un client fonctionne avec Léopard (pour 2 en X.4)
Et au passage sur leopard, plus une impression ne fonctionnait sur ce
poste. Ca m'a obligé de reprogrammer la base en réintroduisant partout
"Parametres impression", et tu peux dire adieu aux impressions multiples
automatiques, et au passage aussi aux impressions en Noir et Blanc,
quelque soit le réglage de la fenêtre du driver, il repasse
automatiquement en couleur. On est sur des imprimantes RICOH.
Passer en V11 suppose une reprogrammation importante, il ne tolère plus
les sous structures. La conversion fait une bonne partie du boulot, en
créant des fichier liés, mais pas tout.
De toute façon, la base d'origine à 20 ans et est passée par toutes les
cersions. Il faudra y passer, mais je suis loin de n'avoir que ça à
faire ça attendra.
Gilles
Le #16479831
d'abord merci a tous les deux

Roaringriri a écrit :
Anonyme a écrit :
Gilles
Anonyme a écrit :

Comme je te l'ai dit, je n'ai pas testé. Je sais que la 6.8 se lance,
mais, connaissant 4d, tu risques d'avoir des surprises sur le
comportement de certaines fenêtres ou de dialogues d'impressions...
Ca a
tout de même pas mal bougé depuis la 6.8...


J'ai qqs petits trucs, mais rien de bien méchant, par exemple l'ordre de
saisie qui se positionne sur une zone non saisissable, les combobox qui
s'ouvrent en fermant la palette...



Arf, tu as essayé 4D Tools avec la fonction de regénération des
formulaires ? (quoique, je ne suis pas sûr que l'option soit présente en
6.8)





Je regarde ça, mais j'ai contourné en rendant la zone saisissable, et en
la replaçant bien après dans l'ordre de saisie, en fait ça me posait un
problème sur ce format qui restait utilisé pour une recherche, c'est
donc résolut...

Le problème avec Leopard c'est que je ne parviens pas a l'installer sur
un disque externe, donc difficile de faire un test...



???? Il n'y a aucun soucis pour installer Leopard sur n'importe quel
disque...





Ben si justement, mais là aussi résolut ( MacBidouille fut mon ami )...
Depuis le DVD directement ça ne marchait pas... et c'est expliqué, je
pense que ça ne concerne peut-être que quelques machines, je sais pas,
en plus après ce semblant d'installation le PBG4 ne boutait plus...

Du coup depuis ce post, j'ai remis ça sur le tapis et maintenant ça
baigne aussi bien le boot sur le PBG4, que sur le Disque externe...

Remarques si t'avais pu essayer ?

En tous cas merci, et il n'y a aucune urgence...



Je veux bien essayer, mais essayer quoi ? Si tu as encore plus de
problème qu'actuellement ? Je peux t'assurer que oui. :-)
Si les problèmes sont gênant ou pas ? Toi seul peut le dire.
Si il vaut mieux faire l'effort de migrer vers une 2004, voir même v11 ?
Je te l'assure... :-)





Ayant installé léopard sur un disque externe, je dois pouvoir me
débrouiller, les bugs sont mineurs, d'ailleurs a première vu ça semble
fonctionner... En tous cas je te remercie


Le problème c'est surtout les impressions.
On est en 2004.6, et un client fonctionne avec Léopard (pour 2 en X.4)
Et au passage sur leopard, plus une impression ne fonctionnait sur ce
poste. Ca m'a obligé de reprogrammer la base en réintroduisant partout
"Parametres impression"....



Je dois dire n'avoir rien de tout ça, et j'en suis a la 6.8.5... Il me
semble avoir eu des problèmes qui généralement se sont solutionnés en
bidouillant les formats concernés et les paramètres d'impression
correspondant... J'ai relativement peu d'impression depuis les formats,
mais par-contre des trucs assez complexes en passant par 4DWrite...

Quelques unes quant même avec des formats inclus dans des inclus,
j'étais jeune aussi...

Du coup je vais jeter un coup d'œil sur ce point avec léopard... et je
reposte a la suite au cas ou...

--
La jeunesse c'est le temps d'étudier la sagesse et la vieillesse c'est
le temps de la pratiquer. (Jean-Jacques ROUSSEAU)
Anonyme
Le #16480071
Roaringriri
Le problème c'est surtout les impressions.



Oui.

On est en 2004.6, et un client fonctionne avec Léopard (pour 2 en X.4)
Et au passage sur leopard, plus une impression ne fonctionnait sur ce
poste.



Enfin, d'un autre côté, la 2004.7rc3 est tout de même vraiment mieux.

Ca m'a obligé de reprogrammer la base en réintroduisant partout
"Parametres impression", et tu peux dire adieu aux impressions multiples
automatiques,



J'ai eu ça aussi. Mais même avant le passage à Leopard. Pas sur tous les
formulaires alors...
Pour les impressions multiples automatiques, il n'y a par contre aucun
problème. Je gère facilement mes trucs avec soit "parametres impression"
soit avec "UTILISER PARAMETRES IMPRESSION" suivi d'imprimer selection ou
imprimer enregistrement...

et au passage aussi aux impressions en Noir et Blanc,
quelque soit le réglage de la fenêtre du driver, il repasse
automatiquement en couleur. On est sur des imprimantes RICOH.



Je suis aussi en RICOH et je n'ai remarqué aucun problème. Les
paramètres choisis restent à priori correctement.

Passer en V11 suppose une reprogrammation importante, il ne tolère plus
les sous structures. La conversion fait une bonne partie du boulot, en
créant des fichier liés, mais pas tout.



A ben forcément, les sous-structures... Ca fait combien de temps aussi
que 4D dit qu'il faudrait les modifier... :-)
La conversion se comporte effectivement bien, mais uniquement avec les
sous-structure du niveau -1 uniquement.

De toute façon, la base d'origine à 20 ans et est passée par toutes les
cersions. Il faudra y passer, mais je suis loin de n'avoir que ça à
faire ça attendra.



Bon courage. Ceci dit, vu tout ce qu'apporte la v11 (aussi bien au
niveau perfs qu'au niveau des nouveautés dans l'interface, et encore
plus au niveau Client/Server), le mal est très vite récompensé.

--
Anonyme ( jayce <@> mosx.org )
********* MosX.org Ce message est sous licence Creative Commons "by-nc-sa-2.0"
Gilles
Le #16481331
Anonyme a écrit :

Passer en V11 suppose une reprogrammation importante, il ne tolère plus
les sous structures. La conversion fait une bonne partie du boulot, en
créant des fichier liés, mais pas tout.



A ben forcément, les sous-structures... Ca fait combien de temps aussi
que 4D dit qu'il faudrait les modifier... :-)
La conversion se comporte effectivement bien, mais uniquement avec les
sous-structure du niveau -1 uniquement.



Ce sont des sous-structures ou des fichiers inclus...
Mais avant la 6, qui fut LA version aboutie dans le principe, Laurent en
personne, en quête que qualité ( hé oui ! ) m'avais promis que ça
resterait ( mais sans évoluer ) comme beaucoup d'autres choses aussi...


De toute façon, la base d'origine à 20 ans et est passée par toutes les
cersions. Il faudra y passer, mais je suis loin de n'avoir que ça à
faire ça attendra.



Bon courage. Ceci dit, vu tout ce qu'apporte la v11 (aussi bien au
niveau perfs qu'au niveau des nouveautés dans l'interface, et encore
plus au niveau Client/Server), le mal est très vite récompensé.



Rapport Prix/utilisation ( pour moi ) non !! je n'en suis qu'a du
maintient ...


--
La jeunesse c'est le temps d'étudier la sagesse et la vieillesse c'est
le temps de la pratiquer. (Jean-Jacques ROUSSEAU)
Publicité
Poster une réponse
Anonyme