les accents après la lettre

Le
siger
Bonjour,

avec Opera (c'est bon avec IE) et XP, sur une page (accès privé,
désolé), je vois les lettres accentuées ainsi :

e` e´ i(suivi d'un carré) o (suivi d'un carré)

Si je copie le texte dans un éditeur de texte, ja vois la même chose,
sauf les 2 derniers :

e` e´ i¨ o^

Si je copie le texte de la page directement sur ce message, c'est bon :

è é ï ô

Affichage/encodage est sur "détection automatique". J'ai essayé les
autres d'Europe de l'Ouest et les UTF, c'est pire.

C'est un site fait avec Crabgrass (une sorte de wiki), je ne pense pas
que les auteurs aient accès à des paramètres de ce genre, mais je n'en
sais rien.

Comment faire pour voir la page normalement avec Opera ?

--
siger
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
rm
Le #23008831
Le Tue, 11 Jan 2011 10:29:32 +0100, siger
Bonjour,



Salut,

avec Opera (c'est bon avec IE) et XP, sur une page (accès privà ©,
désolé)



Ça ne va pas simplifier la compréhension...

je vois les lettres accentuées ainsi :

e` e´ i(suivi d'un carré) o (suivi d'un carré)

Si je copie le texte dans un éditeur de texte, ja vois la mê me chose,
sauf les 2 derniers :

e` e´ i¨ o^

Si je copie le texte de la page directement sur ce message, c'est bon :

è é ï ô



On peut pas avoir le code source de la page ? C'est top secret ?
Ou une copie d'écran ?
Ton Opera est configuré par complètement par défaut ou t' as cliquouillé
sur tout ce qui bouge ?
Quel affichage avec un Chrome ou un Firefox, à tout hasard ?

Affichage/encodage est sur "détection automatique". J'ai essayà © les
autres d'Europe de l'Ouest et les UTF, c'est pire.



Tu as quoi comme indication dans le panneau latéral d'info (pas aff iché
par défaut), rubrique "encodage" lorsque tu accèdes à la page avec un
Opera configuré complètement par défaut ?
As-tu essayé d'utiliser le mode d'affichage dit utilisateur (menu " O" >
Page > style) ou d'utiliser d'autres polices d'affichage en Préfà ©rences >
Avancées > Polices ? Voire un déguisement routinier d'Opera en IE/Firefox
via les préférences "par site" ?

C'est un site fait avec Crabgrass (une sorte de wiki), je ne pense pas
que les auteurs aient accès à des paramètres de ce genr e, mais je n'en
sais rien.



Je suis allé voir la démo sur le site de Crabgrass , rien vu d 'anormal...

Comment faire pour voir la page normalement avec Opera ?



Si le site est en accès restreint, ça sert pas à grand ch ose de remonter
un hypothétique bug, je pense...
Peut-être voir du coté des gestionnaires de ce site, des fois qu'ils
connaissent Opera et qui aient du temps à perdre à tester avec ;)

@+
--
rm - Utilisant le client NNTP d'Opera : http://www.opera.com/mail/
siger
Le #23009471
rm a écrit :

siger
avec Opera (c'est bon avec IE) et XP, sur une page (accès privé,
désolé) je vois les lettres accentuées ainsi :

e` e´ i(suivi d'un carré) o (suivi d'un carré)



On peut pas avoir le code source de la page ? C'est top secret ?



Tu veux des choses en particulier ?

pour info, je vois ça :
<!--[if IE 6]>
(...)
<!--[if IE 7]>

et aussi le mot "wiki" :
<div class='wiki'>
<div id='wiki_html'>

Ou une copie d'écran ?



fichier "normal" :
http://cjoint.com/?0blnxmrxBRK



Ton Opera est configuré par complètement par défaut ou t'as
cliquouillé sur tout ce qui bouge ?



J'ai personnalisé des choses, comme tout le monde :-), et comme je ne
sais pas ce qui peut provoquer ça, à part affichage/encodage, je ne
sais pas où regarder.

J'ai renommé les dossiers "operaopera" qu'on trouve dans "application
data" et "local setting" en "operaopera_old :

c'est pareil pour l'affichage du texte.



Quel affichage avec un Chrome ou un Firefox, à tout hasard ?



Je n'ai pas ça.



Tu as quoi comme indication dans le panneau latéral d'info (pas
affiché par défaut), rubrique "encodage" lorsque tu accèdes à la
page avec un Opera configuré complètement par défaut ?



Avec L'opera que j'ai actuellement, je vois :

Encodage du serveur (utilisé par Opera) : (rien)
Type MIME du serveur : text/html
Content-Type : application/xhtml+xml; charset=utf-8

J'ai renommé les dossiers "operaopera" qu'on trouve dans "application
data" et "local setting" en "operaopera_old

Avec Opera "par défaut" (selon ma description ci-dessus), 2
différences :

Encodage (utilisé par Opera) : utf-8 (utf-8)
Type MIME : text/html
Content-Type : application/xhtml+xml; charset=utf-8


As-tu essayé d'utiliser le mode d'affichage dit utilisateur (menu
"O" > Page > style)



C'est un peu différent : les trémas et accents circonflexes sont
toujours indiqués par un carré à la suite de la lettre, et les accents
graves et aigus sont cette fois au dessus de la lettre, mais plus
éloignés que d'habitude
fichier "perso" :
http://cjoint.com/?0blnxKWRVja


ou d'utiliser d'autres polices d'affichage en
Préférences > Avancées > Polices ? Voire un déguisement routinier
d'Opera en IE/Firefox via les préférences "par site" ?



J'ai changé "texte normal" qui était en verdana : j'ai mis arial. Mais
le texte d'origine ne change pas.

--
siger
Olivier Miakinen
Le #23011061
Bonjour,

Le 11/01/2011 10:29, siger a écrit :

avec Opera (c'est bon avec IE) et XP, sur une page (accès privé,
désolé), je vois les lettres accentuées ainsi :

e` e´ i(suivi d'un carré) o (suivi d'un carré)

Si je copie le texte dans un éditeur de texte, ja vois la même chose,
sauf les 2 derniers :

e` e´ i¨ o^

Si je copie le texte de la page directement sur ce message, c'est bon :

è é ï ô



J'imagine que les caractères accentués sont codés « décomposés ». En
principe ça devrait fonctionner, surtout si ça se recolle dans ton
nouvelleur (quoique je ne fasse pas si confiance que ça à un logiciel
qui a besoin de Mime-proxy pour traiter les accents). Peut-être y a-t-il
des caractères parasites.

Copie une partie (courte) du texte dans le cadre en haut à droite de
viens nous dire ce qui s'affiche dans le cadre en haut à gauche quand
tu cliques ailleurs.

Affichage/encodage est sur "détection automatique". J'ai essayé les
autres d'Europe de l'Ouest et les UTF, c'est pire.



Essaye IBM-850 / CP850, puis regarde la correspondance ici :

Ou bien essaye IBM-850 / CP850, puis envoie-nous une copie d'écran.

Cordialement,
--
Olivier Miakinen
siger
Le #23011211
Olivier Miakinen a écrit :

Le 11/01/2011 10:29, siger a écrit :
avec Opera (c'est bon avec IE) et XP, sur une page (accès privé,
désolé), je vois les lettres accentuées ainsi :

e` e´ i(suivi d'un carré) o (suivi d'un carré)




Copie une partie (courte) du texte dans le cadre en haut à droite
de
et viens nous dire ce qui s'affiche dans le cadre en haut à gauche
quand tu cliques ailleurs.



2011, la dernière crise en date

32 30 31 31 2C 20 6C 61 20 64 65 72 6E 69 65 300 72 65 20 63 72 69 73
65 20 65 6E 20 64 61 74 65


Affichage/encodage est sur "détection automatique". J'ai essayé
les autres d'Europe de l'Ouest et les UTF, c'est pire.




Essaye IBM-850 / CP850, puis regarde la correspondance ici :

Ou bien essaye IBM-850 / CP850, puis envoie-nous une copie
d'écran.



Je n'ai pas d'encodage IBM dans la liste.



--
siger
rm
Le #23011711
Le mardi 11 janvier 2011 à 13:38, siger a écrit :

rm a écrit :

siger


avec Opera (c'est bon avec IE) et XP, sur une page (accès privé,
désolé) je vois les lettres accentuées ainsi :

e` e´ i(suivi d'un carré) o (suivi d'un carré)





On peut pas avoir le code source de la page ? C'est top secret ?



Tu veux des choses en particulier ?

pour info, je vois ça :
<!--[if IE 6]>
(...)
<!--[if IE 7]>



C'est que le site a été testé "with difficulties" avec IE6 et IE7, c'est
déjà pas mal...

et aussi le mot "wiki" :
<div class='wiki'>
<div id='wiki_html'>



Bon ça c'est fait mais point d'accent là dedans...

Ou une copie d'écran ?



fichier "normal" :
http://cjoint.com/?0blnxmrxBRK



Ah oui, c'est vilain... jamais vu ça.

Ton Opera est configuré par complètement par défaut ou t'as
cliquouillé sur tout ce qui bouge ?



J'ai personnalisé des choses, comme tout le monde :-), et comme je ne
sais pas ce qui peut provoquer ça, à part affichage/encodage, je ne
sais pas où regarder.

J'ai renommé les dossiers "operaopera" qu'on trouve dans "application
data" et "local setting" en "operaopera_old :



Donc profil vierge après relance d'Opera, OK.

c'est pareil pour l'affichage du texte.



Donc ça ne vient pas d'une configuration bizarre d'Opera.

Quel affichage avec un Chrome ou un Firefox, à tout hasard ?



Je n'ai pas ça.



Très bien. Enfin, des fois ça peut aider, quand même, pour comparer ; parce
que IE, je sais pas trop si on peu lui faire confiance en terme de
précision de rendu. Si l'affichage est cohérent entre IE ET Firefox ET
Chrome (enfin trois moteurs de rendu différents) ça pourrait vouloir dire
qu'il pourrait y avoir un souci sur le moteur de rendu d'Opera (même si on
a déjà vu que c'était pas systématique) ;)

Tu as quoi comme indication dans le panneau latéral d'info (pas
affiché par défaut), rubrique "encodage" lorsque tu accèdes à la
page avec un Opera configuré complètement par défaut ?



Avec L'opera que j'ai actuellement, je vois :



Quelle version au fait. J'ai supposé la v.11...

Encodage du serveur (utilisé par Opera) : (rien)
Type MIME du serveur : text/html
Content-Type : application/xhtml+xml; charset=utf-8

J'ai renommé les dossiers "operaopera" qu'on trouve dans "application
data" et "local setting" en "operaopera_old

Avec Opera "par défaut" (selon ma description ci-dessus), 2
différences :

Encodage (utilisé par Opera) : utf-8 (utf-8)
Type MIME : text/html
Content-Type : application/xhtml+xml; charset=utf-8



Dans le code de la page y a-t-il une déclaration de charset style <meta
http-equiv="Content-Type" content="text/html; charset=UTF-8" /> ?
Avec Dragonfly (ou un sniffeur TCPIP), tu pourrais regarder si le charset
défini dans les en-têtes http pour le bout de html de cette page est
cohérent avec le meta de la page...
Les mots contenant des accents sont codés comment dans le code source de la
page ?

As-tu essayé d'utiliser le mode d'affichage dit utilisateur (menu
"O" > Page > style)



C'est un peu différent : les trémas et accents circonflexes sont
toujours indiqués par un carré à la suite de la lettre, et les accents
graves et aigus sont cette fois au dessus de la lettre, mais plus
éloignés que d'habitude
fichier "perso" :
http://cjoint.com/?0blnxKWRVja



Bizarre...
Tu as essayé de déguiser Opera en IE sur ce site mystère et de recharger la
page ?

ou d'utiliser d'autres polices d'affichage en
Préférences > Avancées > Polices ? Voire un déguisement routinier
d'Opera en IE/Firefox via les préférences "par site" ?



J'ai changé "texte normal" qui était en verdana : j'ai mis arial. Mais
le texte d'origine ne change pas.



Ok, tant pis.

Bon comme c'est pas fastoche de débuguer un problème sur un site non
public, je t'invite à soulever le problème auprès du gestionnaire de ce
site (qui n'a pas visiblement testé avec Opera 11). Lui seul pourra
analyser la situation et si il est certain que c'est un bug d'Opera, il
fera remonter via https://bugs.opera.com/wizard/ si il a le temps...

Si tu n'as pas envie de contacter le site, menu "Aide > Rapporter un
problème sur un site" avec url du site et des minuscules copies d'écran
réalisées par tes soins et coordonnées mail si possible du gestionnaire de
la page, en ajoutant "à l'attention de Monsieur Karl, Merci <:o) "

@+
--
rm
siger
Le #23011951
rm a écrit :

Quelle version au fait. J'ai supposé la v.11...



Oui, avec XP.


Dans le code de la page y a-t-il une déclaration de charset style
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"
/> ?



Il y a ça :

<meta http-equiv="Content-Type" content="application/xhtml+xml;
charset=utf-8" />



Avec Dragonfly (ou un sniffeur TCPIP), tu pourrais regarder
si le charset défini dans les en-têtes http pour le bout de html
de cette page est cohérent avec le meta de la page...



Heu, là je ne sais pas faire. Je peux me renseigner si besoin.


Les mots contenant des accents sont codés comment dans le code
source de la page ?



Là c'est encore différent, c'est une addition des 2 problèmes :
l'accent est après la lettre, comme "normal", et plus haut, comme
"perso". Et toujours les carrés pour les trémats et accents
circonflexes
"source" = http://cjoint.com/?0blwvuQKXaB


Tu as essayé de déguiser Opera en IE sur ce site mystère et de
recharger la page ?



J'ai tout essayé : "masqué" et "identifier", IE et Firefox, rien ne
change.

Je vais reporter le problème :-)

--
siger
Olivier Miakinen
Le #23012491
Le 11/01/2011 19:27, siger a écrit :

2011, la derni[è]re crise en date

32 30 31 31 2C 20 6C 61 20 64 65 72 6E 69 [65 300] 72 65 20 63 72 69 73
65 20 65 6E 20 64 61 74 65



C'est parfaitement valide : e + accent grave à chasse nulle. Si j'ai le
temps je te ferai une page de test pour ton rapport de bug.

--
Olivier Miakinen
Publicité
Suivre les réponses
Poster une réponse
Anonyme