adaptateur usb-parallel avec une imprimante

Le
Ben
Bonjour à tous,

J'ai un pc récent, ce qui veut dire sans port LPT, et une vieille
imprimante laser apple Laserwriter select 360 parallele.
J'ai donc acheté un adaptateur usb -> LPT. (en db25, pas en centronic),
et j'utilise l'adaptateur usb -> LPT avec un cable LPT -> centronic.
Sous windows, cela fonctionne, mais sous linux, que nenni, j'ai besoin
d'aide

config debian sid, noyau 2.6.25 (j'ai aussi essayé avec le 2.6.24, mais
même problème)

J'ai configuré l'imprimante avec lpadmin :
lpadmin -p Laser -v usb:/dev/usb/lp0 -P apple.ppd
pas d'erreur.
ensuite http://localhost:631 pour configurer cups
start, accept

réponse "Printer not connected; will retry in 30 seconds"

un lpinfo -v me retourne :
network socket
network beh
network http
network ipp
network lpd
direct parallel:/dev/lp0
direct scsi
network smb

et pas d'usb dans le lot

/usr/lib/cups/backend/usb ne me retourne rien

alors, les infos :

"lsusb" :
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 003: ID 1a86:7584
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

"lsusb -v" :

Bus 006 Device 003: ID 1a86:7584
Device Descriptor:
bLength 18
bDescriptorType 1
bcdUSB 1.10
bDeviceClass 0 (Defined at Interface level)
bDeviceSubClass 0
bDeviceProtocol 0
bMaxPacketSize0 8
idVendor 0x1a86
idProduct 0x7584
bcdDevice 2.52
iManufacturer 0
iProduct 2 USB2.0-Print
iSerial 0
bNumConfigurations 1
Configuration Descriptor:
bLength 9
bDescriptorType 2
wTotalLength 32
bNumInterfaces 1
bConfigurationValue 1
iConfiguration 0
bmAttributes 0x80
(Bus Powered)
MaxPower 96mA
Interface Descriptor:
bLength 9
bDescriptorType 4
bInterfaceNumber 0
bAlternateSetting 0
bNumEndpoints 2
bInterfaceClass 7 Printer
bInterfaceSubClass 1 Printer
bInterfaceProtocol 2 Bidirectional
iInterface 0
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x82 EP 2 IN
bmAttributes 2
Transfer Type Bulk
Synch Type None
Usage Type Data
wMaxPacketSize 0x0020 1x 32 bytes
bInterval 0
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x02 EP 2 OUT
bmAttributes 2
Transfer Type Bulk
Synch Type None
Usage Type Data
wMaxPacketSize 0x0020 1x 32 bytes
bInterval 0
Device Status: 0x0000
(Bus Powered)

dmesg | grep printer :
usblp0: USB Bidirectional printer dev 3 if 0 alt 0 proto 2 vid 0x1A86
pid 0x7584

lsmod | grep usb :
usblp 13664 0
usbcore 130032 5 usblp,ehci_hcd,uhci_hcd,ohci_hcd


Si vous aviez des idées, je suis preneur !!!

merci de votre patience, ce message est long ;)

Ben

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Ben
Le #9667881
Ben a écrit :
Bonjour à tous,

J'ai un pc récent, ce qui veut dire sans port LPT, et une vieille
imprimante laser apple Laserwriter select 360 parallele.
J'ai donc acheté un adaptateur usb -> LPT. (en db25, pas en
centronic), et j'utilise l'adaptateur usb -> LPT avec un cable LPT ->
centronic.
Sous windows, cela fonctionne, mais sous linux, que nenni, j'ai besoin
d'aide...

config debian sid, noyau 2.6.25 (j'ai aussi essayé avec le 2.6.24,
mais même problème...)

J'ai configuré l'imprimante avec lpadmin :
lpadmin -p Laser -v usb:/dev/usb/lp0 -P apple.ppd
pas d'erreur.
ensuite http://localhost:631 pour configurer cups
start, accept

réponse "Printer not connected; will retry in 30 seconds..."

un lpinfo -v me retourne :
network socket
network beh
network http
network ipp
network lpd
direct parallel:/dev/lp0
direct scsi
network smb

et pas d'usb dans le lot...

/usr/lib/cups/backend/usb ne me retourne rien...

alors, les infos :

"lsusb" :
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 003: ID 1a86:7584
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

"lsusb -v" :

Bus 006 Device 003: ID 1a86:7584
Device Descriptor:
bLength 18
bDescriptorType 1
bcdUSB 1.10
bDeviceClass 0 (Defined at Interface level)
bDeviceSubClass 0
bDeviceProtocol 0
bMaxPacketSize0 8
idVendor 0x1a86
idProduct 0x7584
bcdDevice 2.52
iManufacturer 0
iProduct 2 USB2.0-Print
iSerial 0
bNumConfigurations 1
Configuration Descriptor:
bLength 9
bDescriptorType 2
wTotalLength 32
bNumInterfaces 1
bConfigurationValue 1
iConfiguration 0
bmAttributes 0x80
(Bus Powered)
MaxPower 96mA
Interface Descriptor:
bLength 9
bDescriptorType 4
bInterfaceNumber 0
bAlternateSetting 0
bNumEndpoints 2
bInterfaceClass 7 Printer
bInterfaceSubClass 1 Printer
bInterfaceProtocol 2 Bidirectional
iInterface 0
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x82 EP 2 IN
bmAttributes 2
Transfer Type Bulk
Synch Type None
Usage Type Data
wMaxPacketSize 0x0020 1x 32 bytes
bInterval 0
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x02 EP 2 OUT
bmAttributes 2
Transfer Type Bulk
Synch Type None
Usage Type Data
wMaxPacketSize 0x0020 1x 32 bytes
bInterval 0
Device Status: 0x0000
(Bus Powered)

dmesg | grep printer :
usblp0: USB Bidirectional printer dev 3 if 0 alt 0 proto 2 vid 0x1A86
pid 0x7584

lsmod | grep usb :
usblp 13664 0
usbcore 130032 5 usblp,ehci_hcd,uhci_hcd,ohci_hcd


Si vous aviez des idées, je suis preneur !!!

merci de votre patience, ce message est long ;)

Ben




Et pour info, un
echo 'test' > /dev/usb/lp0 m'imprime bien une page avec test ;)

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Jean-Michel OLTRA
Le #9667861
Bonjour,


Le mardi 27 mai 2008, Ben a écrit...


réponse "Printer not connected; will retry in 30 seconds..."

un lpinfo -v me retourne :
network socket
network beh
network http
network ipp
network lpd
direct parallel:/dev/lp0
direct scsi
network smb

et pas d'usb dans le lot...



dpkg-reconfigure cupsys

Puis tu coches le port usb dans la liste (on coche quand on est sous
dialog, bien sûr) pour le rajouter. J'ai fait ça il n'y a pas longtemps,
avec une imprimante…série !

--
jm

A.E.L. Sarl (R.C.S CASTRES 490843240)
http://www.spidboutic.fr


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Ben
Le #9667751
Jean-Michel OLTRA a écrit :
Bonjour,


Le mardi 27 mai 2008, Ben a écrit...



réponse "Printer not connected; will retry in 30 seconds..."

un lpinfo -v me retourne :
network socket
network beh
network http
network ipp
network lpd
direct parallel:/dev/lp0
direct scsi
network smb

et pas d'usb dans le lot...




dpkg-reconfigure cupsys

Puis tu coches le port usb dans la liste (on coche quand on est sous
dialog, bien sûr) pour le rajouter. J'ai fait ça il n'y a pas longtemps,
avec une imprimante…série !




Merci pour ta réponse,

j'ai essayé, et l'usb est déjà coché, même problème...

Ben

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Alain Vaugham
Le #9665711
--nextPart6126638.bzfnJTOjF2
Content-Type: text/plain;
charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Le mardi 27 mai 2008 20:56, Ben a écrit :
| Et pour info, un
| echo 'test' > /dev/usb/lp0 m'imprime bien une page avec test ;)

Donc ce n'est pas un problème de câblage.
Le problème est plus haut dans les couches.

Une suggestion :
Vu le temps à passer sur ce problème ainsi que le prix des cartes, ne
serait-il pas envisageable d'installer la carte Centronics qui manque sur l e
bus PCI de la carte mère?

Désolé pour l'absence d'autres solutions concrètes...

--
Cordialement

Alain Vaugham
--------------------------------------------------------
[PUB] Signature numérique GPG de ce courrier: 0xD26D18BC

--nextPart6126638.bzfnJTOjF2
Content-Type: application/pgp-signature

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQBIQDmxlMPLZNJtGLwRAqxFAJ9rKEwMxifwajmtGfIHWRAKLbe5LQCfaeZ6
nby62Ppqpna5oOCyDj9ixYo =cGVx
-----END PGP SIGNATURE-----

--nextPart6126638.bzfnJTOjF2--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Ben
Le #9665511
Alain Vaugham a écrit :
Le mardi 27 mai 2008 20:56, Ben a écrit :
| Et pour info, un
| echo 'test' > /dev/usb/lp0 m'imprime bien une page avec test ;)

Donc ce n'est pas un problème de câblage.
Le problème est plus haut dans les couches.

Une suggestion :
Vu le temps à passer sur ce problème ainsi que le prix des cartes, ne
serait-il pas envisageable d'installer la carte Centronics qui manque sur le
bus PCI de la carte mère?

Désolé pour l'absence d'autres solutions concrètes...




Merci beaucoup pour ta réponse, mais j'aurai bien aimé réussir à le
faire fonctionner, car cette solution va aussi me servir pour un
ordinateur portable (qui est juste connecté à internet, et n'a pas de
serveur sous la main...)

merci pour la propale en tout cas.

Ben

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme