Addition dans une colonne

Le
Mathieu
Bonjour,

Ca ne va pas aujourd'hui,
j'ai une colonne avec des 1 et des blancs
du type:
1
bl
1
1
bl
bl
bl
1
1
1
après chaque série de 1 j'en voudrai le total soit en dessous soit dans la
colonne à coté.
La fonction sous total ne fonctionne pas pour mon problème, (Excel 2003)
Vous allez me dire que je peux le faire manuellement mais cette colonne
contient 30.000 lignes
Si quelqu'un peut m'aider, un grand merci.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Francois L
Le #18475341
Mathieu a écrit :

Bonjour,

Une solution sans macro, dans la colonne d'à coté.
On suppose la colonne de 1 et de blancs en A à partir de la ligne 1.

En B2, la formule sera :
=SI(A2<>1;SOMME($A$1:A1)-SOMME($B$1:B1);"")

à étirer aussi bas que nécessaire.

--
François L


Bonjour,

Ca ne va pas aujourd'hui,
j'ai une colonne avec des 1 et des blancs
du type:
1
bl
1
1
bl
bl
bl
1
1
1
après chaque série de 1 j'en voudrai le total soit en dessous soit dans
la colonne à coté.
La fonction sous total ne fonctionne pas pour mon problème, (Excel 2003)
Vous allez me dire que je peux le faire manuellement mais cette colonne
contient 30.000 lignes
Si quelqu'un peut m'aider, un grand merci.






Mathieu
Le #18475311
Un grand merci pour cette réponse qui me tire d'un mauvais pas.
bon dimanche.
R.Mathieu

"Francois L" de groupe de discussion :
Mathieu a écrit :

Bonjour,

Une solution sans macro, dans la colonne d'à coté.
On suppose la colonne de 1 et de blancs en A à partir de la ligne 1.

En B2, la formule sera :
=SI(A2<>1;SOMME($A$1:A1)-SOMME($B$1:B1);"")

à étirer aussi bas que nécessaire.

--
François L


Bonjour,

Ca ne va pas aujourd'hui,
j'ai une colonne avec des 1 et des blancs
du type:
1
bl
1
1
bl
bl
bl
1
1
1
après chaque série de 1 j'en voudrai le total soit en dessous soit dans
la colonne à coté.
La fonction sous total ne fonctionne pas pour mon problème, (Excel 2003)
Vous allez me dire que je peux le faire manuellement mais cette colonne
contient 30.000 lignes
Si quelqu'un peut m'aider, un grand merci.








Publicité
Poster une réponse
Anonyme