Additionner en fonction des listes déroulante

Le
Pascal
Bonjour à tous.

Je vais essayer d'être clair:
En colonne A un nombre.
En colonne B, une marque de voiture issue d'une liste déroulante.
En colonne C, une couleur de voiture issue d'une liste déroulante.
En colonne D, Le département d'immatriculation de la voiture issue d'une
liste déroulante.

Je remplis ce tableau au gré de mes rencontres (J'ai des joies simples)
Comment faire pour obtenir la somme de Peugeot rouges immatriculées dans
le 29, de Renault vertes immatriculées dans le 05 etc, etc, en fin
de tableau ?????
Merci de vos réponses.

Pascal
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #6756931
Bonjour,

=SOMMEPROD((B2:B10="peugeot")*(C2:C10="vert")*(D2:D10));A2:A10)

JB
http://boisgontierjacques.free.fr

On 2 juin, 07:44, Pascal
Bonjour à tous.

Je vais essayer d'être clair:
En colonne A un nombre.
En colonne B, une marque de voiture issue d'une liste déroulante.
En colonne C, une couleur de voiture issue d'une liste déroulante.
En colonne D, Le département d'immatriculation de la voiture issue d'une
liste déroulante.

Je remplis ce tableau au gré de mes rencontres (J'ai des joies simples.. .)
Comment faire pour obtenir la somme de Peugeot rouges immatriculées dans
le 29, de Renault vertes immatriculées dans le 05 ... etc, etc,  en fi n
de tableau ?????
Merci de vos réponses.

Pascal


LSteph
Le #6756921
Bonjour,


...donc le sommeprod (multicritère)* qui sert à faire l'opération
impose de spécifier chaque critère que tu voudrais additionner

sachant que tu dois lister l'existence de ceux-ci
tu peux soit combiner avec en préalable un filtre élaboré sur les deux
colonnes (marque et couleur dans ton exemple) extraction sans doublons.

ou bien un autre moyen plus directement faire un tcd.

Cordialement.

--
lSteph
*(deux ou trois fils ce même dimanche)


Bonjour à tous.

Je vais essayer d'être clair:
En colonne A un nombre.
En colonne B, une marque de voiture issue d'une liste déroulante.
En colonne C, une couleur de voiture issue d'une liste déroulante.
En colonne D, Le département d'immatriculation de la voiture issue d'une
liste déroulante.

Je remplis ce tableau au gré de mes rencontres (J'ai des joies simples...)
Comment faire pour obtenir la somme de Peugeot rouges immatriculées dans
le 29, de Renault vertes immatriculées dans le 05 ... etc, etc, en fin
de tableau ?????
Merci de vos réponses.

Pascal


Publicité
Poster une réponse
Anonyme