affichage google map api

Le
arnaud.pomart
Bonjour,
Je travail actuellement sur l'integration d'une carte google map pour
le site de ma boite
j'ai repris le code de l'ancien site qui intégrait deja l'api, et qui
fonctionnait très bien
le contenu de la page reste inchangée d'ailleur

cette page est en fait une iframe qui irécupère les données d'un
formulaire présent dans la page contenant l'iframe
je construit donc ma requete en interrogeant ma bas de donnée, puis
j'affiche une carte et une liste d'elements
je cache en premier lieu la carte et un bouton permet de switcher
entre la carte et la liste
chacun des elements de la liste crée un marqueur (un point sur la
carte)
ceux-ci s'affichent tous correctement partout
aucun probleme a ce niveau là


mon problème : lorsque je charge la page (sans aucun critère de
restriction dans le formulaire donc), la carte s'affiche correctement
sous IE et mozilla
pas sous chrome (le navigateur de google), ni netscape, ni safari
ni opera
par contre, dès que je restreint ma recherche a l'aide du formulaire
(ou au moyen de variables de sessions), la carte s'affiche
correctement sous IE
mais plus sous aucun autre
seul le coin haut-gauche de la carte est visible sous les autres
navigateurs

J'ai tester plusieursde solution, je chargais au depart la carte
directement dans le code html (dans le body, a l'aide de balise
script), marchais pas
j'ai donc fais une fonction de chargement, ça a eu le mérite de faire
fonctionner l'affichage sous IE (ce qui n'etais pas le cas au debut)
J'ai inspecter tous le code généré une dizaine de fois car j'ai vu su=
r
un forum que le probleme venait surement d'une balise non fermer
nada, aucune erreur la non plus
J'ai desactivé tous mes modules complémentaires, que dal, j'ai vu
plusieurs fois que le probleme pouvait venir de skype je l'ai pas :
(

et ce n'est pas non plus un probleme de cache, j'ai beau le vider ça
change absolument rien

je suis perdu là help !
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
arnaud.pomart
Le #16755851
problème règlé, merci quand meme
Th.A.C
Le #16758561
a écrit :
problème règlé, merci quand meme



ce newsgroup n'est pas vraiment orienté programmation et espérer avoir
une réponse en moins d'une heure sur un newsgroup (qui est non
commercial, je te le rappelle) relève un peu de l'utopie ou de la chance

Par contre, ta solution pourrait servir à d'autre si tu voulais la
partager (c'est d'ailleurs un des principes des newsgroups: partager) :-)
Publicité
Poster une réponse
Anonyme