affichage incomplet, selon le navigateur

Le
docanski
Bonjour

En cause, cette page :
http://mycorance.free.fr/forum/viewtopic.php?pid#p10
où j'obtiens un affichage complet du *premier message*, en ce compris
deux smileys et le dernier paragraphe qui est le suivant :

> Fichier(s) joint(s): (Prév. pr fichiers images)
> Attachment Icon morille.jpg, Taille: 43,063 bytes, Téléchargements: 0

sous K-Meleon uniquement. Sous Firefox en Win2k ou en Ubuntu, malgré
plusieurs rafraîchissements, ce dernier paragraphe (créé par un include
via un script PHP) n'apparaît pas, ni les smileys !
Sous MSIE 6.x, les smileys apparaissent mais pas le dernier paragraphe !
Comment se fesse ?
Problème de script, de serveur ou de navigateur ?
Quelle solution ?

Cordialement,
--
docanski
Portail et annuaire du nord-Bretagne : http://armorance.free.fr/
Guide des champignons d'Europe : http://mycorance.free.fr/
La vallée de la Rance maritime : http://valderance.free.fr/
Les côtes du nord de la Bretagne : http://docarmor.free.fr/
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
BertrandB
Le #1869357
Bonjour

En cause, cette page :
http://mycorance.free.fr/forum/viewtopic.php?pid#p10
où j'obtiens un affichage complet du *premier message*, en ce compris
deux smileys et le dernier paragraphe qui est le suivant :

Fichier(s) joint(s): (Prév. pr fichiers images)
Attachment Icon morille.jpg, Taille: 43,063 bytes, Téléchargements: 0


sous K-Meleon uniquement. Sous Firefox en Win2k ou en Ubuntu, malgré
plusieurs rafraîchissements, ce dernier paragraphe (créé par un include
via un script PHP) n'apparaît pas, ni les smileys !
Sous MSIE 6.x, les smileys apparaissent mais pas le dernier paragraphe !
Comment se fesse ?
Problème de script, de serveur ou de navigateur ?
Quelle solution ?

Cordialement,
Ce n'est pas dans le source de la page reçu par le navigateur ... c'est

un problème dans le script PHP.
Je suppose que c'est un MOD punbb qui a été installé et qui ne
fonctionne pas ... repartir des sources originaux et réapliquer les mod
sinon -> punbb.fr


docanski
Le #1872697
Alors que les eleveurs et agriculteurs polluent toujours la Bretagne,
BertrandB nous narre ce qui suit en ce 26/03/2008 20:12 :

Ce n'est pas dans le source de la page reçu par le navigateur ... c'est
un problème dans le script PHP.


Aucun report de bug dans le forum PunBB à ce sujet, pourtant.
Par ailleurs j'ai déjà remarqué à plusieurs reprises de sérieux
problèmes avec le serveur Free pour ce qui concerne le service php-sql
et même parfois pour quelque chose de très simple : l'affichage de
fichiers png, très aléatoire.
C'est pourquoi j'envisage aussi cette possibilité : problèmes serveur et
c'est pourquoi j'ai entamé cette discussion ici.
Peut-être y a-t'il des expériences similaires de la part des autres
contributeurs de ce groupe ?

... repartir des sources originaux et réapliquer les mod


Les sources n'ont pas été modifiées, simplement installées par le script
d'installation.
Contrôle fait en local sous EasyPHP :
- K-Meleon affiche correctement la totalité de la page (difficile
d'incriminer scripts, dans ce cas !)
- Firefox n'affiche pas les smileys mais affiche la partie "footer"
(comportant le lien du fichier joint et les liens permettant les réponses)
- MSIE 6.x *et* Opera 9.x affichent les smileys mais n'affichent pas du
tout la partie "footer"
Et c'est là que réside aussi le mystère : ces scripts existent depuis
2005, sont utilisés sur de nombreux forums et semblent pourtant poser
problème selon le navigateur utilisé, du moins chez moi :-(

Cordialement,
--
docanski

Portail et annuaire du nord-Bretagne : http://armorance.free.fr/
Guide des champignons d'Europe : http://mycorance.free.fr/
La vallée de la Rance maritime : http://valderance.free.fr/
Les côtes du nord de la Bretagne : http://docarmor.free.fr/

docanski
Le #1884576
Alors que les eleveurs et agriculteurs polluent toujours la Bretagne,
docanski nous narre ce qui suit en ce 26/03/2008 18:15 :
Bonjour
En cause, cette page :
http://mycorance.free.fr/forum/viewtopic.php?pid#p10
...

Problème de script, de serveur ou de navigateur ?


Après avoir vidé le cache, il semble bien que le problème vient du
script de post ou de celui de l'affichage de celui-ci.
Mais voilà ... je n'y entrave que dalle et le forum d'aide PunBB est
d'un silence assourdissant à ce sujet, après mon appel à l'aide sur
celui-ci :-(
Je fais donc appel aux cracks du coin ; ce serait sympa s'ils pouvaient
jeter un coup d'oeil sur les parties de ces scripts qui pourraient être
en cause. Les voici :

Partie du script "post.php" destiné à l'envoi du fichier attach :
-----------------------------------------------------------------------------

// If the posting user is logged in, increment his/her post count
if (!$pun_user['is_guest'])
{
$low_prio = ($db_type == 'mysql') ? 'LOW_PRIORITY ' : '';
$db->query('UPDATE '.$low_prio.$db->prefix.'users SET
num_posts=num_posts+1, last_post='.$now.' WHERE

id='.$pun_user['id']) or error('Unable to update user', __FILE__,
__LINE__, $db->error());
}
// Attachment Mod Block Start
if
(isset($_FILES['attached_file'])&&$_FILES['attached_file']['size']!=0&&is_uploaded_file($_FILES['attached_file']['tmp_name'])){
//fetch the rules for this forum for this group
$attach_result = $db->query('SELECT rules,size,file_ext FROM
'.$db->prefix.'attach_2_rules WHERE

group_id=''.$pun_user['g_id'].'' AND
forum_id=''.$cur_posting['id'].'' LIMIT 1')or error('Unable to fetch
attachment rules',__FILE__,__LINE__,$db->error());
if($db->num_rows($attach_result)!=0||$pun_user['g_id']==PUN_ADMIN){
$attach_rules=0; $attach_size=0; $attach_file_ext=''; // just some
defaults to get the parser to stop nagging me if

it's an admin :D
if($db->num_rows($attach_result)!=0)

list($attach_rules,$attach_size,$attach_file_ext)=$db->fetch_row($attach_result);
//check so that the user is allowed to upload


if(attach_allow_upload($attach_rules,$attach_size,$attach_file_ext,$_FILES['attached_file']['size'],$_FILES['attached_file']['name'])){
// ok we're allowed to post ... time to fix everything...


if(!attach_create_attachment($_FILES['attached_file']['name'],$_FILES['attached_file']['type'],$_FILES['attached_file']['size'],$_FILES['attached_file']['tmp_na

me'],$new_pid,count_chars($message))){
error('Error creating attachment, inform the owner of this
bulletin board of this problem. (Most

likely something to do with rights on the filesystem)',__FILE__,__LINE__);
}
}else{
// no output ... but if you want, enable this error (you really
shouldn't need to as this will only happen if

someone try to go around the restrictions
// error($lang_attach['Not allowed to post attachments']);
}
}else{
// no output ... but if you want, enable this error (you really
shouldn't need to as this will only happen if someone try

to go around the restrictions
// error($lang_attach['Not allowed to post attachments']);
}
}
// Attachment Mod Block End
redirect('viewtopic.php?pid='.$new_pid.'#p'.$new_pid, $lang_post['Post
redirect']);
}
}


Partie du script "viewtopic.php" destiné à l'affichage du message :
-----------------------------------------------------------------------------------

// Attachment Mod Block Start
$attach_allow_download = false;
$attach_output = '';
$attach_num = 0;
// Check if this post has any attachments
$result_attach = $db->query('SELECT af.id, af.filename, af.size,
af.downloads FROM '.$db->prefix.'attach_2_files AS af WHERE

af.post_id='.$cur_post['id']) or error('Unable to fetch if there were
any attachments to the post', __FILE__, __LINE__, $db->error());
$attach_num = $db->num_rows($result_attach);
if($attach_num > 0){
if($pun_user['g_id']==PUN_ADMIN)$attach_allow_download=true;
else{ //fetch the rules of the forum, and check so that the user is
allowed to download.
$result_attach_two = $db->query('SELECT ar.rules FROM
'.$db->prefix.'attach_2_rules AS ar WHERE

ar.group_id=''.$pun_user['group_id'].'' AND
ar.forum_id='.$cur_topic['forum_id'].' LIMIT 1')or error('Unable to
fetch rules for the attachments', __FILE__,

__LINE__, $db->error());
if($db->num_rows($result_attach_two)==1){
list($attach_rules)=$db->fetch_row($result_attach_two);
$attach_allow_download = attach_rules($attach_rules,ATTACH_DOWNLOAD);
}
}
if($attach_allow_download){//check if the user is allowed to download it.
$attach_output .= $lang_attach['Attachments:'].' ';
while(list($attachment_id, $attachment_filename, $attachment_size,

$attachment_downloads)=$db->fetch_row($result_attach)){
$attachment_extension=attach_get_extension($attachment_filename);
$attach_output .= '<br
/>'."ntttttt".attach_icon($attachment_extension).' <a

href="./attachment.php?item='.$attachment_id.'">'.$attachment_filename.'</a>,
'.$lang_attach['Size:'].' '.number_format($attachment_size).'

'.$lang_attach['bytes'].', '.$lang_attach['Downloads:'].'
'.number_format($attachment_downloads);
}
}
}
// Attachment Mod Block End

?>
<div id="p<?php echo $cur_post['id'] ?>" class="blockpost<?php echo
$vtbg ?><?php if (($post_count + $start_from) == 1) echo ' firstpost'; ?>">
<h2><span><span class="conr">#<?php echo ($start_from + $post_count)
?>&nbsp;</span><a href="viewtopic.php?pid=<?php echo

$cur_post['id'].'#p'.$cur_post['id'] ?>"><?php echo
format_time($cur_post['posted']) ?></a></span></h2>
<div class="box">
<div class="inbox">
<div class="postleft">
<dl>
<dt><strong><?php echo $username ?></strong></dt>
<dd class="usertitle"><strong><?php echo $user_title ?></strong></dd>
<dd class="postavatar"><?php echo $user_avatar ?></dd>
<?php if (count($user_info)) echo
"ttttt".implode(' <?php if (count($user_contacts)) echo "ttttt".'<dd
class="usercontacts">'.implode('&nbsp;&nbsp;',
$user_contacts).' </dl>
</div>
<div class="postright">
<h3><?php if (($post_count + $start_from) > 1) echo ' Re: '; ?><?php
echo

pun_htmlspecialchars($cur_topic['subject']) ?></h3>
<div class="postmsg">
<?php if ($cur_post['edited'] != '') echo "ttttt".'<p
class="postedit"><em>'.$lang_topic['Last edit'].'
'.pun_htmlspecialchars($cur_post['edited_by']).'

('.format_time($cur_post['edited']).') <?php if ($attach_allow_download) echo "ttttt".'<div
class="postsignature"> Attachment Mod row ?>
</div>
<?php if ($signature != '') echo "tttt".'<div
class="postsignature"> </div>
<div class="clearer"></div>
<div class="postfootleft"><?php if ($cur_post['poster_id'] > 1) echo
' <div class="postfootright"><?php echo (count($post_actions)) ?
'
$post_actions).' </div>
</div>
</div>

<?php

}

?>
<div class="postlinksb">
<div class="inbox">
<p class="postlink conr"><?php echo $post_link ?></p>
<p class="pagelink conl"><?php echo $paging_links ?></p>
?></a></li><li>&nbsp;&raquo;&nbsp;<a

href="viewforum.php?id=<?php echo $cur_topic['forum_id'] ?>"><?php echo
pun_htmlspecialchars($cur_topic['forum_name'])

?></a></li><li>&nbsp;&raquo;&nbsp;<?php echo
pun_htmlspecialchars($cur_topic['subject']) ?></li></ul>
<?php echo $subscraction ?>
</div>
</div>

Merci d'avance pour toute aide apportée à la correction de ce(s) script(s)!

Cordialement,
--
docanski

Portail et annuaire du nord-Bretagne : http://armorance.free.fr/
Guide des champignons d'Europe : http://mycorance.free.fr/
La vallée de la Rance maritime : http://valderance.free.fr/
Les côtes du nord de la Bretagne : http://docarmor.free.fr/

Christophe Meresse
Le #2117431
On 28 mar, 13:53, docanski
Alors que les eleveurs et agriculteurs polluent toujours la Bretagne,
docanski nous narre ce qui suit en ce 26/03/2008 18:15 :

Bonjour
En cause, cette page :
http://mycorance.free.fr/forum/viewtopic.php?pid#p10
...

Problème de script, de serveur ou de navigateur ?


Après avoir vidé le cache, il semble bien que le problème vient du
script de post ou de celui de l'affichage de celui-ci.
Mais voilà ... je n'y entrave que dalle et le forum d'aide PunBB est
d'un silence assourdissant à ce sujet, après mon appel à l'aide sur
celui-ci :-(
Je fais donc appel aux cracks du coin ; ce serait sympa s'ils pouvaient
jeter un coup d'oeil sur les parties de ces scripts qui pourraient être
en cause. Les voici :

Partie du script "post.php" destiné à l'envoi du fichier attach :
-----------------------------------------------------------------------------

// If the posting user is logged in, increment his/her post count
if (!$pun_user['is_guest'])


[...]

</div>
</div>

Merci d'avance pour toute aide apportée à la correction de ce(s) script(s)!


Salut,

J'ai installé K-Meleon pour voir concrètement le problème, je me suis
inscrit mais rien... Que ce soit dans K-Melon, IE6 ou Firefox, les
smiley sont là mais pas les lignes concernant les fichiers joints.
Et bien que je sois identifié j'ai toujours cette phrase qui apparait
au début de la page: "Les photos et fichiers joints ne peuvent être
affichés que par les membres qui se sont identifiés !"

Donc à mon avis le problème vient du test des droits de l'utilisateur
à propos des attachements dans le fichier viewtopic.php:

$result_attach_two = $db->query('SELECT
ar.rules FROM
'.$db->prefix.'attach_2_rules AS ar WHERE

ar.group_id=''.$pun_user['group_id'].'' AND
ar.forum_id='.$cur_topic['forum_id'].' LIMIT 1')or error('Unable to
fetch rules for the attachments', __FILE__,

__LINE__, $db->error());
if($db->num_rows($result_attach_two)==1){
list($attach_rules)=$db-
fetch_row($result_attach_two);
$attach_allow_download attach_rules($attach_rules,ATTACH_DOWNLOAD);

}

Pour une raison que j'ignore, je pense qu'aucun row n'est retourné par
la query ou que la fonction attach_rules renvoie false.
Je ne connais pas PunBB mais je suppose qu'il y a des règles à définir
à propos des groupes et des attachement d'après la query...

A+
Christophe


docanski
Le #2145781
Alors que les eleveurs et agriculteurs polluent toujours la Bretagne,
Christophe Meresse nous narre ce qui suit en ce 3/04/2008 15:01 :

Salut,


Yo !

J'ai installé K-Meleon pour voir concrètement le problème, je me suis
inscrit mais rien... Que ce soit dans K-Melon, IE6 ou Firefox, les
smiley sont là mais pas les lignes concernant les fichiers joints.


C'est incompréhensible : j'ai également créé un compte "membre" pour ne
plus avoir les droits d'administrateur afin de vérifier si c'était la
raison et je vois désormais (après petite correction de la semaine) ces
liens vers le fichier joint quand je suis identifié. Essai fait sous
Opera, MSIE, Firefox et K-Meleon.
Attention : il n'existe un tel lien que sur le premier message du forum
"Débats divers" !

Et bien que je sois identifié j'ai toujours cette phrase qui apparait
au début de la page: "Les photos et fichiers joints ne peuvent être
affichés que par les membres qui se sont identifiés !"


Ça, c'est normal : c'est une annonce qui apparaît sur toutes les pages
... en attendant que je puisse permettre l'affichage des liens à tous, y
compris aux non-membres.

Pour une raison que j'ignore, je pense qu'aucun row n'est retourné par
la query ou que la fonction attach_rules renvoie false.


As-tu vérifié le seul message comportant un lien, celui de "Débats divers" ?

Je ne connais pas PunBB mais je suppose qu'il y a des règles à définir
à propos des groupes et des attachement d'après la query...


Ces règles ont été paramétrées de façon à pouvoir être "uploadées" pour
les membres identifiés.
De ce côté-là, il ne doit donc pas y avoir de problème.
Merci en tout cas de t'intéresser à mon problème ... et de me confirmer
à propos de "Débats divers".

Cordialement,
--
docanski

Portail et annuaire du nord-Bretagne : http://armorance.free.fr/
Guide des champignons d'Europe : http://mycorance.free.fr/
La vallée de la Rance maritime : http://valderance.free.fr/
Les côtes du nord de la Bretagne : http://docarmor.free.fr/

docanski
Le #2154271
Alors que les eleveurs et agriculteurs polluent toujours la Bretagne,
docanski nous narre ce qui suit en ce 4/04/2008 0:08 :

C'est incompréhensible : j'ai également créé un compte "membre" pour ne
plus avoir les droits d'administrateur afin de vérifier si c'était la
raison et je vois désormais (après petite correction de la semaine) ces
liens vers le fichier joint quand je suis identifié. Essai fait sous
Opera, MSIE, Firefox et K-Meleon.
Attention : il n'existe un tel lien que sur le premier message du forum
"Débats divers" !


Ben non ! :-( Sans doute le cache qui m'a laissé des scories car après
vidage de celui-ci, je reviens à la case départ.

Je reprends donc avec les parties de code concernées :

Voici la partie de code de viewtopic.php (le fichier qui crée la page
affichée sur le forum) pour attachment :

// Attachment Mod Block Start
$attach_allow_download = false;
$attach_output = '';
$attach_num = 0;
// Check if this post has any attachments
$result_attach = $db->query('SELECT af.id, af.filename, af.size,
af.downloads FROM '.$db->prefix.'attach_2_files AS af WHERE
af.post_id='.$cur_post['id']) or error('Unable to fetch if there were
any attachments to the post', __FILE__, __LINE__, $db->error());
$attach_num = $db->num_rows($result_attach);
if($attach_num > 0){
if($pun_user['g_id']==PUN_ADMIN)$attach_allow_download=true;
else{ //fetch the rules of the forum, and check so that the user is
allowed to download.
$result_attach_two = $db->query('SELECT ar.rules FROM
'.$db->prefix.'attach_2_rules AS ar WHERE
ar.group_id=''.$pun_user['group_id'].'' AND
ar.forum_id='.$cur_topic['forum_id'].' LIMIT 1')or error('Unable to
fetch rules for the attachments', __FILE__, __LINE__, $db->error());
if($db->num_rows($result_attach_two)==1){
list($attach_rules)=$db->fetch_row($result_attach_two);
$attach_allow_download = attach_rules($attach_rules,ATTACH_DOWNLOAD);
}
}
if($attach_allow_download){//check if the user is allowed to download it.
$attach_output .= $lang_attach['Attachments:'].' ';
while(list($attachment_id, $attachment_filename, $attachment_size,
$attachment_downloads)=$db->fetch_row($result_attach)){
$attachment_extension=attach_get_extension($attachment_filename);
$attach_output .= '<br
/>'."ntttttt".attach_icon($attachment_extension).' <a
href="./attachment.php?item='.$attachment_id.'">'.$attachment_filename.'</a>,
'.$lang_attach['Size:'].' '.number_format($attachment_size).'
'.$lang_attach['bytes'].', '.$lang_attach['Downloads:'].'
'.number_format($attachment_downloads);
}
}
}
// Attachment Mod Block End
<div id="p<?php echo $cur_post['id'] ?>" class="blockpost<?php echo
$vtbg ?><?php if (($post_count + $start_from) == 1) echo ' firstpost'; ?>">
<h2><span><span class="conr">#<?php echo ($start_from + $post_count)
?>&nbsp;</span><a href="viewtopic.php?pid=<?php echo
$cur_post['id'].'#p'.$cur_post['id'] ?>"><?php echo

format_time($cur_post['posted']) ?></a></span></h2>
<div class="box">
<div class="inbox">
<div class="postleft">
<dl>
<dt><strong><?php echo $username ?></strong></dt>
<dd class="usertitle"><strong><?php echo $user_title ?></strong></dd>
<dd class="postavatar"><?php echo $user_avatar ?></dd>
<?php if (count($user_info)) echo
"ttttt".implode(' <?php if (count($user_contacts)) echo "ttttt".'<dd
class="usercontacts">'.implode('&nbsp;&nbsp;',
$user_contacts).' </dl>
</div>
<div class="postright">
<h3><?php if (($post_count + $start_from) > 1) echo ' Re: '; ?><?php
echo pun_htmlspecialchars($cur_topic['subject']) ?></h3>
<div class="postmsg">
<?php if ($cur_post['edited'] != '') echo "ttttt".'<p
class="postedit"><em>'.$lang_topic['Last edit'].'
'.pun_htmlspecialchars($cur_post['edited_by']).'

('.format_time($cur_post['edited']).') <?php if ($attach_allow_download) echo "ttttt".'<div
class="postsignature"> Attachment Mod row ?>
</div>
<?php if ($signature != '') echo "tttt".'<div
class="postsignature"> </div>
<div class="clearer"></div>
<div class="postfootleft"><?php if ($cur_post['poster_id'] > 1) echo
' <div class="postfootright"><?php echo (count($post_actions)) ?
' $post_actions).'</li></ul></div>'."n" :

' </div>
</div>
</div>
---------------------------------------------------------------------

Voici le source du topic (page affichée en html, bien entendu) qui
comporte un fichier joint, vu par un membre :

<div class="postsignature"><hr />-- <br />Cordialement,<br
/><strong>docanski</strong></div>
------------------------------------------

Voici le source du topic qui comporte un fichier joint, vu par
l'administrateur :

<div class="postsignature"><hr />Fichier(s) joint(s): (<i>Prév. pr
fichiers images</i>) <br />
<img src="img/attach/image.png" width="15" height="15" alt="Attachment
Icon" />
Téléchargements: 1</div>
<div class="postsignature"><hr />-- <br />Cordialement,<br
/><strong>docanski</strong></div>
------------------------------------------

Pourtant, les permissions de download et upload sont accordées pour les
membres dans le module d'administration de ce "attachment", exactement
comme pour l'administrateur !

Merci d'avance pour toute aide !

Cordialement,
docanski
--
docanski

Portail et annuaire du nord-Bretagne : http://armorance.free.fr/
Guide des champignons d'Europe : http://mycorance.free.fr/
La vallée de la Rance maritime : http://valderance.free.fr/
Les côtes du nord de la Bretagne : http://docarmor.free.fr/

Christophe Meresse
Le #2193621
On 4 avr, 01:14, docanski
Alors que les eleveurs et agriculteurs polluent toujours la Bretagne,
docanski nous narre ce qui suit en ce 4/04/2008 0:08 :

C'est incompréhensible : j'ai également créé un compte "membre" pour ne
plus avoir les droits d'administrateur afin de vérifier si c'était la
raison et je vois désormais (après petite correction de la semaine) ces
liens vers le fichier joint quand je suis identifié. Essai fait sous
Opera, MSIE, Firefox et K-Meleon.
Attention : il n'existe un tel lien que sur le premier message du forum
"Débats divers" !


Ben non ! :-( Sans doute le cache qui m'a laissé des scories car après
vidage de celui-ci, je reviens à la case départ.


[...]

Pourtant, les permissions de download et upload sont accordées pour les
membres dans le module d'administration de ce "attachment", exactement
comme pour l'administrateur !

Merci d'avance pour toute aide !

Cordialement,
docanski
--
docanski

Portail et annuaire du nord-Bretagne :http://armorance.free.fr/
Guide des champignons d'Europe :http://mycorance.free.fr/
La vallée de la Rance maritime :http://valderance.free.fr/
Les côtes du nord de la Bretagne :http://docarmor.free.fr/


Bon, je crois qu'il faut commencer à faire un peu de débugage pour
comprendre ce qui se passe. Rajoute les lignes suivantes (// Ligne à
rajouter) dans le fichier viewtopic.php et poste nous ce qui sera
affiché en haut de ta page:

$result_attach = $db->query('SELECT af.id, af.filename,
af.size,
af.downloads FROM '.$db->prefix.'attach_2_files AS af WHERE
af.post_id='.$cur_post['id']) or error('Unable to fetch if there were
any attachments to the post', __FILE__, __LINE__, $db->error());
$attach_num = $db->num_rows($result_attach);

echo "attach_num: $attach_num<br />"; // Ligne à rajouter

if($attach_num > 0){
if($pun_user['g_id']==PUN_ADMIN)
$attach_allow_download=true;
else{ //fetch the rules of the forum, and
check so that the user is
allowed to download.
$result_attach_two = $db->query('SELECT
ar.rules FROM
'.$db->prefix.'attach_2_rules AS ar WHERE
ar.group_id=''.$pun_user['group_id'].'' AND
ar.forum_id='.$cur_topic['forum_id'].' LIMIT 1')or error('Unable to
fetch rules for the attachments', __FILE__, __LINE__, $db->error());

if($db->num_rows($result_attach_two)==1){

echo "result_attach_two contient quelquechose.<br />"; // Ligne à
rajouter

list($attach_rules)=$db-
fetch_row($result_attach_two);
$attach_allow_download attach_rules($attach_rules,ATTACH_DOWNLOAD);


echo "attach_allow_download: $attach_allow_download<br />"; //
Ligne à rajouter

}
}

---------

Christophe


docanski
Le #2246211
Alors que les eleveurs et agriculteurs polluent toujours la Bretagne,
Christophe Meresse nous narre ce qui suit en ce 4/04/2008 18:00 :

Bon, je crois qu'il faut commencer à faire un peu de débugage pour
comprendre ce qui se passe. Rajoute les lignes suivantes (// Ligne à
rajouter) dans le fichier viewtopic.php et poste nous ce qui sera
affiché en haut de ta page:


Je ne suis plus du tout certain qu'il y ait des erreurs dans ce script
mais plutôt dans celui des permissions et son plugin. En effet, j'ai
modifié à plusieurs reprises les permissions par l'interface
administrateur, d'abord en local, et me suis rendu compte qu'elles
n'étaient pas correctement prises en compte : L'édition de chaque
tableau de chaque forum n'est pas possible et il faut chaque fois
reparamétrer la totalité des permissions ... qui s'avèrent ne pas
toujours correspondre à ce qui était voulu par cette interface. J'ai
tenté de le faire ensuite en "farfouillant" dans la table MySQL
correspondante mais les ID des forums ne correspondent pas ... :-(.
A force de tenter et répéter des paramètrages à peu près correct sur le
forum distant, je suis arrivé à un résultat à peu près satisfaisant.
Mais c'est de l'empirique et pas parfaitement optimisé.
Les fichiers qui sont utilisés pour ce paramétrage sont un
admin_loader.php (3 ko) et son plugin AP_Fichiers_Joints.php (71 ko). Ce
dernier génère le menu administrateur et les interfaces permettant
d'accéder aux paramétrages. Quoique très bien commenté, je ne saurais
toutefois m'en sortir seul : je suis une nouille en PHP :-( et mettre
les mains dans un tel cambouis est donc plus que risqué.
Par ailleurs, publier la totalité de ces fichiers ici ne serait
certainement pas bien vu ...
Dès lors, je ne sais pas trop que faire sinon laisser venir avec le
paramétrage en place, d'autant que je n'obtiens aucune réponse sur le
forum de PunBB : le développeur de ce "mod" ne l'a plus mis à jour
depuis 2005 et ne contribue d'ailleurs pas dans ce forum dédié.
Si jamais tu te sentais d'attaque ... mais je ne voudrais pas abuser de
ta bonne volonté.
Merci, en tout cas, pour tes interventions !

Cordialement,
--
docanski

Portail et annuaire du nord-Bretagne : http://armorance.free.fr/
Guide des champignons d'Europe : http://mycorance.free.fr/
La vallée de la Rance maritime : http://valderance.free.fr/
Les côtes du nord de la Bretagne : http://docarmor.free.fr/

Christophe Meresse
Le #2470311
On 5 avr, 02:48, docanski
Alors que les eleveurs et agriculteurs polluent toujours la Bretagne,
Christophe Meresse nous narre ce qui suit en ce 4/04/2008 18:00 :

Bon, je crois qu'il faut commencer à faire un peu de débugage pour
comprendre ce qui se passe. Rajoute les lignes suivantes (// Ligne à
rajouter) dans le fichier viewtopic.php et poste nous ce qui sera
affiché en haut de ta page:


Je ne suis plus du tout certain qu'il y ait des erreurs dans ce script
mais plutôt dans celui des permissions et son plugin.


[...]

Par ailleurs, publier la totalité de ces fichiers ici ne serait
certainement pas bien vu ...
Dès lors, je ne sais pas trop que faire sinon laisser venir avec le
paramétrage en place, d'autant que je n'obtiens aucune réponse sur le
forum de PunBB : le développeur de ce "mod" ne l'a plus mis à jour
depuis 2005 et ne contribue d'ailleurs pas dans ce forum dédié.
Si jamais tu te sentais d'attaque ... mais je ne voudrais pas abuser de
ta bonne volonté.


Hello,

Pour ne pas que tu attendes dans le vide, je préfère te prévenir que
je n'aurais pas le temps d'étudier ce module.
Essayer de répondre à des questions ciblées je peux, mais me plonger
dans un gros module sans un diagnostic bien précis du problème... j'ai
aussi des développements perso en cours et des problème de
configuration ubuntu qui m'attendent ;)

Merci, en tout cas, pour tes interventions !


Bon courage
Christophe

Cordialement,
--
docanski



docanski
Le #2479231
Alors que les eleveurs et agriculteurs polluent toujours la Bretagne,
Christophe Meresse nous narre ce qui suit en ce 7/04/2008 19:13 :

Hello,


Olé !

Pour ne pas que tu attendes dans le vide, je préfère te prévenir que
je n'aurais pas le temps d'étudier ce module.


Pas de problème, tu en as déjà beaucoup fait ! ;-)

Essayer de répondre à des questions ciblées je peux,


Je te demanderai encore un petit service, alors, car je finis par avoir
des doutes sur l'affichage des différents navigateurs avec lesquels je
teste et leur faculté à vider leur cache. En effet, j'ai fait quelques
modifs qui, de mon poste, semblent produire un meilleur résultat.
Ce service consisterait à vérifier (puisque tu t'es abonné) si les liens
des photos publiées par "jipidoc" sont bien visibles pour toi quand tu
es en ligne et quand tu es simple visiteur. D'ici, avec Opera, MSIE,
Firefox et K-Meleon, j'ai un affichage de ces liens, aussi bien en
"administrateur" qu'en simple "invité". Il me faudrait donc un "membre"
pour vérifier si ces liens sont visibles par tout le monde.

Merci, en tout cas, pour tes interventions !



Que je réitère !

Cordialement,
--
docanski

Portail et annuaire du nord-Bretagne : http://armorance.free.fr/
Guide des champignons d'Europe : http://mycorance.free.fr/
La vallée de la Rance maritime : http://valderance.free.fr/
Les côtes du nord de la Bretagne : http://docarmor.free.fr/


Publicité
Poster une réponse
Anonyme