Affichage du zéro

Le
Jacques
Bonjour,

Via les options on peut demander d'afficher ou non les zéros.

Mon problème est le suivant :

Le zéro doit uniquement s'afficher si l'utilisateur saisit un zéro !

Par exemple, la cellule C3 = A3 + B3. Même si les cellules A3 et B3 sont
vides, un zéro apparait dans la cellule C3.
Comment empêcher l'affichage de ce zéro si l'utilisateur n'a pas saisi un
zéro dans la cellule A3 ou la cellule B3 ? Sans décocher l'option "Valeurs
zéro" dans les options de l'affichage !

Merci de vos réponses

Jacques
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Francois L
Le #16410491
Jacques a écrit :

Bonjour,

Sous réserve que A3 ET B3 ne contiennent pas de formule...
=SI(ET(ESTVIDE(A3);ESTVIDE(B3));"";A3+B3)

--
François L


Bonjour,

Via les options on peut demander d'afficher ou non les zéros.

Mon problème est le suivant :

Le zéro doit uniquement s'afficher si l'utilisateur saisit un zéro !

Par exemple, la cellule C3 = A3 + B3. Même si les cellules A3 et B3 sont
vides, un zéro apparait dans la cellule C3.
Comment empêcher l'affichage de ce zéro si l'utilisateur n'a pas saisi un
zéro dans la cellule A3 ou la cellule B3 ? Sans décocher l'option "Valeurs
zéro" dans les options de l'affichage !

Merci de vos réponses

Jacques







3
isabelle
Le #16410551
bonjour Jacques,

avec une condition ajouté à la formule,

de facon général :
=SI(formule=0;"";formule)

et selon ton exemple :
=SI(A3+B3=0;"";A3+B3)

isabelle


Jacques a écrit :
Bonjour,

Via les options on peut demander d'afficher ou non les zéros.

Mon problème est le suivant :

Le zéro doit uniquement s'afficher si l'utilisateur saisit un zéro !

Par exemple, la cellule C3 = A3 + B3. Même si les cellules A3 et B3 sont
vides, un zéro apparait dans la cellule C3.
Comment empêcher l'affichage de ce zéro si l'utilisateur n'a pas saisi un
zéro dans la cellule A3 ou la cellule B3 ? Sans décocher l'option "Valeurs
zéro" dans les options de l'affichage !

Merci de vos réponses

Jacques






Jacques
Le #16411341
C'est parfait.

Merci


"Francois L" de news:
Jacques a écrit :

Bonjour,

Sous réserve que A3 ET B3 ne contiennent pas de formule...
=SI(ET(ESTVIDE(A3);ESTVIDE(B3));"";A3+B3)

--
François L


> Bonjour,
>
> Via les options on peut demander d'afficher ou non les zéros.
>
> Mon problème est le suivant :
>
> Le zéro doit uniquement s'afficher si l'utilisateur saisit un zéro !
>
> Par exemple, la cellule C3 = A3 + B3. Même si les cellules A3 et B3 sont
> vides, un zéro apparait dans la cellule C3.
> Comment empêcher l'affichage de ce zéro si l'utilisateur n'a pas saisi


un
> zéro dans la cellule A3 ou la cellule B3 ? Sans décocher l'option


"Valeurs
> zéro" dans les options de l'affichage !
>
> Merci de vos réponses
>
> Jacques
>
>
>
>

3


JB
Le #16411221
Bonsoir,

-Format/Cellule/Nombre/Perso
-0,00;-0,00;

http://boisgontierjacques.free.fr/pages_site/Formats.htm#CreationFormat

JB

On 25 juil, 16:48, "Jacques"
Bonjour,

Via les options on peut demander d'afficher ou non les zéros.

Mon problème est le suivant :

Le zéro doit uniquement s'afficher si l'utilisateur saisit un zéro !

Par exemple, la cellule C3 = A3 + B3. Même si les cellules A3 et B3 s ont
vides, un zéro apparait dans la cellule C3.
Comment empêcher l'affichage de ce zéro si l'utilisateur n'a pas sais i un
zéro dans la cellule A3 ou la cellule B3 ? Sans décocher l'option "Va leurs
zéro" dans les options de l'affichage !

Merci de vos réponses

Jacques


Jacques
Le #16428061
bonjour Francois,

Je n'ai pas fait attention à ta remarque "Sous réserve ..."

Justement j'ai utilisé ta formule pour calculer sur la ligne et ensuite
quand j'ai voulu utiliser cette meme formule pour faire le total sur une
colonne, j'ai une erreur !

si j'ai bien compris, c'est parce que le calcul se fait sur une chaine de
caractère ("")

Est-il possible de remédier à cela ?

Merci de ton aide


Jacques



"Francois L" de news:
Jacques a écrit :

Bonjour,

Sous réserve que A3 ET B3 ne contiennent pas de formule...
=SI(ET(ESTVIDE(A3);ESTVIDE(B3));"";A3+B3)

--
François L


> Bonjour,
>
> Via les options on peut demander d'afficher ou non les zéros.
>
> Mon problème est le suivant :
>
> Le zéro doit uniquement s'afficher si l'utilisateur saisit un zéro !
>
> Par exemple, la cellule C3 = A3 + B3. Même si les cellules A3 et B3 sont
> vides, un zéro apparait dans la cellule C3.
> Comment empêcher l'affichage de ce zéro si l'utilisateur n'a pas saisi


un
> zéro dans la cellule A3 ou la cellule B3 ? Sans décocher l'option


"Valeurs
> zéro" dans les options de l'affichage !
>
> Merci de vos réponses
>
> Jacques
>
>
>
>

3


Francois L
Le #16428051
Jacques a écrit :

Bonjour,

Pas compris le problème... peut-être la solution d'Isabelle (qui est
équivalente à la mienne mais moins "stricte") conviendrait mieux dans le
cas présent ou la solution format personnalisé de JB.

--
François L


bonjour Francois,

Je n'ai pas fait attention à ta remarque "Sous réserve ..."

Justement j'ai utilisé ta formule pour calculer sur la ligne et ensuite
quand j'ai voulu utiliser cette meme formule pour faire le total sur une
colonne, j'ai une erreur !

si j'ai bien compris, c'est parce que le calcul se fait sur une chaine de
caractère ("")

Est-il possible de remédier à cela ?

Merci de ton aide


Jacques



"Francois L" de news:
Jacques a écrit :

Bonjour,

Sous réserve que A3 ET B3 ne contiennent pas de formule...
=SI(ET(ESTVIDE(A3);ESTVIDE(B3));"";A3+B3)

--
François L


Bonjour,

Via les options on peut demander d'afficher ou non les zéros.

Mon problème est le suivant :

Le zéro doit uniquement s'afficher si l'utilisateur saisit un zéro !

Par exemple, la cellule C3 = A3 + B3. Même si les cellules A3 et B3 sont
vides, un zéro apparait dans la cellule C3.
Comment empêcher l'affichage de ce zéro si l'utilisateur n'a pas saisi




un
zéro dans la cellule A3 ou la cellule B3 ? Sans décocher l'option




"Valeurs
zéro" dans les options de l'affichage !

Merci de vos réponses

Jacques






3






Publicité
Poster une réponse
Anonyme