Afficher un texte selon une période de dates

Le
Apitos
Bonjour à tous,

Comment faire pour corriger les formules en colonne D et G et les faire ada=
pter au tableau des dates dans la feuille "Fériés" de tel façon a é=
crire cours ou examens ou rien ?

=SI(OU(JOURSEM($B12)=3;JOURSEM($B12)=4);"Cours";"")

http://www.cjoint.com/c/EGwlIxbOIh3

Merci d'avance.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 4
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
DanielCo
Le #26361001
Bonjour,
Tu peux expliquer un peu plus ? Il y a deux plages de dates sur
"Fériés".
Un ou plusieurs exemples sont les bienvenus.
Daniel


Bonjour à tous,

Comment faire pour corriger les formules en colonne D et G et les faire
adapter au tableau des dates dans la feuille "Fériés" de tel façon a écrire
cours ou examens ou rien ?

=SI(OU(JOURSEM($B12)=3;JOURSEM($B12)=4);"Cours";"")

http://www.cjoint.com/c/EGwlIxbOIh3

Merci d'avance.
Apitos
Le #26361009
Bonjour Daniel,

On devra tester si le jour en colonne B est un jour de "Cours" ou d'"Examen " ou un "Congé" par exemple, selon la période définie dans le tableau "A1:C4", sinon la colonne "Emargement" reste vide.

Il y a une seule plage "Fériés" définie comme suit : "=Fériés!$ L$2:$L$4"
DanielCo
Le #26361013
Matricielle en D12 :
=SIERREUR(INDEX(Tableau1[Occup];EQUIV(1;(B12>=Tableau1[Début])*(Feuil1!B12<=Tableau1[Fin])*ESTNA(EQUIV(B12;Fériés;0));0));"")
Daniel


Bonjour Daniel,

On devra tester si le jour en colonne B est un jour de "Cours" ou d'"Examen"
ou un "Congé" par exemple, selon la période définie dans le tableau "A1:C4",
sinon la colonne "Emargement" reste vide.

Il y a une seule plage "Fériés" définie comme suit : "=Fériés!$L$2:$L$4"
Apitos
Le #26361038
Merci pour la formule Daniel.

Seulement, j'aimerais intégrer la formule précédemment postée pour ne pas appliquer l'affichage du mot "Cours" que pour les Mardis et Mercredi s :

=SI(OU(JOURSEM($B12)=3;JOURSEM($B12)=4);"Cours";"")

http://www.cjoint.com/c/EGwuBXGZw78
Jacquouille
Le #26361041
Bonsoir
Peux-tu expliquer la manière de concevoir la date en B12?
ÚTE(G8;MOIS(1&G2);1)
C'est le 1&G2 pour faire le mois ..... que je ne comprends pas.
Merci et bonne soirée
Jacques.


Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"Apitos" a écrit dans le message de groupe de discussion :


Merci pour la formule Daniel.

Seulement, j'aimerais intégrer la formule précédemment postée pour ne pas
appliquer l'affichage du mot "Cours" que pour les Mardis et Mercredis :

=SI(OU(JOURSEM($B12)=3;JOURSEM($B12)=4);"Cours";"")

http://www.cjoint.com/c/EGwuBXGZw78


---
L'absence de virus dans ce courrier électronique a été vérifiée par le logiciel antivirus Avast.
http://www.avast.com
Apitos
Le #26361044
Bonsoir Jacquouille,

C'est le 1&G2 pour faire le mois ..... que je ne comprends pas.



C'est une astuce pour convertir en chiffre un mois écris en lettres.
Jacquouille
Le #26361045
Grand merci... mais chez moi, il affiche #nombre! lorsque j'utilise ce truc.
(-


Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"Apitos" a écrit dans le message de groupe de discussion :


Bonsoir Jacquouille,

C'est le 1&G2 pour faire le mois ..... que je ne comprends pas.



C'est une astuce pour convertir en chiffre un mois écris en lettres.


---
L'absence de virus dans ce courrier électronique a été vérifiée par le logiciel antivirus Avast.
http://www.avast.com
Apitos
Le #26361046
Grand merci... mais chez moi, il affiche #nombre! lorsque j'utilise ce truc.



Essayes ceci :

ÚTE(H8;MOIS(1&H2);1)
DanielCo
Le #26361063
=SI(($B12>=Fériés!$B$2)*($B12<=Fériés!$C$2)*ESTNA(EQUIV($B12;Fériés;0))*((JOURSEM($B12)=3)+(JOURSEM($B12)=4))=1;"Cours";"")&SIERREUR(INDEX(Fériés!$A$3:$A$4;EQUIV(1;($B12>=Fériés!$B$3:$B$4)*(Feuil1!$B12<=Fériés!$C$3:$C$4);0);1);"")
Daniel


Merci pour la formule Daniel.

Seulement, j'aimerais intégrer la formule précédemment postée pour ne pas
appliquer l'affichage du mot "Cours" que pour les Mardis et Mercredis :

=SI(OU(JOURSEM($B12)=3;JOURSEM($B12)=4);"Cours";"")

http://www.cjoint.com/c/EGwuBXGZw78
Apitos
Le #26361097
Bonjour,

Après teste, l'agent en D7 est affiché dans le tableau comme "Congé" pourtant il n'est pas en congé dans ce mois !

http://www.cjoint.com/c/EGxmiaZjp8m
Publicité
Poster une réponse
Anonyme