L'âge du capitaine

Le
DoMi
Bonjour,

Non, ce n'est pas l'âge du capitaine que je cherche, mais l'âge moyen
des adhérents de mon association.
J'ai une feuille sur laquelle j'ai un certain nombre d'informations
sur ces personnes, dont l'âge, calculé par rapport à la date de
naissance. J'ai une colonne où j'indique les anciens adhérents qui
réadhèrent.
Sur une feuille "Statistiques", je calcule le nombre d'hommes ayant
réadhéré avec la formule:
{=SOMME(('2012'!O2:O65536="M")*('2012'!U2:U65536="OK"))}
le sexe étant en colonne O et la réadhésion en colonne U par "OK"
Je calcule ainsi différents paramètres.
Je bloque sur la moyenne d'âge
Qui pourrait m'aider ?

Merci.
DoMi
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
MichD
Le #23899011
Bonjour,

Je pense que tu gagnerais si tu définis un nom pour tes plages (colonnes)
en utilisant ce type de formule : ÞCALER(Feuil1!$A$1;1;;NBVAL(Feuil1!$A:$A);)

Et pour la moyenne :

ColSex et ColAge sont 2 plages nommées, la ligne 1 de chaque colonne étant réservé aux étiquettes de colonnes.
Les plages nommées supposent que tu n'as pas de lignes vides dans tes colonnes!

Validation matricielle : Ctrl + Maj + Enter
=MOYENNE(SI(ColSex="M";ColAge))


MichD
------------------------------------------
"DoMi" a écrit dans le message de groupe de discussion :


Bonjour,

Non, ce n'est pas l'âge du capitaine que je cherche, mais l'âge moyen
des adhérents de mon association.
J'ai une feuille sur laquelle j'ai un certain nombre d'informations
sur ces personnes, dont l'âge, calculé par rapport à la date de
naissance. J'ai une colonne où j'indique les anciens adhérents qui
réadhèrent.
Sur une feuille "Statistiques", je calcule le nombre d'hommes ayant
réadhéré avec la formule:
{=SOMME(('2012'!O2:O65536="M")*('2012'!U2:U65536="OK"))}
le sexe étant en colonne O et la réadhésion en colonne U par "OK"
Je calcule ainsi différents paramètres.
Je bloque sur la moyenne d'âge...
Qui pourrait m'aider ?

Merci.
DoMi
MichD
Le #23899931
Bonjour,

Je pense que tu gagnerais si tu définis un nom pour tes plages (colonnes)
en utilisant ce type de formule : ÞCALER(Feuil1!$A$1;1;;NBVAL(Feuil1!$A:$A);)

Et pour la moyenne :

ColSex et ColAge sont 2 plages nommées, la ligne 1 de chaque colonne étant réservé aux étiquettes de colonnes.
Les plages nommées supposent que tu n'as pas de lignes vides dans tes colonnes!

Validation matricielle : Ctrl + Maj + Enter
=MOYENNE(SI(ColSex="M";ColAge))


MichD
------------------------------------------
"DoMi" a écrit dans le message de groupe de discussion :


Bonjour,

Non, ce n'est pas l'âge du capitaine que je cherche, mais l'âge moyen
des adhérents de mon association.
J'ai une feuille sur laquelle j'ai un certain nombre d'informations
sur ces personnes, dont l'âge, calculé par rapport à la date de
naissance. J'ai une colonne où j'indique les anciens adhérents qui
réadhèrent.
Sur une feuille "Statistiques", je calcule le nombre d'hommes ayant
réadhéré avec la formule:
{=SOMME(('2012'!O2:O65536="M")*('2012'!U2:U65536="OK"))}
le sexe étant en colonne O et la réadhésion en colonne U par "OK"
Je calcule ainsi différents paramètres.
Je bloque sur la moyenne d'âge...
Qui pourrait m'aider ?

Merci.
DoMi
Jacky
Le #23899271
Bonsoir,

Essaye..

=ENT(SOMMEPROD((PlageSexe="M")*(PlageOK="OK")*PlageAge)/SOMMEPROD((PlageSexe="M")*(PlageOK="OK")))

--
Salutations
JJ


"DoMi"
Bonjour,

Non, ce n'est pas l'âge du capitaine que je cherche, mais l'âge moyen
des adhérents de mon association.
J'ai une feuille sur laquelle j'ai un certain nombre d'informations
sur ces personnes, dont l'âge, calculé par rapport à la date de
naissance. J'ai une colonne où j'indique les anciens adhérents qui
réadhèrent.
Sur une feuille "Statistiques", je calcule le nombre d'hommes ayant
réadhéré avec la formule:
{=SOMME(('2012'!O2:O65536="M")*('2012'!U2:U65536="OK"))}
le sexe étant en colonne O et la réadhésion en colonne U par "OK"
Je calcule ainsi différents paramètres.
Je bloque sur la moyenne d'âge...
Qui pourrait m'aider ?

Merci.
DoMi
DoMi
Le #23899531
On 24 oct, 19:00, "Jacky"
Bonsoir,

Essaye..

=ENT(SOMMEPROD((PlageSexe="M")*(PlageOK="OK")*PlageAge)/SOMMEPROD(( PlageSex­e="M")*(PlageOK="OK")))

--
Salutations
JJ

"DoMi"
Bonjour,

Non, ce n'est pas l'âge du capitaine que je cherche, mais l'âge moyen
des adhérents de mon association.
J'ai une feuille sur laquelle j'ai un certain nombre d'informations
sur ces personnes, dont l'âge, calculé par rapport à la date de
naissance. J'ai une colonne où j'indique les anciens adhérents qui
réadhèrent.
Sur une feuille "Statistiques", je calcule le nombre d'hommes ayant
réadhéré avec la formule:
{=SOMME(('2012'!O2:O65536="M")*('2012'!U2:U65536="OK"))}
le sexe étant en colonne O et la réadhésion en colonne U par "OK"
Je calcule ainsi différents paramètres.
Je bloque sur la moyenne d'âge...
Qui pourrait m'aider ?

Merci.
DoMi



Merci !

Pour le moment, aucune réinscription n'ayant été enregistrée, j'ai
complété la formule pour que ça fasse plus propre :
=SI(SOMMEPROD((ColSexe="M")*(ColOK="OK"))=0;"";ENT(SOMMEPROD((ColSe xe="M")*(ColOK="OK")*ColAge)/
SOMMEPROD((ColSexe="M")*(ColOK="OK"))))

Bonne soirée
DoMi
MichD
Le #23899921
Ceci ne fonctionne pas ?

Validation matricielle : Maj+Ctrl+Enter
=moyenne(si((PlageSexe="M")*(PlageOK="OK")=1;PlageAge))



MichD
------------------------------------------
"DoMi" a écrit dans le message de groupe de discussion :


On 24 oct, 19:00, "Jacky"
Bonsoir,

Essaye..

=ENT(SOMMEPROD((PlageSexe="M")*(PlageOK="OK")*PlageAge)/SOMMEPROD((PlageSex­e="M")*(PlageOK="OK")))

--
Salutations
JJ

"DoMi"
Bonjour,

Non, ce n'est pas l'âge du capitaine que je cherche, mais l'âge moyen
des adhérents de mon association.
J'ai une feuille sur laquelle j'ai un certain nombre d'informations
sur ces personnes, dont l'âge, calculé par rapport à la date de
naissance. J'ai une colonne où j'indique les anciens adhérents qui
réadhèrent.
Sur une feuille "Statistiques", je calcule le nombre d'hommes ayant
réadhéré avec la formule:
{=SOMME(('2012'!O2:O65536="M")*('2012'!U2:U65536="OK"))}
le sexe étant en colonne O et la réadhésion en colonne U par "OK"
Je calcule ainsi différents paramètres.
Je bloque sur la moyenne d'âge...
Qui pourrait m'aider ?

Merci.
DoMi



Merci !

Pour le moment, aucune réinscription n'ayant été enregistrée, j'ai
complété la formule pour que ça fasse plus propre :
=SI(SOMMEPROD((ColSexe="M")*(ColOK="OK"))=0;"";ENT(SOMMEPROD((ColSexe="M")*(ColOK="OK")*ColAge)/
SOMMEPROD((ColSexe="M")*(ColOK="OK"))))

Bonne soirée
DoMi
DoMi
Le #23901901
On 24 oct, 19:54, "MichD"
Ceci ne fonctionne pas ?

Validation matricielle : Maj+Ctrl+Enter
=moyenne(si((PlageSexe="M")*(PlageOK="OK")=1;PlageAge))

MichD
------------------------------------------
"DoMi"  a écrit dans le message de groupe de discussion :


On 24 oct, 19:00, "Jacky"




> Bonsoir,

> Essaye..

> =ENT(SOMMEPROD((PlageSexe="M")*(PlageOK="OK")*PlageAge)/SOMMEPROD ((PlageSex­­e="M")*(PlageOK="OK")))

> --
> Salutations
> JJ

> "DoMi" >
> Bonjour,

> Non, ce n'est pas l'âge du capitaine que je cherche, mais l'âge moy en
> des adhérents de mon association.
> J'ai une feuille sur laquelle j'ai un certain nombre d'informations
> sur ces personnes, dont l'âge, calculé par rapport à la date de
> naissance. J'ai une colonne où j'indique les anciens adhérents qui
> réadhèrent.
> Sur une feuille "Statistiques", je calcule le nombre d'hommes ayant
> réadhéré avec la formule:
> {=SOMME(('2012'!O2:O65536="M")*('2012'!U2:U65536="OK"))}
> le sexe étant en colonne O et la réadhésion en colonne U par "OK"
> Je calcule ainsi différents paramètres.
> Je bloque sur la moyenne d'âge...
> Qui pourrait m'aider ?

> Merci.
> DoMi

Merci !

Pour le moment, aucune réinscription n'ayant été enregistrée, j'a i
complété la formule pour que ça fasse plus propre :
=SI(SOMMEPROD((ColSexe="M")*(ColOK="OK"))=0;"";ENT(SOMMEPROD((Col Sexe="M")*­(ColOK="OK")*ColAge)/
SOMMEPROD((ColSexe="M")*(ColOK="OK"))))

Bonne soirée
DoMi- Masquer le texte des messages précédents -

- Afficher le texte des messages précédents -



Si ! Et elle a l'avantage d'être plus concise !

Merci
DoMi
DoMi
Le #23905661
On 25 oct, 12:20, DoMi
On 24 oct, 19:54, "MichD"




> Ceci ne fonctionne pas ?

> Validation matricielle : Maj+Ctrl+Enter
> =moyenne(si((PlageSexe="M")*(PlageOK="OK")=1;PlageAge))

> MichD
> ------------------------------------------
> "DoMi"  a écrit dans le message de groupe de discussion :
>

> On 24 oct, 19:00, "Jacky"
> > Bonsoir,

> > Essaye..

> > =ENT(SOMMEPROD((PlageSexe="M")*(PlageOK="OK")*PlageAge)/SOMMEPR OD((PlageSex­­­e="M")*(PlageOK="OK")))

> > --
> > Salutations
> > JJ

> > "DoMi" > >
> > Bonjour,

> > Non, ce n'est pas l'âge du capitaine que je cherche, mais l'âge m oyen
> > des adhérents de mon association.
> > J'ai une feuille sur laquelle j'ai un certain nombre d'informations
> > sur ces personnes, dont l'âge, calculé par rapport à la date de
> > naissance. J'ai une colonne où j'indique les anciens adhérents qu i
> > réadhèrent.
> > Sur une feuille "Statistiques", je calcule le nombre d'hommes ayant
> > réadhéré avec la formule:
> > {=SOMME(('2012'!O2:O65536="M")*('2012'!U2:U65536="OK"))}
> > le sexe étant en colonne O et la réadhésion en colonne U par "O K"
> > Je calcule ainsi différents paramètres.
> > Je bloque sur la moyenne d'âge...
> > Qui pourrait m'aider ?

> > Merci.
> > DoMi

> Merci !

> Pour le moment, aucune réinscription n'ayant été enregistrée, j 'ai
> complété la formule pour que ça fasse plus propre :
> =SI(SOMMEPROD((ColSexe="M")*(ColOK="OK"))=0;"";ENT(SOMMEPROD((C olSexe="M")*­­(ColOK="OK")*ColAge)/
> SOMMEPROD((ColSexe="M")*(ColOK="OK"))))

> Bonne soirée
> DoMi- Masquer le texte des messages précédents -

> - Afficher le texte des messages précédents -

Si ! Et elle a l'avantage d'être plus concise !

Merci
DoMi- Masquer le texte des messages précédents -

- Afficher le texte des messages précédents -



Bonjour,

Vous m'avez bien aidé pour la moyenne d'âge par sexe, mais je bloque
encore sur la moyenne générale:
Je voudrais la moyenne d'âge, tous sexes confondus, des personnes dont
la colonne "OK" est à "OK"

Merci
DoMi
Jacquouille
Le #23905721
Bonjour
Un filtre auto, puis dans une cellule qui ne sera pas cachée:
=Sous.total(1;A3:A1000) ---> si les "Date naiss" sont dans la col A
Cette solution, moins scientifique, permettra d'un seul clic, de connaître
la moy pour tous, pour les hommes, pour les femmes, ou, pour les + de x ans
.....


Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"DoMi" a écrit dans le message de groupe de discussion :



Bonjour,

Vous m'avez bien aidé pour la moyenne d'âge par sexe, mais je bloque
encore sur la moyenne générale:
Je voudrais la moyenne d'âge, tous sexes confondus, des personnes dont
la colonne "OK" est à "OK"

Merci
DoMi
MichD
Le #23905911
Validation matricielle : Maj+Ctrl+Enter
=MOYENNE(SI(PlageOK="OK";PlageAge))


MichD
------------------------------------------
DoMi
Le #23906851
On 26 oct, 13:42, "MichD"
Validation matricielle : Maj+Ctrl+Enter
=MOYENNE(SI(PlageOK="OK";PlageAge))

MichD
------------------------------------------



Super !

Merci
DoMi
Publicité
Poster une réponse
Anonyme