Aide sur ALSA pour tous.

Le
Vecu BOSSEUR
Bonjour,

Depuis une fenêtre terminal sous X (environnements Gnome et KDE), j'ai
l'habitude d'utiliser l'utilitaire sux pour lancer des applications
sous une autre identité.

Ca fonctionne très bien (graphismes avec 3D, clavier, souris, )
MAIS le son ne fonctionne pas pour les programmes que je lance sous
une identité différente de l'identité de ma session graphique
XWindows.

Sûrement qu'il y a une politique de sécurité, ou de "confort", là
derrière qui bloque l'API ALSA et d'autres APIs sonores dans ces
circonstances.

Si vous pouviez m'en apprendre plus pour que je puisse contourner
cette limitation.

Merci d'avance.

Cordialement,
Valentin

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/BANLkTik1y_H1ti+uhTYB6e8_vPjp1mhFtA@mail.gmail.com
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Raphaël POITEVIN
Le #23496361
Le 24/06/11, Vecu BOSSEUR
Depuis une fenêtre terminal sous X (environnements Gnome et KDE), j'ai
l'habitude d'utiliser l'utilitaire sux pour lancer des applications
sous une autre identité.

Ca fonctionne très bien (graphismes avec 3D, clavier, souris, ...)
MAIS le son ne fonctionne pas pour les programmes que je lance sous
une identité différente de l'identité de ma session graphique
XWindows.



Est-ce que ton utilisateur est bien dans le groupe audio ?
--
Raphaël POITEVIN

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/BANLkTikX3ZRhYzD8T5zAJxTpZT+
Vecu BOSSEUR
Le #23496531
Bonjour, et merci pour votre intervention.

L'utilisateur "alternatif" (instancié via l'utilitaire sux)
n'appartient pas au groupe "audio".
Mais l'utilisateur de la session graphique (GNOME/XWindows) n'est ni
supeutilisateur (root), ni membre du groupe "audio" non plus.

Notez, Monsieur, que j'utilise Debian GNU/Linux testing(Wheezy) le
plus à jour possible (avec "mixin" unstable(Sid)).

En vous remerciant pour votre intérêt mon ma pauvre cause de simple mor tel,

Je vous souhaite, Monsieur, de pouvoir montrer que vous saurez
résoudre cette énigme ;-)

Cordialement,
Valentin QUEQUET

Le 24 juin 2011 13:57, Raphaël POITEVIN
Le 24/06/11, Vecu BOSSEUR
Depuis une fenêtre terminal sous X (environnements Gnome et KDE), j'ai
l'habitude d'utiliser l'utilitaire sux pour lancer des applications
sous une autre identité.

Ca fonctionne très bien (graphismes avec 3D, clavier, souris, ...)
MAIS le son ne fonctionne pas pour les programmes que je lance sous
une identité différente de l'identité de ma session graphique
XWindows.



Est-ce que ton utilisateur est bien dans le groupe audio ?
--
Raphaël POITEVIN




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/BANLkTi=hVraGCUV1x=8SDYpwU6A0W1js+
Vecu BOSSEUR
Le #23497531
Le 24 juin 2011 14:35, Vecu BOSSEUR
Bonjour, et merci pour votre intervention.

L'utilisateur "alternatif" (instancié via l'utilitaire sux)
n'appartient pas au groupe "audio".
Mais l'utilisateur de la session graphique (GNOME/XWindows) n'est ni
supeutilisateur (root), ni membre du groupe "audio" non plus.



[...]
Valentin QUEQUET

Le 24 juin 2011 13:57, Raphaël POITEVIN
Le 24/06/11, Vecu BOSSEUR
Depuis une fenêtre terminal sous X (environnements Gnome et KDE), j'a i
l'habitude d'utiliser l'utilitaire sux pour lancer des applications
sous une autre identité.

Ca fonctionne très bien (graphismes avec 3D, clavier, souris, ...)
MAIS le son ne fonctionne pas pour les programmes que je lance sous
une identité différente de l'identité de ma session graphique
XWindows.



Est-ce que ton utilisateur est bien dans le groupe audio ?
--
Raphaël POITEVIN






Bonsoir,

C'est génial, ça fonctionne.

Vu le nombre d'APIs audio (noyau + différents serveurs de playback ou
mixage, orienté local ou réseau, + librairies de portage, ...) sous
Linux, une chatte n'y retrouverai pas ses petits.

Merci encore.
Valentin

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/BANLkTinjk3aQ1g4sTUM8aYR-=
Publicité
Poster une réponse
Anonyme